방법: 코드 감싸기 코드 조각 사용How to: Use surround-with code snippets

다음 프로시저에서는 코드 감싸기 코드 조각을 사용하는 방법을 설명합니다.The following procedures describe how to use surround-with code snippets. 코드 감싸기 코드 조각은 세 가지 방법 즉, 바로 가기 키, 편집 메뉴 및 바로 가기 메뉴를 통해 사용할 수 있습니다.Surround-with code snippets are available three ways: through a keyboard shortcut, through the Edit menu, and through the context menu.

바로 가기 키를 통해 코드 감싸기 코드 조각을 사용하려면To use surround-with code snippets through keyboard shortcut

  1. Visual Studio IDE에서 편집할 파일을 엽니다.In the Visual Studio IDE, open the file that you intend to edit.

  2. 코드 편집기에서 감싸기 할 텍스트를 선택합니다.In the Code Editor, select text to surround.

  3. Ctrl+K, Ctrl+S를 입력합니다.Type Ctrl+K, Ctrl+S.

  4. 코드 조각 목록에서 마우스를 사용하거나 코드 조각 이름을 입력하고 Tab 키 또는 Enter 키를 눌러 코드 조각을 선택합니다.Select the code snippet from the code snippet list using the mouse, or by typing the name of the code snippet and pressing Tab or Enter.

[편집] 메뉴를 통해 코드 감싸기 코드 조각을 사용하려면To use surround-with code snippets through the Edit menu

  1. Visual Studio IDE에서 편집할 파일을 엽니다.In the Visual Studio IDE, open the file that you intend to edit.

  2. 코드 편집기에서 감싸기 할 텍스트를 선택합니다.In the Code Editor, select text to surround.

  3. 편집 메뉴에서 IntelliSense를 선택하고 코드 감싸기 명령을 선택합니다.From the Edit menu, select IntelliSense and then select the Surround With command.

  4. 코드 조각 삽입기에서 코드 조각을 선택하고 Tab 키 또는 Enter 키를 누릅니다.Select the code snippet from the code snippet inserter and then press Tab or Enter.

    또는 코드 조각의 이름을 입력한 다음, Tab 키 또는 Enter 키를 누릅니다.Alternatively, you can type the name of the code snippet, and then press Tab or Enter.

바로 가기 메뉴를 통해 코드 감싸기 코드 조각을 사용하려면To use surround-with code snippets through the context menu

  1. Visual Studio IDE에서 편집할 파일을 엽니다.In the Visual Studio IDE, open the file that you intend to edit.

  2. 코드 편집기에서 감싸기 할 텍스트를 선택합니다.In the Code Editor, select text to surround.

  3. 선택한 텍스트를 마우스 오른쪽 단추로 클릭한 다음 바로 가기 메뉴에서 코드 감싸기 명령을 선택합니다.Right-click the selected text and then select the Surround With command from the context menu.

  4. 코드 조각 삽입기에서 코드 조각을 선택하고 Tab 키 또는 Enter 키를 누릅니다.Select the code snippet from the code snippet inserter and then press Tab or Enter.

    또는 코드 조각의 이름을 입력한 다음, Tab 키 또는 Enter 키를 누릅니다.Alternatively, you can type the name of the code snippet, and then press Tab or Enter.

참고 항목See also