옵션 대화 상자, 환경, 문서Documents, Environment, Options Dialog Box

옵션 대화 상자의 이 페이지를 사용하여 IDE(통합 개발 환경)에서 문서 표시를 제어하고 문서 및 파일에 대한 외부 변경 내용을 관리합니다.Use this page of the Options dialog box to control the display of documents in the integrated development environment (IDE) and manage external changes to documents and files. 이 대화 상자에 액세스하려면 도구 메뉴에서 옵션을 클릭하고 환경 노드에서 문서를 선택합니다.You can access this dialog box by clicking Options on the Tools menu and then selecting Documents in the Environment node. 문서가 목록에 나타나지 않으면 옵션 대화 상자에서 모든 설정 표시를 선택합니다.If Documents does not appear in the list, select Show all settings in the Options dialog box.

참고

대화 상자에서 사용할 수 있는 옵션과 메뉴 명령의 이름 및 위치는 실제 설정이나 버전에 따라 도움말에서 설명하는 것과 다를 수 있습니다.The options available in dialog boxes, and the names and locations of menu commands you see, might differ from what is described in Help depending on your active settings or edition. 설정을 변경하려면 도구 메뉴에서 설정 가져오기 및 내보내기 를 선택합니다.To change your settings, choose Import and Export Settings on the Tools menu. 자세한 내용은 Visual Studio IDE 개인 설정을 참조하세요.For more information, see Personalize the Visual Studio IDE.

저장되면 현재 문서 창 다시 사용 이 옵션을 선택하면 저장된 현재 문서가 닫히고 새 문서가 같은 창에서 열립니다.Reuse current document window, if saved When selected, closes your current document if it has been saved, and opens a new document in the same window. 현재 문서가 저장되지 않은 경우에는 문서가 열려 있고 새 문서가 별도의 창에서 열립니다.If your current document has not been saved, it remains open and the new document is opened in a separate window. 이 옵션을 선택 취소하면 새 문서가 항상 별도의 창에서 열립니다.When this option is cleared, new documents always open in separate windows.

다중 문서 잘라내기 및 붙여넣기 작업을 자주 수행하지 않는 경우 작업 공간에서 열린 문서 및 창 수를 최소화하려면 이 옵션을 시도하세요.If you perform multi-document cut and paste operations infrequently and want to minimize the number of open documents and windows in your working space, try this option.

파일이 환경 외부에서 변경되면 검색 이 옵션을 선택하면 IDE 외부에서 편집기를 통해 적용된 열린 파일의 변경 내용에 대한 메시지가 제공됩니다.Detect when file is changed outside the environment When this option is selected, a message immediately notifies you of changes to an open file that have been made by an editor outside the IDE. 메시지를 통해 저장소에서 파일을 다시 로드할 수 있습니다.The message lets you reload the file from storage.

저장되면 변경 내용 자동 로드 파일이 환경 외부에서 변경되면 검색을 선택하고 IDE의 열린 파일을 IDE 외부에서 변경하는 경우 기본적으로 경고 메시지가 생성됩니다.Auto-load changes, if saved When you have Detect when file is changed outside the environment selected and an open file in the IDE changes outside the IDE, a warning message is generated by default. 이 옵션을 사용하도록 설정하면 경고가 나타나지 않고 외부 변경 내용을 선택하도록 문서가 IDE에 다시 로드됩니다.If this option is enabled, no warning appears and the document is reloaded in the IDE to pick up the external changes.

읽기 전용 파일 편집 허용(저장할 때 경고 표시) 이 옵션을 사용하면 읽기 전용 파일을 열고 편집할 수 있습니다.Allow editing of read-only files; warn when attempt to save When this option is enabled you can open and edit a read-only file. 작업을 완료하고 변경 내용 레코드를 저장할 때 새 이름으로 파일을 저장하려면 다른 이름으로 저장 명령을 사용해야 합니다.When you are finished, you must use the Save Ascommand to save the file by a new name if you want to save a record of your changes.

현재 활성 문서의 디렉터리를 사용하여 파일 열기 이 옵션을 선택하면 파일 열기 대화 상자에 활성 문서의 디렉터리가 표시되도록 지정합니다.Open file using directory of currently active document When selected, this option specifies that the Open File dialog box displays the directory of the active document. 이 옵션을 선택 취소하면 파일 열기 대화 상자에 파일을 여는 데 마지막으로 사용되는 디렉터리가 표시됩니다.When this option is cleared, the Open File dialog box displays the directory last used to open a file.

로드할 때 줄 끝 일관성 검사 편집기에서 파일의 줄 끝을 검색하고 줄 끝 형식 지정 방법이 일치하지 않는 것을 발견할 경우 메시지 상자를 표시하게 하려면 이 옵션을 선택합니다.Check for consistent line endings on load Select this option to have the editor scan the line endings in a file and display a message box if inconsistencies are detected in how line endings are formatted.

전체 실행 취소로 인해 편집된 파일이 수정될 때 경고 표시 전체 실행 취소 명령이 리팩터링 작업 후에 변경된 파일에 적용된 리팩터링 변경 내용을 롤백할 경우 메시지를 표시하려면 이 옵션을 선택합니다.Display warning when global undo will modify edited files Select this option to display a message box when the Global Undo command will roll back refactoring changes made in files that also were changed after the refactoring operation. 파일을 리팩터링 전 상태로 되돌리려면 파일에 적용된 후속 변경 내용이 취소될 수 있습니다.Returning a file to its pre-refactoring state might discard subsequent changes made in the file.

솔루션 탐색기에 기타 파일 표시 솔루션 탐색기에서 기타 파일 노드를 표시하려면 이 옵션을 선택합니다.Show Miscellaneous files in Solution Explorer Select this option to display the Miscellaneous Files node in Solution Explorer. 기타 파일은 프로젝트나 솔루션과 연결되지 않은 파일이지만, 편의를 위해 솔루션 탐색기에 표시될 수 있습니다.Miscellaneous files are files that are not associated with a project or solution but can appear in Solution Explorer for your convenience.

참고

활성 웹 응용 프로그램에 포함되지 않은 웹 문서의 경우 파일 메뉴에서 브라우저에서 보기 명령을 사용하도록 설정하려면 이 옵션을 선택합니다.Select this option to enable the View in Browser command on the File menu for Web documents not included in the active Web application.

< n > 기타 파일 프로젝트에 저장된 항목 솔루션 탐색기기타 파일 폴더에 유지할 파일 수를 지정합니다.< n > items saved in the Miscellaneous files project Specifies the number of files to persist in the MiscellaneousFiles folder of Solution Explorer. 이러한 파일은 편집기에서 더 이상 열려 있지 않은 경우에도 나열됩니다.These files are listed even if they are no longer open in an editor. 0~256의 정수를 지정할 수 있습니다.You can specify any whole number from 0 to 256. 기본 개수는 0개입니다.The default number is 0.

예를 들어 이 옵션을 5로 설정하고 10개의 기타 파일이 열려 있으면 10개 파일을 모두 닫을 때 처음 5개가 기타 파일 폴더에 계속 표시됩니다.For example, if you set this option to 5 and have 10 miscellaneous files open, when you close all 10 files, the first 5 will still be shown in the Miscellaneous Files folder.

데이터를 코드 페이지에 저장할 수 없을 때 문서를 유니코드로 저장 선택한 코드 페이지와 호환되지 않는 정보가 포함된 파일이 기본적으로 유니코드로 저장되도록 하려면 이 옵션을 선택합니다.Save documents as Unicode when data cannot be saved in codepage Select this option to cause files containing information incompatible with the selected codepage to be saved as Unicode by default.

참고 항목See Also