옵션 대화 상자, 환경, 일반General, Environment, Options Dialog Box

이 페이지에서는 IDE(통합 개발 환경)에 대한 다른 옵션 중에서도 색 테마, 상태 표시줄 설정 및 파일 확장명 연결을 변경할 수 있습니다.Use this page to change color themes, status bar settings, and file extension associations, among other options, for the integrated development environment (IDE). 도구 메뉴를 열고 옵션을 선택한 다음 환경 폴더를 열고 일반 페이지를 선택하여 옵션 대화 상자에 액세스할 수 있습니다.You can access the Options dialog box by opening the Tools menu, choosing Options, opening the Environment folder and then choosing the General page. 이 페이지가 목록에 나타나지 않으면 옵션 대화 상자에서 모든 설정 표시 확인란을 선택합니다.If this page does not appear in the list, select the Show all settings check box in the Options dialog box.

참고

표시되는 대화 상자와 메뉴 명령은 활성 설정이나 버전에 따라 도움말에서 설명하는 것과 다를 수 있습니다.The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 설정을 변경하려면 도구 메뉴를 열고 설정 가져오기 및 내보내기를 선택합니다.To change your settings, open the Tools menu, and then choose Import and Export Settings. 자세한 내용은 Visual Studio IDE 개인 설정을 참조하세요.For more information, see Personalize the Visual Studio IDE.

시각적 효과Visual Experience

색 테마Color theme

IDE에 대해 파란 색 테마, 밝은 색 테마 또는 어두운 색 테마를 선택합니다.Choose the Blue, Light or Dark color theme for the IDE.

Visual Studio Marketplace에서 Visual Studio 색 테마 편집기를 다운로드 및 설치하여 미리 정의된 추가 테마를 설치하고 사용자 지정 테마를 만들 수 있습니다.You can install additional predefined themes, and create custom themes, by downloading and installing the Visual Studio Color Theme Editor from the Visual Studio Marketplace. 이 도구를 설치하면 색 테마 목록 상자에 추가적인 색 테마가 나타납니다.After you install this tool, additional color themes appear in the Color theme list box.

메뉴 모음에 단어의 첫 글자를 대문자로 표시 적용Apply title casing in menu bar

메뉴는 기본적으로 단어의 첫 글자를 대문자로 표시가 적용된 상태입니다.Menus are in Title Casing by default. 모두 대문자로로 설정하려면 이 옵션의 선택을 취소하세요.Un-check this option to set them to ALL CAPS.

클라이언트 성능에 따른 시각적 효과 자동 조정Automatically adjust visual experience based on client performance

Visual Studio에서 시각적 효과 조정을 자동으로 설정하는지 또는 명시적으로 조정을 설정하는지를 지정합니다.Specifies whether Visual Studio sets the adjustment to the visual experience automatically or you set the adjustment explicitly. 이러한 조정은 색 표시를 그라데이션에서 단색으로 변경하거나 메뉴 또는 팝업 창에서 애니메이션 사용을 제한할 수 있습니다.This adjustment may change the display of colors from gradients to flat colors, or it may restrict the use of animations in menus or popup windows.

리치 클라이언트 시각적 효과 사용Enable rich client experience

그라데이션 및 애니메이션을 포함하여 Visual Studio의 완전한 시각적 효과를 사용하도록 설정합니다.Enables the full visual experience of Visual Studio, including gradients and animations. 이러한 기능으로 인해 성능이 저하될 수 있으므로 원격 데스크톱 연결 또는 이전 그래픽 어댑터를 사용하는 경우에는 이 옵션을 선택 취소합니다.Clear this option when using Remote Desktop connections or older graphics adapters, because these features may have poor performance in those cases. 이 옵션은 클라이언트 성능에 따른 시각적 효과 자동 조정 옵션을 선택 취소하는 경우에만 사용할 수 있습니다.This option is available only when you clear the Automatically adjust visual experience based on client option.

사용 가능한 경우 하드웨어 그래픽 가속 기능 사용Use hardware graphics acceleration if available

소프트웨어 가속 대신 하드웨어 그래픽 가속을 사용합니다(사용 가능한 경우).Uses hardware graphics acceleration if it is available, rather than software acceleration.

기타Other

창 메뉴에 표시되는 항목Items shown in Window menu
메뉴의 Windows 목록에 표시되는 창 수를 사용자 지정합니다.Customizes the number of windows that appear in the Windows list of the Window menu. 1에서 24 사이의 숫자를 입력합니다.Type a number between 1 and 24. 기본적으로 개수는 10개입니다.By default, the number is 10.

최근 사용한 목록에 표시되는 항목Items shown in recently used lists
파일 메뉴에 표시되는 가장 최근에 사용한 프로젝트 및 파일 수를 사용자 지정합니다.Customizes the number of most recently used projects and files that appear on the File menu. 1에서 24 사이의 숫자를 입력합니다.Type a number between 1 and 24. 기본적으로 개수는 10개입니다.By default, the number is 10. 이 방법으로 최근에 사용한 프로젝트 및 파일을 쉽게 검색할 수 있습니다.This is an easy way to retrieve recently used projects and files.

상태 표시줄 표시Show status bar
상태 표시줄을 표시합니다.Displays the status bar. 상태 표시줄은 IDE 창의 맨 아래에 있고 진행 중인 작업의 진행률에 대한 정보를 표시합니다.The status bar is located at the bottom of the IDE window and displays information about the progress of ongoing operations.

활성 도구 창에서만 [닫기] 단추 수행Close button affects active tool window only
닫기 단추를 클릭할 때 도킹된 집합의 모든 도구 창이 아니라 포커스가 있는 도구 창만 닫히도록 지정합니다.Specifies that when the Close button is clicked, only the tool window that has focus is closed and not all of the tool windows in the docked set. 기본적으로 이 옵션이 선택됩니다.By default, this option is selected.

활성 도구 창에서만 [자동 숨기기] 단추 수행Auto Hide button affects active tool window only
자동 숨기기 단추를 클릭할 때 도킹된 집합의 모든 도구 창이 아니라 포커스가 있는 도구 창만 자동으로 숨겨지도록 지정합니다.Specifies that when the Auto Hide button is clicked, only the tool window that has focus is hidden automatically and not all of the tool windows in the docked set. 기본적으로 이 옵션은 선택되어 있지 않습니다.By default, this option is not selected.

참고 항목See also

옵션 대화 상자, 환경Environment Options Dialog Box
창 레이아웃 사용자 지정Customizing window layouts