방법: 단독으로 키보드 사용How to: Use the Keyboard Exclusively

접근성에 대한 최신 업데이트에 대한 자세한 내용은 Accessibility improvements in Visual Studio 2017 version 15.3(Visual Studio 2017 버전 15.3의 접근성 향상) 블로그 게시물을 참조하세요.To learn more about recent accessibility updates, see the Accessibility improvements in Visual Studio 2017 version 15.3 blog post.

Visual StudioVisual Studio에서는 IDE(통합 개발 환경) 내에서 쉽게 탐색 및 코딩할 수 있도록 하는 다양한 기본 바로 가기 키 조합을 제공합니다. provides many default shortcut key combinations to make it easy to navigate and code within the integrated development environment (IDE). Visual Studio에서 사용되는 바로 가기 키의 전체 목록은 기본 바로 가기 키를 참조하세요.For a full listing of shortcut keys used in Visual Studio, see Default Keyboard Shortcuts. 다른 Microsoft 제품에 사용 가능한 바로 가기 키에 대한 자세한 내용은 http://www.microsoft.com/enable/products/keyboard.aspx 페이지를 참조하세요.For information on keyboard shortcuts available for other Microsoft products, see http://www.microsoft.com/enable/products/keyboard.aspx.

참고

표시되는 대화 상자와 메뉴 명령은 활성 설정이나 버전에 따라 도움말에서 설명하는 것과 다를 수 있습니다.The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 설정을 변경하려면 도구 메뉴에서 설정 가져오기 및 내보내기 를 선택합니다.To change your settings, choose Import and Export Settings on the Tools menu. 자세한 내용은 Visual Studio IDE 개인 설정을 참조하세요.For more information, see Personalize the Visual Studio IDE.

도구 상자 컨트롤Toolbox Controls

키보드를 사용하여 도구 상자의 컨트롤을 폼 또는 디자이너에 추가할 수 있습니다.You can add a control on the Toolbox to a form or designer using the keyboard.

키보드에서 도구 상자의 컨트롤을 디자이너에 추가하려면To add controls from the Toolbox to a designer from the keyboard

  1. 메뉴 모음에서 보기, 도구 상자를 차례로 선택합니다.On the menu bar, choose View, Toolbox.

  2. Ctrl+위쪽 화살표 또는 Ctrl+아래쪽 화살표 키를 사용하여 현재 도구 상자 탭의 섹션 간에 이동합니다.Use the Ctrl + Up Arrow or Ctrl + Down Arrow keys to move among the sections in the current Toolbox tab.

  3. 위쪽 화살표 또는 아래쪽 화살표 키를 사용하여 컨트롤 간에 이동합니다.Use the Up Arrow or Down Arrow keys to move among the controls.

  4. 컨트롤이 선택된 후 Enter 키를 사용합니다.After the control is selected, use the Enter key.

    컨트롤이 폼 또는 디자이너에 추가됩니다.The control is added to the form or designer.

대화 상자 옵션Dialog Box Options

키보드를 사용하여 대화 상자에서 옵션 간에 이동하고 옵션 설정을 변경할 수 있습니다.You can move among the options in a dialog and change option settings using the keyboard.

키보드에서 대화 상자 옵션을 설정하려면To set dialog box options from the keyboard

  1. TAB 또는 SHIFT+TAB을 사용하여 대화 상자의 컨트롤 간에 위아래로 이동합니다.Use TAB or SHIFT + TAB to move up and down through the controls in the dialog box.

  2. 옵션 설정을 변경하려면:To change option settings:

    • 라디오 단추의 경우 위쪽 화살표아래쪽 화살표를 사용하여 선택을 변경합니다.For radio buttons, use UP ARROW and DOWN ARROW to change the selection.

    • 확인란의 경우 스페이스바를 사용하여 선택하거나 선택 취소합니다.For check boxes, use SPACEBAR to select or unselect.

    • 드롭다운 목록의 경우 ALT + 아래쪽 화살표를 사용하여 항목을 표시하고 나서 위쪽 화살표아래쪽 화살표를 사용하여 선택한 항목을 변경합니다.For drop-down lists, use ALT + DOWNARROW to display items and then use UPARROW and DOWNARROW to change the selected item.

    • 단추의 경우 ENTER 키를 눌러 호출합니다.For buttons, press ENTER to invoke.

    • 눈금의 경우 화살표 키를 사용하여 탐색합니다.For grids, use the Arrow keys to navigate. 눈금에 있는 드롭다운 목록의 경우 SHIFT + ALT + 아래쪽 화살표를 사용하여 항목을 표시하고 나서 위쪽 화살표아래쪽 화살표를 사용하여 선택한 항목을 변경합니다.For drop-down lists in grids, use SHIFT + ALT + DOWNARROW to display items and then use UPARROW and DOWNARROW to change the selected item.

창 및 파일 탐색Window and File Navigation

IDE에서는 다양한 방식으로 키보드를 사용하여 열린 도구 및 문서 창 간에 이동할 수 있습니다.The IDE provides several ways for you to move among open tool and document windows using the keyboard. 키보드를 사용하여 서로 다른 위치에서 도구 창을 이동 및 도킹할 수도 있습니다.You can also move and dock tool windows in different locations using the keyboard.

키보드에서 IDE의 창 및 파일 간에 이동하려면To navigate among windows and files in the IDE from the keyboard

  • 편집기 또는 디자이너에서 파일 간에 이동하려면 CTRL+TAB 키를 선택하여 활성 파일이 선택되어 있는 IDE 탐색기를 표시합니다.To move among files in an editor or designer, choose CTRL + TAB keys to display the IDE Navigator with Active Files selected. Enter 키를 선택하여 강조 표시된 파일로 이동합니다.Choose the Enter key to navigate to the highlighted file.

  • 도킹된 도구 창 간에 이동하려면 Alt+F7을 선택하여 활성 도구 창이 선택되어 있는 IDE 탐색기를 표시합니다.To move among docked tool windows, choose Alt + F7 to display the IDE Navigator with Active Tool Windows selected. Enter 키를 선택하여 강조 표시된 창으로 이동합니다.Choose the Enter key to navigate to the highlighted window.

키보드에서 도구 창을 이동 및 도킹하려면To move and dock tool windows from the keyboard

  1. 이동할 도구 창으로 이동하고 포커스를 지정합니다.Navigate to the tool window you intend to move and give it focus.

  2. 메뉴에서 도킹 가능 옵션을 선택합니다.On the Window menu, select the Dockable option.

  3. ALT + 스페이스바를 누르고 나서 이동을 선택합니다.Press ALT + Space and then choose Move.

    도킹 안내 다이아몬드가 나타납니다.The docking guide diamond appears.

  4. 화살표 키를 사용하여 창을 새 위치로 이동합니다.Use the ARROW keys to move the window to a new location.

    화살표 키를 사용함에 따라 마우스 포인터가 창과 함께 이동합니다.The mouse pointer moves with the window as you use the ARROW keys.

  5. 새 위치에 도달한 경우 화살표 키를 사용하여 마우스 포인터를 안내 다이아몬드의 올바른 부분 위로 이동합니다.When you have reached the new location, use the ARROW keys to move the mouse pointer over the correct portion of the guide diamond.

    도구 창의 윤곽이 새 도킹 위치에 나타납니다.An outline of the tool window appears in the new docking location.

  6. ENTER 키를 누릅니다.Press ENTER.

    도구 창이 새 도킹 위치의 제자리에 맞춰집니다.The tool window snaps into place at the new docking location.

참고 항목See Also

바로 가기 키 식별 및 사용자 지정 Identifying and Customizing Keyboard Shortcuts
접근성 팁과 요령 Accessibility Tips and Tricks
기본 바로 가기 키Default Keyboard Shortcuts