옵션 대화 상자(Visual Studio)Options Dialog Box (Visual Studio)

옵션 대화 상자에서는 필요에 맞게 IDE(통합 개발 환경)를 구성할 수 있습니다.The Options dialog box enables you to configure the integrated development environment (IDE) to your needs. 예를 들어 프로젝트의 기본 저장 위치를 설정하고, 창의 기본 모양과 동작을 변경하고, 일반적으로 사용되는 명령의 바로 가기를 만들 수 있습니다.For example, you can establish a default save location for your projects, alter the default appearance and behavior of windows, and create shortcuts for commonly used commands. 개발 언어 및 플랫폼에 관련된 옵션도 있습니다.There are also options specific to your development language and platform. 도구 메뉴에서 옵션에 액세스할 수 있습니다.You can access Options from the Tools menu.

참고

대화 상자에서 사용할 수 있는 옵션과 메뉴 명령의 이름 및 위치는 실제 설정이나 버전에 따라 도움말에서 설명하는 것과 다를 수 있습니다.The options available in dialog boxes, and the names and locations of menu commands you see, might differ from what is described in Help depending on your active settings or edition. 설정을 변경하려면 도구 메뉴에서 설정 가져오기 및 내보내기 를 선택합니다.To change your settings, choose Import and Export Settings on the Tools menu. 자세한 내용은 Visual Studio IDE 개인 설정을 참조하세요.For more information, see Personalize the Visual Studio IDE.

옵션 대화 상자의 레이아웃Layout of the Options dialog box

옵션 대화 상자는 왼쪽 탐색 창 및 오른쪽 표시 영역의 두 부분으로 구분됩니다.The Options dialog box is divided into two parts: a navigation pane on the left and a display area on the right. 탐색 창의 트리 컨트롤에는 환경, 텍스트 편집기, 프로젝트 및 솔루션, 소스 제어와 같은 폴더 노드가 포함됩니다.The tree control in the navigation pane includes folder nodes, such as Environment, Text Editor, Projects and Solutions, and Source Control. 폴더 노드를 확장하여 포함된 옵션 페이지를 나열합니다.Expand any folder node to list the pages of options that it contains. 특정 페이지에 대한 노드를 선택하면 해당 옵션이 표시 영역에 나타납니다.When you select the node for a particular page, its options appear in the display area.

IDE 기능이 메모리에 로드될 때까지 해당 기능에 대한 옵션이 탐색 창에 나타나지 않습니다.Options for an IDE feature do not appear in the navigation pane until the feature is loaded into memory. 따라서 마지막 세션을 종료했을 때 표시된 것과 동일한 옵션이 새 세션을 시작할 때 표시되지 않을 수 있습니다.Therefore, the same options might not be displayed as you begin a new session that were displayed as you ended the last. 프로젝트를 만들거나 특정 응용 프로그램을 사용하는 명령을 실행하면 관련 옵션에 대한 노드가 [옵션] 대화 상자에 추가됩니다.When you create a project or run a command that uses a particular application, nodes for relevant options are added to the Options dialog box. 이러한 추가된 옵션은 IDE 기능이 메모리에 남아 있는 한 계속 사용할 수 있습니다.These added options will then remain available as long as the IDE feature remains in memory.

참고

일부 설정 컬렉션은 [옵션] 대화 상자의 탐색 창에 나타나는 페이지의 범위를 지정합니다.Some settings collections scope the number of pages that appear in the navigation pane of the Options dialog box. 모든 설정 표시를 선택하여 모든 가능한 페이지를 볼 수 있습니다.You can choose to view all possible pages by selecting Show all settings.

옵션 적용 방법How options are applied

옵션 대화 상자에서 [확인]을 클릭하면 모든 페이지의 모든 설정이 저장됩니다.Clicking OK in the Options dialog box saves all settings on all pages. 모든 페이지에서 [취소]를 클릭하면 다른 옵션 페이지에서 방금 변경한 내용을 포함하여 모든 변경 요청이 취소됩니다.Clicking Cancel on any page cancels all change requests, including any just made on other Options pages. 옵션 대화 상자, 환경, 글꼴 및 색에서 변경한 내용과 같은 옵션 설정에 대한 일부 변경 내용은 Visual Studio를 닫았다 다시 열어야 적용됩니다.Some changes to option settings, such as those made on Fonts and Colors, Environment, Options Dialog Box, will only take effect after you close and reopen Visual Studio.

모든 설정 표시Show all settings

모든 설정 표시를 선택하거나 선택 취소하면 확인을 클릭하지 않았더라도 옵션 대화 상자에서 적용한 모든 변경 내용이 적용됩니다.Selecting or unselecting Show all settings applies all changes you have made in the Options dialog box, even though you have not yet clicked OK.

참고 항목See Also

편집기 사용자 지정Customizing the Editor