옵션, 텍스트 편집기, 모든 언어Options, Text Editor, All Languages

이 대화 상자에서는 코드 편집기의 기본 동작을 변경할 수 있습니다.This dialog box allows you to change the default behavior of the Code Editor. 이러한 설정은 HTML 디자이너의 소스 뷰와 같이 코드 편집기를 기반으로 하는 다른 편집기에도 적용됩니다.These settings also apply to other editors based upon the Code Editor, such as the HTML Designer's Source view. 이 대화 상자를 열려면 도구 메뉴에서 옵션을 선택합니다.To open this dialog box, select Options from the Tools menu. 텍스트 편집기 폴더 내에서 모든 언어 하위 폴더를 확장하고 일반을 선택합니다.Within the Text Editor folder, expand the All Languages subfolder and then choose General.

주의

이 페이지에서는 모든 개발 언어에 대한 기본 옵션을 설정합니다.This page sets default options for all development languages. 이 대화 상자에서 옵션을 다시 설정하면 여기서 선택한 항목이 무엇이든 모든 언어의 일반 옵션이 다시 설정됩니다.Remember that resetting an option in this dialog will reset the General options in all languages to whatever choices are selected here. 하나의 언어에 대한 텍스트 편집기 옵션만 변경하려면 해당 언어의 하위 폴더를 확장하고 해당 옵션 페이지를 선택합니다.To change Text Editor options for just one language, expand the subfolder for that language and select its option pages.

일부 프로그래밍 언어에 대한 일반 옵션 페이지에서만 옵션이 선택된 경우 회색으로 표시된 확인 표시가 표시됩니다.A grayed checkmark is displayed when an option has been selected on the General options pages for some programming languages, but not for others.

참고

표시되는 대화 상자와 메뉴 명령은 활성 설정이나 버전에 따라 도움말에서 설명하는 것과 다를 수 있습니다.The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 설정을 변경하려면 도구 메뉴에서 설정 가져오기 및 내보내기 를 선택합니다.To change your settings, choose Import and Export Settings on the Tools menu. 자세한 내용은 Visual Studio IDE 개인 설정을 참조하세요.For more information, see Personalize the Visual Studio IDE.

문 완성Statement Completion

멤버 목록 자동 표시Auto list members
이 옵션을 선택하면 사용자가 편집기에서 입력할 때 IntelliSense에 의해 사용 가능한 멤버, 속성, 값 또는 메서드의 팝업 목록이 표시됩니다.When selected, pop-up lists of available members, properties, values, or methods are displayed by IntelliSense as you type in the editor. 팝업 목록에서 항목을 선택하여 코드에 삽입합니다.Choose any item from the pop-up list to insert the item into your code. 이 옵션을 선택하면 고급 멤버 숨기기 옵션이 사용하도록 설정됩니다.Selecting this option enables the Hide advanced members option.

고급 멤버 숨기기Hide advanced members
이 옵션을 선택하면 가장 일반적으로 사용되는 항목만 표시되므로 팝업 문 완성 목록이 축소됩니다.When selected, shortens pop-up statement completion lists by displaying only those items most commonly used. 다른 항목은 목록에서 필터링됩니다.Other items are filtered from the list.

매개 변수 정보Parameter information
이 옵션을 선택하면 현재 선언 또는 프로시저에 대한 전체 구문이 사용할 수 있는 모든 매개 변수와 함께 편집기의 삽입 지점 아래에 표시됩니다.When selected, the complete syntax for the current declaration or procedure is displayed under the insertion point in the editor, with all of its available parameters. 다음에 할당할 수 있는 매개 변수는 굵게 표시됩니다.The next parameter you can assign is displayed in bold.

설정Settings

가상 공간 활성화Enable virtual space
이 옵션을 선택하고 자동 줄 바꿈의 선택을 취소하면 코드 편집기에서 줄 끝 뒤에 있는 어느 위치든 클릭하여 내용을 입력할 수 있습니다.When this option is selected and Word wrap is cleared, you can click anywhere beyond the end of a line in the Code Editor and type. 이 기능은 코드 옆의 일관된 위치에 주석을 배치하는 데도 사용할 수 있습니다.This feature can be used to position comments at a consistent point next to your code.

단어 줄 바꿈Word wrap
이 옵션을 선택하면 줄이 편집기에서 가로로 볼 수 있는 영역을 벗어나는 경우에 자동으로 다음 줄에 표시됩니다.When selected, any portion of a line that extends horizontally beyond the viewable editor area is automatically displayed on the next line. 또한 이 옵션을 선택하면 자동 줄 바꿈 시각 문자 표시 확인란을 사용할 수 있게 됩니다.Selecting this option enables the Show visual glyphs for word wrap option.

참고

자동 줄 바꿈이 켜져 있는 동안에는 가상 공간 기능이 꺼집니다.The Virtual Space feature is turned off while Word Wrap is on.

자동 줄 바꿈 시각 문자 표시Show visual glyphs for word wrap
이 옵션을 선택하면 긴 줄이 다음 줄로 줄 바꿈되는 위치에 줄 바꿈 화살표 표시기가 표시됩니다.When selected, a return-arrow indicator is displayed where a long line wraps onto a second line.

LineBreakSymbol 스크린샷LineBreakSymbol screenshot

이러한 표시기를 표시하지 않으려면 이 옵션의 선택을 취소합니다.Clear this option if you prefer not to display these indicators.

참고

이러한 알림 화살표는 코드에 추가되거나 인쇄되지 않습니다.These reminder arrows are not added to your code, and do not print. 참조용으로만 사용됩니다.They are for reference only.

선택 영역이 없는 경우 잘라내기 또는 복사 명령을 빈 줄에 적용Apply Cut or Copy commands to blank lines when there is no selection
이 옵션은 삽입 지점을 빈 줄에 배치하고 아무것도 선택하지 않은 다음, [복사] 또는 [잘라내기]를 선택한 경우 편집기의 동작을 설정합니다.This option sets the behavior of the editor when you place the insertion point on a blank line, select nothing, and then Copy or Cut.

  • 이 옵션을 선택하면 빈 줄이 복사되거나 잘립니다.When this option is selected, the blank line is copied or cut. 그런 다음 붙여넣기를 수행하면 빈 줄이 새로 삽입됩니다.If you then Paste, a new, blank line is inserted.

  • 이 옵션의 선택을 취소하고 [잘라내기] 명령을 선택하면 빈 줄이 제거됩니다.When this option is cleared, the Cut command removes blank lines. 그러나 클립보드의 데이터는 유지됩니다.However, the data on the Clipboard is preserved. 따라서 이후 [붙여넣기] 명령을 사용하면 최근에 클립보드에 복사된 콘텐츠가 붙여넣어집니다.Therefore, if you then use the Paste command, the content most recently copied onto the Clipboard is pasted. 전에 아무것도 복사하지 않았으면 아무것도 붙여넣지 않습니다.If nothing has been copied previously, nothing is pasted.

이 설정은 줄이 비어 있지 않은 경우의 [복사] 또는 [잘라내기]에 영향을 미치지 않습니다.This setting has no effect on Copy or Cut when a line is not blank. 선택한 내용이 없는 경우에는 줄 전체가 복사되거나 잘립니다.If nothing is selected, the entire line is copied or cut. 그런 다음 [붙여넣기]를 수행하면 줄 전체의 텍스트와 해당 줄 끝 문자가 붙여넣어집니다.If you then Paste, the text of the entire line and its endline character are pasted.

공백, 탭 및 줄 끝에 대한 표시기를 나타내어 완전히 비어 있는 줄과 들여쓴 줄을 구분하려면 편집 메뉴에서 고급을 선택하고 공백 보기를 선택합니다.To display indicators for spaces, tabs, and line ends, and thus distinguish indented lines from lines that are entirely blank, select Advanced from the Edit menu and choose View White Space.

표시Display

줄 번호Line numbers
이 옵션을 선택하면 각 코드 줄 옆에 줄 번호가 나타납니다.When selected, a line number appears next to each line of code.

참고

이러한 줄 번호는 코드에 추가되거나 인쇄되지 않으며These line numbers are not added to your code, and do not print. 참조용으로만 사용됩니다.They are for reference only.

한 번 클릭으로 URL 탐색Enable single-click URL navigation
이 옵션을 선택하면 편집기에서 마우스 커서가 URL 위를 지날 때마다 가리키는 손 모양으로 변합니다.When selected, the mouse cursor changes to a pointing hand as it passes over a URL in the editor. URL을 클릭하면 표시된 페이지가 웹 브라우저에서 열립니다.You can click the URL to display the indicated page in your Web browser.

탐색 모음Navigation bar
이 옵션을 선택하면 코드 편집기 맨 위에 탐색 모음이 표시됩니다.When selected, displays the Navigation bar at the top of the code editor. 개체멤버 드롭다운 목록을 사용하여 코드에서 특정 개체를 선택하고, 멤버 중에서 선택하고, 코드 편집기에서 선택된 멤버의 선언으로 이동할 수 있습니다.Its dropdown Objects and Members lists allow you to choose a particular object in your code, select from its members, and navigates to the declaration of the selected member in the Code Editor.

참고 항목See Also

옵션, 텍스트 편집기, 모든 언어, 탭 Options, Text Editor, All Languages, Tabs
옵션 대화 상자, 환경, 일반 General, Environment, Options Dialog Box
IntelliSense 사용Using IntelliSense