옵션, 텍스트 편집기, 파일 확장명Options, Text Editor, File Extension

이 [옵션] 대화 상자에서는 특정 파일 확장명을 가진 모든 파일이 Visual Studio IDE(통합 개발 환경)에서 처리되는 방법을 지정할 수 있습니다.This Options dialog allows you to specify how all files with certain file extensions will be handled by the Visual Studio integrated development environment (IDE). 입력하는 각 확장명에 대해 편집 환경을 선택할 수 있습니다.For each Extension that you enter, you can select an Editing Experience. 이렇게 하면 특정 형식의 문서가 열리는 IDE 편집기 또는 디자이너를 선택할 수 있습니다.This allows you to choose the IDE editor or designer in which documents of a certain type will open. 이러한 옵션을 표시하려면 도구 메뉴에서 옵션을 선택하고, 텍스트 편집기 노드를 확장하고, 파일 확장명을 선택합니다.To display these options, choose Options from the Tools menu, expand the Text Editor node, and select File Extension.

“인코딩 사용” 옵션을 선택하면 해당 형식의 문서를 열 때마다 해당 문서에 대한 인코딩 체계를 선택할 수 있는 대화 상자가 표시됩니다.When you select an option "with Encoding," a dialog will be displayed whenever you open a document of that type that allows you to select an encoding scheme for that document. 다양한 플랫폼에서 또는 다양한 대상 언어로 사용할 프로젝트 문서 버전을 준비 중이라면 이 대화 상자가 유용할 수 있습니다.This can be helpful if you are preparing versions of your project documents for use on different platforms or in different target languages.

참고

표시되는 대화 상자와 메뉴 명령은 활성 설정이나 버전에 따라 도움말에서 설명하는 것과 다를 수 있습니다.The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 설정을 변경하려면 도구 메뉴에서 설정 가져오기 및 내보내기 를 선택합니다.To change your settings, choose Import and Export Settings on the Tools menu. 자세한 내용은 Visual Studio IDE 개인 설정을 참조하세요.For more information, see Personalize the Visual Studio IDE.

UI 요소 목록UIElement List

확장Extension
정의할 IDE의 편집 환경을 포함하는 파일 확장명을 입력합니다.Type the file extension whose Editing Experience in the IDE you wish to define.

편집기Editor
이 파일 확장명을 가진 문서가 열릴 IDE 편집기 또는 디자이너를 선택합니다.Select the IDE editor or designer in which documents with this file extension will open. “인코딩 사용” 옵션을 선택하면 해당 문서를 열 때마다 인코딩 체계를 선택할 수 있는 대화 상자가 표시됩니다.When you select an option "with Encoding," a dialog will be displayed whenever you open such a document that allows you to select an encoding scheme.

추가Add
지정된 확장명편집 환경을 포함하는 항목을 확장명 목록에 추가합니다.Adds an entry that includes the specified Extension and Editing Experience to the Extension List.

제거Remove
확장명 목록에서 선택한 항목을 삭제합니다.Deletes the selected entry from the Extension List.

확장명 목록Extension List
편집 환경이 지정된 모든 확장명을 나열합니다.Lists all extensions for which an Editing Experience has been specified.

확장명 없는 파일을 다음에 매핑Map extensionless files to
확장명이 없는 파일이 IDE에서 처리되는 방법을 지정할 경우 이 옵션을 선택합니다.Select this option if you wish to specify how files without an extension will be handled by the IDE.

확장명 없는 파일 옵션Extensionless file options
편집기와 동일한 목록을 제공합니다.Provides the same list as Editor. 파일 확장명이 없는 문서가 열릴 IDE 편집기 또는 디자이너를 선택합니다.Select the IDE editor or designer in which documents without file extensions will open.

참고 항목See Also

방법: 편집기 모드 관리How to: Manage Editor Modes