프로젝트 및 솔루션, 옵션 대화 상자Projects and Solutions, Options Dialog Box

프로젝트 및 솔루션과 관련된 Visual StudioVisual Studio 동작을 설정합니다.Sets Visual StudioVisual Studio behavior related to projects and solutions. 이러한 옵션에 액세스하려면 도구 > 옵션을 선택하고 프로젝트 및 솔루션을 확장한 후 일반을 클릭합니다.To access these options, select Tools > Options expand Projects and Solutions, and click General.

프로젝트 및 템플릿 폴더에 대한 기본 경로는 같은 대화 상자의 위치 탭을 통해 설정됩니다.The default paths for project and template folders are set through the Locations tab in the same dialog box.

참고

대화 상자에서 사용할 수 있는 옵션과 메뉴 명령의 이름 및 위치는 실제 설정이나 버전에 따라 도움말에서 설명하는 것과 다를 수 있습니다.The options available in dialog boxes, and the names and locations of menu commands you see, might differ from what is described in Help depending on your active settings or edition. 이 도움말 페이지는 일반 개발 설정을 염두에 두고 작성되었습니다.This Help page was written with the General Development settings in mind. 설정을 보거나 변경하려면 도구 메뉴에서 설정 가져오기 및 내보내기를 선택합니다.To view or change your settings, choose Import and Export Settings on the Tools menu. 자세한 내용은 Visual Studio IDE 개인 설정을 참조하세요.For more information, see Personalize the Visual Studio IDE.

일반 탭 옵션General tab options

오류로 인해 빌드가 종료될 때 항상 오류 목록 표시Always show Error List if build finishes with errors
프로젝트 빌드가 실패하는 경우에만 빌드 완료 시 오류 목록 창을 엽니다.Opens the Error List window on build completion, only if a project failed to build. 빌드 프로세스 중 발생하는 오류가 표시됩니다.Errors that occur during the build process are displayed. 이 옵션을 선택 취소하면 오류는 계속 발생하지만 빌드 완료 시 창이 열리지 않습니다.When this option is cleared, the errors still occur but the window does not open when the build is complete. 기본적으로 이 옵션은 사용하도록 설정됩니다.This option is enabled by default.

솔루션 탐색기에서 활성화된 항목 추적Track Active Item in Solution Explorer
이 옵션을 선택하면 솔루션 탐색기가 자동으로 열리고 활성 항목이 선택됩니다.When selected, Solution Explorer automatically opens and the active item is selected. 선택한 항목은 프로젝트 또는 솔루션에서 다른 파일로 작업하거나 디자이너에서 다른 구성 요소로 작업하면 변경됩니다.The selected item changes as you work with different files in a project or solution, or different components in a designer. 이 옵션을 선택 취소해도 솔루션 탐색기의 선택 항목이 자동으로 변경되지는 않습니다.When this option is cleared, the selection in Solution Explorer does not change automatically. 기본적으로 이 옵션은 사용하도록 설정됩니다.This option is enabled by default.

고급 빌드 구성 표시Show advanced build configurations
이 옵션을 선택하면 빌드 구성 옵션이 프로젝트 속성 페이지 대화 상자 및 솔루션 속성 페이지 대화 상자에 표시됩니다.When selected, the build configuration options appear on the Project Property Pages dialog box and the Solution Property Pages dialog box. 이 옵션을 선택 취소하면 구성 디버그 및 릴리스 하나 또는 두 개를 포함하는 Visual BasicVisual BasicVisual C#Visual C# 프로젝트의 프로젝트 속성 페이지 대화 상자와 솔루션 속성 페이지 대화 상자에 빌드 구성 옵션이 나타나지 않습니다.When cleared, the build configuration options do not appear on the Project Property Pages dialog box and the Solution Property Pages dialog box for Visual BasicVisual Basic and Visual C#Visual C# projects that contain one configuration or the two configurations debug and release. 프로젝트에 사용자 정의 구성이 있으면 빌드 구성 옵션이 표시됩니다.If a project has a user-defined configuration, the build configuration options are shown.

이 옵션을 선택 취소하면 빌드 메뉴의 명령(예: 솔루션 빌드, 솔루션 다시 빌드솔루션 지우기)이 릴리스 구성에 대해 수행되고, 디버그 메뉴의 명령(예: 디버깅 시작디버깅하지 않고 시작)이 디버그 구성에 대해 수행됩니다.When unselected, the commands on the Build menu, such as Build Solution, Rebuild Solution, and Clean Solution, are performed on the Release configuration and the commands on the Debug menu, such as Start Debugging and Start Without Debugging, are performed on the Debug configuration.

솔루션 항상 표시Always show solution
이 옵션을 선택하면 솔루션과 솔루션에서 작동하는 모든 명령이 IDE에 항상 표시됩니다.When selected, the solution and all commands that act on solutions are always shown in the IDE. 이 옵션을 선택 취소하면 모든 프로젝트가 독립 실행형 프로젝트로 만들어지고, 솔루션이 하나의 프로젝트만 포함하는 경우 IDE의 솔루션에서 작동하는 명령이나 솔루션 탐색기의 솔루션이 표시되지 않습니다.When cleared, all projects are created as stand-alone projects and you do not see the solution in Solution Explorer or commands that act on solutions in the IDE if the solution contains only one project.

만들어질 때 새 프로젝트 저장Save new projects when created
이 옵션을 선택하면 새 프로젝트 대화 상자에 프로젝트의 위치를 지정할 수 있습니다.When selected, you can specify a location for your project in the New Project dialog box. 이 옵션을 선택 취소하면 모든 새 프로젝트가 임시 프로젝트로 만들어집니다.When cleared, all new projects are created as temporary projects. 임시 프로젝트로 작업할 경우에는 디스크 위치를 지정하지 않아도 프로젝트를 만들고 사용할 수 있습니다.When you are working with temporary projects, you can create and experiment with a project without having to specify a disk location.

프로젝트 위치를 신뢰할 수 없을 때 사용자에게 경고Warn user when the project location is not trusted
완전히 신뢰할 수 없는 위치(예: UNC 경로 또는 HTTP 경로)에서 새 프로젝트를 만들거나 기존 프로젝트를 열려고 하면 메시지가 표시됩니다.If you attempt to create a new project or open an existing project in a location that is not fully trusted (for example, on a UNC path or an HTTP path), a message is displayed. 완전히 신뢰할 수 없는 위치에서 프로젝트를 만들거나 열려고 할 때마다 메시지를 표시할지 여부를 지정하려면 이 옵션을 사용합니다.Use this option to specify whether the message is displayed each time that you attempt to create or open a project in a location that is not fully trusted.

빌드를 시작할 때 출력 창 표시Show Output window when build starts
솔루션 빌드 시작 시에 IDE에 출력 창이 자동으로 표시됩니다.Automatically displays the Output Window in the IDE at the outset of solution builds. 자세한 내용은 방법: 출력 창 제어를 참조하세요.For more information, see How to: Control the Output Window.

파일 이름을 바꿀 때 기호화된 이름 바꾸기 확인Prompt for symbolic renaming when renaming files
이 옵션을 선택하면 Visual StudioVisual Studio에서 프로젝트에서 코드 요소에 대한 모든 참조 이름을 바꿀지 묻는 메시지 상자를 표시합니다.When selected, Visual StudioVisual Studio displays a message box asking whether or not it should also rename all references in the project to the code element.

파일을 새 위치로 이동하기 전에 확인Prompt before moving files to a new location
이 옵션을 선택하면 솔루션 탐색기에서 작업을 통해 파일 위치를 변경하기 전에 Visual StudioVisual Studio에서 확인 메시지 상자를 표시합니다.When selected, Visual StudioVisual Studio displays a confirmation message box before the locations of files are changed by actions in Solution Explorer.

위치 탭 옵션Locations tab options

프로젝트 위치Projects location
Visual StudioVisual Studio에서 새 프로젝트 및 솔루션 폴더를 만드는 기본 위치를 지정합니다.Specifies the default location where Visual StudioVisual Studio creates new projects and solution folders. 여러 대화 상자에서 이 옵션에 설정된 위치가 폴더 시작 지점으로 사용되기도 합니다.Several dialog boxes also use the location set in this option for folder starting points. 예를 들어 프로젝트 열기 대화 상자에서는 내 프로젝트 바로 가기에 이 위치가 사용됩니다.For example, the Open Project dialog box uses this location for the My Projects shortcut.

사용자 프로젝트 템플릿 위치User project templates location
새 프로젝트 대화 상자에서 내 템플릿 목록을 만드는 데 사용하는 기본 위치를 지정합니다.Specifies the default location that the New Project dialog box uses to create the list of My Templates. 자세한 내용은 방법: 템플릿 찾기 및 구성을 참조하세요.For more information, see How to: Locate and Organize Templates.

사용자 항목 템플릿 위치User item templates location
새 항목 추가 대화 상자에서 내 템플릿 목록을 만드는 데 사용하는 기본 위치를 지정합니다.Specifies the default location that the Add New Item dialog box uses to create the list of My Templates. 자세한 내용은 방법: 템플릿 찾기 및 구성을 참조하세요.For more information, see How to: Locate and Organize Templates.

참고 항목See Also