Visual Studio의 솔루션 및 프로젝트Solutions and projects in Visual Studio

프로젝트Projects

Visual Studio에서 앱, 웹 사이트, 플러그인 등을 만들 때 프로젝트를 시작합니다.When you create an app, website, plug-in, etc. in Visual Studio, you start with a project. 논리적인 측면에서 프로젝트에는 실행 파일, 라이브러리 또는 웹 사이트로 컴파일되는 모든 소스 코드 파일, 아이콘, 이미지, 데이터 파일 등이 포함됩니다.In a logical sense, a project contains all the source code files, icons, images, data files, etc. that are compiled into an executable, library, or website. 프로젝트에도 프로그램이 통신하는 여러 서비스 또는 구성 요소에 필요할 수 있는 컴파일러 설정 및 기타 구성 파일이 포함되어 있습니다.A project also contains compiler settings and other configuration files that might be needed by various services or components that your program communicates with.

참고

Visual Studio에서 코드를 편집, 빌드 및 디버깅하기 위해 솔루션이나 프로젝트를 사용할 필요는 없습니다.You don't have to use solutions or projects in Visual Studio to edit, build and debug code. Visual Studio에서 소스 파일이 들어 있는 폴더를 열고 편집을 시작하면 됩니다.You can simply open the folder that contains your source files in Visual Studio and start editing. 자세한 내용은 프로젝트 또는 솔루션 없이 Visual Studio에서 코드 개발을 참조하세요.For more information, see Develop code in Visual Studio without projects or solutions.

프로젝트는 .vbproj, .csproj 또는 .vcxproj와 같은 확장명의 XML 파일로 정의됩니다.A project is defined in an XML file with an extension such as .vbproj, .csproj, or .vcxproj. 이 파일에는 가상 폴더 계층과 프로젝트의 모든 항목에 대한 경로가 포함됩니다.This file contains a virtual folder hierarchy, and paths to all the items in the project. 빌드 설정을 포함합니다.It also contains the build settings.

Visual Studio에서 프로젝트 파일의 콘텐츠를 보려면 먼저 솔루션 탐색기에서 프로젝트 이름을 선택하고 상황에 맞는 메뉴 또는 마우스 오른쪽 단추를 클릭하여 나타나는 메뉴에서 언로드 프로젝트를 선택하여 프로젝트를 언로드합니다.To look at the contents of a project file in Visual Studio, first unload the project by selecting the project name in Solution Explorer and choosing Unload Project from the context or right-click menu. 그런 다음 상황에 맞는 메뉴를 다시 열고 <projectname> 편집을 선택합니다.Then, open the context menu again and choose Edit <projectname>.

Visual Studio에서 프로젝트 파일은 솔루션 탐색기에서 프로젝트 내용 및 설정을 표시하는 데 사용됩니다.In Visual Studio, the project file is used by Solution Explorer to display the project contents and settings. 프로젝트를 컴파일할 때 MSBuild 엔진은 프로젝트 파일을 사용하여 실행 파일을 만듭니다.When you compile your project, the MSBuild engine consumes the project file to create the executable. 또한 다른 종류의 출력을 생성하는 프로젝트를 사용자 지정할 수 있습니다.You can also customize projects to produce other kinds of output.

솔루션Solutions

프로젝트는 솔루션에 포함되어 있습니다.A project is contained within a solution. 솔루션에는 빌드 정보, Visual Studio 창 설정 및 특정 프로젝트와 관련이 없는 기타 파일과 함께 하나 이상의 관련된 프로젝트가 포함됩니다.A solution contains one or more related projects, along with build information, Visual Studio window settings, and any miscellaneous files that aren't associated with a particular project. 솔루션은 고유한 형식을 가진 텍스트 파일(.sln 확장명)으로 설명되고 직접 편집할 수 없습니다.A solution is described by a text file (extension .sln) with its own unique format; it is not intended to be edited by hand.

솔루션에는 프로젝트에 참여한 각 사용자에 대한 설정, 기본 설정 및 구성 정보를 저장하는 연결된 .suo 파일이 있습니다.A solution has an associated .suo file that stores settings, preferences, and configuration information for each user that has worked on the project.

새 프로젝트 만들기Create new projects

새 프로젝트를 만드는 가장 쉬운 방법은 특정 유형의 응용 프로그램이나 웹 사이트에 대한 프로젝트 템플릿에서 시작하는 것입니다.The easiest way to create a new project is to start from a project template for a particular type of application or website. 프로젝트 템플릿은 미리 생성된 코드 파일, 구성 파일, 자산 및 설정의 기본 집합으로 구성됩니다.A project template consists of a basic set of pre-generated code files, config files, assets, and settings. 이러한 템플릿은 파일 > 새로 만들기 > 프로젝트 또는 파일 > 새로 만들기 > 웹 사이트를 선택하면 표시되는 새 프로젝트 또는 새 웹 사이트 대화 상자에서 확인할 수 있습니다.These templates are what you see in the New Project or New Web Site dialog box when you choose File > New > Project or File > New > Web Site. 자세한 내용은 솔루션 및 프로젝트 만들기를 참조하세요.For more information, see Create solutions and projects.

사용자 지정 프로젝트 및 항목 템플릿을 만들 수도 있습니다.You can also create custom project and item templates. 자세한 내용은 프로젝트 템플릿 및 항목 템플릿 만들기를 참조하세요.For more information, see Create project and item templates.

솔루션 탐색기의 프로젝트 관리Manage projects in Solution Explorer

새 프로젝트를 만든 후에 솔루션 탐색기 를 사용하여 프로젝트와 솔루션 및 연결된 항목을 볼 수 있고 관리할 수 있습니다.After you create a new project, you can use Solution Explorer to view and manage the project and solution, and their associated items. 다음 그림은 두 프로젝트가 포함되어 있으며, C# 솔루션을 사용하는 솔루션 탐색기를 보여 줍니다.The following illustration shows Solution Explorer with a C# solution that contains two projects.

솔루션 탐색기

참고 항목See also