Visual Studio의 솔루션 및 프로젝트Solutions and projects in Visual Studio

이 페이지에서는 Visual Studio의 ‘프로젝트’ 및 ‘솔루션’ 개념에 대해 설명합니다. This page describes the concept of a project and a solution in Visual Studio. 솔루션 탐색기 도구 창과 새 프로젝트를 만드는 방법에 대해서도 간략하게 설명합니다.It also briefly covers the Solution Explorer tool window and how to create a new project.

참고

이 토픽은 Windows용 Visual Studio에만 적용됩니다.This topic applies to Visual Studio on Windows. Mac용 Visual Studio는 Mac용 Visual Studio의 프로젝트 및 솔루션을 참조하세요.For Visual Studio for Mac, see Projects and solutions in Visual Studio for Mac.

프로젝트Projects

Visual Studio에서 앱이나 웹 사이트를 만드는 경우 ‘프로젝트’에서 시작합니다.When you create an app or website in Visual Studio, you start with a project. 논리적인 측면에서 프로젝트에는 실행 파일, 라이브러리 또는 웹 사이트로 컴파일되는 모든 파일이 포함됩니다.In a logical sense, a project contains all files that are compiled into an executable, library, or website. 이러한 파일에는 소스 코드, 아이콘, 이미지, 데이터 파일 등이 포함될 수 있습니다.Those files can include source code, icons, images, data files, and so on. 프로젝트에도 프로그램이 통신하는 여러 서비스 또는 구성 요소에 필요할 수 있는 컴파일러 설정 및 기타 구성 파일이 포함되어 있습니다.A project also contains compiler settings and other configuration files that might be needed by various services or components that your program communicates with.

프로젝트 파일Project file

Visual Studio는 MSBuild를 사용하여 솔루션의 각 프로젝트를 빌드하고, 각 프로젝트에는 MSBuild 프로젝트 파일이 포함됩니다.Visual Studio uses MSBuild to build each project in a solution, and each project contains an MSBuild project file. 파일 확장명은 C# 프로젝트(.csproj), Visual Basic 프로젝트(.vbproj), 데이터베이스 프로젝트(.dbproj)와 같이 프로젝트 형식을 반영합니다.The file extension reflects the type of project, for example, a C# project (.csproj), a Visual Basic project (.vbproj), or a database project (.dbproj). 프로젝트 파일은 콘텐츠, 플랫폼 요구 사항, 버전 관리 정보, 웹 서버 또는 데이터베이스 서버 설정, 수행할 작업 등을 포함하여 MSBuild에서 프로젝트를 빌드하는 데 필요한 모든 정보와 지침이 포함된 XML 문서입니다.The project file is an XML document that contains all the information and instructions that MSBuild needs in order to build your project, including the content, platform requirements, versioning information, web server or database server settings, and the tasks to perform.

프로젝트 파일은 MSBuild XML 스키마를 기반으로 합니다.Project files are based on the MSBuild XML schema. Visual Studio에서 최신 SDK 스타일 프로젝트 파일의 내용을 살펴보려면, 솔루션 탐색기 에서 프로젝트 노드를 마우스 오른쪽 단추로 클릭하고 <projectname> 편집 을 선택합니다.To look at the contents of newer, sdk-style project files in Visual Studio, right-click on the project node in Solution Explorer and select Edit <projectname>. 해당 스타일의 다른 프로젝트와 .NET Framework의 내용을 살펴보려면, 솔루션 탐색기 에서 프로젝트 노드를 마우스 오른쪽 단추로 클릭하고 프로젝트 언로드 를 선택하여 프로젝트를 먼저 언로드합니다.To look at the contents of .NET Framework and other projects of that style, first unload the project (right-click on the project node in Solution Explorer and select Unload Project). 그런 다음, 프로젝트를 마우스 오른쪽 단추로 클릭하고 <projectname> 편집 을 선택합니다.Then, right-click on the project and choose Edit <projectname>.

참고

Visual Studio에서 코드를 편집, 빌드, 디버그하기 위해 솔루션이나 프로젝트를 사용할 필요는 없습니다.You don't have to use solutions or projects in Visual Studio to edit, build, and debug code. Visual Studio에서 소스 파일이 들어 있는 폴더를 열고 편집을 시작하면 됩니다.You can simply open the folder that contains your source files in Visual Studio and start editing. 자세한 내용은 프로젝트 또는 솔루션 없이 Visual Studio에서 코드 개발을 참조하세요.For more information, see Develop code in Visual Studio without projects or solutions.

새 프로젝트 만들기Create new projects

새 프로젝트를 만드는 가장 쉬운 방법은 원하는 프로젝트 형식에 맞는 프로젝트 템플릿을 사용하는 것입니다.The easiest way to create a new project is to use a project template for the project type you want. 프로젝트 템플릿에는 미리 생성된 코드 파일, 구성 파일, 자산, 설정의 기본 세트가 포함됩니다.A project template includes a basic set of pre-generated code files, config files, assets, and settings. 파일 > 새로 만들기 > 프로젝트 를 사용하여 프로젝트 템플릿을 선택합니다.Use File > New > Project to select a project template. 자세한 내용은 새 프로젝트 만들기를 참조하세요.For more information, see Create a new project.

새 프로젝트를 만드는 데 사용할 수 있는 사용자 지정 프로젝트 템플릿을 만들 수도 있습니다.You can also create a custom project template that you can use to create new projects from. 자세한 내용은 프로젝트 템플릿 및 항목 템플릿 만들기를 참조하세요.For more information, see Create project and item templates.

새 프로젝트를 만들면 Visual Studio에서 기본 위치인 %USERPROFILE%\source\repos 에 저장합니다.When you create a new project, Visual Studio saves it to its default location, %USERPROFILE%\source\repos. 이 위치를 변경하려면 도구 > 옵션 > 프로젝트 및 솔루션 > 위치 로 이동합니다.To change this location, go to Tools > Options > Projects and Solutions > Locations. 자세한 내용은 옵션 대화 상자: 프로젝트 및 솔루션 > 위치를 참조하세요.For more information, see Options dialog box: Projects and Solutions > Locations.

솔루션Solutions

프로젝트는 솔루션 에 포함되어 있습니다.A project is contained within a solution. 이름과 달리 솔루션은 "정답"이 아닙니다.Despite its name, a solution is not an "answer". 이는 간단히 빌드 정보, Visual Studio 창 설정 및 특정 프로젝트와 관련이 없는 기타 파일과 함께 하나 이상의 관련된 프로젝트를 위한 컨테이너입니다.It's simply a container for one or more related projects, along with build information, Visual Studio window settings, and any miscellaneous files that aren't associated with a particular project.

솔루션 파일Solution file

Visual Studio에서는 두 가지 파일 형식( .sln.suo)을 사용하여 솔루션 관련 설정을 저장합니다.Visual Studio uses two file types (.sln and .suo) to store settings for solutions:

확장명Extension 이름Name 설명Description
.sln.sln Visual Studio 솔루션Visual Studio Solution 솔루션에서 프로젝트, 프로젝트 항목 및 솔루션 항목을 구성합니다.Organizes projects, project items, and solution items in the solution.
.suo.suo 솔루션 사용자 옵션Solution User Options 중단점과 같은 사용자 수준 설정 및 사용자 지정을 저장합니다.Stores user-level settings and customizations, such as breakpoints.

중요

솔루션은 고유한 형식을 가진 텍스트 파일( .sln 확장명)로 설명되고 직접 편집할 수 없습니다.A solution is described by a text file (extension .sln) with its own unique format; it's not intended to be edited by hand. 반대로 .suo 파일은 파일 탐색기의 기본 설정으로는 표시되지 않는 숨겨진 파일입니다.Conversely, the .suo file is a hidden file that is not displayed under the default File Explorer settings. 숨겨진 파일을 표시하려면 파일 탐색기의 보기 메뉴에서는 숨겨진 항목 확인란을 선택합니다.To show hidden files, on the View menu in File Explorer, select the Hidden Items checkbox.

솔루션 폴더Solution folder

"솔루션 폴더"는 솔루션 탐색기 에만 있는 가상 폴더이며 솔루션에서 프로젝트를 그룹화하는 데 사용할 수 있습니다.A "solution folder" is a virtual folder that's only in Solution Explorer, where you can use it to group projects in a solution. 컴퓨터에서 솔루션 파일을 찾으려면 도구 > 옵션 > 프로젝트 및 솔루션 > 위치 로 이동합니다.If you want to locate a solution file on a computer, go to Tools > Options > Projects and Solutions > Locations. 자세한 내용은 옵션 대화 상자: 프로젝트 및 솔루션 > 위치를 참조하세요.For more information, see Options dialog box: Projects and Solutions > Locations.

처음부터 프로젝트 및 솔루션을 만들고 단계별 지침 및 샘플 코드를 사용하여 완료하는 예제는 프로젝트 및 솔루션 소개를 참조하세요.For an example of a project and solution created from scratch, complete with step-by-step instructions and sample code, see Introduction to projects and solutions.

솔루션 탐색기Solution Explorer

새 프로젝트를 만든 후에 솔루션 탐색기 를 사용하여 프로젝트와 솔루션 및 연결된 항목을 보고 관리할 수 있습니다.After you create a new project, you can use Solution Explorer to view and manage the project and solution and their associated items. 다음 그림은 두 프로젝트가 포함되어 있으며, C# 솔루션을 사용하는 솔루션 탐색기 를 보여 줍니다.The following illustration shows Solution Explorer with a C# solution that contains two projects:

두 프로젝트가 있는 솔루션 탐색기의 스크린샷

솔루션 탐색기 의 위쪽에 있는 도구 모음에는 솔루션 보기를 폴더 보기로 전환하고 숨겨진 파일을 표시하고 모든 노드를 축소하는 등의 작업을 위한 단추가 있습니다.The toolbar across the top of Solution Explorer has buttons to switch from a solution view to a folder view, show hidden files, collapse all nodes, and more.

Visual Studio 2019의 프로젝트 두 개가 있는 솔루션 탐색기의 스크린샷

솔루션 탐색기 위쪽에 있는 도구 모음에는 솔루션 보기를 폴더 보기로 전환하고 보류 중인 변경 내용을 필터링하고 모든 파일을 표시하고 모든 노드를 축소하고 속성 페이지를 표시하고 코드 편집기에서 코드를 미리 보는 등의 작업을 위한 단추가 있습니다.The toolbar across the top of Solution Explorer has buttons to switch from a solution view to a folder view, filter pending changes, show all files, collapse all nodes, view properties pages, preview code in the code editor, and more.

대부분의 메뉴 명령은 솔루션 탐색기 에 있는 다양한 항목의 마우스 오른쪽 단추 클릭 상황에 맞는 메뉴에서 사용할 수 있습니다.Many menu commands are available from the right-click context menu on various items in Solution Explorer. 이러한 명령에는 프로젝트 빌드, NuGet 패키지 관리, 참조 추가, 파일 이름 바꾸기, 테스트 실행 등이 포함됩니다.These commands include building a project, managing NuGet packages, adding a reference, renaming a file, and running tests, just to name a few.

ASP.NET Core 프로젝트의 경우에는 파일이 솔루션 탐색기 에 중첩되는 방식을 사용자 지정할 수 있습니다.For ASP.NET Core projects, you can customize how files are nested in Solution Explorer. 자세한 내용은 솔루션 탐색기에서 파일 중첩 사용자 지정을 참조하세요.For more information, see Customize file nesting in Solution Explorer.

솔루션 탐색기를 닫은 후 다시 열려면 메뉴 모음에서 보기 > 솔루션 탐색기 를 선택하거나 Ctrl+Alt+L 을 누릅니다.If you've closed Solution Explorer and you want to open it again, choose View > Solution Explorer from the menu bar, or press Ctrl+Alt+L. 그리고, 사이드 탭을 닫은 후 해당 탭을 기본 위치로 복원하려면 메뉴 모음에서 > 창 레이아웃 다시 설정 을 선택합니다.And, if you've closed side tabs and you want to restore them to their default locations, choose Window > Reset Window Layout from the menu bar.

참고

Visual Studio에 표시되는 애플리케이션 이미지와 아이콘을 보려면 Visual Studio 이미지 라이브러리를 다운로드합니다.To view the application images and icons that appear in Visual Studio, download the Visual Studio Image Library.

추가 정보See also