작업 목록 사용Using the Task List

작업 목록 을 사용하여 TODOHACK같은 토큰 또는 사용자 지정 토큰을 사용하는 코드 주석을 추적하고 코드에서 미리 정의된 위치로 직접 연결되는 바로 가기를 관리합니다.Use the Task List to track code comments that use tokens such as TODO and HACK, or custom tokens, and to manage shortcuts that will take you directly to a predefined location in the code. 목록의 항목을 클릭하면 소스 코드의 해당 위치로 이동합니다.Click on the item in the list to go to its location in the source code.

항목 내용:In this topic:

작업 목록 창The Task List window

작업 목록 이 열리면서 응용 프로그램 창의 아래쪽에 나타납니다.When the Task List is open, it appears at the bottom of the application window.

작업 목록을 열려면To open the Task List

  • 보기 메뉴에서 작업 목록(키보드: Ctrl+\,T)을 선택합니다.On the View menu, choose Task List (Keyboard: Ctrl+\,T).

    작업 목록 창Task List window

목록의 정렬 순서를 변경하려면To change the sort order of the list

  • 열 머리글을 클릭합니다.Click the header of any column. 검색 결과를 더 구체화하려면 Shift 키를 누르고 두 번째 열 머리글을 클릭합니다.To further refine your search results, press Shift and click a second column header.

    또는 바로 가기 메뉴에서 정렬 기준을 선택하고 머리글을 선택합니다.As an alternative, on the shortcut menu, choose Sort by, and choose a header. 검색 결과를 더 구체화하려면 Shift 키를 누르고 두 번째 머리글을 선택합니다.To further refine your search results, press Shift and choose a second header.

열을 표시하거나 숨기려면To show or hide columns

  • 바로 가기 메뉴에서 열 표시를 선택합니다.On the shortcut menu, choose Show Columns. 표시하거나 숨길 열을 선택합니다.Choose the columns that you want to show or hide.

열 순서를 변경하려면To change the order of the columns

  • 열 머리글을 원하는 위치로 끕니다.Drag any column header to the location that you want.

사용자 작업User Tasks

사용자 작업 기능이 Visual Studio 2015에서 제거되었습니다.The user task feature has been removed in Visual Studio 2015. Visual Studio 2015에서 Visual Studio 2013 이전 버전의 사용자 작업 데이터가 들어 있는 솔루션을 열 경우 .suo 파일의 사용자 작업 데이터는 영향을 받지 않지만, 사용자 작업이 작업 목록에 표시되지 않습니다.When you open a solution which has user task data from Visual Studio 2013 and earlier in Visual Studio 2015, the user task data in your .suo file will not be affected, but the user tasks will not be displayed in the task list.

사용자 작업 데이터에 계속 액세스하여 업데이트하려면 Visual Studio 2013에서 프로젝트를 열고 사용자 작업 내용을 기본 프로젝트 관리 도구(예: Team Foundation Server)에 복사해야 합니다.If you wish to continue to access and update your user task data, you should open the project in Visual Studio 2013 and copy the content of any user tasks into your preferred project management tool (such as Team Foundation Server).

토큰 및 주석Tokens and comments

주석 마커 뒤에 오는 코드의 주석과 미리 정의된 토큰도 작업 목록 창에 나타납니다.A comment in your code preceded by a comment marker and a predefined token will also appear in the Task List window. 예를 들어 다음 C# 주석은 세 개의 구분된 부분으로 되어 있습니다.For example, the following C# comment has three distinct parts:

  • 주석 마커(//)The comment marker (//)

  • 예: 토큰(TODO)The token, for example (TODO)

  • 주석(텍스트의 나머지 부분)The comment (the rest of the text)

// TODO: Load state from previously suspended application  

TODO 는 미리 정의된 토큰이므로 이 주석은 목록에 TODO 작업으로 표시됩니다.Because TODO is a predefined token, this comment appears as a TODO task in the list.

사용자 지정 토큰Custom tokens

기본적으로 Visual Studio에는 HACK, TODO, UNDONE, NOTE 토큰이 포함됩니다.By default, Visual Studio includes the following tokens: HACK, TODO, UNDONE, NOTE. 이러한 토큰은 대/소문자를 구분하지 않습니다.These are not case sensitive.

또한 사용자가 직접 토큰을 만들 수도 있습니다.You can also create your own custom tokens.

사용자 지정 토큰을 만들려면To create a custom token
  1. 도구 메뉴에서 옵션을 선택합니다.On the Tools menu, choose Options.

  2. 환경 폴더를 연 다음 작업 목록을 선택합니다.Open the Environment folder and then choose Task List.

    Task List, Environment, Options Dialog Box 가 표시됩니다.The Task List, Environment, Options Dialog Box is displayed.

    Visual Studio 작업 목록Visual Studio Task List

  3. 토큰 범주에서 이름 텍스트 상자에 토큰 이름(예: “BUG”)을 입력합니다.In the Tokens category, in the Name text box, enter your token name, for example "BUG".

  4. 우선 순위 드롭다운 목록에서 새 토큰의 기본 우선 순위를 선택합니다.In the Priority drop-down list, choose a default priority for the new token. 추가 단추를 선택합니다.Choose the Add button.

C++ TODO 주석C++ TODO comments

기본적으로 C++ TODO 주석은 작업 목록 창에 표시됩니다.By default, C++ TODO comments are displayed in the Task List window. 이 동작을 변경할 수 있습니다.You can change this behavior.

C++ TODO 주석을 끄려면To turn off C++ TODO comments
  1. 도구 메뉴에서 옵션 | 텍스트 편집기 | C/C++ | 보기 | 주석 작업 열거로 이동한 다음 값을 false로 설정합니다.On the Tools menu, go to Options | Text Editor | C/C++ | View | Enumerate Comment Tasks and set the value to false.

  2. 옵션 대화 상자에서 텍스트 편집기를 엽니다.In the Options dialog box, open Text Editor.

  3. C/C++에서 보기를 선택한 다음 주석 작업 열거False로 설정합니다.Under C/C++, choose View, and then set Enumerate Comment Tasks to False.

바로 가기Shortcuts

바로 가기작업 목록에서 추적되는 코드의 책갈피이며, 일반 책갈피와 다른 아이콘이 사용됩니다.A shortcut is a bookmark in the code that is tracked in the Task List; it has a different icon than a regular bookmark. 작업 목록 의 바로 가기를 두 번 클릭하여 코드의 해당 위치로 이동합니다.Double-click the shortcut in the Task List to go to the corresponding location in the code.

Visual Studio 작업 목록 바로 가기 아이콘Visual Studio Task List Shortcut Icon

바로 가기를 만들려면To create a shortcut

  • 바로 가기를 저장할 코드에 포인터를 삽입합니다.Insert the pointer into the code where you want to place a shortcut. 편집 | 책갈피 | 작업 목록 바로 가기 추가를 선택하거나 키보드에서 Ctrl+K, Ctrl+H를 누릅니다.Choose Edit | Bookmarks | Add Task List Shortcut or press (Keyboard: Ctrl+K, Ctrl+H).

    코드에서 바로 가기를 탐색하려면 목록에서 바로 가기를 선택한 다음 바로 가기 메뉴에서 다음 작업 또는 이전 작업 을 선택합니다.To navigate through the shortcuts in the code, choose a shortcut in the list, and then choose Next Task or Previous Task from the shortcut menu.

참고 항목See Also

옵션 대화 상자, 환경, 작업 목록Task List, Environment, Options Dialog Box