Visual Studio IDE 개요Visual Studio IDE overview

Visual Studio IDE(대화형 개발 환경)는 코드를 보고 편집한 다음, 앱을 디버그, 빌드 및 게시하는 데 사용할 수 있는 창의적인 실행 패드입니다.The Visual Studio interactive development environment (IDE) is a creative launching pad that you can use to view and edit code, and then debug, build, and publish an app.

Visual Studio는 Windows 및 Mac에서 사용할 수 있습니다.Visual Studio is available for Windows and Mac. Mac용 Visual Studio에는 Visual Studio 2017과 동일한 기능이 많이 있으며 플랫폼 간 및 모바일 앱 개발을 위한 최적화되어 있습니다.Visual Studio for Mac has many of the same features as Visual Studio 2017, and is optimized for developing cross-platform and mobile apps.

이 문서에서는 Windows용 Visual Studio 2017에 대해 중점적으로 설명합니다.This article focuses on Visual Studio 2017 for Windows. IDE의 기본 기능을 소개합니다.It introduces you to the basic features of the IDE. 간단한 프로젝트 만들기, 코딩 도구로 IntelliSense 사용, 앱을 디버깅하여 프로그램 실행 중 변수 값을 확인하는 방법 등 Visual Studio로 수행할 수 있는 몇 가지 작업을 살펴보겠습니다.We'll walk through some things you can do with Visual Studio, including creating a simple project, using IntelliSense as a coding aid, and debugging an app to see the value of a variable during the program's execution. 또한 다양한 도구 창을 살펴보겠습니다.We'll also take a tour of the various tool windows.

Visual Studio IDE 설치Install the Visual Studio IDE

시작하려면 Visual Studio 2017을 다운로드하여 시스템에 설치합니다.To get started, download Visual Studio 2017 and install it on your system.

모듈식 설치 관리자를 사용하면 선호하는 프로그래밍 언어 또는 플랫폼에 필요한 기능 그룹인 워크로드를 선택하여 설치할 수 있습니다.The modular installer enables you to choose and install workloads, which are groups of features needed for the programming language or platform you prefer. 프로그램 생성 단계를 수행하려면 설치 중에 .NET Core 플랫폼 간 개발 워크로드를 선택해야 합니다.To follow the steps for creating a program, be sure to select the .NET Core cross-platform development workload during installation. Visual Studio에서 C++ 시작과 같은 빠른 시작 항목에는 다른 워크로드를 설치하는 방법에 대한 지침이 포함되어 있습니다.The quickstart topics, such as Get started with C++ in Visual Studio, contain instructions for installing other workloads.

Visual Studio 설치 관리자

Visual Studio를 처음 시작하면 필요에 따라 Microsoft 계정이나 회사 또는 학교 계정으로 로그인할 수 있습니다.When you start Visual Studio for the first time, you can optionally sign in using your Microsoft account, or your work or school account.

IDE 둘러보기Tour of the IDE

다음 이미지에서는 Visual Studio에 대한 높은 수준의 시각적 개요를 제공하기 위해 열려 있는 프로젝트가 있는 Visual Studio와 가장 많이 사용하는 몇 가지 주요 도구 창을 보여 줍니다.To give you a high-level visual overview of Visual Studio, the following image shows Visual Studio with an open project along with several key tool windows you will most likely use:

Visual Studio IDE

  • 솔루션 탐색기 - 코드 파일을 보고, 탐색하고, 관리할 수 있습니다.Solution Explorer lets you view, navigate, and manage your code files. 솔루션 탐색기에서 파일을 솔루션 및 프로젝트로 그룹화하여 코드를 구성할 수 있습니다.Solution Explorer can help organize your code by grouping the files into solutions and projects.

  • 대부분의 시간을 보낼 가능성이 있는 편집기 창은 코드를 보여주고 이를 통해 소스 코드를 편집하고 UI를 디자인할 수 있습니다.The editor window, where you'll likely spend a majority of your time, shows your code and enables you to edit source code and design a UI.

  • 출력 창에는 디버깅 및 오류 메시지, 컴파일러 경고, 게시 상태 메시지 등의 Visual Studio 알림이 표시됩니다.The Output window is where Visual Studio sends its notifications, such as debugging and error messages, compiler warnings, publishing status messages, and more. 각 메시지 원본에 해당하는 탭이 있습니다.Each message source has its own tab.

  • 팀 탐색기(VSTS) - Git, TFVC(Team Foundation 버전 제어) 등의 버전 제어 기술을 통해 작업 항목을 추적하고 다른 사용자와 코드를 공유할 수 있습니다.Team Explorer (VSTS) lets you track work items and share code with others using version control technologies such as Git and Team Foundation Version Control (TFVC).

다음은 Visual Studio의 다른 인기 있는 생산성 기능입니다.Following are some other popular productivity features in Visual Studio:

  • 리팩터링에는 변수의 지능형 이름 바꾸기, 선택한 코드 줄을 별도 함수로 이동, 코드를 다른 위치로 이동, 함수 매개 변수 다시 정렬 등의 작업이 포함되어 있습니다.Refactoring includes operations such as intelligent renaming of variables, moving selected lines of code into a separate function, moving code to other locations, reordering function parameters, and more.

    리팩터링

  • IntelliSense 는 편집기에서 직접 코드에 대한 형식 정보를 표시하고 경우에 따라 약간의 코드를 자동으로 작성하는 인기 있는 기능 집합에 대한 포괄적인 용어입니다.IntelliSense is an umbrella term for a set of popular features that display type information about your code directly in the editor and, in some cases, write small bits of code for you. IntelliSense는 별도의 도움말 창에서 형식 정보를 조회할 필요가 없도록 기본 설명서를 편집기에 인라인으로 포함하는 것과 같습니다.It's like having basic documentation inline in the editor, which saves you from having to look up type information in a separate help window. IntelliSense 기능은 언어에 따라 달라집니다.IntelliSense features vary by language. 자세한 내용은 C# IntelliSense, Visual C++ IntelliSense, JavaScript IntelliSenseVisual Basic IntelliSense를 참조하세요.For more information, see C# IntelliSense, Visual C++ IntelliSense, JavaScript IntelliSense, and Visual Basic IntelliSense. 다음 그림에서는 일부 IntelliSense 기능의 작동을 보여 줍니다.The following illustration shows some IntelliSense features at work:

    Visual Studio 멤버 목록

  • 빠른 실행 검색 상자는 Visual Studio에서 필요한 항목을 빠르게 찾을 수 있는 좋은 방법입니다.The Quick Launch search box is a great way to rapidly find what you need in Visual Studio. 찾으려는 이름을 입력하기만 하면 Visual Studio는 원하는 곳으로 정확하게 안내하는 결과를 나열합니다.Just start typing in the name of whatever you are looking for, and Visual Studio lists results that take you exactly where you want to go. 빠른 실행은 작업 또는 개별 구성 요소에 대한 Visual Studio 설치 관리자를 시작하는 링크도 표시합니다.Quick Launch also shows links that start Visual Studio Installer for any workload or individual component.

    빠른 실행 검색 상자

  • 오류 표시선은 물결 모양의 밑줄이며, 입력할 때 코드의 오류 또는 잠재적인 문제를 실시간으로 알려줍니다.Squiggles are wavy underlines that alert you to errors or potential problems in your code in real time as you type. 이렇게 하면 컴파일 또는 런타임 중에 오류를 발견할 때까지 기다리지 않고 바로 수정할 수 있습니다.This enables you to fix them immediately without waiting for the error to be discovered during compilation or run time. 오류 표시선 위로 마우스를 가져가면 오류에 대한 추가 정보가 표시됩니다.If you hover over the squiggle, you see additional information about the error. 오류를 수정하기 위한 작업과 함께 전구가 왼쪽 여백에 나타날 수도 있습니다.A light bulb may also appear in the left margin with actions to fix the error. 자세한 내용은 빠른 작업을 참조하세요.For more information, see Quick Actions.

    오류 표시선

  • 텍스트 편집기의 상황에 맞는 메뉴에서 호출 계층 구조 창을 열어 캐럿(삽입 지점) 아래에서 호출하는 메서드와 이 메서드로 호출되는 메서드를 표시할 수 있습니다.The Call Hierarchy window can be opened on the text editor context menu to show the methods that call, and are called by, the method under the caret (insertion point).

    호출 계층 구조 창

  • 코드 렌즈를 사용하면 편집기 내에서 코드 참조, 코드 변경 내용, 연결된 버그, 작업 항목, 코드 검토 및 단위 테스트를 확인할 수 있습니다.CodeLens enables you to find references and changes to your code, linked bugs, work items, code reviews, and unit tests, all without leaving the editor.

    CodeLens

  • 정의 보기 창은 현재 컨텍스트를 벗어나지 않고 메서드 또는 형식 정의를 인라인으로 표시합니다.The Peek to Definition window shows a method or type definition inline, without navigating away from your current context.

    정의 보기

  • 정의로 이동 상황에 맞는 메뉴 옵션은 함수 또는 개체가 정의된 위치로 바로 이동합니다.The Go To Definition context menu option takes you directly to the place where the function or object is defined. 편집기에서 마우스 오른쪽 단추를 클릭하면 다른 탐색 명령도 사용할 수 있습니다.Other navigation commands are also available by right-clicking in the editor.

    정의로 이동

프로그램 만들기Create a program

이제 새롭고 간단한 프로그램을 만들어 보겠습니다.Let's dive in and create a new, simple program.

  1. Visual Studio를 엽니다.Open Visual Studio. 메뉴에서 파일 > 새로 만들기 > 프로젝트를 선택합니다.On the menu, choose File > New > Project.

    메뉴 모음의 파일 > 새 프로젝트

  2. 새 프로젝트 대화 상자에는 여러 프로젝트 템플릿이 표시됩니다.The New Project dialog box shows several project templates. 템플릿에는 지정된 프로젝트 형식에 필요한 기본 파일과 설정이 포함되어 있습니다.A template contains the basic files and settings needed for a given project type. Visual C# 에서 .NET Core 범주를 선택한 다음 콘솔 앱(.NET Core) 템플릿을 선택합니다.Choose the .NET Core category under Visual C#, and then choose the Console App (.NET Core) template. 이름 텍스트 상자에 HelloWorld를 입력한 다음, 확인 단추를 선택합니다.In the Name text box, type HelloWorld, and then select the OK button.

    .NET Core 앱 템플릿

    Visual Studio가 프로젝트를 만듭니다.Visual Studio creates the project. 이 프로젝트는 Console.WriteLine() 메서드를 호출하여 리터럴 문자열 “Hello World!”를 표시하는 간단한 “Hello World” 응용 프로그램입니다.It's a simple "Hello World" application that calls the Console.WriteLine() method to display the literal string "Hello World!" 콘솔 창에 표시합니다.in the console window.

    참고

    .NET Core 범주가 표시되지 않으면 .NET Core 플랫폼 간 개발 워크로드를 설치해야 합니다.If you don't see the .NET Core category, you need to install the .NET Core cross-platform development workload. 이를 수행하려면 새 프로젝트 대화 상자의 왼쪽 아래에 있는 Visual Studio 설치 관리자 열기 링크를 선택합니다.To do this, choose the Open Visual Studio Installer link on the bottom left of the New Project dialog. Visual Studio 설치 관리자가 열리면 아래로 스크롤하여 .NET Core 플랫폼 간 개발 워크로드를 선택한 다음, 수정을 선택합니다.After Visual Studio Installer opens, scroll down and select the .NET Core cross-platform development workload, and then select Modify.

    잠시 후 다음과 같은 정보가 표시됩니다.Shortly, you should see something like the following:

    Visual Studio IDE

    응용 프로그램의 C# 코드는 대부분의 공간을 차지하는 편집기 창에 표시됩니다.The C# code for your application is shown in the editor window, which takes up most of the space. 텍스트는 지정된 색으로 자동으로 표시되어 다른 측면(예: 키워드 또는 형식)을 나타냅니다.Notice that the text is automatically colorized to indicate different aspects of the code, such as keywords and types. 또한 코드에서 작은 세로 파선은 서로 일치하는 중괄호를 나타내며, 줄 번호는 나중에 코드를 찾는 데 도움이 됩니다.In addition, small, vertical dashed lines in the code indicate which braces match one another, and line numbers help you locate code later. 작은 상자 안에 있는 빼기 기호를 선택하여 코드를 축소하거나 확장할 수 있습니다.You can choose the small, boxed minus signs to collapse or expand code. 이 코드 개요 기능을 사용하면 필요 없는 코드를 숨길 수 있으므로 화면 상의 혼란을 최소화할 수 있습니다.This code outlining feature lets you hide code you don't need, helping to minimize onscreen clutter.

    프로젝트 파일은 솔루션 탐색기라는 창의 오른쪽에 나열됩니다.The project files are listed on the right side in a window called Solution Explorer.

    빨간색 상자가 있는 Visual Studio IDE

    다른 메뉴와 도구 창을 사용할 수 있지만 지금은 넘어가겠습니다.There are other menus and tool windows available, but let's move on for now.

  3. 이제 앱을 시작합니다.Now, start the app. 메뉴 모음의 디버그 메뉴에서 디버깅하지 않고 시작을 선택하면 됩니다.You can do this by choosing Start Without Debugging from the Debug menu on the menu bar. Ctrl+F5를 누를 수도 있습니다.You can also press Ctrl+F5.

    디버그 > 디버깅하지 않고 시작 메뉴

    Visual Studio에서 앱을 빌드하며, 콘솔 창이 열리고 Hello World! 메시지가 표시됩니다.Visual Studio builds the app, and a console window opens with the message Hello World!. 이제 실행 중인 앱이 있습니다!You now have a running app!

    콘솔 창

  4. 콘솔 창을 닫으려면 키보드에서 아무 키나 누릅니다.To close the console window, press any key on your keyboard.

  5. 앱에 일부 코드를 추가하겠습니다.Let's add some additional code to the app. Console.WriteLine("Hello World!"); 줄 앞에 다음 C# 코드를 추가합니다.Add the following C# code before the line that says Console.WriteLine("Hello World!");:

    Console.WriteLine("\nWhat is your name?");
    var name = Console.ReadLine();
    

    이 코드는 콘솔 창에 이름이 무엇입니까? 를 표시한 다음, 사용자가 텍스트를 입력한 후 Enter 키를 누를 때까지 기다립니다.This code displays What is your name? in the console window, and then waits until the user enters some text followed by the Enter key.

  6. Console.WriteLine("Hello World!");이라고 표시된 줄을 다음 코드로 변경합니다.Change the line that says Console.WriteLine("Hello World!"); to the following code:

    Console.WriteLine($"\nHello {name}!");
    
  7. 디버그 > 디버깅하지 않고 시작을 선택하거나 Ctrl+F5를 눌러 앱을 다시 실행합니다.Run the app again by selecting Debug > Start Without Debugging or by pressing Ctrl+F5.

    Visual Studio에서 앱을 다시 빌드하고, 콘솔 창이 열리며 사용자 이름을 묻는 메시지가 표시됩니다.Visual Studio rebuilds the app, and a console window opens and prompts you for your name.

  8. 콘솔 창에 이름을 입력하고 Enter 키를 누릅니다.Enter your name in the console window and press Enter.

    콘솔 창 입력

  9. 아무 키나 눌러 콘솔 창을 닫고 실행 중인 프로그램을 중지합니다.Press any key to close the console window and stop the running program.

리팩터링 및 IntelliSense 사용Use refactoring and IntelliSense

리팩터링IntelliSense로 더 효율적으로 코딩하는 데 도움이 되는 몇 가지 방법을 살펴보겠습니다.Let's look at a couple of the ways that refactoring and IntelliSense can help you code more efficiently.

먼저 name 변수의 이름을 변경합니다.First, let's rename the name variable:

  1. name 변수를 두 번 클릭하여 선택합니다.Double-click the name variable to select it.

  2. 변수의 새 이름 username을 입력합니다.Type in the new name for the variable, username.

    변수 주위에 회색 상자가 나타나고 여백에 전구가 나타납니다.Notice that a gray box appears around the variable, and a light bulb appears in the margin.

  3. 전구 아이콘을 선택하여 사용 가능한 빠른 작업을 표시합니다.Select the light bulb icon to show the available Quick Actions. 'name'의 이름을 'username'으로 바꾸기를 선택합니다.Select Rename 'name' to 'username'.

    Visual Studio에서 작업 이름 바꾸기

    프로젝트 전체에서 변수의 이름이 변경됩니다. 이 경우에는 두 군데밖에 없습니다.The variable is renamed across the project, which in our case is only two places.

    Visual Studio에서 이름 바꾸기 리팩터링을 보여 주는 애니메이션된 gif

  4. 이제 IntelliSense를 살펴보겠습니다.Now let's take a look at IntelliSense. Console.WriteLine($"\nHello {username}!");이라고 표시된 줄 아래에 DateTime now = DateTime을 입력합니다.Below the line that says Console.WriteLine($"\nHello {username}!");, type DateTime now = DateTime..

    상자에 DateTime 클래스의 멤버가 표시됩니다.A box displays the members of the DateTime class. 또한 현재 선택된 멤버의 설명이 별도 상자에 표시됩니다.In addition, the description of the currently selected member displays in a separate box.

    Visual Studio의 IntelliSense 목록 멤버

  5. 클래스의 속성인 Now라는 멤버를 두 번 클릭하거나 Tab 키를 눌러 선택합니다. 세미콜론 ; 를 추가하여 코드 줄을 완료합니다.Select the member named Now, which is a property of the class, by double-clicking on it or pressing Tab. Complete the line of code by adding a semi-colon ;.

  6. 그 아래에 다음 코드 줄을 입력하거나 복사합니다.Below that, type in or copy the following lines of code:

    int dayOfYear = now.DayOfYear;
    
    Console.Write("Day of year: ");
    Console.WriteLine(dayOfYear);
    

    Console.Write은 인쇄 후 줄 종결자를 추가하지 않는다는 점에서 Console.WriteLine과 약간 다릅니다.Console.Write is a little different to Console.WriteLine in that it doesn't add a line terminator after it prints. 즉, 출력으로 전송되는 다음 텍스트가 같은 줄에 인쇄됩니다.That means that the next piece of text that's sent to the output will print on the same line. 코드에서 이러한 각 메서드 위로 마우스를 가져가면 설명을 볼 수 있습니다.You can hover over each of these methods in your code to see their description.

  7. 다음으로, 리팩터링을 다시 사용하여 코드를 좀 더 간결하게 만듭니다.Next, we'll use refactoring again to make the code a little more concise. DateTime now = DateTime.Now; 줄에서 변수 now를 클릭합니다.Click on the variable now in the line DateTime now = DateTime.Now;.

    해당 줄의 여백에 작은 스크루드라이버 아이콘이 나타납니다.Notice that a little screwdriver icon appears in the margin on that line.

  8. 스크루드라이버 아이콘을 클릭하면 Visual Studio에서 제안하는 사항을 볼 수 있습니다.Click the screwdriver icon to see what suggestions Visual Studio has available. 여기에는 전체 동작을 변경하지 않고 코드 줄을 제거할 수 있는 인라인 임시 변수 리팩터링이 표시되어 있습니다.In this case, it's showing the Inline temporary variable refactoring to remove a line of code without changing the overall behavior:

    Visual Studio의 인라인 임시 변수 리팩터링

  9. 인라인 임시 변수를 클릭하여 코드를 리팩터링합니다.Click Inline temporary variable to refactor the code.

  10. Ctrl+F5 키를 눌러 프로그램을 다시 실행합니다.Run the program again by pressing Ctrl+F5. 출력은 다음과 같습니다.The output looks something like this:

    프로그램 출력이 표시된 콘솔 창

코드 디버그Debug code

코드를 작성할 때 코드를 실행하고 버그를 테스트해야 합니다.When you write code, you need to run it and test it for bugs. Visual Studio의 디버깅 시스템을 사용하면 코드를 단계별로 진행하면서 명령문을 한 번에 하나씩 실행하면서 변수를 검사할 수 있습니다.Visual Studio's debugging system lets you step through code one statement at a time and inspect variables as you go. 지정된 조건이 true인 경우에만 적중되는 중단점을 설정할 수 있습니다.You can set breakpoints that are only hit when a specified condition is true. 코드 실행 등과 같은 변수 값을 모니터링할 수 있습니다.You can monitor the values of variables as the code runs, and more.

중단점을 설정하여 프로그램이 "이동 중"일 때 username 변수의 값을 확인하겠습니다.Let's set a breakpoint to see the value of the username variable while the program is "in flight".

  1. Console.WriteLine($"\nHello {username}!");이라고 표시된 코드 줄을 찾습니다.Find the line of code that says Console.WriteLine($"\nHello {username}!");. 이 코드 줄에 중단점을 설정하려면, 즉 이 줄에서 프로그램이 실행을 일시 중지하도록 하려면 편집기의 맨 왼쪽 여백을 클릭합니다.To set a breakpoint on this line of code, that is, to make the program pause execution at this line, click in the far left margin of the editor. 코드 줄의 아무 곳이나 클릭한 다음, F9 키를 누를 수도 있습니다.You can also click anywhere on the line of code and then press F9.

    맨 왼쪽 끝에 빨간색 원이 표시되고 코드가 빨간색으로 강조 표시됩니다.A red circle appears in the far left margin, and the code is highlighted in red.

    Visual Studio 코드 줄의 중단점

  2. 디버그 > 디버깅 시작을 선택하거나 F5 키를 눌러 디버깅을 시작합니다.Start debugging by selecting Debug > Start Debugging or by pressing F5.

  3. 콘솔 창이 나타나고 사용자 이름을 묻는 메시지가 표시되면 입력하고 Enter 키를 누릅니다.When the console window appears and asks for your name, type it in and press Enter.

    Visual Studio 코드 편집기로 포커스가 돌아오고 중단점이 있는 코드 줄이 노란색으로 강조 표시됩니다.Notice that the focus returns to the Visual Studio code editor and the line of code with the breakpoint is highlighted in yellow. 이는 프로그램이 실행할 다음 코드 줄을 의미합니다.This signifies that it's the next line of code that the program will execute.

  4. 마우스를 username 변수 위로 가져가면 해당 값을 볼 수 있습니다.Hover your mouse over the username variable to see its value. 또는 username을 마우스 오른쪽 단추로 클릭하고 조사식 추가를 선택하여 변수를 조사식 창에 추가할 수 있습니다. 이 창에서 해당 값을 볼 수도 있습니다.Alternatively, you can right-click on username and select Add Watch to add the variable to the Watch window, where you can also see its value.

    Visual Studio에서 디버깅하는 동안 변수 값

  5. 프로그램 실행을 완료하려면 F5 키를 다시 누릅니다.To let the program run to completion, press F5 again.

Visual Studio의 디버깅에 대한 자세한 내용은 디버거 기능 둘러보기를 참조하세요.To get more details about debugging in Visual Studio, see Debugger feature tour.

Visual Studio 사용자 지정Customize Visual Studio

기본 색 테마 변경을 포함하여 IDE를 개인 설정할 수 있습니다.You can personalize the IDE, including changing the default color theme. 어둡게 테마로 변경하려면:To change to the Dark theme:

  1. 메뉴 모음에서 도구 > 옵션을 선택하여 옵션 대화 상자를 엽니다.On the menu bar, choose Tools > Options to open the Options dialog.

  2. 환경 > 일반 옵션 페이지에서 색 테마 선택을 어두운으로 변경한 다음, 확인을 선택합니다.On the Environment > General options page, change the Color theme selection to Dark, and then choose OK.

    전체 IDE의 색 테마가 어둡게로 변경됩니다.The color theme for the entire IDE changes to Dark.

    어두운 테마의 VS

IDE를 개인 설정할 수 있는 다른 방법을 배우려면 Visual Studio 개인 설정을 참조하세요.To learn about other ways you can personalize the IDE, see Personalize Visual Studio.

자세한 정보Learn more

Android 또는 iOS 휴대폰용 앱을 만들고 싶으십니까?Do you want to create an app for an Android or iOS phone? 3D 게임 또는 클라우드 기반 앱은 어떻습니까?How about a 3D game, or a cloud-enabled app? Visual Studio의 이러한 기능 및 기타 기능에 대해 배우려면 Visual Studio 2017의 기능을 참조하세요.To learn about these and other features of Visual Studio, see Features of Visual Studio 2017.

이제 코딩을 시작할 준비가 되었으면 첫 번째 ASP.NET Core 웹앱 만들기와 같은 목차에서 빠른 시작 항목 중 하나를 선택합니다.If you're just ready to get started coding now, choose one of the Quickstart topics from the table of contents, such as Create your first ASP.NET Core web app.

Microsoft Virtual Academy에서 제공되는 무료 Visual Studio 과정을 확인할 수도 있습니다.You can also check out the free Visual Studio courses available on Microsoft Virtual Academy.

참고 항목See also