연습: 응용 프로그램 빌드Walkthrough: Building an Application

이 연습을 완료하면 Visual Studio로 응용 프로그램을 빌드할 때 구성할 수 있는 여러 옵션에 더 익숙해집니다.By completing this walkthrough, you'll become more familiar with several options that you can configure when you build applications with Visual Studio. 샘플 응용 프로그램에 대한 사용자 지정 빌드 구성을 만들고, 특정 경고 메시지를 숨기고, 빌드 출력 정보를 늘립니다.You'll create a custom build configuration, hide certain warning messages, and increase build output information for a sample application.

이 항목에는 다음과 같은 단원이 포함되어 있습니다.This topic contains the following sections:

샘플 응용 프로그램 설치Install the Sample Application

사용자 지정 빌드 구성 만들기Create a Custom Build Configuration

응용 프로그램 빌드Build the Application

컴파일러 경고 숨기기Hide Compiler Warnings

출력 창에 추가 빌드 세부 정보 표시Display Additional Build Details in the Output Window

릴리스 빌드 만들기Create a Release Build

샘플 응용 프로그램 설치Install the Sample Application

WPF 응용 프로그램 빌드 소개 샘플을 다운로드합니다.Download the Introduction to Building WPF Applications sample. C# 또는 Visual Basic을 선택합니다.Choose either C# or Visual Basic. .zip 파일을 다운로드한 후 압축을 풀고 Visual Studio를 사용하여 ExpenseItIntro.sln 파일을 엽니다.After the .zip file has downloaded, extract it and open the ExpenseItIntro.sln file using Visual Studio.

사용자 지정 빌드 구성 만들기Create a Custom Build Configuration

솔루션을 만들면 솔루션에 대한 디버그 및 릴리스 빌드 구성과 해당 기본 플랫폼 대상이 자동으로 정의됩니다.When you create a solution, debug and release build configurations and their default platform targets are defined for the solution automatically. 나중에 이러한 구성을 사용자 지정하거나 고유한 구성을 만들 수 있습니다.You can then customize these configurations or create your own. 빌드 구성은 빌드 형식을 지정합니다.Build configurations specify the build type. 빌드 플랫폼은 응용 프로그램이 해당 구성에 대한 대상으로 지정하는 운영 체제를 지정합니다.Build platforms specify the operating system that an application targets for that configuration. 자세한 내용은 빌드 구성 이해, 빌드 플랫폼 이해디버그 및 릴리스 프로젝트 구성을 참조하세요.For more information, see Understanding Build Configurations, Understanding Build Platforms, and Debug and Release Project Configurations.

구성 관리자 대화 상자를 사용하여 구성 및 플랫폼 설정을 변경하거나 만들 수 있습니다.You can change or create configurations and platform settings by using the Configuration Manager dialog box. 이 절차에서는 테스트용 빌드 구성을 만듭니다.In this procedure, you'll create a build configuration for testing.

빌드 구성을 만들려면To create a build configuration

  1. 구성 관리자 대화 상자를 엽니다.Open the Configuration Manager dialog box.

    빌드 메뉴, 구성 관리자 명령Build menu, Configuration Manager command

  2. 활성 솔루션 구성 목록에서 <새로 만들기...>를 선택합니다.In the Active solution configuration list, choose <New...>.

  3. 새 솔루션 구성 대화 상자에서 새 구성의 이름을 Test로 지정하고, 기존 디버그 구성에서 설정을 복사하고, 확인 단추를 선택합니다.In the New Solution Configuration dialog box, name the new configuration Test, copy settings from the existing Debug configuration, and then choose the OK button.

    새 솔루션 구성 대화 상자New Solution Configuration Dialog Box

  4. 활성 솔루션 플랫폼 목록에서 <새로 만들기...>를 선택합니다.In the Active solution platform list, choose <New...>.

  5. 새 솔루션 플랫폼 대화 상자에서 x64를 선택하지만 x86 플랫폼에서 설정을 복사하지 않습니다.In the New Solution Platform dialog box, choose x64, and don't copy settings from the x86 platform.

    새 솔루션 플랫폼 대화 상자New Solution Platform Dialog Box

  6. 확인 단추를 선택합니다.Choose the OK button.

    활성 솔루션 구성이 Test로 변경되고 활성 솔루션 플랫폼이 x64로 설정되었습니다.The active solution configuration has been changed to Test with the active solution platform set to x64.

    테스트 구성이 있는 구성 관리자Configuration Manager with Test configuration

  7. 닫기를 선택합니다.Choose Close.

표준 도구 상자에서 솔루션 구성 목록을 사용하여 활성 솔루션 구성을 빠르게 확인하거나 변경할 수 있습니다.You can quickly verify or change the active solution configuration by using the Solution Configurations list on the Standard toolbar.

솔루션 구성 옵션 표준 도구 모음Solution Configuration option Standard Toolbar

응용 프로그램 빌드Build the Application

다음에는 사용자 지정 빌드 구성을 사용하여 솔루션을 빌드합니다.Next, you'll build the solution with the custom build configuration.

솔루션을 빌드하려면To build the solution

  • 메뉴 모음에서 빌드, 솔루션 빌드를 선택합니다.On the menu bar, choose Build, Build Solution.

    출력 창에는 빌드 결과가 표시됩니다.The Output window displays the results of the build. 빌드에 성공했습니다.The build succeeded.

컴파일러 경고 숨기기Hide Compiler Warnings

다음으로 컴파일러에서 생성되는 경고를 발생하는 일부 코드를 소개합니다.Next we'll introduce some code that causes a warning to be generated by the compiler.

  1. C# 프로젝트에서 ExpenseReportPage.xaml.cs 파일을 엽니다.In the C# project, open the ExpenseReportPage.xaml.cs file. ExpenseReportPage 메서드에 다음 코드를 추가합니다. int i;In the ExpenseReportPage method, add the following code: int i;.

    또는OR

    Visual Basic 프로젝트에서 ExpenseReportPage.xaml.vb 파일을 엽니다.In the Visual Basic project, open the ExpenseReportPage.xaml.vb file. 사용자 지정 생성자 Public Sub New...에서 다음 코드를 추가합니다. Dim iIn the custom constructor Public Sub New..., add the following code: Dim i.

  2. 솔루션을 빌드합니다.Build the solution.

출력 창에는 빌드 결과가 표시됩니다.The Output window displays the results of the build. 빌드에 성공했지만 경고가 발생했습니다.The build succeeded, but warnings were generated:

그림 1: Visual Basic 경고Figure 1: Visual Basic warnings

출력 창(Visual Basic)Output Window Visual Basic

그림 2: Visual C# 경고Figure 2: Visual C# warnings

출력 창(Visual C#)Output Window Visual C#

빌드 출력을 어지럽히지 않도록 빌드하는 동안 특정 경고 메시지를 일시적으로 숨길 수 있습니다.You can temporarily hide certain warning messages during a build rather than have them clutter up the build output.

특정 Visual C# 경고를 숨기려면To hide a specific Visual C# warning

  1. 솔루션 탐색기에서 최상위 프로젝트 노드를 선택합니다.In Solution Explorer, choose the top-level project node.

  2. 메뉴 모음에서 보기, 속성 페이지를 선택합니다.On the menu bar, choose View, Property Pages.

    프로젝트 디자이너가 열립니다.The Project Designer opens.

  3. 빌드 페이지를 선택하고 경고 표시 안 함 상자에서 경고 번호 0168을 지정합니다.Choose the Build page and then, in the Suppress warnings box, specify the warning number 0168.

    프로젝트 디자이너, 빌드 페이지Build page, Project Designer

    자세한 내용은 프로젝트 디자이너, 빌드 페이지(C#)를 참조하세요.For more information, see Build Page, Project Designer (C#).

  4. 솔루션을 빌드합니다.Build the solution.

    출력 창에는 빌드에 대한 요약 정보만 표시됩니다.The Output window displays only summary information for the build.

    출력 창, Visual C# 빌드 경고Output Window, Visual C# Build Warnings

모든 Visual Basic 빌드 경고를 표시하지 않으려면To suppress all Visual Basic build warnings

  1. 솔루션 탐색기에서 최상위 프로젝트 노드를 선택합니다.In Solution Explorer, choose the top-level project node.

  2. 메뉴 모음에서 보기, 속성 페이지를 선택합니다.On the menu bar, choose View, Property Pages.

    프로젝트 디자이너가 열립니다.The Project Designer opens.

  3. 컴파일 페이지에서 모든 경고 사용 안 함 확인란을 선택합니다.On the Compile page, select the Disable all warnings check box.

    프로젝트 디자이너, 컴파일 페이지Compile page, Project Designer

    자세한 내용은 Visual Basic에서 경고 구성을 참조하세요.For more information, see Configuring Warnings in Visual Basic.

  4. 솔루션을 빌드합니다.Build the solution.

    출력 창에는 빌드에 대한 요약 정보만 표시됩니다.The Output window displays only summary information for the build.

    출력 창, Visual Basic 빌드 경고Output Window, Visual Basic Build Warnings

    자세한 내용은 방법: 컴파일러 경고 표시 안 함을 참조하세요.For more information, see How to: Suppress Compiler Warnings.

출력 창에 추가 빌드 세부 정보 표시Display Additional Build Details in the Output Window

출력 창에 표시할 빌드 프로세스에 대한 정보의 양을 변경할 수 있습니다.You can change how much information about the build process appears in the Output window. 빌드의 자세한 정도는 대개 최소로 설정되고, 이는 출력 창에 빌드 프로세스의 요약만 높은 우선 순위 또는 오류와 함께 표시됨을 의미합니다.Build verbosity is usually set to Minimal, which means that the Output window displays only a summary of the build process along with any high priority warnings or errors. 옵션 대화 상자, 프로젝트 및 솔루션, 빌드 및 실행을 사용하여 빌드에 대한 추가 정보를 표시할 수 있습니다.You can display more information about the build by using the Options Dialog Box, Projects and Solutions, Build and Run.

중요

추가 정보를 표시하면 빌드를 완료하는 데 더 오랜 시간이 걸립니다.If you display more information, the build will take longer to complete.

[출력] 창에서 정보의 양을 변경하려면To change the amount of information in the Output window

  1. 옵션 대화 상자를 엽니다.Open the Options dialog box.

    도구 메뉴의 옵션 명령Options command on the Tools menu

  2. 프로젝트 및 솔루션 범주를 선택하고 나서 빌드 및 실행 페이지를 선택합니다.Choose the Projects and Solutions category, and then choose the Build and Run page.

  3. MSBuild 프로젝트 빌드 출력의 자세한 정도 목록에서 보통을 선택하고 나서 확인 단추를 선택합니다.In the MSBuild project build output verbosity list, choose Normal, and then choose the OK button.

  4. 메뉴 모음에서 빌드, 솔루션 정리를 선택합니다.On the menu bar, choose Build, Clean Solution.

  5. 솔루션을 빌드하고 출력 창에서 정보를 검토합니다.Build the solution, and then review the information in the Output window.

    빌드 정보에는 빌드가 시작된 시간(시작 부분에 있음) 및 파일이 처리된 순서가 포함됩니다.The build information includes the time that the build started (located at the beginning) and the order in which files were processed. 이 정보에는 빌드하는 동안 Visual Studio에서 실행하는 실제 컴파일러 구문도 포함됩니다.This information also includes the actual compiler syntax that Visual Studio runs during the build.

    예를 들어 Visual C# 빌드에서 /nowarn 옵션은 이 항목에서 이전에 지정한 경고 코드, 1762를 세 개의 다른 경고와 함께 나열합니다.For example, in the Visual C# build, the /nowarn option lists the warning code, 1762, that you specified earlier in this topic, along with three other warnings.

    Visual Basic 빌드에서 /nowarn은 제외할 특정 경고를 포함하지 않으므로 경고가 나타나지 않습니다.In the Visual Basic build, /nowarn doesn't include specific warnings to exclude, so no warnings appear.

    Ctrl+F 키를 선택하여 찾기 대화 상자를 표시하면 출력 창의 내용을 검색할 수 있습니다.You can search the contents of the Output window if you display the Find dialog box by choosing the Ctrl+F keys.

자세한 내용은 방법: 빌드 로그 파일 보기, 저장 및 구성을 참조하세요.For more information, see How to: View, Save, and Configure Build Log Files.

릴리스 빌드 만들기Create a Release Build

전달에 최적화된 샘플 응용 프로그램 버전을 빌드할 수 있습니다.You can build a version of the sample application that's optimized for shipping it. 릴리스 빌드의 경우 빌드가 시작되기 전에 실행 파일이 네트워크 공유에 복사되도록 지정합니다.For the release build, you'll specify that the executable is copied to a network share before the build is kicked off.

자세한 내용은 방법: 빌드 출력 디렉터리 변경Visual Studio에서 프로젝트 및 솔루션 빌드 및 정리를 참조하세요.For more information, see How to: Change the Build Output Directory and Building and Cleaning Projects and Solutions in Visual Studio.

Visual Basic에 대한 릴리스 빌드를 지정하려면To specify a release build for Visual Basic

  1. 프로젝트 디자이너를 엽니다.Open the Project Designer.

    보기 메뉴, 속성 페이지 명령View menu, Property Pages command

  2. 컴파일 페이지를 선택합니다.Choose the Compile page.

  3. 구성 목록에서 릴리스를 선택합니다.In the Configuration list, choose Release.

  4. 플랫폼 목록에서 x86을 선택합니다.In the Platform list, choose x86.

  5. 빌드 출력 경로 상자에서 네트워크 경로를 지정합니다.In the Build output path box, specify a network path.

    예를 들어 \\myserver\builds를 지정할 수 있습니다.For example, you can specify \\myserver\builds.

    중요

    지정한 네트워크 공유가 신뢰할 수 있는 위치가 아님을 경고하는 메시지 상자가 나타날 수 있습니다.A message box might appear, warning you that the network share that you've specified might not be a trusted location. 지정한 위치를 신뢰하는 경우 메시지 상자에서 확인 단추를 선택합니다.If you trust the location that you've specified, choose the OK button in the message box.

  6. 응용 프로그램을 빌드합니다.Build the application.

    빌드 메뉴의 솔루션 빌드 명령Build Solution command on the Build menu

Visual C#에 대한 릴리스 빌드를 지정하려면To specify a release build for Visual C#

  1. 프로젝트 디자이너를 엽니다.Open the Project Designer.

    보기 메뉴, 속성 페이지 명령View menu, Property Pages command

  2. 빌드 페이지를 선택합니다.Choose the Build page.

  3. 구성 목록에서 릴리스를 선택합니다.In the Configuration list, choose Release.

  4. 플랫폼 목록에서 x86을 선택합니다.In the Platform list, choose x86.

  5. 출력 경로 상자에서 네트워크 경로를 지정합니다.In the Output path box, specify a network path.

    예를 들어 \\myserver\builds를 지정할 수 있습니다.For example, you could specify \\myserver\builds.

    중요

    지정한 네트워크 공유가 신뢰할 수 있는 위치가 아님을 경고하는 메시지 상자가 나타날 수 있습니다.A message box might appear, warning you that the network share that you've specified might not be a trusted location. 지정한 위치를 신뢰하는 경우 메시지 상자에서 확인 단추를 선택합니다.If you trust the location that you've specified, choose the OK button in the message box.

  6. 표준 도구 모음에서 솔루션 구성을 릴리스로, 솔루션 플랫폼을 x86으로 설정합니다.On the Standard toolbar, set the Solution Configurations to Release and the Solution Platforms to x86.

  7. 응용 프로그램을 빌드합니다.Build the application.

    빌드 메뉴의 솔루션 빌드 명령Build Solution command on the Build menu

    실행 파일이 지정한 네트워크 경로에 복사됩니다.The executable file is copied to the network path that you specified. 해당 경로는 \\myserver\builds\FileName.exe입니다.Its path would be \\myserver\builds\FileName.exe.

축하합니다. 이 연습을 완료했습니다.Congratulations: you've successfully completed this walkthrough.

참고 항목See Also

연습: 프로젝트 빌드(C++) Walkthrough: Building a Project (C++)
ASP.NET 웹 응용 프로그램 프로젝트 미리 컴파일 개요 ASP.NET Web Application Project Precompilation Overview
연습: MSBuild 사용Walkthrough: Using MSBuild