새 프로젝트 만들기Create a New Project

프로젝트 만들기 대화 상자 열기Opening the Project Creation Dialog

Mac용 Visual Studio에서 새 프로젝트를 만드는 여러 방법이 있습니다.There are a few ways to create a new project in Visual Studio for Mac. Mac용 Visual Studio를 처음 열면 시작 창이 표시됩니다.When you first open Visual Studio for Mac, the start window is shown. 여기에서 새로 만들기 를 선택하면 프로젝트 만들기 화면으로 이동합니다.From here you can choose New which takes you to the project creation screen.

또한 시작 창에서 최근 프로젝트 및 솔루션을 열고 검색할 수도 있습니다.Additionally, from the start window, you can also open and search for recent projects and solutions. 메뉴 모음으로 이동하여 파일 > 최근 솔루션 을 선택하여 최근 프로젝트를 열 수도 있습니다.You can also open recent projects by going to the menu bar and choosing File > Recent Solutions

새 프로젝트 만들기가 표시된 시작 창

솔루션이 로드된 상태로 Mac용 Visual Studio가 이미 열려 있는 경우 메뉴 모음으로 이동한 후 파일> 새 솔루션 을 선택하여 새 솔루션을 만들 수 있습니다.If Visual Studio for Mac is already open with a solution loaded, you can create a new solution by going to the menu bar and choosing File > New Solution. 이러한 방식으로 새 솔루션을 만들면 이미 로드된 솔루션은 닫힙니다.Creating a new solution this way closes the solution that is already loaded.

새 프로젝트 만들기Creating a New Project

새 프로젝트 대화 상자는 기본적으로 가장 최근에 사용한 템플릿을 기준으로 정렬된 사용자가 최근에 사용한 템플릿을 보여줍니다.The New Project dialog, by default, will show your recently used templates sorted by most recently used.

최근 템플릿을 사용하지 않으려면 대화 상자 왼쪽에 있는 범주에서 선택할 수 있습니다.If you do not want to use a recent template, you can choose from the categories on the left of the dialog. 각 범주에는 사용자가 선택할 수 있는 여러 프로젝트 템플릿이 있습니다.Each category contains several project templates for you to choose from. 프로젝트 형식을 클릭하면 화면 오른쪽에서 설명을 볼 수 있습니다.Clicking on a project type allows you to see a description on the right side of the screen.

새 프로젝트 화면

새 프로젝트 구성Configuring Your New Project

프로젝트 템플릿을 선택하면 다음 화면들이 나타나 프로젝트를 설정하는 데 필요한 구성 단계를 안내하며, 프로젝트 형식에 따라 다를 수 있습니다.Once you have chosen a project template, the following screens will take you through any configuration steps required to set up the project; this can vary by project type.

모든 프로젝트에는 파일을 저장할 위치와 함께, 새 프로젝트가 필요합니다.All projects require a new project, along with a location to store the files. 해당 프로젝트를 기존 솔루션에 추가하는 것이 아니라 새 솔루션의 일부인 경우, 솔루션 이름도 필요합니다.If the project is part of a new solution, rather than adding it to an existing solution, a solution name will also be required.

필요에 따라 이 단계에서 Git 원본 제어 옵션도 구성할 수 있습니다.Optionally, at this stage you can also configure Git source control options. 다음 이미지는 .NET Core 프로젝트의 최종 구성 단계의 예입니다.The following image is an example of the final configuration step for a .NET Core project:

새 프로젝트 구성

추가 프로젝트를 솔루션에 추가Adding Additional Projects to a Solution

솔루션 창 에서 솔루션을 마우스 오른쪽 단추로 클릭하고 추가 > 새 프로젝트 추가 또는 추가 > 기존 프로젝트 추가 를 선택하여 솔루션에 프로젝트를 더 추가할 수 있습니다.You can add additional projects to a solution by right-clicking the solution in the Solution Window and choosing either Add > Add New Project or Add > Add Existing Project.

새 프로젝트를 추가하면 새 프로젝트 구성에 표시된 대로 프로젝트 만들기가 진행됩니다.Adding a new project will take you through project creation, as shown in Configuring Your New Project.

기존 프로젝트를 추가하도록 선택하면 컴퓨터에서 기존 프로젝트를 찾아 솔루션에 추가할 수 있습니다.Choosing to add an existing project will allow you to browse for an existing project on your machine and add it to the solution.

참조See also