Mac용 Visual Studio의 여러 솔루션 또는 인스턴스 열기Open multiple solutions or instances of Visual Studio for Mac

Mac에서 Mac용 Visual Studio를 포함한 모든 애플리케이션은 기본적으로 단일 인스턴스 앱입니다.By default, all applications on a Mac, including Visual Studio for Mac, are single-instance apps. 즉, 사용하려는 애플리케이션이 이미 열려 있는 경우(도크의 아이콘 아래에 점으로 표시됨), 아이콘을 다시 선택하면 새 인스턴스가 아닌 실행 중인 인스턴스가 열립니다.This means that if the application you want to use is already open (illustrated by a dot under the icon in the dock), selecting the icon again opens the running instance, rather than a new one. 다음 섹션에 설명된 대로 애플리케이션의 추가 인스턴스가 필요한 경우 시스템에 열라는 메시지를 표시할 수 있습니다.If you require additional instances of the application, you can prompt the system to open it for you, as described in the next section.

또한 솔루션을 열면 기본 동작은 새 작업 영역에서 솔루션을 열고 현재 작업 영역을 닫는 것입니다(필요한 경우).In addition, when you open a solution, the default behavior is to open the solution in a new workspace and close the current workspace (if necessary). 두 번째 솔루션 열기 섹션에 설명된 대로 현재 작업 영역이 열린 상태로 유지하여 이 기본 동작을 재정의할 수 있습니다.You can override this default behavior by keeping the current workspace open, as described in the Open a second solution section.

Mac용 Visual Studio의 두 번째 인스턴스 열기Open a second instance of Visual Studio for Mac

IDE(통합 개발 환경)의 두 번째 인스턴스를 열려면 dock 또는 애플리케이션 폴더에서 Visual Studio 아이콘을 마우스 오른쪽 단추로 클릭하고 새 인스턴스 를 선택합니다.To open a second instance of the integrated development environment (IDE), right-click on the Visual Studio icon in your dock or Applications folder, and select New Instance.

마우스 오른쪽 단추로 클릭한 Visual Studio 아이콘의 새 인스턴스 메뉴 옵션 스크린샷

단일 인스턴스 내에서 두 번째 솔루션 열기Open a second solution inside a single instance

첫 번째 솔루션과 함께 두 번째 솔루션을 열려면 다음 단계를 사용합니다.To open a second solution alongside your first solution, use the following steps:

  1. 첫 번째 솔루션을 열고 파일 > 열기 를 선택합니다.With your first solution already open, select File > Open.

  2. 기존 솔루션을 찾으려면 파일 시스템을 검색합니다.Browse the file system to find the existing solution.

  3. .sln 파일을 선택하고 옵션 을 선택합니다.Select the .sln file, and select Options:

    .sln 파일 및 옵션이 강조 표시된 Mac용 Visual Studio 스크린샷

  4. 현재 작업 영역 닫기 확인란의 선택을 취소합니다.Clear the Close current workspace box:

    현재 작업 영역 닫기 확인란이 선택 취소된 옵션 대화 상자 스크린샷

  5. 열기 를 선택하여 솔루션 창에서 두 번째 솔루션을 엽니다.Select Open to open the second solution in the Solution Window.

또는 솔루션을 최근에 열었다면 다음 단계를 사용할 수 있습니다.Alternatively, if you've recently opened the solution, you can use the following steps:

  1. 파일 > 최근 솔루션 으로 이동합니다.Go to File > Recent Solutions.

    최근 솔루션 메뉴 스크린샷

  2. Ctrl 키를 누른 채로 솔루션을 선택합니다.Hold down the Ctrl key and select the solution. 이 조합은 솔루션 창에서 두 번째 솔루션을 엽니다.This combination opens the second solution in the Solution Window.