Visual Studio Icon Mac용 Visual Studio 2019 버전 8.0 릴리스 정보Visual Studio 2019 for Mac version 8.0 Release Notes



개발자 커뮤니티 | 시스템 요구 사항 | 호환성 | 배포 가능한 코드 | 설명서 | 블로그 | 서비스Developer Community | System Requirements | Compatibility | Distributable Code | Documentation | Blogs | Servicing


다운로드Download

단추를 클릭하여 Mac용 Visual Studio 2019 최신 버전을 다운로드합니다.Click the button to download the latest version of Visual Studio 2019 for Mac. 시스템 요구 사항에 대한 정보는 Mac 시스템 요구 사항Mac 플랫폼 대상 지정 및 호환성 가이드를 참조하세요.For information on the system requirements see the see Mac System Requirements and Mac Platform Targeting and Compatibility guides.

Mac용 Visual Studio 2019 설치 및 업데이트에 대한 지침은 Mac용 Visual Studio 설치 가이드를 참조하세요.For instructions on installing and updating Visual Studio 2019 for Mac, see the Install Visual Studio for Mac guide.

Download VS for Mac

다른 관련 다운로드에 대해 자세히 알아보려면 다운로드 페이지를 참조하세요.To learn more about other related downloads, see the Downloads page.

중요

Mac용 Visual Studio 2019(버전 8 이상)는 Mac OS X 10.11(El Capitan) 이하에서 지원되지 않습니다.Visual Studio 2019 for Mac (version 8 and higher) is not supported on Mac OS X 10.11 (El Capitan) or lower. Mac용 Visual Studio 2017(버전 7)이 있는 경우 Mac용 Visual Studio 2019에 대한 업데이트가 표시되지 않습니다.If you have Visual Studio 2017 for Mac (version 7), you will not be shown an update to Visual Studio 2019 for Mac. 설치도 차단됩니다.Installation will also be blocked. 이 문제를 해결하려면 macOS 10.12(Sierra) 이상으로 업데이트하세요.To resolve this issue, update to macOS 10.12 (Sierra) or higher


Mac용 Visual Studio 2019의 새로운 기능What's New in Visual Studio 2019 for Mac

Mac용 Visual Studio 2019 버전 8.0 릴리스Visual Studio 2019 for Mac version 8.0 Releases

Mac용 Visual Studio 2019 블로그Visual Studio 2019 for Mac Blog

Mac용 Visual Studio 2019 블로그 는 엔지니어링 팀의 제품 정보가 제공되는 공식 출처입니다.The Visual Studio 2019 for Mac Blog is the official source of product insight from the Visual Studio Engineering Team. 다음 게시물에서 Mac용 Visual Studio 2019 릴리스에 대한 자세한 정보를 찾을 수 있습니다.You can find in-depth information about the Visual Studio 2019 for Mac releases in the following posts:

릴리스 주요 내용Release Highlights

  • 이 릴리스에는 Mac용 Visual Studio를 위한 차세대 텍스트 편집기미리 보기 가 포함되어 있습니다.This release contains a preview of the next generation text editor for Visual Studio for Mac.
  • 새로운 시작 환경을 도입되었습니다.We've introduced a new getting started experience.
  • 쉽게 IDE의 여러 인스턴스를 실행하기 위한 지원을 추가했습니다.We've added support for easily running multiple instances of the IDE.
  • 여러 시작 프로젝트를 설정하는 새로운 방법을 추가하여 디버깅 시 여러 프로젝트를 시작하는 솔루션 실행 구성을 쉽게 만들 수 있습니다.We've added a new way to set multiple startup projects, making it easier to create a solution Run Configuration that will launch multiple projects when debugging.
  • Mac용 Visual Studio는 이제 Azure Functions 템플릿에 대한 업데이트를 사용할 수 있는지 감지할 수 있으며, 업데이트할 수 있는 대화 상자를 제공합니다.Visual Studio for Mac can now detect that updates to Azure Functions templates are available, and will provide you with a dialog to update them.
  • Windows에서 Visual Studio tools for Unity에서 사용하는 디버거 공유를 통해 Unity 프로젝트를 위한 디버깅 환경을 개선했습니다.We've improved the debugging experience for Unity projects by sharing the debugger used by Visual Studio Tools for Unity on Windows.
  • Git 및 Azure DevOps/Team Foundation Server를 사용하는 Microsoft 계정 인증에 대한 지원을 추가했습니다.We have added support for Microsoft Account authentication with Git and Azure DevOps/Team Foundation Server.
  • 다음과 같은 세 가지 채널인 알파, 베타, 안정적을 미리 보기 및 안정적으로 변경했습니다.We've moved from having three channels: Alpha, Beta, Stable to just Preview and Stable. Visual Studio > 업데이트 확인... 에서 업데이트에 액세스할 수 있습니다.You can access updates from the Visual Studio > Check for Updates… 메뉴 항목.menu item.

Mac용 Visual Studio 2019 버전 8.0(8.0.9.5)Visual Studio 2019 for Mac version 8.0 (8.0.9.5)

릴리스 날짜: 2019년 5월 30일released May 30, 2019

다음과 같은 문제가 이 릴리스에서 해결되었습니다.We fixed the following issues in this release:

Mac용 Visual Studio 2019 버전 8.0(8.0.8.2)Visual Studio 2019 for Mac version 8.0 (8.0.8.2)

릴리스 날짜: 2019년 5월 23일released May 23, 2019

이 릴리스에서는 Unity를 사용하여 디버깅하는 동안 단계별로 작동하지 않는 문제를 해결했습니다.This release fixes an issue where stepping during debugging with Unity does not work.

Mac용 Visual Studio 2019 버전 8.0(8.0.7.3)Visual Studio 2019 for Mac version 8.0 (8.0.7.3)

릴리스 날짜: 2019년 5월 21일released May 21, 2019

이 릴리스에서는 Xamarin.Forms 셸 템플릿이 최신 버전의 셸에서 실행되도록 업데이트됩니다.This release updates the Xamarin.Forms Shell template to work with the latest version of Shell.

Mac용 Visual Studio 2019 버전 8.0(8.0.6.4)Visual Studio 2019 for Mac version 8.0 (8.0.6.4)

릴리스 날짜: 2019년 5월 14일released May 14, 2019

이 릴리스에서는 편집기에서 중단점을 렌더링할 때 충돌이 발생할 수 있는 문제를 해결합니다.This release addresses an issue that can lead to a crash when rendering breakpoints in the editor.

Mac용 Visual Studio 2019 버전 8.0(8.0.5.9)Visual Studio 2019 for Mac version 8.0 (8.0.5.9)

릴리스 날짜: 2019년 4월 29일released April 29, 2019

다음과 같은 문제가 이 릴리스에서 해결되었습니다.We fixed the following issues in this release:

Mac용 Visual Studio 2019 버전 8.0(8.0.4.0)Visual Studio 2019 for Mac version 8.0 (8.0.4.0)

릴리스 날짜: 2019년 4월 18일released April 18, 2019

다음과 같은 문제가 이 릴리스에서 해결되었습니다.We fixed the following issues in this release:

Mac용 Visual Studio 2019 버전 8.0(8.0.3.14)Visual Studio 2019 for Mac version 8.0 (8.0.3.14)

릴리스 날짜: 2019년 4월 15일released April 15, 2019

다음과 같은 문제가 이 릴리스에서 해결되었습니다.We fixed the following issues in this release:

Mac용 Visual Studio 2019 버전 8.0(8.0.2.23)Visual Studio 2019 for Mac version 8.0 (8.0.2.23)

릴리스 날짜: 2019년 4월 9일released April 9, 2019

이 릴리스에서는 Xcode 10.2에 대한 지원이 추가되었습니다.This release adds support for Xcode 10.2.

다음과 같은 문제가 이 릴리스에서 해결되었습니다.We fixed the following issues in this release:

Mac용 Visual Studio 2019 버전 8.0(8.0.1.1)Visual Studio 2019 for Mac version 8.0 (8.0.1.1)

릴리스 날짜: 2019년 4월 4일released April 4, 2019

  • 프로젝트가 생성되는 동안 시작 창이 닫히는 경우 IDE에서 충돌이 발생하는 문제를 해결했습니다.We fixed an issue where the IDE would crash if the Start Window was closed while a project was being created.

Mac용 Visual Studio 2019 버전 8.0(8.0.0.3001)Visual Studio 2019 for Mac version 8.0 (8.0.0.3001)

릴리스 날짜: 2019년 4월 2일released April 2, 2019

설치Install

  • Mac용 Visual Studio 설치 관리자에게 업데이트된 아이콘, 시작 화면 및 모든 개발자에게 유용한 콘텐츠가 있는 회전식 화면을 새롭게 제공했습니다.We've given the Visual Studio for Mac Installer a fresh look with updated icons, splash screens, and carousel screens with useful content for all developers.
  • Mac용 Visual Studio(10.12)에 필요한 최소 버전의 macOS에 대한 지원을 추가했습니다.We added support for a minimum version of macOS required for Visual Studio for Mac (10.12). macOS 10.12의 최신 버전이 아닌 경우 설치 관리자에서 지금 macOS 버전을 업그레이드하라는 메시지가 표시됩니다.If you're not on macOS 10.12 of newer the installer now prompts you to upgrade your version of macOS.
  • 설치 관리자의 기본값을 작고 스마트한 설치로 변경했습니다.We changed our installer defaults to a smaller and smarter install. 기본적으로 모든 항목을 선택하는 대신 모든 사용자에 대해 IDE 및 .NET Core를 선택하고, 머신에서 Xcode 또는 Android SDK 버전이 검색되면 iOS 또는 Android만 선택합니다.Instead of selecting everything by default, we select the IDE and .NET Core for all users, and only select iOS or Android if any version of Xcode or Android SDK is detected on your machine.
  • Xamarin.iOS 또는 Xamarin.Mac 앱을 개발 중인 경우, 아직 설치되지 않았으면 지금 권장되는 버전의 Xcode으로 업데이트하라는 메시지가 표시됩니다.If you are developing Xamarin.iOS or Xamarin.Mac apps, we now prompt you to update to the recommended version of Xcode, if you don't already have it installed.
  • Android SDK 다운로드에서 NDK를 제거했습니다.We removed the NDK from the Android SDK download.
  • UI를 개선하고 사용자가 Xamarin.Android의 선택을 취소할 수 있도록 하는 등 Android 권한 대화 상자를 많이 개선했습니다.We made many improvements to the Android permissions dialog, including improving the UI and allowing the user to uncheck Xamarin.Android.

시작 창Start Window

이번 릴리스를 통해 프로젝트와 상호 작용하고 IDE에서 이동해야 하는 위치를 가져오는 새로운 방법을 도입했습니다.With this release, we've introduced a brand new way of interacting with your projects and getting you to where you need to go in the IDE.

Mac용 Visual Studio를 처음 사용하는 경우 IDE를 처음 열 때 로그인하라는 메시지가 표시됩니다.If you're a new Visual Studio for Mac user, you'll be prompted to log in when you first open the IDE. 로그인하면 Professional 또는 Enterprise 계정을 활성화하거나 Azure에 연결할 수 있습니다.By logging in you can activate your Professional or Enterprise account or connect to Azure. 로그인할 준비가 되지 않았으면 건너뛰기 단추를 누르고 Visual Studio > 로그인 메뉴 항목을 통해 로그인할 수 있습니다.If you're not ready to sign in, you can press the Skip button and sign in through the Visual Studio > Sign In menu item.

Sign-in Dialog
새로운 로그인 대화 상자New Sign in dialog

그러면 새로운 시작 창을 마주하게 됩니다.You'll then be greeted with the new start window. 이 창에는 새 프로젝트와 기존 프로젝트를 만들거나 열 수 있는 세 개의 주요 섹션이 있습니다.This window has three main sections, allowing you to create or open new and existing projects:

New Start Window
새로운 시작 창New Start window
  • 최근에 사용한 프로젝트: 여기서 가장 최근에 사용한 25개의 프로젝트 목록을 찾을 수 있습니다.Recent Projects: Here you can find a list of your 25 most recent projects. 프로젝트를 목록의 맨 위에 유지하려는 경우 필요에 따라 가장 자주 사용하는 프로젝트를 "고정"할 수 있습니다.You can optionally "pin" your most frequently used project, if you'd prefer to keep them at the top of the list. 검색 상자를 사용하여 목록의 모든 최근 프로젝트를 필터링할 수 있습니다.The search box can be used to filter through all recent projects in the list.
  • 열기: 이 단추를 사용하여 로컬 디렉터리에서 .csproj, .fsproj, .sln 또는 기타 지원되는 파일을 열 수 있습니다.Open: You can open any .csproj, .fsproj, .sln or any other supported file from your local directory using this button.
  • 새로 만들기: 새 프로젝트를 시작하는 데 도움이 되는 미리 채워진 여러 템플릿 중에서 선택할 수 있습니다.New: You can select from the many pre-populated templates to help you get started with a new project. 새 프로젝트 대화 상자에서 시작하고 실행하는 데 도움이 되는 모든 필요한 구성을 통해 안내합니다.The new project dialog will take you through all the necessary configurations to help you get up and running.

새 코드 편집기New Code Editor

Mac용 Visual Studio 2019에는 Mac용 Visual Studio를 위한 차세대 텍스트 편집기의미리 보기가 포함되어 있습니다.Visual Studio for Mac 2019 contains a preview of the next generation text editor for Visual Studio for Mac! 이 새 텍스트 편집기는 완전히 새로워진 네이티브 사용자 인터페이스를 통해 Visual Studio Windows와 동일한 핵심 구성 요소를 공유합니다.This new text editor shares the same core components with Visual Studio Windows, with an entirely new, native user interface.

New Editor
Mac용 Visual Studio의 새 편집기 기능New editor features in Visual Studio for Mac

현재 새 편집기는 C# 파일만 지원합니다.At this time, the new editor supports C# files only. 향후 릴리스에서 다른 언어를 추가로 지원할 예정입니다.Additional language support will be added in future releases.

새로운 Mac용 Visual Studio 편집기는 다음 기능을 제공합니다.The new Visual Studio for Mac editor brings the following features:

  • 네이티브 macOS(Cocoa 기반) 사용자 인터페이스(도구 설명, 편집기 화면, 여백 장식, 텍스트 렌더링 IntelliSense)Native macOS (Cocoa-based) user interface (tooltips, editor surface, margin adornments, text rendering, IntelliSense)
  • 네이티브 텍스트 입력 지원Support for native text inputs
  • RTL/BiDi 언어 지원RTL/BiDi language support
  • 공통 Visual Studio 플랫폼 코어Common Visual Studio Platform core
  • Roslyn 3Roslyn 3
  • 다중 캐럿 지원Multi-caret support
  • 자동 줄 바꿈Word Wrap
  • IntelliSense UI 업데이트Update IntelliSense UI
  • 개선된 찾기/바꾸기Improved Find/Replace

이제 예외는 Cocoa UI를 사용하여 예외 알림 및 세부 정보를 포함한 예외 메시지를 표시합니다.Exceptions now use the Cocoa UI to display exception messages, including exception notification and details:

New Exceptions in Visual Studio for Mac
Mac용 Visual Studio의 새로운 예외New exceptions in Visual Studio for Mac

컨텍스트 메뉴 탐색이 활성화됩니다.Context Menu Navigation is enabled. 이제 "선언으로 이동" 및 "구현으로 이동"과 같은 팝업 메뉴 기반 탐색 명령을 사용할 수 있습니다.You can now use context menu based navigation commands like "Go to Declaration" and "Go To Implementation". "Using 제거 및 정렬"도 사용하도록 설정했습니다.We have also enabled "Remove and Sort Usings".

편집기를 사용 또는 사용하지 않도록 설정하는 방법How to enable or disable the editor

새 편집기는 Mac용 Visual Studio 2019의 미리 보기 기능이므로, 이 기능을 사용하려면 옵트인해야 합니다.As the new editor is a preview feature within Visual Studio for Mac 2019, you have to opt-in to use the feature. Visual Studio > 기본 설정... > 텍스트 편집기 > 일반 섹션으로 이동하여 새 편집기에서 C# 파일 열기 확인란을 선택합니다.Go to the Visual Studio > Preferences… > Text Editor > General section and check the Open C# files in the New Editor checkbox. 이 옵션을 선택하면 새로 열리는 C# 파일이 새 편집기를 사용하게 됩니다.Once this option is checked, any newly opened C# files will be using the new editor. 편집 창의 오른쪽 아래에 "새 편집기 미리 보기" 단추가 표시되면 새 편집기가 사용되는 것을 알 수 있습니다.You will know the new editor is enabled when the "New Editor Preview" button appears in the bottom-right of the editing window.

새 편집기를 사용하지 않도록 설정하려면 편집기 창의 오른쪽 아래에서 새 편집기 미리 보기 단추를 클릭하고 새 편집기 미리 보기 사용 안 함 을 선택하거나, Visual Studio > 기본 설정... > 텍스트 편집기 > 일반 섹션으로 이동하여 새 편집기에서 C# 파일 열기 확인란의 선택을 취소합니다.To disable the new editor, either click the New Editor Preview button in the bottom right of the editor pane and select Disable the New Editor Preview or navigate to the Visual Studio > Preferences… > Text Editor > General section and un-check the Open C# files in the New Editor checkbox.

편집기를 사용하여 문제를 보고하는 방법How to Report a Problem with the editor

새 편집기에서 문제를 보고하려면 편집기 창의 오른쪽 아래에서 "새 편집기 미리 보기" 단추를 클릭하고 "문제 보고"를 선택합니다.To report a problem in the new editor, either click the "New Editor Preview" button in the bottom right of the editor pane and select "Report a Problem". 개발자 커뮤니티로 직접 이동할 수도 있습니다.You can also go directly to Developer Community.

여러 인스턴스 지원Support for multiple instances

Mac용 Visual Studio는 이제 도크에서 여러 IDE 인스턴스를 여는 것을 지원합니다.Visual Studio for Mac now supports opening multiple instances of the IDE from the dock. Mac용 Visual Studio는 창 하나에서 여러 솔루션 열기를 항상 지원했지만, IDE에 대해 창 여러 개를 지원해 달라는 요청이 정말 많았습니다.Visual Studio for Mac has always had support for opening multiple solutions in one window but we’ve heard a lot of requests to support multiple windows for the IDE. 새 인스턴스를 열려면 도크의 아이콘을 마우스 오른쪽 단추로 클릭하고 새 인스턴스 를 선택합니다.To open a new instance, right-click on the icon in the dock and select New Instance:

Opening a new instance graphic
Mac용 Visual Studio의 새 인스턴스 열기Opening a new instance of Visual Studio for Mac

시작 프로젝트 설정Set Startup projects

새 명령 시작 프로젝트 설정 을 사용하면 디버깅 시 여러 프로젝트를 시작하는 솔루션 실행 구성을 쉽게 만들 수 있습니다.A new command, Set Startup Projects, is available to make it easier to create a solution Run Configuration that will launch multiple projects when debugging. 여러 시작 프로젝트 설정에 대한 정보는 설명서를 참조하세요.For information on setting multiple startup projects, see the documentation.

Set startup projects dialog
시작 프로젝트 설정 대화 상자Set Startup Projects dialog

Unity의 디버깅 기능 향상Debugging improvements for Unity

이 릴리스에서는 Unity 프로젝트용으로 사용되는 디버거를 Windows에서 Visual Studio Tools for Unity의 디버거로 대체했습니다.In this release we've replaced the debugger that's used for Unity projects with the debugger from Visual Studio Tools for Unity on Windows. 이러한 변경으로 인해 이전 버전의 Unity와의 호환성이 향상되고, 안전하지 않은 C# 코드를 디버깅하기 위한 개선이 이루어졌으며, 안정성을 향상되었습니다.This change has better compatibility with older versions of Unity, improvements for debugging unsafe C# code, and provides better reliability.

Xamarin 개선Xamarin Improvements

Xamarin 개발자는 이 릴리스에서 많은 개선 사항을 확인할 수 있습니다.Xamarin developers should find a ton of improvements in this release. 새로운 주요 기능은 다음과 같습니다.New highlights include:

Xamarin.AndroidXamarin.Android

Microsoft는 개발자들이 하루에 빌드-배포-디버그 주기를 셀 수 없이 많이 반복한다는 것을 알고 있으며, 내부 개발 주기 반복을 줄이기 위해 계속 노력하고 있습니다.We know that developers run through the build-deploy-debug cycle countless times a day, and we're consistently working towards shortening the inner development loop even more. 이 릴리스에서는 증분 빌드 및 배포를 최적화하여 많은 개선이 이루어졌습니다.In this release, we've made huge gains by optimizing incremental builds and deployments.

테스트를 위해 SmartHotel360 앱을 사용하여 증분 빌드 시간이 29%까지 줄었고 배포 시간은 최대 2배 더 빨라졌습니다.Using the SmartHotel360 app for testing, incremental build times have been trimmed by up to 29%, and deployment times are up to twice as fast. 빌드 성능 프로파일링 및 방법론에 대한 전체 보고서는 Xamarin.Android wiki에서 확인할 수 있으며, 간단한 개요는 다음과 같습니다.A full report of build performance profiling and methodology is available on the Xamarin.Android wiki, but here’s a quick overview:

단계Step Visual Studio 2017Visual Studio 2017 Visual Studio 2019Visual Studio 2019 델타Delta
첫 번째 빌드First build 01:04.2001:04.20 00:50.1300:50.13 -21.95%-21.95%
증분 빌드(XAML 변경)Incremental Build (XAML Change) 00:10.6200:10.62 00:07.4700:07.47 -29.66%-29.66%
배포(XAML 변경)Deploy (XAML Change) 00:09.0300:09.03 00:04.4400:04.44 -50.83%-50.83%

빌드 안정성을 향상하려는 노력을 계속하고 있으며, Android 리소스 업데이트를 최적화했습니다.Our mission to continually increase build reliability continues and one area we've made optimizations to is Android resource updates. 빌드 시 리소스 업데이트가 발생하는 경우를 최소화함으로써 이 영역에서 발생하는 충돌로 인한 빌드 문제를 상당히 줄였습니다.By minimizing scenarios where resource updates would occur at build time, there should be a significant reduction of build issues stemming from conflicts in this area.

Windows 환경의 Visual Studio에서 Android와 동등하게 만드는 단계에서 배포 프로세스가 훨씬 더 간소화되었으며, 이제 빌드를 시작할 때 Android Emulator가 실행됩니다.In a step towards parity with the Android in Visual Studio on Windows experience, the deployment process has been further streamlined and the Android emulator will now launch when starting a build.

Xamarin.FormsXamarin.Forms

Xamarin Forms 셸용 새 템플릿을 사용할 수 있으며, IDE에서 더욱 통합된 환경을 위해 이 릴리스에는 이전에 Windows의 Visual Studio에서만 사용 가능했던 새 파일 템플릿이 포함됩니다.The brand-new template for Xamarin Forms Shell projects is now available, and for a more uniform experience across IDEs, this release also includes new file templates previously available only in Visual Studio on Windows. Mac용 Visual Studio 2019 메뉴에서 [파일] > [새 파일] > [Forms] 로 이동하여 새 XAML 파일을 사용할 수 있습니다.You can use the new XAML files today by navigating to File > New File… > Forms in the Visual Studio 2019 for Mac menu. 새 파일 항목은 다음과 같습니다.The new file items are:

  • Forms ListViewPage XAMLForms ListViewPage XAML
  • Forms MasterDetailPage XAMLForms MasterDetailPage XAML
  • Forms TabbedPage XAMLForms TabbedPage XAML
  • Forms ViewCell XAMLForms ViewCell XAML

그리고 생산성을 향상하기 위해 이제 FontFamily용 Xamarin.Forms XAML 파일의 Intellisense 지원이 제공됩니다.And to help make productivity a touch better, Intellisense in Xamarin.Forms XAML files for FontFamily support is now available:

New Xamarin.Forms XAML files
새 Xamarin.Forms XAML 파일New Xamarin.Forms XAML files

Android DesignerAndroid Designer

이제 Android Pie(9.0)에 대한 지원도 제공됩니다!We now have support for Android Pie (9.0)! 또한 Android Designer 시작 시간과 위젯 스크롤 지원을 개선했습니다.Additionally, we made enhancements to increase Android Designer start up time and improved scrolling widget support.

또한 이 릴리스에서는 ‘@’, ‘?’ 같은 이스케이프 시퀀스와 유니코드 이스케이프 시퀀스에 대한 지원뿐만 아니라, 해당 특성이 설정된 경우 문서에 “표준” XML 네임스페이스 추가가 지원됩니다.This release also ships support for adding “standard” XML namespaces to documents when a corresponding attribute is set, as well as support for escape sequences like '@', '?' and Unicode escape sequences.

iOS DesigneriOS Designer

이미지 형식으로써 PDF 지원이 추가되고, 색 공간 및 색 정밀도 지원이 향상되었습니다.We’ve added support for PDF as an image format, and improved support for color spaces and color precision. 이제 자산 카탈로그에서 명명된 색을 색 속성 값으로 선택할 수도 있습니다.Additionally, you can now select named colors from asset catalogs as the value for color properties.

이제 기본 동적 라이브러리 또는 프레임워크를 로드해야 하는 사용자 지정 컨트롤을 지원합니다(정적 라이브러리는 지원되지 않음).We now have support for custom controls that need to load native dynamic libraries or frameworks (note that static libraries are not supported). 또한 CGSize 형식의 사용자 지정 속성이 이제 사용자 지정 컨트롤의 속성 패널에 표시됩니다.Additionally, custom properties of type CGSize will now appear in the property panel for custom controls

Azure Functions 개선 사항Azure Functions improvements

이 릴리스에서 Azure Functions 런타임 및 템플릿(CLI)을 업데이트했습니다.We have updated Azure Functions runtime and templates (CLI) in this release. 또한 Mac용 Visual Studio는 새로운 함수 프로젝트를 만들 때 새 템플릿을 사용할 수 있는 경우, 함수 템플릿을 업데이트할 수 있는 기능을 제공합니다.In addition, Visual Studio for Mac will offer you the ability to update your function templates if new templates are available when creating a new Functions project. Azure Functions 템플릿을 업데이트하려면 "업데이트된 템플릿을 사용할 수 있음" 텍스트 옆에 있는 업데이트 단추를 선택합니다.To update Azure Functions templates, select the update button next to the text "Updated templates are available":

Update Azure Fucntions templates
Azure Functions 템플릿 및 CLI 업데이트Update Azure Functions templates and CLI

Mac용 Visual Studio는 HomeBrew를 통해 설치된 Azure Functions CLI도 지원하며 가장 많이 검색된 버전으로 인스턴스를 선택합니다.Visual Studio for Mac also supports Azure Functions CLI installed via HomeBrew and will choose the instance with the highest discovered version.

해결된 문제Issues Fixed

이 릴리스에서 다음과 같은 문제도 해결되었습니다.The following issues have also been fixed in this release.

코드 편집기Code Editor

프로젝트Projects

IDEIDE

  • '구조적 빌드 출력 창에서 포커스 없이 선택한 행에서 잘못된 텍스트 색이 사용됨' 문제가 해결되었습니다.We fixed an issue where the wrong text color is used in an unfocused but selected row in the structured build output window.
  • '솔루션 탐색기 에서 새 폴더를 만들면 폴더 이름을 동시에 지정할 수 없음' 문제가 해결되었습니다.We fixed an issue where creating a new folder in the Solution Explorer does not let you name the folder at the same time.
  • 디버깅하지 않고 시작 후에 디버깅 시작 을 수행하면 ASP.Net 프로젝트 예외가 발생합니다.Start Debugging after Start without Debugging results in an exception for ASP.Net projects.
  • 솔루션 탐색기 에서 항목 실행 명령의 이름이 프로젝트 실행 으로 변경되었습니다.The Run Item command on the Solution Explorer has been renamed to Run Project.
  • 이제 Mac용 Visual Studio는 거의 모든 요청에 대한 웹 요청을 만들 때 HttpClient 및 네이티브 Mac 네트워킹 API를 사용합니다.Visual Studio for Mac will now use HttpClient and the native Mac networking API when making web requests for nearly all its requests. 일부 영역은 Xamarin.Mac의 NSUrlSession을 통해 제공되는 HttpClient 및 Mac 네트워킹 API를 사용하도록 아직 업데이트되지 않았습니다.Some areas have not yet been updated to use HttpClient and the Mac networking API available through Xamarin.Mac's NSUrlSession. Mac의 네트워킹 API는 자체 프록시를 기본적으로 지원합니다.The Mac's networking API provides its own built in support for proxies. Mono의 네트워킹 API를 대안으로 사용하도록 Mac용 Visual Studio를 구성할 수도 있습니다.Visual Studio for Mac can also be configured to use Mono's networking API as an alternative. 로그인 대화 상자 같은 일부 영역은 아직 지원되지 않으며 앞으로도 Mono의 네트워킹 API를 계속 사용할 것입니다.Some areas are not yet supported such as the sign in dialog, and will continue to use Mono's networking API.
  • 코드 서식 지정 정책이 UI에 표시되지 않는 문제를 해결했습니다.We fixed an issue where not seeing Code Formatting policies in the UI.
  • Mac용 Visual Studio에서 프로젝트를 C# -> F# 또는 그 반대로 변경할 수 없는 문제를 해결했습니다.We fixed an issue where VisualStudio for Mac cannot change projects from C# -> F# or vice versa.
  • XAML용 Toolbox Clipboard Ring 파일에서 항목을 삭제할 수 없는 문제를 해결했습니다.We fixed an issue where it was not possible to delete entries from Toolbox Clipboard Ring for XAML files.
  • Visual Studio로 초점을 맞추어 UI에서 기본 포커스 요소를 변경하는 문제를 해결했습니다.We fixed an issue where focusing out/into Visual Studio changes the default focused element on the UI.
  • 탐색 기록이 기록에서 파일을 제거하는 문제를 해결했습니다.We fixed an issue where navigation history removes files from history.
  • 도움말 메뉴에서 항목을 업데이트했습니다.We updated items in the help menu.
  • 2개의 솔루션이 열린 2열 편집 모드로 포커스를 설정할 수 없음 문제를 해결했습니다.We fixed an issue where you cannot set focus in 2 column edit mode with 2 solutions open.
  • "정보" 대화 상자 창 제목을 좀 더 읽기 좋게 업데이트했습니다.We updated the "About" dialog window title to be more human readable.
  • 일부 창이 잘못된 위치에 표시되는 문제를 해결했습니다.We fixed an issue where some windows appear positioned incorrectly.
  • 파일 추가 모달 진행률 창에서 모달 복사/이동이 모호함 문제를 해결했습니다.We fixed an issue where Adding Files modal progress window obscures copy/move modal.

.NET Core.NET Core

ASP.NET CoreASP.NET Core

  • API 백 엔드와 함께 제공되는 템플릿에 두 프로젝트를 시작하는 실행 구성이 없는 문제를 해결했습니다.We fixed an issue where templates that come with an API backend did not have a run configuration that launches both projects.
  • ASP.NET Core 프로젝트의 탐색 -> 멤버를 구현하는 중 이 작동하지 않는 문제를 해결했습니다.We fixed an issue where Navigate -> Implementing Members in ASP.NET Core project doesn't work.
  • ASP.NET Core 웹앱을 사용하는 솔루션인 경우 솔루션 형식 변환 이 아무 것도 하지 않는 문제를 해결했습니다.We fixed an issue where Convert Solution Format doesn't do anything for a solution with an ASP.NET Core web app.

NuGetNuGet

웹 도구Web Tools

  • .ts 파일이 VSMac에서 작동하지 않는 문제를 해결했습니다.We fixed an issue where .ts files are not working in VSMac.
  • Mac용 Visual Studio 2019에서 Docker 프로젝트를 열 수 없는 문제를 해결했습니다.We fixed an issue where Visual Studio for Mac 2019 cannot open Docker projects.
  • JavaScript 요약 정보 도구 설명이 편집기 창 밖에 표시되는 문제를 해결했습니다.We fixed an issue where JavaScript quick info tooltip is showing up outside the editor window.
  • launchSettings.json에서 복사하여 붙여넣기 작업을 수행할 때 Mac용 Visual Studio가 충돌하는 문제를 해결했습니다.We fixed an issue where Visual Studio for Mac crashes on copy & paste in launchSettings.json.

XamarinXamarin

  • Mac용 Visual Studio에서 Live Player가 제거되었습니다.We have removed the Live Player from Visual Studio for Mac.
  • 도움말 -> 릴리스 정보 가 엉뚱한 위치로 연결되는 문제를 해결했습니다.We fixed an issue where the Help -> Release Notes linked to the wrong place.

디자이너Designers

Android DesignerAndroid Designer

Xamarin.FormsXamarin.Forms

Xamarin.iOSXamarin.iOS

Xamarin.AndroidXamarin.Android

  • Xamarin Android Player 에뮬레이터에 대한 나열 및 표시 지원이 제거되었습니다.We have removed support for listing and showing Xamarin Android Player emulators.
  • '새 Android 앱의 패키지 이름에 대문자가 있음' 문제가 해결되었습니다.We fixed an issue where new Android apps have uppercase letters in the package name.
  • 새 프로젝트에서 strings.xml의 대/소문자 구분이 일관되지 않음 문제가 해결되었습니다.We fixed an issue where the casing of strings.xml was inconsistent for new projects.
  • '문제 보고 대화 상자가 열리면 "JDK 설치" 대화 상자도 표시됨' 문제가 해결되었습니다.We fixed an issue where opening the Report A Problem dialog also displays "Install JDK" dialog.
  • 새 프로젝트가 최솟값 및 대상 API를 올바르게 설정하지 않는 문제를 해결했습니다.We fixed an issue where new projects do not have the min and target API set correctly.
  • Android 'WebView 앱' 템플릿에 프로젝트 생성 대화 상자의 '최신 개발' 옵션이 제공되지 않는 문제를 해결했습니다.We fixed an issue where the Android ‘WebView App’ template does not have a ‘Modern Development’ option in project creation dialog.
  • Mac용 Visual Studio에서 Android Emulator 시작이 매우 느림 문제를 해결했습니다.We fixed an issue where the Android Emulator Launch in Visual Studio for Mac is extremely slow.
  • Android 앱을 실행하면 Mac용 Visual Studio 2019에서 "HAXM"으로 시작하지 않음 문제를 해결했습니다.We fixed an issue where running the Android app does not start with "HAXM" on Visual Studio for Mac 2019.
  • 이제 프로젝트를 빌드할 때 Android 에뮬레이터를 시작합니다.We now start the Android emulator when starting to build the project.
  • 이제 사용자는 Xamarin.Android 프로젝트 설정에서 AAPT와 AAPT2 중 하나를 선택할 수 있습니다.Users can now choose between AAPT and AAPT2 in Xamarin.Android project settings.
  • 디바이스에 배포가 100% 중단되는 문제를 해결했습니다.We fixed an issue where deploying to device hangs at 100%.
  • Android 에뮬레이터 시작을 취소할 수 없고 이미지가 손상된 경우 Mac용 Visual Studio를 강제로 종료해야 하는 문제를 해결했습니다.We fixed an issue where it was not possible to cancel starting an Android emulator, and having to force quit Visual Studio for Mac if the image was broken.
  • 프로젝트용 Android .csproj 파일이 여러 개 있는 경우(패키지 이름이 다른 여러 Android 매니페스트 사용) 올바르지 않거나 잘못된 보관 파일을 생성하여 게시하지 못하는 문제를 해결했습니다.We fixed an issue where, if there were multiple Android .csproj files for a project (using different Android Manifests with differing package names), would produce incorrect or invalid archive and would fail to publish.
  • Android 이외의 프로젝트에서도 홈페이지에 JDK 알림이 표시되는 문제를 해결했습니다.We fixed an issue where the JDK notification was shown on the welcome page, even for non-Android projects.
  • Android 리소스 업데이트가 빌드 문제를 일으킬 수 있는 빌드와 동시에 발생할 수 있는 문제를 해결했습니다.We fixed an issue where the Android resource update could occur at the same time as a build which could then cause build issues.

Xamarin.MacXamarin.Mac

테스트 도구Test Tools

액세스 가능성Accessibility

  • 이 릴리스에서는 디버거 및 iOS 개발자 인증서 생성 시의 몇 가지 VoiceOver 문제 및 Android SDK Manager의 키보드 문제를 포함하여 여러 접근성 문제가 해결되었습니다.We fixed a number of accessibility issues in this release, including several VoiceOver issues in the Debugger and in creating iOS developer certificates, and Keyboard issues in the Android SDK Manager.

소스 제어Source Control

Git 및 Azure DevOps/Team Foundation Server를 사용하는 Microsoft 계정 인증에 대한 지원을 추가했습니다. 이전에는 성공적으로 연결하지 않고도 지속적으로 자격 증명을 묻는 메시지를 표시했습니다.We have added support for Microsoft Account authentication with Git and Azure DevOps/Team Foundation Server, which previously would continually prompt for credentials without successfully connecting.

GitGit

디버거Debugger

Azure 도구Azure Tools

  • Azure Functions는 이제 새 프로젝트 대화 상자에 있는 두 단어입니다.Azure functions is now two words in the New Project Dialog.

프로파일러Profiler

  • VSMac 기본 설정을 삭제한 후에 NullReferenceException이 throw되는 문제를 해결했습니다.We fixed an issue where a NullReferenceException is thrown after deleting VSMac preferences.

InstallerInstaller

  • Android 사용 권한으로 인해 애플리케이션이 중단되는 문제를 해결했습니다.We fixed an issue where the Android Permissions were causing the application to hang.
  • 개별 구성 요소에 대해 보고하는 오류를 개선하여 오류 페이지를 즉시 표시하지 않게 되었습니다.We improved the error reporting for individual components and will not show the error page right away.
  • 이전 Mac용 Visual Studio 버전을 백업용으로 복사할 때 symlinks가 중단되는 버그를 해결했습니다.We fixed bug where symlinks were breaking when an older Visual Studio for Mac version was copied for backup.
  • 비-레티나/low-res 아이콘이 모든 곳에 표시되는 버그를 해결했습니다.We fixed a bug where non-retina/low-res icons are being displayed everywhere.

UpdaterUpdater

  • 업데이트를 확인하면 로그인하라는 프롬프트가 여러 개 발생할 수 있는 문제를 해결했습니다.We fixed an issue where checking for updates can result in multiple prompts to sign in.
  • 업데이트 후 다시 시작하지 않으면 이상한 MSBuild 오류가 발생할 수 있는 문제를 해결했습니다.We fixed an issue where updating without restarting can cause strange MSBuild errors.

기타Other


피드백 및 제안Feedback and Suggestions

Microsoft는 여러분의 의견을 기다리고 있습니다!We would love to hear from you! Mac용 Visual Studio IDE의 문제 보고 옵션을 통해 문제를 보고할 수 있습니다.You can report a problem through the Report a Problem option in Visual Studio for Mac IDE. 개발자 커뮤니티 포털에서 제안 사항을 포함하여 피드백을 추적할 수 있습니다.You can track your feedback, including suggestions, in the Developer Community portal.


알려진 문제Known Issues

Mac용 Visual Studio 2019 버전 8.0에서 알려진 기존의 모든 문제 목록은 다음과 같습니다.The following is a list of all existing known issues in Visual Studio 2019 for Mac version 8.0:


Mac용 Visual Studio 릴리스 정보 기록Visual Studio for Mac Release Notes History

릴리스 정보 기록 페이지에서 Mac용 Visual Studio 2017 이전 버전의 릴리스 정보를 볼 수 있습니다.You can view prior versions of Visual Studio 2017 for Mac release notes on the Release notes history page.


위쪽
Top of Page