Visual Studio Icon Mac용 Visual Studio 2019 버전 8.3 릴리스 정보Visual Studio 2019 for Mac version 8.3 Release Notes



개발자 커뮤니티 | 시스템 요구 사항 | 호환성 | 배포 가능한 코드 | 설명서 | 블로그 | 서비스Developer Community | System Requirements | Compatibility | Distributable Code | Documentation | Blogs | Servicing


단추를 클릭하여 Mac용 Visual Studio 2019 최신 버전을 다운로드합니다.Click the button to download the latest version of Visual Studio 2019 for Mac. 시스템 요구 사항에 대한 정보는 Mac 시스템 요구 사항Mac 플랫폼 대상 지정 및 호환성 가이드를 참조하세요.For information on the system requirements see the see Mac System Requirements and Mac Platform Targeting and Compatibility guides.

Mac용 Visual Studio 2019 설치 및 업데이트에 대한 지침은 Mac용 Visual Studio 설치 가이드를 참조하세요.For instructions on installing and updating Visual Studio 2019 for Mac, see the Install Visual Studio for Mac guide.

Download VS for Mac

다른 관련 다운로드에 대해 자세히 알아보려면 다운로드 페이지를 참조하세요.To learn more about other related downloads, see the Downloads page.


Mac용 Visual Studio 2019의 새로운 기능What's New in Visual Studio 2019 for Mac

Mac용 Visual Studio 2019 릴리스Visual Studio 2019 for Mac Releases

Mac용 Visual Studio 2019 블로그 게시물Visual Studio 2019 for Mac Blog Posts

Visual Studio 블로그 는 엔지니어링 팀의 제품 정보가 제공되는 공식 출처입니다.The Visual Studio Blog is the official source of product insight from the Visual Studio Engineering Team. 다음 게시물에서 Mac용 Visual Studio 2019 릴리스에 대한 자세한 정보를 찾을 수 있습니다.You can find in-depth information about the Visual Studio 2019 for Mac releases in the following posts:


릴리스 주요 내용Release Highlights

알려진 문제Known Issues

알려진 문제 섹션을 참조하세요.Refer to the Known Issues section.


Release Notes Icon Mac용 Visual Studio 2019 버전 8.3.11(8.3.11.1)Visual Studio 2019 for Mac version 8.3.11 (8.3.11.1)

릴리스 날짜: 2019년 12월 11일released December 11, 2019

이 서비스 릴리스는 .NET 런타임 2.1.14 및 .NET Core SDK 3.0.101에 대한 지원을 제공합니다.This service release provides support for .NET Runtime 2.1.14 and .NET Core SDK 3.0.101.

Release Notes Icon Mac용 Visual Studio 2019 버전 8.3.10(8.3.10.2)Visual Studio 2019 for Mac version 8.3.10 (8.3.10.2)

릴리스 날짜: 2019년 11월 21일released November 21, 2019

이 서비스 릴리스는 다음 문제를 해결합니다.This service release fixes the following issues:

Release Notes Icon Mac용 Visual Studio 2019 버전 8.3.9(8.3.9.2)Visual Studio 2019 for Mac version 8.3.9 (8.3.9.2)

릴리스 날짜: 2019년 11월 18일released November 18, 2019

이 서비스 릴리스는 다음 문제를 해결합니다.This service release fixes the following issues:

Release Notes Icon Mac용 Visual Studio 2019 버전 8.3.8(8.3.8.8)Visual Studio 2019 for Mac version 8.3.8 (8.3.8.8)

릴리스 날짜: 2019년 11월 11일released November 11, 2019

이 서비스 릴리스는 다음 문제를 해결합니다.This service release fixes the following issues:

Release Notes Icon Mac용 Visual Studio 2019 버전 8.3.7(8.3.7.1)Visual Studio 2019 for Mac version 8.3.7 (8.3.7.1)

릴리스 날짜: 2019년 11월 5일released November 5, 2019

이 서비스 릴리스에서는 Xcode 11.2에 대한 지원이 추가되었습니다.This service release adds support for Xcode 11.2.

Release Notes Icon Mac용 Visual Studio 2019 버전 8.3.6(8.3.6.4)Visual Studio 2019 for Mac version 8.3.6 (8.3.6.4)

릴리스 날짜: 2019년 11월 1일released November 1, 2019

이 서비스 릴리스는 해당 OS 버전의 메모리 압력이 증가하여 macOS Catalina에서 발생하는 충돌을 해결합니다.This service release addresses crashes on macOS Catalina as a result of increased memory pressure in that OS version.

Release Notes Icon Mac용 Visual Studio 2019 버전 8.3.5(8.3.5.13)Visual Studio 2019 for Mac version 8.3.5 (8.3.5.13)

릴리스 날짜: 2019년 10월 28일released October 28, 2019

이 서비스 릴리스는 다음 문제를 해결합니다.This service release fixes the following issues:

Release Notes Icon Mac용 Visual Studio 2019 버전 8.3.4(8.3.4.7)Visual Studio 2019 for Mac version 8.3.4 (8.3.4.7)

릴리스 날짜: 2019년 10월 14일released October 14, 2019

이 릴리스는 Mac용 Visual Studio가 Catalina에서 작동이 중단되는 해결합니다.This release fixes issues that were causing Visual Studio for Mac to crash on Catalina. 작동이 중단되는 경우 미리 보기 채널로 전환하세요.If you are experiencing crashing, please switch to the Preview channel.

Release Notes Icon Mac용 Visual Studio 2019 버전 8.3.3(8.3.3.8)Visual Studio 2019 for Mac version 8.3.3 (8.3.3.8)

릴리스 날짜: 2019년 10월 10일released October 10, 2019

이 릴리스에서는 Xcode 11.1에 대한 지원이 추가되었습니다.This release adds support for Xcode 11.1.

이 서비스 릴리스는 다음 문제를 해결합니다.This service release also fixes the following issues:

  • Xcode가 이 애플리케이션을 제거했으므로 [애플리케이션 로더] 명령을 제거했습니다.We removed the [Application Loader] command as Xcode has removed this application. 이 가이드의 단계를 사용하여 App Store Connect에 업로드하세요.Use the steps in this guide to upload it to App Store Connect.
  • 원격 분석을 통해 다양한 크래시가 보고되었습니다.Various crashes reported through telemetry.
  • 프로파일러가 시작되지 않았습니다.The profiler does not start.

Release Notes Icon Mac용 Visual Studio 2019 버전 8.3.2(8.3.2.32)Visual Studio 2019 for Mac version 8.3.2 (8.3.2.32)

릴리스 날짜: 2019년 10월 7일released October 7, 2019

이 서비스 릴리스는 다음 문제를 해결합니다.This service release fixes the following issues:

  • [정규식 바꾸기]가 새 편집기에 없습니다.Regular Expression Replace is missing from new editor.
  • 특정 값과 함께 [탐색]을 사용할 때 작동이 중단됩니다.A crash when using Navigate To with certain values.
  • [핫 다시 로드]를 사용할 때 iOS 디바이스에서 실행 중 중단점을 삽입할 수 없습니다.Unable to insert a breakpoint when running on iOS device when using Hot Reload.
  • 설치되지 않은 .Net Core의 미리 보기를 참조하는 global.json을 사용하여 솔루션을 열려고 하면 오류가 발생합니다.Error when trying to open a solution with a global.json that references a preview of .Net Core that is not installed.
  • 새 편집기에서 이모지 선택기를 풀할 수 없습니다.Unable to pull up the emoji selector from the new editor.

Release Notes Icon Mac용 Visual Studio 2019 버전 8.3.1(8.3.1.18)Visual Studio 2019 for Mac version 8.3.1 (8.3.1.18)

릴리스 날짜: 2019년 9월 30일released September 30, 2019

이 서비스 릴리스는 다음 문제를 해결합니다.This service release fixes the following issues:

  • VSMac는 시작 시 “오류를 페치하는 중” 창을 표시합니다.VSMac displays the error "Error fetching rights" window on launch.
  • 웹 편집기는 jsx/tsx 파일 확장명이 있는 파일을 지원하지 않습니다.Web Editors don't support files with jsx/tsx file extension.
  • F# 파일을 구문 분석하는 동안 스택 오버플로가 발생하면 IDE 작동이 중단됩니다.A stack overflow while parsing F# files causes IDE to crash.
  • Azure에 Azure 함수를 게시할 수 없습니다(dotnet이 예기치 않게 닫힘).Azure functions cannot be published to Azure (dotnet closed unexpectedly).
  • .cshtml 페이지 이름을 바꾸면 .cshtml.cs 파일이 사라집니다.When renaming page .cshtml the .cshtml.cs file disappears.
  • 중첩된 파일을 두 개 이상 이동하기는 작동하지 않습니다.Moving more than 2 nested files does not work.
  • .xaml 탭으로, 또는 탭에서 전환할 때 전체 IDE 셸이(.xaml 파일 사이에도) 공백으로 깜빡입니다.Entire IDE shell flashes blank when switching to/from a .xaml tab (even between .xaml files).

Release Notes Icon Mac용 Visual Studio 2019 버전 8.3(8.3.0.1805)Visual Studio 2019 for Mac version 8.3 (8.3.0.1805)

릴리스 날짜: 2019년 9월 23일released September 23, 2019

새 기능New Features

웹 편집기Web Editors

이 릴리스에서는 Mac용 Visual Studio 2019 버전 8.1에 도입된 새로운 네이티브 코드 편집기에 웹 파일 지원을 추가했습니다.In this release, we have added support for web files to the new native code editor, which was introduced in Visual Studio 2019 for Mac 8.1

JavaScript IntelliSense in the new editor graphic
새 편집기의 JavaScript IntelliSenseJavaScript IntelliSense in the new editor

Mac용 Visual Studio는 다음과 같은 파일 형식에 새로운 네이티브 코드 편집기를 사용합니다.Visual Studio for Mac will now use the new native code editor for the following file types:

  • .JS.JS
  • .TS.TS
  • .HTML.HTML
  • .CSS.CSS
  • .CSHTML.CSHTML
  • .JSON.JSON
  • .LESS.LESS
  • .SCSS.SCSS

새 웹 편집기에는 C# 및 XAML 편집기와 동일한 네이티브 편집기 인터페이스가 제공되며, 공유 Visual Studio 언어 서비스가 지원됩니다.The new web editors are powered by the same native editor interface as the C# and XAML editors and are powered by the shared Visual Studio language service. 새 편집기에서 다음을 기대할 수 있습니다.With the new editors, you can expect:

  • 향상된 IntelliSense 성능Improved IntelliSense performance
  • IntelliSense 형식 필터링IntelliSense type filtering
  • 다중 캐럿 편집Multi-caret editing
  • RTL(오른쪽에서 왼쪽) 및 BiDi(양방향) 텍스트 지원RTL (right-to-left) and BiDi (Bidirectional) text support
  • 네이티브 입력 지원Native input support
  • 향상된 입력 성능Improved typing performance
  • 향상된 텍스트 렌더링Improved text rendering
  • 단어 줄 바꿈Word wrap
  • 향상된 서식 지정Improved formatting
  • 향상된 분류Improved classification

새 편집기를 도입하여 성능 및 파일 지원과 관련된 버그를 비롯한 수많은 버그를 해결했습니다.We've also addressed numerous bugs by implementing the new editors, including bugs related to performance and file support.

멀티 타기팅Multi-Targeting

이 릴리스에는 다중 대상 프레임워크를 포함하는 프로젝트에 대한 향상된 지원을 추가했습니다.In this release we have added improved support for projects that have multi-target frameworks. 몇 가지 기능과 이점은 아래에서 자세히 설명합니다.Some of the features and benefits are detailed below:

  • 다중 대상 프레임워크 프로젝트의 파일을 편집하는 경우, 대상 프레임워크를 선택하여 편집기에서 IntelliSense를 안내할 수 있습니다.When editing a file in a multi-target framework project, the target framework can be selected to guide the intellisense in the editor:

    Multi-target framework editor graphic
    Mac용 Visual Studio의 다중 대상 프레임워크 프로젝트 편집기 환경Multi-target framework project editor experience in Visual Studio for Mac
  • 편집기에는 특정 대상 프레임워크에 사용할 수 없는 API에 대한 IntelliSense 및 도구 설명의 정보가 표시됩니다.The editor will show information in IntelliSense and tooltips about APIs that are not available for a particular target framework.

  • 또한 특정 프레임워크에 대한 디버깅 지원을 추가했습니다.We have also added support for debugging against a specific framework:

    Debugging multi-target framework graphic
    Mac용 Visual Studio에서 다중 대상 프레임워크 프로젝트 디버깅Debugging a multi-target framework project in Visual Studio for Mac

.NET Core.NET Core

이 릴리스에서는 ASP.NET Core 웹 애플리케이션을 실행하거나 디버그할 때 사용되는 브라우저를 선택할 수 있는 기능을 추가했습니다.This release adds the ability to select the browser that is used when you run, or debug, your ASP.NET Core web application.

Select browser graphic
브라우저 선택Select browser

.NET Core 콘솔 및 .NET Standard 라이브러리 프로젝트에 대한 게시 지원Publish support for .NET Core Console and .NET Standard Library Projects

이전 릴리스에서는 ASP.NET Core 프로젝트를 폴더에 게시하는 기능을 추가했습니다.In a previous release we added the ability to publish an ASP.NET Core project to a folder. 이 릴리스에서는 .NET Core 콘솔 및 .NET Standard 라이브러리 프로젝트 게시 지원을 도입했습니다.In this release we have introduced support to publish .NET Core Console and .NET Standard Library Projects. 이 기능을 사용하는 방법에 대한 자세한 내용은 게시 폴더 문서를 참조하세요.For more information on how to use this feature, see the Publish Folder documentation.

launchSettings.json 지원Support for launchSettings.json

ASP.NET Core 애플리케이션을 개발하는 경우, launchSettings.json 파일을 사용하여 개발 목적으로 애플리케이션을 시작하는 방법을 구성할 수 있습니다.When developing ASP.NET Core applications, you can configure how the application is launched for development purposes using the launchSettings.json file. 이 파일에 대한 자세한 내용은 .NET Core 환경 문서를 참조하세요.For more info on this file, see the .NET Core Environments documentation. LaunchSettings 파일에서 실행 또는 디버그 시 적용되는 환경 변수뿐만 아니라 수신 대기할 앱의 URL을 구성할 수도 있습니다.In the launchSettings file, you can configure the URL for the app to listen on as well as environment variables that are applied on run or debug. 이 업데이트를 사용하면 Mac용 Visual Studio를 사용하지 않는 다른 사용자와도 보다 간편하게 프로젝트에서 협업할 수 있습니다.With this update, we have made it easier for you to collaborate on projects with others that may not be using Visual Studio for Mac. Visual Studio, Visual Studio Code 및 dotnet CLI(명령줄 인터페이스)는 모두 이 파일을 지원합니다.Visual Studio, Visual Studio Code and the dotnet CLI (Command Line Interface) all support this file.

파일 중첩 지원File Nesting support

이 릴리스에서는 ASP.NET Core 프로젝트에 대한 자동 파일 중첩 기능을 추가했습니다.In this release we are adding automatic file nesting for ASP.NET Core projects. 적용되는 자동 파일 중첩 규칙은 Visual Studio에서와 동일합니다.The auto file nesting rules applied are the same as what you find in Visual Studio. 파일 중첩을 사용하도록 설정하면 자주 편집하는 파일에 더 잘 집중할 수 있습니다.With file nesting enabled, you can focus better on the files that you edit most frequently. 생성된 파일 및 덜 자주 편집되는 파일은 다른 관련 파일에 중첩됩니다.Generated files, and less frequently edited files will be nested under other related files.

  • 이 릴리스에서 수정된 모든 .NET 버그에 대한 자세한 내용은 버그 수정 섹션을 참조하세요.For information on all .NET bugs fixed in this release, jump to the bug fixes section.

.Net Core의 모든 새로운 기능에 대한 자세한 내용은 .Net Core 릴리스 정보를 참조하세요.For more information on everything new with .NET Core, see the .NET Core release notes.

UnityUnity

Unity와 관련된 새로운 진단을 추가하여 Unity 프로젝트를 위한 Mac용 Visual Studio의 기능에 대한 해석을 심화했습니다.We've deepened the understanding that Visual Studio for Mac has for Unity projects by adding new diagnostics specific to Unity. Unity 프로젝트에 적용되지 않는 일반적인 C# 진단을 억제하여 IDE를 보다 효율적으로 만들었습니다.We've also made the IDE smarter by suppressing general C# diagnostics that don't apply to Unity projects. 예를 들어 IDE에 검사기 변수를 readonly로 변경하는 빠른 수정이 표시되지 않습니다. 이렇게 하면 Unity 편집기에서 변수를 수정할 수 없습니다.For example, the IDE won't show a quick-fix to change an inspector variable to readonly - which would prevent you from modifying the variable in the Unity Editor.

개발자에게서 모범 사례를 배우며 이와 같은 Unity 관련 진단 기능을 추가할 계획입니다.We'll add more of these Unity-specific diagnostics as we learn best practices from developers. 원하는 기능이 있는지, 있다면 어떻게 도움이 될지 알려주세요!Let us know if there is something you'd like to see and how it would help!

빠른 수정이 포함된 새로운 진단New diagnostics with quick-fixes

  • UNT0001: Unity 메시지는 비어 있는 경우에도 런타임에 의해 호출되며, Unity 런타임에 의한 불필요한 처리를 방지하려면 이 메시지를 선언하지 마십시오.UNT0001: Unity messages are called by the runtime even if they are empty, do not declare them to avoid uncesseray processing by the Unity runtime.
  • UNT0002: 문자열 같음을 사용한 태그 비교는 기본 제공 CompareTag 메서드보다 느립니다.UNT0002: Tag comparison using string equality is slower than the built-in CompareTag method.
  • UNT0003: 형식 안전성을 위해 GetComponent의 일반 형식을 사용하는 것이 좋습니다.UNT0003: Usage of the generic form of GetComponent is preferred for type safety.
  • UNT0004: Update 메시지는 프레임 속도에 따라 달라지며, Time.fixedDeltaTime 대신 Time.deltaTime을 사용해야 합니다.UNT0004: Update message is frame-rate dependent, and should use Time.deltaTime instead of Time.fixedDeltaTime.
  • UNT0005: FixedUpdate 메시지는 프레임 속도와 별개이며, Time.deltaTime 대신 Time.fixedDeltaTime을 사용해야 합니다.UNT0005: FixedUpdate message is frame-rate independent, and should use Time.fixedDeltaTime instead of Time.deltaTime.
  • UNT0006: 이 Unity 메시지에 대해 잘못된 메서드 시그니처가 검색되었습니다.UNT0006: An incorrect method signature was detected for this Unity message.
  • UNT0007: Unity는 null 결합과 호환되지 않는 Unity 개체에 대해 null 비교 연산자를 재정의합니다.UNT0007: Unity overrides the null comparison operator for Unity objects which is incompatible with null coalescing.
  • UNT0008: Unity는 null 전파와 호환되지 않는 Unity 개체에 대해 null 비교 연산자를 재정의합니다.UNT0008: Unity overrides the null comparison operator for Unity objects which is incompatible with null propagation.
  • UNT0009: 클래스에 InitializeOnLoad 특성을 적용하는 경우 정적 생성자를 제공해야 합니다.UNT0009: When applying the InitializeOnLoad attribute to a class, you need to provide a static constructor. InitializeOnLoad 특성은 편집기를 시작할 때 호출되도록 합니다.InitializeOnLoad attribute ensures that it will be called as the editor launches.
  • UNT0010: MonoBehaviours를 만들 때는 반드시 AddComponent()를 사용해야 합니다.UNT0010: MonoBehaviours should only be created using AddComponent(). MonoBehaviour는 구성 요소이며, GameObject에 연결되어야 합니다.MonoBehaviour is a component, and needs to be attached to a GameObject.
  • UNT0011: ScriptableObject를 만들 때는 반드시 CreateInstance()를 사용해야 합니다.UNT0011: ScriptableObject should only be created using CreateInstance(). Unity 메시지 메서드를 처리하려면 ScriptableObject는 Unity 엔진으로 만들어야 합니다.ScriptableObject needs to be created by the Unity engine to handle Unity message methods.

새 진단 억제 장치New diagnostic suppressors

  • IDE0029를 위한 USP0001: Unity 개체는 null 결합을 사용하면 안 됩니다.USP0001 for IDE0029: Unity objects should not use null coalescing
  • IDE0031을 위한 USP0002: Unity 개체는 null 전파를 사용하면 안 됩니다.USP0002 for IDE0031: Unity objects should not use null propagation
  • IDE0051을 위한 USP0003: Unity 메시지는 Unity 런타임에 의해 호출됩니다.USP0003 for IDE0051: Unity messages are invoked by the Unity runtime
  • IDE0044를 위한 USP0004: SerializeField 특성이 있는 필드는 readonly로 설정하면 안 됩니다.USP0004 for IDE0044: Fields with a SerializeField attribute should not be made readonly

또한 Mac용 Visual Studio를 사용하는 Unity 개발자를 위해 다음 사항을 개선했습니다.We also made the following improvements for Unity developers using Visual Studio for Mac:

  • 프로세스 ID를 포함하여 [인스턴스에 연결] 대화 상자에 표시되는 정보를 개선했습니다.Improved the information displayed in the attach to instance dialog, including process ID
  • 바이트 배열 및 문자열을 검사할 때 16진수 편집기 지원을 추가했습니다.Added support for the hex editor when inspecting byte arrays and strings
  • 디버거에서 포인터 멤버 액세스 지원을 추가했습니다(p->foo->bar).Added support for pointer member access in the debugger, i.e. p->foo->bar
  • 배열 이니셜라이저의 암시적 변환 지원을 추가했습니다(new byte[] {1,2,3,4}).Added support for implicit conversions in array initializers, i.e. new byte[] {1,2,3,4}

XamarinXamarin

Xamarin.FormsXamarin.Forms

Xamarin.Forms용 XAML 핫 다시 로드XAML Hot Reload for Xamarin.Forms

이제 Mac용 Visual Studio에서 Xamarin.Forms용 XAML 핫 다시 로드의 공개 미리 보기를 사용할 수 있습니다.You can now use the public preview of XAML Hot Reload for Xamarin.Forms in Visual Studio for Mac! XAML 핫 다시 로드를 사용하면 에뮬레이터, 시뮬레이터 또는 물리적 디바이스에 대해 앱을 디버그하고, XAML을 변경하고, [저장]을 눌러 해당 UI에서 빠르게 반복하여 실행 중인 앱에 즉시 반영된 해당 변경 내용을 확인할 수 있습니다.XAML Hot Reload enables you to rapidly iterate on your UIs by debugging your app to an emulator, simulator, or physical device, changing your XAML, and hitting save to see those changes immediately reflected on the running app.

XAML 핫 다시 로드를 사용하도록 설정하려면 Visual Studio > 기본 설정 > 프로젝트 > Xamarin 핫 다시 로드 에서 Xamarin 핫 다시 로드 사용 을 선택합니다.To enable XAML Hot Reload check the Enable Xamarin Hot Reload checkbox at Visual Studio > Preferences > Projects > Xamarin Hot Reload.

자세한 내용은 XAML 핫 다시 로드 문서를 참조하세요.For more info, see the XAML Hot Reload documentation.

XAML Hot Reload graphic
Mac용 Visual Studio에 기본 제공되는 XAML 핫 다시 로드XAML Hot Reload built into Visual Studio for Mac

XAML 미리 보기의 시각적 재질 디자인Visual Material Design in the XAML Previewer

이제 Xamarin.Forms 시각적 개체를 사용한 재질 디자인이 Xamarin.Forms XAML 미리 보기에서 iOS 및 Android용 미리 보기로 제공됩니다.Material design using Xamarin.Forms Visual now previews for both iOS and Android in the Xamarin.Forms XAML Previewer. XAML 미리 보기에 대한 자세한 내용은 XAML 미리 보기를 참조하세요.For more information on the XAML Previewer, see the XAML Previewer documentation.

Xamarin.Forms의 모든 새로운 기능에 대한 자세한 내용은 Xamarin.Forms 릴리스 정보를 참조하세요.For more information on everything new with Xamarin.Forms, see the Xamarin.Forms release notes.

Xamarin.AndroidXamarin.Android

Xamarin에 대해 Android 10 지원 추가됨Added Android 10 support for Xamarin

이제 Xamarin.Android 내에서 Android 10 API를 사용할 수 있습니다.You can now use Android 10 APIs within Xamarin.Android. 다음 Android 버전을 사용하여 컴파일을 설정하여 Android 10을 시작할 수 있습니다. (대상 프레임워크)를 사용하여 컴파일Android 10.0(Q) 으로 설정하여 Build > General Android Q Preview를 시작할 수 있습니다.You can get started with the Android 10 by setting Compile using Android version: (Target Framework) to Android 10.0 (Q) under the Build > General tab of the Visual Studio for Mac project property pages. Android 10의 새로운 기능은 다음과 같습니다.Features new to Android 10 include:

  • 시스템 수준 어두운 테마를 사용하는 사용자에게 일관된 환경을 제공하도록 어두운 테마를 지원 합니다.Support a Dark Theme to ensure a consistent experience for users who enable system-wide dark theme.
  • 에지 간 이동하고 사용자 지정 제스처가 시스템 탐색 제스처를 보완하도록 하여 앱에서 제스처 탐색을 지원 합니다.Support Gesture Navigation in your app by going edge-to-edge and making sure your custom gestures are complementary to the system navigation gestures.
  • Foldables에 최적화: 오늘날 혁신적인 폴딩 가능 디바이스에서 원활한 에지 간 환경을 제공합니다.Optimize for foldables: Deliver seamless, edge-to-edge experiences on today’s innovative foldable devices.
  • 알림에서 제안된 회신 및 작업을 통해 사용자와 연결할 수 있도록 대화형 알림을 추가 합니다.More interactive notifications by enabling suggested replies and actions in your notifications to engage with your users.
  • Wi-Fi 네트워크 요청 및 연결을 위한 네트워킹 API가 향상 되었습니다.Better Networking APIs for Wi-Fi network requests and connectivity.
Set the Compile using Android graphic
Android 버전: (대상 프레임워크)를 사용하여 컴파일을 Android 10.0(Q)으로 설정합니다.Set the Compile using Android version: (Target Framework) to Android 10.0 (Q).

Android 10에 대한 자세한 내용은 설명서를 참조하세요.To learn more about Android 10, see our documentation.

향상된 Android Designer 분할 보기 환경Improved Android designer split-view experience

Android 레이아웃 편집 시 분할 보기 환경을 다수 개선했습니다.We have made a number of improvements to the split-view experience when editing Android layouts:

  • 캐럿 동기화: 소스 편집기에서 캐럿을 이동할 때 항목이 자동으로 선택됩니다.Caret synchronization: items will automatically be selected when moving the caret in the source editor.
  • 이제 디자인 화면과 소스 편집기 둘 다에 도구 상자 요소를 끌어다 놓을 수 있습니다.Toolbox elements can now be drag & dropped to both the design surface and the source editor.
  • 이제 “주석 설정/해제” 명령이 지원됩니다.The "Toggle Comment" command is now supported.

Xamarin.Android의 모든 새로운 기능에 대한 자세한 내용은 Xamarin.Android 릴리스 정보를 참조하세요.For more information on everything new with Xamarin.Android, see the Xamarin.Android release notes.

Xamarin.iOSXamarin.iOS

Xcode 11 및 iOS 13 지원Xcode 11 and iOS 13 Support

이 릴리스에서는 iOS 13, tvOS 13, watchOS 6용 앱 빌드 및 디버그에 Xcode 11 지원을 추가했습니다.This release adds support for Xcode 11 to build and debug apps for iOS 13, tvOS 13, and watchOS 6. 사용 가능한 새로운 기능에 대한 자세한 내용은 iOS 13 소개를 참조하세요.See our Introduction to iOS 13 for more details on the new features available.

App Store Connect에 업로드Upload to App Store Connect

애플리케이션 로더 도구가 더 이상 Xcode에 포함되지 않으므로, 이제 Mac용 Visual Studio의 게시 마법사를 사용하여 App Store Connect에 업로드할 수 있습니다.You can upload to App Store Connect using the publishing wizard in Visual Studio for Mac now that the Application Loader tool is no longer included with Xcode. Xamarin.iOS 앱을 앱 스토어에 게시 설명서 페이지에서 이 새 워크플로를 자세히 설명합니다.Our Publishing Xamarin.iOS apps to the App Store documentation page details this new workflow.

제약 조건 편집기Constraints Editor

Xamarin Designer for iOS는 제약 조건이 있는 새로운 작동 방법을 소개합니다.The Xamarin Designer for iOS is introducing a new way to work with constraints. 제한 가능한 보기를 선택하면 도구 모음의 제약 조건 고정 모드 선택기 옆에 줄임표가 표시됩니다.When you select a constrainable view, an ellipsis will now appear in the toolbar next to the Constraints Pinning Mode selector. 줄임표를 클릭하여 선택한 보기에 제약 조건 편집을 위한 팝오버를 표시합니다.Click the ellipsis to display a popover for editing constraints on the selected view:

Constraints Pining Mode Graphic
제약 조건 고정 모드 선택기Constraints Pining Mode selector

Xamarin.iOS의 모든 새로운 기능에 대한 자세한 내용은 Xamarin.iOS 릴리스 정보를 참조하세요.For more information on everything new with Xamarin.iOS, see the Xamarin.iOS release notes.

새로운 [NuGet 패키지 관리] 대화 상자New Manage NuGet packages dialog

이제 NuGet 패키지 관리 대화 상자를 사용하여 한 단계로 여러 프로젝트에 대해 NuGet 패키지를 설치, 업데이트 또는 제거할 수 있습니다.NuGet packages can now be installed, updated, or uninstalled for multiple projects in one step with the Manage NuGet Packages dialog:

Managing NuGet packages Graphic
Mac용 Visual Studio에서 솔루션용 NuGet 패키지 관리Managing NuGet packages for the solution in Visual Studio for Mac

이전 패키지 추가 대화 상자가 다음 4개의 탭이 있는 새로운 NuGet 패키지 관리 대화 상자로 대체되어 NuGet 제어가 강화되었습니다.The old Add Packages dialog has been replaced with a new Manage NuGet Packages dialog that has four tabs, giving you more control over NuGets:

  • 찾아보기 - 선택한 패키지 소스에서 사용할 수 있는 패키지를 표시합니다.Browse - shows packages available from the selected package source.
  • 설치됨 - 솔루션에 설치된 패키지를 표시하거나 단일 프로젝트의 패키지를 관리하는 경우 프로젝트를 표시합니다.Installed - shows packages installed in the solution, or project if managing packages for a single project.
  • 업데이트 - 솔루션에 사용할 수 있거나 단일 프로젝트의 패키지를 관리하는 경우 프로젝트에 사용할 수 있는 패키지 업데이트를 표시합니다.Updates - shows package updates available for the solution, or project if managing packages for a single project.
  • 통합 - 솔루션에서 여러 가지 버전이 있는 패키지를 표시합니다.Consolidate - shows packages that have different versions across the solution.

솔루션에 대한 [NuGet 패키지 관리] 대화 상자를 열려면 다음을 수행합니다.To open the Manage NuGet Packages dialog for the solution, do the following:

  1. [솔루션] 창에서 솔루션을 선택했는지 확인합니다.Make sure the solution is selected in the Solution window.
  2. 솔루션을 마우스 오른쪽 단추로 클릭하고 NuGet 패키지 관리 를 선택하거나, 프로젝트 메뉴에서 NuGet 패키지 관리 를 선택합니다.Right click the solution and select Manage NuGet Packages OR select Manage NuGet Packages from the Project menu.

다음과 같은 방법으로 탭을 사용할 수 있습니다.The tabs can be used in the following ways:

설치/제거Install / Uninstall

여러 프로젝트에 패키지를 설치 하려면 다음을 수행합니다.To install a package into multiple projects, do the following:

  1. 찾아보기 탭에서 패키지를 선택합니다.Select the package in the Browse tab.
  2. 패키지 추가 단추를 클릭합니다.Click the Add Package button.
  3. [프로젝트 선택] 대화 상자에서 프로젝트를 선택하고 아래 그림과 같이 확인 을 클릭합니다.Check the projects in the Select Projects dialog and click OK, as illustrated below:
Select Projects dialog graphic
Mac용 Visual Studio의 프로젝트 선택 대화 상자Select Projects dialog in Visual Studio for Mac

여러 프로젝트에서 패키지를 제거 하려면 다음을 수행합니다.To uninstall a package from multiple projects:

  1. 설치됨 탭을 선택합니다.Select the Installed tab.
  2. 제거하려는 패키지를 선택합니다.Select the package you want to uninstall.
  3. 패키지 제거 단추를 클릭합니다.Click the Uninstall Package button.
  4. 패키지를 제거할 프로젝트를 선택하고 확인 을 클릭합니다.Check the projects you want the package to be uninstalled from and click OK.

UpdatesUpdates

여러 프로젝트에서 패키지를 업데이트 하려면 다음을 수행합니다.To update a package in multiple projects:

  1. 업데이트 탭에서 패키지를 선택합니다.Select the package in the Updates tab.
  2. 패키지 업데이트 단추를 클릭합니다.Click the Update Package button.
  3. [프로젝트 선택] 대화 상자에서 프로젝트를 선택하고 확인 을 클릭합니다.Check the projects in the Select Projects dialog and click OK.

통합Consolidate

여러 프로젝트에서 패키지를 통합 하려면 다음을 수행합니다.To consolidate package in multiple projects:

  1. 통합 탭을 선택합니다.Select the Consolidate tab.

  2. 통합하려는 패키지를 선택합니다.Select the package you want to consolidate.

  3. 프로젝트 목록에서 프로젝트를 선택하거나 선택 취소합니다.Check or uncheck projects in the projects list. 기본적으로 선택한 NuGet 패키지를 포함하는 프로젝트가 선택됩니다.By default projects that contain the selected NuGet package will be checked.

  4. 통합할 패키지 버전을 선택합니다.Select the package version to consolidate to. 기본적으로 최신 패키지 버전이 선택됩니다.By default the latest package version will be selected.

  5. 통합 단추를 클릭합니다.Click the Consolidate button:

    NuGet Packages Dialog graphic
    Mac용 Visual Studio의 NuGet 패키지 관리 대화 상자 통합 탭Manage NuGet Packages dialog consolidate tab in Visual Studio for Mac

단일 프로젝트의 NuGet 패키지를 관리하려면 다음을 수행합니다.To manage NuGet packages for a single project:

  1. Solution Pad에서 프로젝트를 선택합니다.Select the project in the Solution pad.
  2. 프로젝트를 마우스 오른쪽 단추로 클릭하고 NuGet패키지 관리 를 선택한 후 위의 필요한 단계를 수행합니다.Right click the project and select Manage NuGet Packages, and follow the steps you need above. 통합 탭이 표시되지 않지만 찾아보기, 설치됨업데이트 탭을 사용할 수 있습니다.Note that the Consolidate tab will not be displayed but the Browse, Installed, and Updates tabs will be available

고정된 문서Pinned Documents

이 릴리스에서는 문서 탭을 고정 하여 즐겨 찾는 파일 탭이 항상 열려 있고 표시되도록 고정할 수 있는 기능을 도입했습니다.In this release we have introduced the ability to pin document tabs allowing you to pin your favorite file-tabs to keep them always open and visible:

Pinned Tabs Graphic
고정된 탭Pinned Tabs

탭을 고정하려면 고정 아이콘, 상황에 맞는 메뉴 또는 탭 고정/고정 해제 명령(⌥⌘P)을 사용합니다.To pin a tab, use the Pin icon, document context menu, or the Pin/Unpin Tab command (⌥⌘P). 작업 영역에서 끌어 고정된 탭을 다시 정렬할 수도 있습니다.You can also rearrange pinned tabs by dragging in the workspace.

시작 화면 – 즐겨 찾는 바로 가기 키Welcome Screen – Favorite Keyboard Shortcuts

Mac용 Visual Studio를 처음 사용하는 경우, 첫 실행 경험의 일부로 즐겨 찾는 바로 가기 키 구성표를 선택하라는 메시지가 아래 그림과 같이 표시됩니다.If you're a new Visual Studio for Mac user, you will be asked to select your favorite Keyboard Shortcut Scheme as part of the first run experience, as illustrated below. 나중에 Visual Studio > 기본 설정 에서 구성표를 선택하거나 처음부터 직접 빌드할 수도 있습니다.Of course, you can also select a scheme or build your own from scratch later under Visual Studio > Preferences.

Welcome Screen Keyboard Shortcuts Graphic
시작 화면 - 바로 가기 키Welcome Screen – Keyboard Shortcuts

이제 Mac용 Visual Studio에서 소스 링크를 지원합니다.Visual Studio for Mac now supports Source Link. 이를 통해 소스 파일 링크가 있는 PDB를 제공하는 NuGet 패키지에서 소스 코드로 디버그할 수 있습니다.This allows you to debug into source code from NuGet packages that ship .PDBs with links to source files. Mac용 Visual Studio는 소스 파일을 사용할 수 있는지 검색하며, 소스 파일을 다운로드하는 기능을 제공하므로 패키지 코드를 단계별로 실행할 수 있습니다.Visual Studio for Mac will detect that source files are available and offer to download the source file allowing you to step through package code. 소스 링크는 Mono BCL 코드에서도 작동하므로 .NET Framework 코드를 한 단계씩 실행할 수도 있습니다.Source Link also works with Mono BCL code allowing you to step into .NET Framework code as well.

Step into External Code option graphic
외부 코드 옵션 한 단계씩 실행Step into External Code option
Link Prompt graphic
소스 링크 프롬프트Source Link prompt

새 패키지 업데이트 정보New Package update information

이제 패키지 업데이트 정보가 Solution Pad의 SDK 스타일 프로젝트에 표시됩니다.Package update information is now displayed for SDK style projects in the Solution pad.

SDK 스타일 및 비 SDK 프로젝트에 대한 정보가 표시되는 방식이 일관성이 있습니다.The way the information is displayed for SDK style and non-SDK projects has been made consistent. 업데이트된 NuGet 패키지 버전을 보여 주는 도구 설명과 함께 업데이트 아이콘이 표시됩니다.An update icon is now displayed with a tooltip showing the updated NuGet package version. 이제 모든 프로젝트 형식에서 설치된 버전이 NuGet 패키지 ID 옆에 표시됩니다.The installed version is now displayed next to the NuGet package id for all projects types:

NuGet Package Updates Solution Window Graphic
Mac용 Visual Studio의 솔루션 창에 있는 NuGet 패키지 업데이트NuGet package updates in the Solution window in Visual Studio for Mac

InstallerInstaller

설치 관리자는 다음과 같이 개선되었습니다.The following improvements were made in the installer:

  • 패키지가 더 빨리 다운로드되도록 몇 가지 확인을 추가했습니다.We added some some additional verification to make downloading packages much faster.
  • 어떤 이유로든 다운로드가 실패하거나 중단되면 설치 관리자가 처음부터가 아니라 오류 지점부터 다시 시작됩니다.If download fails or gets interrupted for some reason, the installer will resume from the failure point rather than from the start. 어떤 이유로든 캐시 파일이 손상되면 제품이 다시 다운로드됩니다.If for any reason cache file gets corrupted, product will be re-downloaded again.
  • 이제 설치 관리자가 각 패키지의 진행률을 훨씬 더 정확하게 표시합니다.The Installer now displays much more accurate progress for each package.
  • 또한 설치 중의 UI 기능을 추가로 개선했습니다.We also added additional UI improvements during installation. 이제 설치해야 하는 패키지 수와 남은 패키지 수를 정확하게 보여 줍니다.We now accurately show how many packages you have to install and how many are left.
  • 항상 권장 릴리스 버전의 Xamarin, .NET Core 및 Mono를 설치하려고 합니다.We'll always try to install the recommended released versions of Xamarin, .NET Core and Mono. 이 때문에 지원되는 상태가 되도록 사용 중인 버전을 다운그레이드하는 경우도 있습니다.Sometimes this will mean downgrading your versions to get you into a supported state.
  • 인증 관련 문제를 해결했습니다.We fixed issues with authorization. 이제 설치 중에 암호 확인 메시지가 5분마다 한 번만 표시됩니다.The password prompt should only shown once per every 5 minutes during installation.
  • 수행할 작업이 없을 경우 이제 '위치' 단추가 숨겨집니다.We now hide the ‘location’ button if there is no actions to do.

버그 수정Bug Fixes

설치Installation

설치 관리자에서 다음과 같은 주요 문제를 해결했습니다.We fixed the following top issues in the Installer:

  • Catalina 관련 버그 수정Bug fixes for Catalina.
  • 지역화된 언어로 사용할 경우 숫자 구분 기호 구성 때문에 발생하는 백분율 증가 버그 수정Fixed percentage increment bug resulted by number separator configuration when used with localized languages
  • 설치할 항목이 VSFMac뿐인 경우 올바른 크기를 표시하도록 수정Fix to display correct size when VSFMac is the only item to install.

웹 및 AzureWeb and Azure

.NET Core와 ASP.NET Core 지원 및 도구와 관련해서 다음과 같은 주요 문제를 해결했습니다.We fixed the following top issues with .NET Core and ASP.NET Core support and tooling:

  • 업데이트를 설치한 후에도 .NET Core SDK 3.0.100이 계속 업데이트에 표시됩니다..NET Core SDK 3.0.100 still appears in the updater after installing updates.
  • 개발 인증서를 신뢰하는 데 잘못된 명령이 제안됩니다.Incorrect command is suggested for trusting development certificate.
  • JavaScript 파일 형식 템플릿이 추가 > 새 파일 > 웹 에 없습니다.JavaScript File Type template is not under Add > New File > Web.
  • Mac용 Visual Studio에서 새 JSON 파일을 UTF-8 BOM으로 저장합니다.Visual Studio for Mac saves new JSON file as UTF-8 BOM.
  • 자식 요소가 있는 파일을 제거할 때 파일 하나가 제거되지 않습니다.When removing a file that has a child, one file is not removed.
  • IDE를 다시 시작하면 웹앱 URL이 5001로 돌아갑니다.The Web app URL reverts back to 5001 after the IDE is restarted.
  • 사용자가 “디버깅하지 않고 시작”을 선택하면 환경 변수가 선택되지 않습니다.Environment variables are not getting picked up when a user chooses to "Start without Debugging".
  • 표시되지 않아야 할 상황에서 “프로젝트에 포함” 상황에 맞는 메뉴가 표시됩니다."Include in Project" context menu appears when it shouldn't.

Azure와 관련해서 다음과 같은 주요 문제를 해결했습니다.We fixed the following top issues with with Azure:

셸 및 도구Shell and Tools

IDE와 관련해서 다음과 같은 주요 문제를 해결했습니다.We fixed the following top issues with the IDE:

소스 코드 편집Source Code Editing

소스 코드 편집과 관련해서 다음과 같은 주요 문제를 해결했습니다.We fixed the following top issues with editing source code:

버전 제어Version Control

버전 제어와 관련해서 다음과 같은 주요 문제를 해결했습니다.We fixed the following top issues with Version Control:

  • Xcode Interface Builder에서 스토리보드를 열 때 IDE의 버전 제어가 중단됩니다.The IDE hangs in version control when opening a Storyboard in Xcode Interface Builder.
  • 분기를 전환할 때 Mac용 Visual Studio 2019가 중지됩니다.Visual Studio 2019 for Mac freezes when switching branch.
  • Git 버전 제어에서 파일 이름을 바꾸면 IntelliSense가 사라집니다.Renaming files under Git version control make IntelliSense disappear.
  • 이전에 연 C# 파일로 솔루션을 열면 버전 제어 탭이 표시되지 않습니다.Version control tabs do not appear when opening solutions with previously open C# files.
  • 앱 번들에는 Git를 사용할 때 포함되지 말아야 할 파일이 포함되어 있습니다.The App bundle contains files it shouldn't when using Git.
  • GitHub에 게시할 때 IDE 작동이 중단됩니다.The IDE crashes when publishing to GitHub.
  • 충돌이 있는 git 스태시를 팝하면 잘못된 경고가 발생하고 로그가 추가되지 않습니다.Popping a git stash that has conflicts gives invalid warning and no further logs.
  • '버전 제어 작업 제출됨' 오류로 인해 하위 모듈을 사용한 프로젝트 복제가 중지됩니다.Cloning project with sub-modules stops with error 'Version control operation filed'.
  • Git에 커밋하려고 할 때 Visual Studio가 충돌/종료합니다.Visual Studio crashes/exists when attempting to commit to Git.
  • "변경 내용" 탭이 새로 고쳐지지 않습니다.The "Changes" tab is not refreshed.
  • Solution Pad에서 Diff/View 명령이 손상되었습니다.Diff/View commands are broken in Solution Pad.
  • "Create Patch" 명령이 손상되었습니다."Create Patch" command is broken.
  • Diff/Comparison 뷰에서 수정 버전이 매우 느리게 로드됩니다.Very slow revision loading in Diff/Comparison view.
  • Mac용 VS가 git revert 시 동결됩니다.VS for Mac freezes on git revert.
  • 새 편집기에서 버전 제어 문서 보기가 누락됩니다.Version control document views are missing with the new editor.
  • 사용자 이름 및 암호를 사용하여 리포지토리를 체크 아웃하는 경우 사용자 이름이 유지되지 않습니다.Checking out a repository with a username and password would not preserve the username.
  • 포트 없이 svn+ssh를 통해 Subversion을 사용할 수 없습니다.It is not possible to use Subversion over svn+ssh without a port.
  • 분기 전환에 대상 프레임워크 변경 내용이 반영되지 않습니다.Switching branches doesn't respect target framework changes.
  • Azure DevOps Git에서 분기를 페치하려고 하면 SIGABRT가 발생합니다.SIGABRT when attempting to fetch a branch from Azure DevOps Git.

테스트 도구Testing Tools

테스트와 관련해서 다음과 같은 문제를 해결했습니다.We fixed the following issue with testing:

  • LibGit2Sharp 어셈블리를 로드하지 못하므로 IDE에서 MonoDevelop.VersionControl.Git.Test에 정의된 단일 테스트를 실행할 수 없습니다.It is not possible to execute single tests defined in MonoDevelop.VersionControl.Git.Test from the IDE, because it fails to load the LibGit2Sharp assembly.

프로젝트 시스템Project System

다음과 같은 프로젝트 문제를 해결했습니다.We fixed the following issues with Projects:

NuGetNuGet

NuGet과 관련해서 다음과 같은 문제를 해결했습니다.We fixed the following issue with NuGet:


알려진 문제 Known Issues

  • Xamarin.Forms용 XAML 핫 다시 로드가 iOS 디바이스에서 작동하지 않고, 몇 분 후에 문제를 보고하라는 정보 표시줄이 나타납니다.XAML Hot Reload for Xamarin.Forms is not functional on iOS devices, and displays an Info Bar after a couple minutes asking you to report an issue. 이 문제는 이후 릴리스에서 해결될 예정입니다.This will be fixed in an upcoming release.
  • Xamarin 다중 플랫폼 앱을 만들 때 공유 코드 옵션이 없습니다.Shared Code option is missing when creating a Xamarin Multi-platform app.

중요

Mac용 Visual Studio 2019는 macOS Catalina 베타 버전에 설치할 수 있지만 미리 보기 OS에서는 예상대로 작동하지 않을 수 있습니다.Visual Studio 2019 for Mac can be installed on macOS Catalina Beta, but may not work as expected with a preview OS. 문제 보고를 사용하여 Mac 및 Catalina용 Visual Studio를 사용하는 동안 발견한 문제를 알려 주세요.Please use Report a Problem to inform us of any issues you discover while using Visual Studio for Mac and Catalina.


피드백 및 제안Feedback and Suggestions

Microsoft는 여러분의 의견을 기다리고 있습니다!We would love to hear from you! Mac용 Visual Studio IDE의 문제 보고 옵션을 통해 문제를 보고할 수 있습니다.You can report a problem through the Report a Problem option in Visual Studio for Mac IDE. 개발자 커뮤니티 포털에서 제안 사항을 포함하여 피드백을 추적할 수 있습니다.You can track your feedback, including suggestions, in the Developer Community portal.


위쪽
Top of Page