Visual Studio에서 R 작업Working with R in Visual Studio

R은 통계 계산 및 그래픽을 위한 고도로 확장 가능한 언어 및 환경입니다.R is a highly extensible language and environment for statistical computing and graphics. 이 프로그램은 GNU General Public License에 따라 무료로 배포되며, 강력한 커뮤니티 지원을 활용할 수 있고, 수학 기호 및 수식을 포함하는 게시 품질 도표를 생성하는 기능으로 잘 알려져 있습니다.It's distributed for free under the GNU General Public License, enjoys strong community support, and is known for its ability to produce publication-quality plots including mathematical symbols and formulae. r project.orgAn Introduction to R(R 소개)에서 R에 대해 자세히 알아볼 수 있습니다.You can learn more about R at r-project.org and An Introduction to R.

RTVS(R Tools for Visual Studio)는 MIT 라이선스에 따라 출시된 Visual Studio 2017 및 Visual Studio 2015 Update 3 이상을 위한 무료 오픈 소스 확장 프로그램입니다.R Tools for Visual Studio (RTVS) is a free, open-source extension for Visual Studio 2017 and Visual Studio 2015 Update 3 (or higher), released under the MIT license. (RHost라고 하며 R 인터프리터 이진 파일에 연결되는 또 다른 오픈 소스 구성 요소가 GNU 공용 라이선스 V2에 따라 출시되었습니다.)(A second open-source component called RHost, which links to the R interpreter binaries, is released under the GNU Public License V2.)

참고

RTVS는 현재 Windows의 Visual Studio에서만 지원되며 Mac용 Visual Studio에서는 지원되지 않습니다.RTVS is presently supported only in Visual Studio on Windows and not Visual Studio for Mac.

Visual Studio에서 R을 사용해 보려면To experience R in Visual Studio:

그런 후 아래 링크에 따라 R 관련 기능과 Visual Studio 자체의 일반 기능에 대해 알아보세요.Then follow the links below to learn more about R-related features as well as the general capabilities of Visual Studio itself.

기능Feature 설명Description 일반 Visual Studio 설명서General Visual Studio Documentation
Visual Studio 프로젝트 시스템Visual Studio project system 관련 파일을 편리한 구조로 구성하고 관리하며, R 코드, R 설명서, R Markdown, SQL 쿼리 및 저장 프로시저와 같은 항목에 대한 유용한 템플릿을 사용할 수 있습니다.Organize and manage related files in a convenient structure, and take advantage of useful templates for items such as R code, R documentation, R Markdown, SQL queries, and stored procedures. 또한 패키지 관리자SQL Server Integration 기능도 사용해볼 수 있습니다.Also enjoy the package manager and SQL Server integration. Visual Studio의 솔루션 및 프로젝트Solutions and Projects in Visual Studio
작업 영역Workspace RTVS는 로컬 및 원격 작업 영역에 바인딩되어 좀 더 작은 데이터 집합으로 로컬로 R 코드를 개발한 다음, 훨씬 더 큰 데이터 집합을 사용해서 더욱 강력한 클라우드 기반 컴퓨터에서 코드를 쉽게 실행할 수 있도록 합니다.RTVS can bind to local and remote workspaces, allowing you to develop R code locally with smaller data sets, then easily run the code on more powerful cloud-based computers with much larger data sets. 해당 없음n/a
R Tools 옵션R Tools options RTVS의 다양한 측면을 제어합니다.Control various aspects of RTVS. 옵션 대화 상자Options dialog box
다양한 편집 기능, IntelliSense 및 코드 조각Rich editing, IntelliSense, and code snippets 구문 색 지정, 모든 코드 및 라이브러리에 대한 IntelliSense, 코드 서식 지정, 시그니처 도움말, 정의로 이동, 모든 참조 찾기, 코드 조각 등을 포함합니다.Includes syntax coloring, IntelliSense across all your code and libraries, code formatting, signature help, Go to Definition, Find All References, code snippets, and more. 코드 및 텍스트 편집기에서 코드 작성Writing Code in the Code and Text Editor
R MarkdownR Markdown R Markdown 문서는 데이터 결과를 markdown 코드 블록 내에 통합된 R 코드와 공유하도록 도와줍니다.R Markdown documents help you share your data results, with integrated R code inside markdown code blocks. 해당 없음n/a
대화형 창Interactive Window R에 대한 전체 REPL 환경에 대화형 창에서 소스 파일의 코드를 쉽게 실행할 수 있는 기능을 제공합니다.Provides a full REPL experience for R with the ability to easily run code in a source file in the interactive window. 해당 없음n/a
코드 시각화Visualizing data 도표는 R 환경의 통합 부분이며, RTVS는 각각이 자체적인 기록과 창 간에 도표를 이동하는 기능을 갖춘 여러 개의 독립적인 도표 창을 지원합니다.Plotting is an integral part of the R experience, and RTVS supports multiple, independent plot windows, each with their own history and the ability to move plots between windows. 도표는 비트맵 및 PDF 파일에 저장되거나 비트맵 또는 메타파일로 클립보드에 복사될 수 있습니다.Plots can be saved to bitmap and PDF files, or copied to the clipboard as a bitmap or metafile. 해당 없음n/a
변수 탐색기Variable Explorer 정렬 가능한 표를 보고 CSV로 내보내는 기능을 사용해 전역 또는 패키지별 범위에서 변수를 검사합니다.Examine variables in the global or package-specific scopes, with the ability to view sortable tables and export to CSV. 해당 없음n/a
완전한 기능의 디버깅Full-featured debugging 대화형 창과의 통합을 포함합니다.Includes integration with the interactive window. Visual Studio의 디버깅Debugging in Visual Studio

질문과 대답을 참조하세요.Also see Frequently asked questions.

또한 다음 비디오에서는 R Tools 기능을 간단히(5분 48초 분량) 검토합니다.The following video also provides a brief (5m 48s) review of the R Tools capabilities:

피드백을 보내주세요.Send us your feedback!

  1. Github 문제: RTVS 팀에 연락하는 가장 좋은 방법은 GitHub에서 문제를 신고하거나 R Tools > 피드백 메뉴를 사용하는 것입니다.Github issues: The best way to reach the RTVS team is by filing an issue on GitHub, or by using the R Tools > Feedback menu.

  2. 웃는 얼굴/찡그린 얼굴 보내기: R Tools > 피드백 메뉴에서는 문제점 진단에 도움이 될 수 있게 신속하게 피드백을 보내고 RTVS 로그 파일을 첨부할 수 있습니다.Send a Smile / Frown: The R Tools > Feedback menu is a quick way to send feedback and attach RTVS log files to assist in the diagnosis of your issue. (로그를 따로 전송하려는 경우 %temp%/RTVSlogs.zip에 기록됩니다.) 도움말 > 피드백 > 설정 메뉴 명령을 사용하거나 설치 중에 Visual Studio 원격 분석에서 옵트아웃(opt-out)한 경우 로깅이 사용되지 않도록 설정됩니다.(Logs are written into %temp%/RTVSlogs.zip in case you want to send them separately.) Logging is disabled if you've opted out of Visual Studio telemetry through the Help > Feedback > Settings menu command, or during installation.

  3. 전자 메일: microsoft.com의 rtvsuserfeedback에서 팀으로 직접 피드백을 보낼 수 있습니다.Email: You can send direct feedback to the team at rtvsuserfeedback (at) microsoft.com.