Visual Studio용 R 도구 시작Getting started with R Tools for Visual Studio

RTVS(Visual Studio용 R 도구)를 설치한 후(설치 참조) 해당 도구가 제공하는 환경을 빠르게 경험할 수 있습니다.Once you have R Tools for Visual Studio (RTVS) installed (see Installation), you can quickly get a taste of the experience that those tools provide. 다음 섹션에서는 짧은 둘러보기를 안내합니다.The following sections guide you through a short tour:

R 프로젝트 만들기Create an R project

  1. Visual Studio를 시작합니다.Start Visual Studio.
  2. 파일 > 새로 만들기 > 프로젝트...를 선택합니다. (Ctrl+Shift+N)Choose File > New > Project... (Ctrl+Shift+N)
  3. 템플릿 > R 아래에서 “R 프로젝트”를 선택하고, 프로젝트의 이름과 위치를 입력한 후 확인을 선택합니다.Select "R Project" from under Templates > R, give the project a name and location, and select OK:

    Visual Studio의 R(VS2017의 RTVS)에 대한 새 프로젝트 대화 상자

  4. 프로젝트가 생성되면 다음 창이 표시됩니다.Once the project is created, you see the following windows:

    • 오른쪽에 있는 Visual Studio 솔루션 탐색기에서는 포함 솔루션 내에서 프로젝트를 확인할 수 있습니다.On the right is Visual Studio Solution Explorer, where you see your project inside a containing solution. 솔루션에는 다양한 형식의 프로젝트가 개수 제한 없이 포함될 수 있습니다. 자세한 내용은 프로젝트를 참조하세요.(Solutions can contain any number of projects of different types; see Projects for details.
    • 왼쪽 위에 있는 새 R 파일(script.R)에서는 모든 Visual Studio 편집 기능을 사용하여 소스 코드를 편집할 수 있습니다.On the top left is a new R file (script.R) where you can edit source code with all of Visual Studio's editing features.
    • 왼쪽 아래에 있는 R 대화형 창에서는 대화형으로 코드를 개발 및 테스트할 수 있습니다.On the bottom left is the R Interactive window in which you can interactively develop and test code.

참고

프로젝트를 열 필요 없이 다른 프로젝트 형식이 로드된 경우에도 R 대화형 창을 사용할 수 있습니다.You can use the R Interactive window without having any projects open, and even when a different project type is loaded. 언제든지 R 도구 > 창 > R 대화형을 선택하면 됩니다.Just select R Tools > Windows > R Interactive at any time.

대화형 창 및 IntelliSense 살펴보기Explore the Interactive window and IntelliSense

  1. 3 + 4를 입력하여 대화형 창이 작동하는지 테스트하고 Enter 키를 눌러 결과를 확인합니다.Test that the interactive window is working by typing in 3 + 4 and then Enter to see the result:

    Visual Studio 2017(VS2017)의 R 대화형 창

  2. 약간 더 복잡한 ds <- c(1.5, 6.7, 8.9) * 1:12를 입력하고 ds를 입력하여 결과를 확인합니다.Enter something a little more complicated, ds <- c(1.5, 6.7, 8.9) * 1:12, and then enter ds to see the result:

    Visual Studio의 R에 대한 추가 대화형 예제

  3. mean(ds)을 입력하지만 m 또는 me를 입력하자마자 Visual Studio IntelliSense에서 자동 완성 옵션을 제공합니다.Type in mean(ds) but notice that as soon as you type m or me, Visual Studio IntelliSense provides auto-completion options. 목록에서 원하는 완성이 선택되면 Tab 키를 눌러 완성을 삽입합니다. 화살표 키 또는 마우스를 사용하여 선택을 변경할 수 있습니다.When the completion you want is selected in the list, press Tab to insert it; you can change the selection with the arrow keys or the mouse.

    코드를 입력할 때 나타나는 IntelliSense

  4. mean을 완성한 후 여는 괄호(()를 입력하고 IntelliSense가 함수에 대한 인라인 도움말을 제공하는 방식을 확인합니다.After completing mean, type the opening parenthesis ( and note how IntelliSense gives you inline help for the function:

    함수에 대한 도움말을 표시하는 IntelliSense

  5. mean(ds) 줄을 완성하고 Enter 키를 눌러 결과([1] 39.51667)를 확인합니다.Complete the line mean(ds) and press Enter to see the result ([1] 39.51667).

  6. 대화형 창은 도움말과 통합되어 있으므로, ?mean을 입력하면 Visual Studio의 R 도움말 창에 해당 함수에 대한 도움말이 표시됩니다.The Interactive window is integrated with help, so entering ?mean displays help for that function in the R Help window in Visual Studio. 자세한 내용은 Visual Studio용 R 도구의 도움말을 참조하세요.For details, see Help in R Tools for Visual Studio.

    Visual Studio의 R 도움말 창

  7. plot(1:100) 등의 일부 명령은 대화형 창에 직접 출력을 표시할 수 없는 경우 Visual Studio에서 새 창을 엽니다.Some commands, such as plot(1:100), open a new window in Visual Studio when the output can't be displayed directly in the interactive window:

    Visual Studio의 플롯 표시

대화형 창에서는 기록을 검토하고, 작업 영역을 로드 및 저장하고, 디버거에 연결하고, 복사-붙여넣기를 사용하는 대신 소스 코드 파일을 조작할 수도 있습니다.The interactive window also lets you review your history, load and save workspaces, attach to a debugger, and interact with source code files instead of using copy-paste. 자세한 내용은 R 대화형 창 사용을 참조하세요.See Working with the R Interactive Window for details.

코드 기능 편집 경험Experience code editing features

대화형 창에서 잠시 작업하면 코드 편집기에서도 작동하는 IntelliSense 등의 기본 편집 기능을 확인할 수 있습니다.Working briefly with the interactive window demonstrates basic editing features like IntelliSense that also work in the code editor. 이전과 같은 코드를 입력하면 동일한 자동 완성 및 IntelliSense 프롬프트가 표시되지만 출력은 표시되지 않습니다.If you enter the same code as before, you see the same auto-completion and IntelliSense prompts, but not the output.

.R 파일에 코드를 작성하면 모든 코드를 한 번에 확인할 수 있고, 사소한 변경을 수행한 다음 대화형 창에서 코드를 실행하여 결과를 빠르게 확인하기가 더 쉽습니다.Writing code in a .R file lets you see all your code at once, and makes it easier to make small changes and then quickly see the result by running the code in the interactive window. 프로젝트에 원하는 개수만큼 파일을 포함할 수도 있습니다.You can also have as many files as you want in a project. 코드가 파일에 있으면 디버거에서 코드를 단계별로 실행할 수도 있습니다(이 항목의 뒷부분에서 설명).When code is in a file, you can also run it step-by-step in the debugger (discussed later in this topic). 이러한 기능은 계산 알고리즘을 개발하고 코드를 작성하여 하나 이상의 데이터 집합을 조작할 경우, 특히 모든 중간 결과를 조사하려는 경우에 유용합니다.These capabilities are helpful when you're developing computational algorithms and writing code to manipulate one or more datasets, especially when you want to examine all intermediate results.

예제와 같이 다음 단계에서는 간단한 코드를 만들어 중심 극한 정리(Wikipedia)를 살펴봅니다.As an example, the following steps create a little code to explore the Central Limit Theorem (Wikipedia). 이 예제는 Paul Teetor에 의해 R Cookbook에서 변형되었습니다.(This example is adapted from the R Cookbook by Paul Teetor.)

  1. script.R 편집기에서 다음 코드를 입력합니다.In the script.R editor, enter the following code:

    mu <- 50
    stddev <- 1
    N <- 10000
    pop <- rnorm(N, mean = mu, sd = stddev)
    plot(density(pop), main = "Population Density", xlab = "X", ylab = "")
    
  2. 결과를 빠르게 확인하려면 모든 코드를 선택하고(Ctrl+A), Ctrl+Enter를 누르거나 마우스 오른쪽 단추를 클릭하고 대화형으로 실행을 선택합니다.To quickly see the results, select all the code (Ctrl+A), then press Ctrl+Enter or right-click and select Execute In Interactive. 선택한 모든 코드가 직접 입력한 것처럼 대화형 창에서 실행되고 결과가 플롯 창에 표시됩니다.All the selected code is run in the interactive window as if you typed it directly, showing the result in a plot window:

    Visual Studio의 플롯 표시

  3. 한 줄의 경우 언제든지 Ctrl+Enter만 누르면 대화형 창에서 해당 줄이 실행됩니다.For a single line, just press Ctrl+Enter at any time to run that line in the interactive window.

편집하고 Ctrl+Enter를 눌러(또는 Ctrl+A로 모든 내용을 선택하고 Ctrl+Enter를 눌러) 코드를 빠르게 실행하는 패턴을 알아봅니다.Learn the pattern of making edits and pressing Ctrl+Enter (or selecting everything with Ctrl+A and then pressing Ctrl+Enter) to quickly run the code. 이 방법은 같은 작업에 마우스를 사용하는 것보다 훨씬 더 효율적입니다.Doing so is much more efficient than using the mouse for the same operations.

또한 Visual Studio 프레임에서 플롯 창을 끌어서 놓고 디스플레이에서 필요할 때마다 다른 곳에 배치할 수 있습니다.In addition, you can drag and drop the plot window out of the Visual Studio frame and place it whenever else you want on your display. 그런 다음 플롯 창을 원하는 크기로 조정하고 이미지 또는 PDF 파일에 저장할 수 있습니다.You can then resize the plot window to the dimensions you want and then save it to an image or PDF file.

  1. 몇 줄의 코드를 더 추가하여 두 번째 플롯을 포함합니다.Add a few more lines of code to include a second plot:

    n <- 30
    samp.means <- rnorm(N, mean = mu, sd = stddev / sqrt(n))    
    lines(density(samp.means))
    
  2. Ctrl+A 및 Ctrl+Enter를 다시 눌러 코드를 실행하고 다음 결과를 생성합니다.Press Ctrl+A and Ctrl+Enter again to run the code, producing the following result:

    Visual Studio의 업데이트된 이중 플롯

  3. 문제는 첫 번째 플롯이 세로 배율을 결정하므로 두 번째 플롯(lines 포함)이 맞지 않는다는 것입니다.The problem is that the first plot determines the vertical scale, so the second plot (with lines) doesn't fit. 이 문제를 해결하려면 plot 호출에서 ylim 매개 변수를 설정해야 하지만, 이 작업을 제대로 수행하려면 최대 세로 값을 계산하는 코드를 추가해야 합니다.To correct this problem, we need to set the ylim parameter on the plot call, but do so that properly we need to add code to calculate the maximum vertical value. plot을 호출하기 전에 samp.means를 사용하려면 코드를 다시 정렬해야 하므로 대화형 창에서 이 코드를 한 줄씩 실행하는 것은 불편합니다.Doing this line-by-line in the interactive window is inconvenient because we need to rearrange the code to use samp.means before calling plot. 하지만 코드 파일에서는 손쉽게 제대로 편집할 수 있습니다.In a code file, though, we can easily make the appropriate edits:

    mu <- 50
    stddev <- 1
    N <- 10000
    pop <- rnorm(N, mean = mu, sd = stddev)
    
    n <- 30
    samp.means <- rnorm(N, mean = mu, sd = stddev / sqrt(n))
    max.samp.means <- max(density(samp.means)$y)
    
    plot(density(pop), main = "Population Density",
        ylim = c(0, max.samp.means),
        xlab = "X", ylab = "")
    lines(density(samp.means))
    
  4. Ctrl+A 및 Ctrl+Enter를 다시 누르면 결과가 표시됩니다.Ctrl+A and Ctrl+Enter again to see the result:

    제대로 크기 조정된 Visual Studio의 업데이트된 이중 플롯

편집기에서 더 많은 작업을 수행할 수 있습니다.There's more you can do in the editor. 자세한 내용은 편집 코드, IntelliSense코드 조각을 참조하세요.For details, see editing code, IntelliSense, and code snippets.

코드 디버그Debugging your code

Visual Studio의 키 수준 중 하나는 디버깅 UI입니다.One of the key strengths of Visual Studio is its debugging UI. RTVS는 이 강력한 기초 위에 빌드되고 변수 탐색기 및 데이터 테이블 뷰어와 같은 혁신적인 UI를 추가합니다.RTVS builds on top of this strong foundation and adds innovative UI such as the Variable Explorer and Data Table Viewer. 여기서 디버깅의 개요를 살펴보겠습니다.Here, let's just take a first look at debugging.

  1. 시작하려면 R 도구 > 세션 > 다시 설정 메뉴 명령을 통해 현재 작업 영역을 다시 설정하여 지금까지 수행한 모든 작업을 지웁니다.To begin, reset the current workspace to clear everything you've done so far by using the R Tools > Session > Reset menu command. 기본적으로 대화형 창에서 수행한 모든 작업은 현재 세션에서 생성된 후 디버거에서 사용됩니다.By default, everything you do in the interactive window accrues to the current session, which is then also used by the debugger. 세션을 다시 설정하면 디버깅 세션이 기존 데이터 없이 시작됩니다.By resetting the session, you ensure that the debugging session starts with no pre-existing data. 그러나 다시 설정 명령은 script.R 소스 파일에 영향을 주지 않습니다. 소스 파일이 작업 영역 외부에서 관리 및 저장되기 때문입니다.The Reset command, however, doesn't affect your script.R source file, because that's managed and saved outside of the workspace.

  2. 이전 섹션에서 생성된 script.R 파일을 사용하여 pop <-로 시작하는 줄에 캐럿을 배치하고 F9 키를 누르거나 디버그 > 중단점 설정/해제 메뉴 명령을 선택하여 해당 줄에서 중단점을 설정합니다.With the script.R file created in the previous section, set a breakpoint on the line that begins with pop <- by placing the caret on that line and then pressing F9, or selecting the Debug > Toggle Breakpoint menu command. 또는 빨간색 중단점이 나타나는 줄의 왼쪽 여백을 클릭하면 됩니다.Alternately, simply click in the left-hand margin (or gutter) for that line where the red breakpoint dot appears:

    편집기에서 중단점 설정

  3. 도구 모음에서 소스 시작 파일 단추를 선택하거나, 디버그 > 소스 시작 파일 메뉴 항목을 선택하거나, F5 키를 눌러 script.R의 코드를 사용하여 디버거를 시작합니다.Launch the debugger with the code in script.R by either selecting the Source startup file button on the toolbar, selecting the Debug > Source startup file menu items, or pressing F5. Visual Studio가 디버깅 모드로 전환되고 코드 실행이 시작됩니다.Visual Studio enters its debugging mode and starts running the code. 하지만 코드는 중단점을 설정한 줄에서 중지합니다.It stops, however, on the line where you set the breakpoint:

    Visual Studio 디비거의 중단점에서 중지

  4. 디버깅하는 동안 Visual Studio는 한 줄씩 코드를 단계별로 실행하는 기능을 제공합니다.During debugging, Visual Studio provides the ability to step through your code line by line. 함수에 대해 한 단계씩 코드 실행, 프로시저 단위 실행 또는 호출 컨텍스트로 프로시저 나가기를 수행할 수 있습니다.You can also step into functions, step over them, or step out of them to the calling context. 이러한 기능은 다른 기능과 함께 디버그 메뉴, 편집기의 마우스 오른쪽 단추 클릭 상황에 맞는 메뉴 및 디버그 도구 모음에서 찾을 수 있습니다.These capabilities, along with others, can be found on the Debug menu, the right-click context menu in the editor, and the Debug toolbar:

    Visual Studio의 디버그 도구 모음

  5. 중단점에서 중지한 경우 변수 값을 검사할 수 있습니다.When stopped at a breakpoint, you can examine the values of variables. Visual Studio에서 자동 창을 찾고 아래쪽 가장자리에 있는 로컬이라는 탭을 선택합니다.Locate the Autos window in Visual Studio and select the tab along the bottom named Locals. 로컬 창에는 프로그램의 현재 지점에 있는 로컬 변수가 표시됩니다.The Locals window shows local variables at the current point in the program. 이전에 설정한 중단점에서 중지된 경우 pop 변수가 아직 정의되지 않은 것으로 표시됩니다.If you're stopped on the breakpoint set earlier, you see that the pop variable isn't yet defined. 이제 디버그 > 프로시저 단위 실행 명령(F10 키)을 사용하면 pop 값이 나타납니다.Now use the Debug > Step Over command (F10), and you see the value for pop appear:

    Visual Studio의 로컬 창

  6. 전역 범위 및 패키지 범위를 포함하여 다른 범위의 변수를 검사하려면 변수 탐색기를 사용합니다.To examine variables in different scopes, including the global scope and package scopes, use the Variable Explorer. 변수 탐색기에서는 정렬 가능한 열이 있는 테이블 형식 뷰로 전환하고 데이터를 CSV 파일로 내보내는 기능을 제공합니다.The Variable Explorer also gives you the ability to switch to a tabular view with sortable columns and to export data to a CSV file.

    변수 탐색기의 확장된 보기

  7. 계속해서 프로그램을 한 줄씩 단계별로 실행하거나 계속(F5)을 선택하여 완료될 때까지(또는 다음 중단점까지) 실행할 수 있습니다.You can continue stepping through the program line by line, or select Continue (F5) to run it to completion (or the next breakpoint).

자세한 내용은 디버깅변수 탐색기를 참조하세요.To go deeper, see Debugging and Variable Explorer.

다음 단계Next steps

이 연습에서는 Visual Studio의 대화형 창, 코드 편집 및 디버깅을 사용하여 R 프로젝트의 기본 사항을 알아보았습니다.In this walkthrough you've learned the basics of R projects, using the interactive window, code editing, and debugging in Visual Studio. 계속해서 더 많은 기능을 살펴보려면 목록에 표시된 항목과 다음 항목을 참조하세요.To continue exploring more capabilities, see the following topics as well as topics shown in the table of contents: