Visual Studio용 R 도구 옵션R Tools for Visual Studio options

R 도구 > 옵션 메뉴를 통해 액세스하거나 도구 > 옵션을 통해 R 도구로 스크롤하여 설정에 액세스합니다.Settings are access through the R Tools > Options menu, or through Tools > Options and scrolling to R Tools:

R 도구의 [옵션] 대화 상자

다음 섹션에서는 이 페이지에서 제공되는 다양한 옵션을 설명합니다.The following sections describe the different options available on this page.

참고

일반 도구 > 옵션 메뉴를 통해 옵션에 액세스할 경우 R 도구 페이지를 표시하려면 아래쪽에서 모든 설정 표시 상자를 선택해야 할 수 있습니다.When accessing options through the general Tools > Options menu, you may need to select the Show all settings box at the bottom for the R Tools page to appear.

<a name="data-scientist-layout"<a name="data-scientist-layout"

R 도구 > 데이터 과학 설정 메뉴 항목은 데이터 과학자의 필요에 맞게 최적화된 레이아웃으로 Visual Studio IDE도 구성합니다.The R Tools > Data Science Settings menu item also configures the Visual Studio IDE with a layout that's optimized for the needs of data scientists. 특히 이 옵션을 선택하면 대화형, 변수 탐색기작업 영역 창이 열립니다.Specifically, this option opens the Interactive, Variable Explorer, and Workspaces windows:

Visual Studio의 데이터 과학자 창 레이아웃

중요

나중에 다른 Visual Studio 설정으로 되돌리려면 먼저 도구 > 설정 가져오기 및 내보내기 명령을 사용하여 선택한 환경 설정 내보내기를 선택하고 파일 이름을 지정합니다.To revert to other Visual Studio settings later on, first use the Tools > Import and Export Settings command, select Export selected environment settings, and specify a file name. 해당 설정을 복원하려면 같은 명령을 사용하고 선택한 환경 설정 가져오기를 선택합니다.To restore those settings, use the same command and select Import selected environment settings. 데이터 과학자 레이아웃을 변경한 후 나중에 다시 해당 레이아웃으로 돌아가려는 경우에도 데이터 과학 설정 명령을 직접 사용하는 대신 같은 명령을 사용할 수 있습니다.You can also use the same commands if you change the data scientist layout and want to return to it later on, rather than using the Data Science Settings command directly.

디버깅Debugging

이러한 옵션은 변수 탐색기 및 [조사식] 및 [지역] 같은 디버거 창에서 값을 처리하는 방법을 제어합니다(디버깅 참조).These options control how values are handled in Variable Explorer and in debugger windows like Watch and Locals (see Debugging.

옵션Option 기본값Default value 설명Description
활성 바인딩 평가Evaluate active bindings True True인 경우 변수 및 속성을 검사할 때 항상 최신 값이 표시되도록 합니다.When True, ensures that you always see the most up-to-date value when inspecting variables and properties. 식을 평가하면 구현 방법에 따라 부작용이 발생할 수 있습니다.The risk is that evaluating the expressions may cause side-effects, depending on how they were implemented.
점 접두사가 있는 변수 표시Show dot-prefixed variables False . 접두사가 있는 변수를 표시할지 지정합니다.Specifies whether variables prefixed with . are shown.

일반General

옵션Option 기본값Default value 설명Description
설문 조사/뉴스 확인Survey/News Check Once a week R 도구가 서버에서 뉴스 및 설문 조사 업데이트를 확인하는 빈도를 지정합니다.Specifies how often R Tools should check with the server for news and survey updates.

도움말Help

옵션Option 기본값Default value 설명Description
F1 웹 브라우저F1 Web browser Internal Ctrl+F1을 사용하여 용어를 검색하는 동안 도움말이 표시되는 방식을 제어합니다.Controls how help is displayed when you are searching for a term using Ctrl+F1. Internal로 설정되면 Visual Studio의 도구 창 내에서 도움말이 렌더링됩니다.When set to Internal, help is rendered within a tool window in Visual Studio. External로 설정되면 기본 웹 브라우저에서 도움말이 나타납니다.When set to External, help appears in your default web browser.
F1 웹 검색 문자열F1 Web Search String R site:stackoverflow.com 편집기의 용어에서 Ctrl+F1을 누를 때 검색어가 검색 엔진에 전달되는 방식을 제어합니다.Controls how search terms are passed to your search engine when you press Ctrl+F1 on a term in the editor. 기본적으로 문자열은 R site:stackoverflow.com입니다. 이 문자열은 R를 검색어에 추가합니다.By default the string is R site:stackoverflow.com, which appends R to your search term. site:stackoverflow.comstackoverflow.com 도메인 내의 페이지로 검색 범위를 지정하도록 알리는 검색 엔진에 대한 지시문입니다.The site:stackoverflow.com is a directive to the search engine that tells it to scope the search to pages within the stackoverflow.com domain.
R 도움말 브라우저R Help Browser Automatic F1, ? 또는 ??를 사용하여 R 문서를 검색하는 동안 도움말이 표시되는 방식을 제어합니다.Controls how help is displayed when you are searching the R documentation using F1, ?, or ??. Automatic으로 설정되면 해당하는 창에서 도움말이 렌더링됩니다.When set to Automatic, help renders in the appropriate window. 예를 들어 HTML 도움말은 Visual Studio 도구 창 내에 표시되지만 PDF는 기본 PDF 프로그램에 나타납니다.For example, HTML help appears within a Visual Studio tool window, whereas PDFs appear in your default PDF program. External로 설정되면 기본 웹 브라우저에서 도움말이 렌더링됩니다.When set to External, help is rendered in your default web browser.

기록History

옵션Option 기본값Default value 설명Description
항상 기록 저장Always save history True RTVS가 프로젝트가 닫힐 때마다 작업 디렉터리의 .RHistory 파일에 명령 기록을 쓸지 제어합니다.Controls whether RTVS writes your command history to a .RHistory file in your working directory whenever the project is closed. 종료하기 전에 프로젝트를 저장하지 않은 경우에도 기록 저장이 수행됩니다.Saving the history happens even if you don't save your project before you exit.
검색 필터 다시 설정Reset search filter True [기록] 창에서 부분 문자열이 [R 기록] 대화 상자의 필터 용어와 일치하는 명령만 표시하도록 명령 기록을 필터링할 수 있는지 결정합니다.Determines whether the History window can filter your command history to show only the commands that substring match against the filter term in the R History dialog. 이 설정에 따라 새 명령을 실행할 때마다 또는 새 프로젝트로 전환하여 다른 .RHistory 파일의 로드를 트리거할 때마다 기록 검색 필터를 다시 설정할지가 결정됩니다.This setting determines whether to reset your History search filter whenever you run a new command or switch to a new project, which triggers the load of a different .RHistory file. 기본 설정 True는 필터 집합 관련 명령을 실행할 때 문제를 최소화하며 사용자는 방금 실행한 명령이 기록에 표시되지 않은 이유를 궁금해합니다.The default setting of True minimizes surprise when you run a command with a filter set, and you wonder why the command you just ran didn't show up in the History.
여러 줄 선택 사용Use multiline selection True 한 번 클릭으로 기록에서 여러 줄 문을 선택할 수 있는지 지정합니다.Specifies whether you can select a multi-line statement in History with a single click. 또한 줄이 아닌 문별로 대화형 창에서 위쪽/아래쪽 화살표 탐색을 사용하도록 설정합니다.Also enables up/down arrow navigation in the Interactive Windows by statements rather than lines.

HTMLHTML

옵션Option 기본값Default value 설명Description
HTML 페이지 브라우저HTML Pages browser External ggvis 플롯 등의 콘텐츠나 shiny 응용 프로그램이 렌더링되는 위치를 결정합니다.Determines where content such as a ggvis plot, or a shiny application is rendered. Internal은 Visual Studio의 도구 창 내에 HTML 출력을 표시합니다. External은 기본 브라우저에 HTML 출력을 표시합니다.Internal shows HTML output within a tool window in Visual Studio; External displays HTML output in your default browser.

로깅Logging

옵션Option 기본값Default value 설명Description
로그 이벤트Log events Normal RTVS 진단에 사용되는 로깅의 자세한 정도를 제어합니다.Controls the verbosity of the logging used for RTVS diagnostics. Normal의 기본 설정은 TEMP 디렉터리에서 로그 파일을 만듭니다.The default setting of Normal creates a log file in your TEMP directory. Traffic으로 설정되면 RTVS는 해당 세션의 모든 명령과 응답을 기록합니다.When set to Traffic, RTVS logs all commands, and responses in your session. 이러한 로그 파일은 컴퓨터에서 유지되며 RTVS에서 문제를 진단하는 데 도움이 될 수 있습니다.These log files never leave your machine, but may be helpful for diagnosing problems in RTVS.

MarkdownMarkdown

옵션Option 기본값Default value 설명Description
Markdown 미리 보기 단추Markdown preview browser External RMarkdown HTML 출력을 표시할지 결정합니다.Determines where RMarkdown HTML output is displayed. Internal은 Visual Studio의 도구 창 내에 RMarkdown HTML 문서를 표시합니다. External은 기본 브라우저에 RMarkdown HTML을 표시합니다.Internal shows RMarkdown HTML document within a tool window in Visual Studio; External displays RMarkdown HTML using your default browser.

R 엔진R Engine

옵션Option 기본값Default value 설명Description
코드 페이지Code page (OS Default) R에 대한 코드 페이지(로캘)를 설정합니다. 기본적으로 운영 체제의 기본 로캘을 사용합니다.Sets the code page (locale) for R. By default it uses the underlying locale of the operating system.
CRAN 미러CRAN Mirror (Use .Rprofile) 패키지 설치에 대한 기본 CRAN 미러를 설정합니다.Sets the default CRAN mirror for package installations. Use .Rprofile의 기본 설정은 CRAN Mirror 설정을 .RProfile 파일에 보존합니다.The default setting of Use .Rprofile respects the CRAN Mirror settings in your .RProfile file.
작업 디렉터리Working directory 사용자별 폴더user-specific folder Sets가 현재 작업 디렉터리이고 대개 프로젝트가 열릴 때마다 설정됩니다.Sets is the current working directory, which is typically set whenever a project is opened.

작업 영역Workspace

옵션Option 기본값Default value 설명Description
프로젝트가 열리면 작업 영역 로드Load workspace when project opens No Yes로 설정하면 프로젝트가 열릴 때 .RData 파일에서 전역 환경으로 세션 데이터를 로드할 수 있습니다.Setting to Yes enables loading of session data from the .RData file into the global environment when the project is opened.
다시 설정할 때 작업 영역 저장 메시지 표시Prompt to save workspace on reset Yes No로 설정하면 대화형 창에서 [다시 설정] 단추를 클릭할 때 작업 영역을 저장할지 묻는 메시지가 표시되지 않습니다.Setting to No disables prompting of saving your workspace when you click on the Reset button in the Interactive Window.
프로젝트가 닫히면 작업 영역 저장Save workspace when project closes No Yes로 설정하면 프로젝트가 닫힐 때 전역 환경을 .RData 파일에 저장할 수 있습니다.Setting to Yes enables saving the global environment to the .RData file when the project is closed.
작업 영역을 전환하기 전에 확인 대화 상자를 표시합니다.Show confirmation dialog before switching workspaces Yes No로 설정하면 작업 영역 간에 전환할 때 사용자에게 확인 메시지가 표시되지 않습니다.Setting to No disables prompting the user for confirmation when switching between different workspaces. 작업 영역 간 전환을 참조하세요.See switching between workspaces