Visual Studio에서 R 프로젝트 만들기Creating R projects in Visual Studio

R 프로젝트(.rxproj 파일)는 프로젝트와 관련된 모든 소스 및 콘텐츠 파일을 식별합니다.An R project (an .rxproj file) identifies all the source and content files associated with your project. 또한 각 파일에 대한 빌드 정보를 포함하고 소스 제어 시스템과 통합할 정보를 유지 관리하며 응용 프로그램을 논리 구성 요소로 구성하는 데 도움을 줍니다.It also contains build information for each file, maintains the information to integrate with source-control systems, and helps you organize your application into logical components. 그러나 설치된 패키지 목록과 같은 작업 영역 관련 정보는 작업 영역 자체에서 별도로 유지 관리됩니다.Workspace-related information such as the list of installed packages, however, is maintained separately in the workspace itself.

프로젝트는 항상 Visual Studio 솔루션 내에서 관리되므로 서로를 참조할 수 있는 프로젝트를 여러 개 포함할 수 있습니다.Projects are always managed within a Visual Studio solution, which can contain any number of projects that can reference one another. Visual Studio에서 여러 프로젝트 형식 사용을 참조하세요.See Use multiple project types in Visual Studio.

새 R 프로젝트 만들기Creating a new R project

  1. Visual Studio를 시작합니다.Start Visual Studio.
  2. 파일 > 새로 만들기 > 프로젝트...를 선택합니다. (Ctrl+Shift+N)Choose File > New > Project... (Ctrl+Shift+N)
  3. 템플릿 > R 아래에서 “R 프로젝트”를 선택하고, 프로젝트의 이름과 위치를 입력한 후 확인을 선택합니다.Select "R Project" from under Templates > R, give the project a name and location, and select OK:

    Visual Studio의 R(VS2017의 RTVS)에 대한 새 프로젝트 대화 상자

이 명령은 프로젝트를 만들고 편집기에서 빈 script.R 파일을 엽니다.This command creates a project with an empty script.R file open in the editor. 솔루션 탐색기에서는 프로젝트의 두 가지 기타 파일을 확인할 수 있습니다.Notice also in Solution Explorer there are two other files in the project:

템플릿에서 생성된 R 프로젝트의 콘텐츠

R 대화형 창에 입력한 명령에 관계없이 .Rhistory 레코드.The .Rhistory records whatever commands you enter into the R Interactive window. R 도구 > Windows > 기록 명령을 사용하여 전용 기록 창을 열 수 있습니다.You can open a dedicated history window with the R Tools > Windows > History command. 해당 창에는 기록 내용을 지우는 도구 모음 단추 및 상황에 맞는 메뉴 항목이 있습니다.That window has a toolbar button and context menu items to clear history contents.

rproject.rproj 파일에서는 Visual Studio에서 관리되지 않는 R 관련 프로젝트 설정이 유지 관리됩니다.The rproject.rproj file maintains certain R-specific project settings that aren't otherwise managed by Visual Studio:

속성Property 기본Default 설명Description
버전Version 1.01.0 프로젝트를 만드는 데 사용되는 Visual Studio용 R 도구 버전.The version of R Tools for Visual Studio used to create the project.
RestoreWorkspaceRestoreWorkspace 기본Default .RData 파일에서 이전 작업 영역 변수를 프로젝트 디렉터리에 자동으로 로드합니다.Automatically load previous Workspace variables from the .RData file in the project directory.
SaveWorkspaceSaveWorkspace 기본Default 프로젝트를 닫을 때 현재 작업 영역 변수를 직접 프로젝트 디렉터리의 .RData 파일에 저장합니다.Save current workspace variables to the .RData file in the project directory when closing a project.
AlwaysSaveHistoryAlwaysSaveHistory 기본Default 프로젝트를 닫을 때 현재 대화형 창 기록을 직접 프로젝트 디렉터리의 .RHistory 파일에 저장합니다.Save current Interactive Window history to the .RHistory file in the project directory when closing a project.
EnableCodeIndexingEnableCodeIndexing Yes 코드 검색 속도를 높이기 위해 백그라운드 인덱싱 작업을 실행할지 결정합니다.Determines whether to run a background indexing task to speed code searches.
UseSpacesForTabUseSpacesForTab Yes 편집기에서 Tab 키를 누를 때 공백(Yes) 또는 Tab 문자(No)를 삽입할지 결정합니다.Determines whether to insert spaces (Yes) or a Tab character (No) when the Tab key is pressed in the editor.
NumSpacesForTabNumSpacesForTab 22 UseSpacesForTab이 Yes인 경우 삽입할 공백 수.The number of spaces to insert if UseSpacesForTab is Yes.
인코딩Encoding UTF-8UTF-8 .R 파일의 기본 인코딩.The default encoding for .R files.
RnwWeaveRnwWeave SweaveSweave Rnw 파일을 평직 처리할 때 사용할 패키지.Package to use when weaving a Rnw file.
LaTeXLaTeX pdfLaTeXpdfLaTeX RMarkdwon을 PDF로 변환할 때 사용할 라이브러리.Library to use when converting RMarkdwon to PDF.

파일 폴더를 R 프로젝트로 변환Converting a folder of files to an R project

프로젝트에서 관리할 .R 파일의 기존 폴더가 있는 경우 다음 단계를 수행합니다.If you have an existing folder of .R files that you want to manage in a project, do the following steps:

  1. 이전 섹션처럼 Visual Studio에서 새 프로젝트를 만듭니다.Create a new project in Visual Studio as in the previous section.
  2. 파일을 프로젝트 폴더로 복사합니다.Copy your files into the project folder.
  3. Visual Studio 솔루션 탐색기에서 프로젝트를 마우스 오른쪽 단추로 클릭하고 추가 > 기존 항목을 선택하고 추가할 파일로 이동합니다.In the Visual Studio Solution Explorer, right-click the project, select Add > Exiting Item, and browse to the files you want to add. 확인을 선택하면 이러한 파일이 프로젝트 트리에 표시됩니다.Those files appear in your project tree after selecting OK.
  4. 코드를 하위 폴더로 구성하려면 프로젝트를 마우스 오른쪽 단추로 클릭하고 먼저 추가 > 새 폴더를 선택한 다음 파일을 해당 폴더로 복사하고 3단계의 기존 항목을 추가합니다.To organize code into subfolders, right-click the project, select Add > New Folder first, then copy your files into that folder and add those existing items in step 3.

프로젝트 속성Project properties

프로젝트 속성 페이지를 열려면 솔루션 탐색기에서 프로젝트를 마우스 오른쪽 단추로 클릭하고 속성을 선택하거나, 프로젝트 > (프로젝트 이름) 속성...* 메뉴 항목을 선택합니다.To open the project property pages, right-click the project in **Solution Explorer and select Properties, or select the *Project > (project name) properties... menu item. 창이 열리면 프로젝트 속성이 표시됩니다.The window that opens displays project properties:

Tab 속성Property 설명Description
실행Run 시작 파일Startup file 소스 시작 파일 명령, F5, 디버그 > 디버깅 시작 또는 디버그 > 디버그하지 않고 시작을 통해 실행된 파일의 이름입니다.The name of the file that is run with Source startup file command, F5, Debug > Start debugging, or Debug > Start without debugging. 프로젝트에서 파일을 마우스 오른쪽 단추로 클릭하고 시작 R 스크립트로 설정을 선택해도 시작 파일로 설정됩니다.Right-clicking the file in the project and selecting Set as startup R script also sets it as the startup file.
실행 시 R 대화형 다시 설정Reset R Interactive on Run 프로젝트를 실행할 때 대화형 창의 작업 영역에서 모든 변수를 지웁니다.Clears all variables from the interactive window's workspace when running the project. 이 작업을 실행하면 이전 실행의 남은 작업 영역 콘텐츠가 없게 됩니다.Doing so guarantees that there's no residual workspace contents from pervious runs.
원격 프로젝트 경로Remote Project Path 원격 작업 영역의 경로입니다.Path to a remote workspace.
실행 시 파일 전송Transfer files on run 전송할 파일에서 필터를 적용할 프로젝트 파일을 실행할 때마다 원격 작업 영역으로 복사할지 여부를 나타냅니다.Indicates whether the project files, subject to the filter in Files to transfer, are to be copied to a remote workspace with each run.
전송할 파일Files to transfer 실행 시 파일 전송이 선택된 경우 원격 작업 영역으로 복사할 특정 파일을 나타내는 파일 이름 및 와일드카드입니다.Filenames and wildcards indicating the specific files to copy to a remote workspace if Transfer files on run is selected.
설정Settings (Settings.R 파일)(Settings.R file) R 프로젝트 설정은 프로젝트 내부에 있는 Settings.R 또는 *.Settings.R 파일에서 가져옵니다.R project settings come from Settings.R or *.Settings.R files that are located inside the project. 설정 파일이 없는 경우 변수를 추가하고 페이지를 저장할 수 있으며, 기본 Settings.R 파일이 자동으로 생성됩니다.If there is no settings file, you can add variables, save the page, and a default Settings.R file is created for you. *파일 > 새 항목 추가... 메뉴 명령을 통해 프로젝트에 설정 파일을 추가할 수도 있습니다.You can also add settings file to the project through the *File > Add New Item... menu command.
설정은 R 코드로 저장되며, 다른 모듈을 실행하기 전에 파일을 원본 제공하여 환경을 미리 정의된 설정으로 미리 채울 수 있습니다.Settings are stored as R code and the file can be sourced before running other modules, thus pre-populating environment with the predefined settings.

R 관련 프로젝트 명령R-specific project commands

Visual Studio 프로젝트는 마우스 오른쪽 클릭 메뉴 및 프로젝트 메뉴를 통해 다양한 일반적인 명령을 지원합니다.Visual Studio projects support a number of general commands through both the right-click menu and the Project menu. 이러한 일반적인 기능에 대한 자세한 내용은 Visual Studio의 솔루션 및 프로젝트를 참조하세요.For details on these general capabilities, see Solutions and Projects in Visual Studio. 하지만 다음을 주의하세요.Keep in mind, however, that

RTVS(Visual Studio용 R 도구)에서는 다양한 자체 명령을 R 프로젝트 및 프로젝트 내 파일과 폴더에 대한 마우스 오른쪽 클릭 메뉴에 추가합니다.R Tools for Visual Studio (RTVS) adds a number of its own commands to the right-click menu for an R project and also files and folders within the project.

명령Command 설명Description
여기에 작업 디렉터리 설정Set Working Directory Here R 대화형 창의 작업 디렉터리를 프로젝트 내의 모든 하위 폴더에서도 사용할 수 있는 프로젝트 폴더로 설정합니다.Sets the R Interactive window's working directory to the project folder, which can also be used on any subfolder within a project.
상위 폴더 열기Open Containing Folder 선택한 파일의 위치에서 Windows 탐색기를 엽니다.Opens Windows Explorer at the location of the selected file.
R 스크립트 추가Add R Script 기본 이름으로 새 .R 파일을 만들고 엽니다.Creates and opens a new .R file with a default name. 추가 > 새 항목... 명령을 사용하여 .R 파일 및 다양한 기타 파일 형식을 만들 수도 있습니다.You can also use the Add > New Item... command to create .R files as well as a number of other file types. R 관련 항목 템플릿을 참조하세요.See R-specific item templates.
R Markdown 추가Add R Markdown 기본 이름으로 새 .rmd 문서를 만들고 엽니다.Creates and opens new .rmd document with a default name. 추가 > 새 항목... 명령을 사용하여 .rmd 파일 및 다양한 기타 파일 형식을 만들 수도 있습니다.You can also use the Add > New Item... command to create .rmd files as well as a number of other file types. R 관련 항목 템플릿을 참조하세요.See R-specific item templates.
저장 프로시저 게시Publish Stored Procedures R 스크립트에 포함된 저장 프로시저를 게시하기 위한 프로세스를 시작합니다.Starts a process to publish any stored procedures contained in R scripts. SQL Server 저장 프로시저 사용을 참조하세요.See Working with SQL Server stored procedures.

R 관련 항목 템플릿R-specific item templates

RTVS에는 특정 파일 형식에 대한 다양한 템플릿이 포함되어 있습니다.RTVS includes a number of templates for specific file types. R 프로젝트를 마우스 오른쪽 단추로 클릭하고 추가 > 새 항목...을 선택하거나, 프로젝트 > 새 항목 추가...를 선택하거나, 파일 > 새로 만들기 > 파일...을 사용하고 R 탭을 선택하여 템플릿에 액세스합니다. 템플릿을 탐색하는 가장 좋은 방법은 새 프로젝트를 만들고 각 형식의 파일을 삽입하는 것입니다.You access templates by right-clicking an R project and selecting Add > New Item..., by selecting Project > Add New Item..., or by using File > New > File... and selecting the R tab. The best way to explore a template is to create a new project and insert files of each type.

참고

추가 > 새 항목... 명령은 표에 나열되지 않은 일반적인 파일 형식도 표시합니다. 파일 > 새로 만들기 > 파일...을 사용하면 해당 형식이 일반 탭에 포함됩니다.The Add > New Item... commands also display general file types that aren't listed in the table; with File > New > File... those types are contained instead on the General tab.

파일 형식File Type 설명Description
R 스크립트R Script R 명령줄에서 입력할 수 있는 동일한 명령이 포함된 텍스트 파일입니다.A text file containing the same commands that can be entered on the R command line.
R MarkdownR Markdown R Markdown 문서가 포함된 파일입니다.A file containing an R Markdown document.
R 설정R Settings R 응용 프로그램 설정을 포함하는 파일입니다.A file that holds R application settings.
R 설명서R Documentation 이름, 별칭 및 제목 필드만 포함된 일반 R 설명서 파일입니다.A generic R documentation file containing only name, alias, and title fields.
R 설명서(함수)R Documentation (Function) 함수를 설명하기 위한 많은 필드가 주석과 함께 포함된 R 설명서 파일입니다.An R documentation file containing many fields with comments for describing a function.
R 설명서(데이터 집합)R Documentation (Dataset) 데이터 집합을 설명하기 위한 많은 필드가 주석과 함께 포함된 R 설명서 파일입니다.An R documentation file containing many fields with comments for describing a dataset.
SQL 쿼리SQL Query .sql 파일입니다.And empty .sql file. SQL Server 통합을 참조하세요.See SQL Server integration.
저장 프로시저(R 사용)Stored Procedure with R 자식 SQL 쿼리 및 자식 저장 프로시저 템플릿 파일이 있는 R 파일입니다.An R file with child SQL Query and child stored procedure template file. SQL Server 통합을 참조하세요.See SQL Server integration.

Visual Studio에서 여러 프로젝트 형식 사용Use multiple project types in Visual Studio

Visual Studio 솔루션은 관련 프로젝트를 하나의 논리적 위치에서 수집 및 관리할 수 있는 편리한 위치를 제공합니다.Visual Studio Solutions provide a convenient place to gather and manage related projects in one logical place. 솔루션을 사용하여 코드를 정리된 상태로 유지하고 팀 내에서 쉽게 공동 작업을 진행할 수 있습니다.Solutions help keep your code organized and facilitates collaboration within teams.

아래 예제에서 솔루션에는 R과 Azure Machine Learning을 사용하여 빌드된 모델이 포함된 R 프로젝트, Python/scikit-learn 프로젝트, 계산 집약적인 작업에 대한 모듈이 포함된 C++ 프로젝트, 데이터 관리에 대한 SQL 프로젝트 및 결과를 게시하는 웹 사이트에 대한 Python/Bottle 프로젝트가 포함됩니다.In the example below, the solution contains an R project with a model built using R and Azure Machine Learning, a Python/scikit-learn project, a C++ project containing modules for intensive computational work, a SQL project for data management, and a Python/Bottle project for the web site that publishes the result:

솔루션의 여러 관련 프로젝트를 보여 주는 Visual Studio 솔루션 탐색기

굵게 강조 표시된 프로젝트는 솔루션에 대한 “시작” 프로젝트입니다. 변경하려면 다른 프로젝트를 마우스 오른쪽 단추로 클릭하고 시작 프로젝트로 설정을 선택합니다.The project highlighted with boldface is the "startup" project for the solution; to change it, right-click a different project and select Set as startup project.

참고

현재 명시적인 R과 C#/C++의 언어 통합이 제공되지 않습니다. 제공되는 Python 언어 통합에 대해서는 Python용 C++ 확장 만들기를 참조하세요.At present, there isn't any explicit R to C#/C++ language integration in place (as there is for Python, see Creating a C++ extension for Python). 하지만 R에 대한 C# 및 C++ 브리지를 제공하는 라이브러리를 사용할 수 있습니다.However there are libraries available that provide C# and C++ bridges for R.

일반적인 프로젝트 및 솔루션 관리에 대한 자세한 내용은 Visual Studio의 솔루션 및 프로젝트를 참조하세요.For more information on managing projects and solutions in general, see Solutions and Projects in Visual Studio.