R Markdown 문서 만들기Creating R Markdown documents

R Markdown은 R의 분석을 고품질 문서, 보고서, 프레젠테이션 및 대시보드로 전환하는 문서 형식입니다.R Markdown is a document format that turns analysis in R into high-quality documents, reports, presentations, and dashboards.

RTVS(Visual Studio용 R 도구)는 R Markdown 항목 템플릿, 편집기 지원(편집기 내에 R 코드용 IntelliSense 포함), 파일 생성 기능 및 실시간 미리 보기를 제공합니다.R Tools for Visual Studio (RTVS) provides a R Markdown item template, editor support (including IntelliSense for R code within the editor), file generation capabilities, and live preview.

R Markdown 사용Using R Markdown

  1. Visual Studio를 닫습니다.Close Visual Studio.
  2. (한 번만 실행) pandoc.org에서 pandoc를 설치합니다.(One time only) Install pandoc from pandoc.org.
  3. Visual Studio를 다시 시작합니다(pandoc 설치를 선택해야 함).Restart Visual Studio, which should pick up the pandoc installation.
  4. knitrrmarkdown 패키지를 설치합니다(대화형 창에서 수행할 수 있음).Install the knitr and rmarkdown packages, which you can do from the interactive window:

    install.packages("knitr")
    install.packages("rmarkdown")
    
  5. 파일 > 새로 만들기 > 파일 메뉴 명령을 사용하고 목록에서 R > R Markdown을 선택하여 새로운 R Markdown 파일을 만듭니다.Create a new R Markdown file using the File > New > File menu command and selecting R > R Markdown from the list. 프로젝트의 컨텍스트에서 솔루션 탐색기의 프로젝트를 마우스 오른쪽 단추로 클릭하고 R Markdown 추가를 선택(하거나 추가 > 새 항목... 을 선택하고 목록에서 R Markdown을 선택)합니다.In the context of a project, right-click the project in Solution Explorer and select Add R Markdown (or Add > New Item... and selecting R Markdown from the list).

  6. 새 파일의 기본 콘텐츠는 다음과 같습니다.The default contents of the new file are as follows:

    ---
    title: "Untitled"
    output: html_document
    ---
    
    This is an R Markdown document. Markdown is a simple formatting syntax for authoring HTML, PDF, and Microsoft Word documents. For more details on using R Markdown see <http://rmarkdown.rstudio.com>.
    
    When you click the **R Tools | Publish | Preview** button a document will be generated that includes both content as well as the output of any embedded R code chunks within the document. You can embed an R code chunk like this:
    
    ```{r}
    summary(cars)
    ```
    
    You can also embed plots, for example:
    
    ```{r, echo=FALSE}
    plot(cars)
    ```
    
    Note that the `echo = FALSE` parameter was added to the code chunk to prevent printing of the R code that generated the plot.
    

미리 보기Previews

Visual Studio 2017 버전 15.5 이상은 R Markdown에 대한 실시간 미리 보기를 자동으로 제공합니다.Visual Studio 2017 version 15.5 and later automatically provide live preview for R Markdown. 편집기와 미리 보기 간에 자동 동기화를 설정하려면 R 도구 > Markdown > 자동 동기화(Ctrl+Shift+Y)를 선택합니다.To turn on automatic sync between the editor and the preview, select R Tools > Markdown > Automatic Sync (Ctrl+Shift+Y). 자동 동기화를 사용하지 않는 경우 R 도구 > Markdown > R Markdown 미리 보기 다시 로드를 사용하여 미리 보기를 새로 고칠 수 있습니다.If you aren't using automatic sync, you can refresh the preview using R Tools > Markdown > Reload R Markdown Preview.

편집기에서 마우스 오른쪽 단추로 클릭하고 미리 보기 명령 중 하나를 선택하여 HTML, PDF 및 Microsoft Word 형식의 파일을 미리 볼 수 있습니다.You can also preview the file in HTML, PDF, and Microsoft Word formats by right-clicking in the editor and selecting one of the Preview commands. 동일한 명령을 R 도구 > Markdown 메뉴에서 사용할 수 있습니다.The same commands are also available on the R Tools > Markdown menu. (이전 버전의 Visual Studio인 경우 이러한 명령은 R 도구 > 게시 메뉴에 있습니다.)(In earlier versions of Visual Studio these commands are found on the R Tools > Publish menu.)

R Markdown 실시간 미리 보기 및 기타 미리 보기 메뉴 명령