변수 탐색기Variable Explorer

R 도구 > Windows > 변수 탐색기(또는 R 도구 > 데이터 과학 설정을 사용한 경우 Ctrl+8)을 사용하여 연 변수 탐색기 창에는 현재 R 세션에서 제공된 범위의 모든 변수가 표시됩니다.The Variable Explorer window, opened using R Tools > Windows > Variable Explorer (or Ctrl+8 if you've used R Tools > Data Science Settings), shows all variables at a given scope in the current R session. 예를 들어 변수 탐색기를 열고 대화형 창에 다음 줄을 입력할 경우:For example, if you're opened the Variable Explorer and enter the following lines in the interactive window:

x <- 42
y <- 43
n <- c(1,2,3,5,8,13)

[변수 탐색기] 창이 다음과 같이 표시됩니다.The Variable Explorer window then appears as follows:

Visual Studio의 변수 탐색기 창

세션에 정의된 더 복잡한 R 데이터 프레임이 있는 경우 데이터로 이동할 수 있습니다.If you have a more complex R data frame defined in the session, you can navigate into the data. 예를 들어 cars <- mtcars를 실행한 후 변수 탐색기에서 다른 노드를 확장하여 데이터 집합을 탐색할 수 있습니다.For example, after running cars <- mtcars you can navigate through the dataset by expanding the different nodes in the Variable Explorer:

변수 탐색기의 확장된 보기

변수를 삭제하려면 마우스 오른쪽 단추를 클릭하고 삭제를 선택하거나, 변수를 선택하고 Delete 키를 누릅니다.To delete variables, right-click and select Delete, or select the variable and press the Delete key.

증분 검색을 사용하여 데이터 프레임에서 관찰을 검색할 수도 있습니다.You can also search for an observation in a data frame using incremental search. 먼저 검색할 데이터 프레임에서 노드를 확장하고 검색 상자에 검색어를 입력합니다.First, expand the nodes in the data frame that you want to search, then enter search terms in the search box.

세부 정보(테이블) 보기Details (table) view

데이터는 테이블 형식으로 제공되는 경우가 많으므로 돋보기 아이콘을 선택하거나 마우스 오른쪽 단추를 클릭하고 자세한 정보 표시를 선택하여 복잡한 데이터 형식을 개별 테이블로 볼 수 있습니다.Because data is often tabular, you can view any complex data type as a separate table by selecting the magnifying glass icon or right-clicking and selecting Show Details.

변수 탐색기 테이블 뷰

열 제목을 클릭하면 데이터가 열을 기준으로 정렬됩니다(오름차순 및 내림차순 간 전환).Clicking on a column heading sorts the data by column (alternating between ascending and descending). Shift 키를 누른 채 추가 열을 클릭하면 해당 열도 정렬에 추가됩니다.Holding down Shift and clicking on additional columns adds those columns to the sorting as well. Shift 키 없이 열을 클릭하면 단일 열 정렬로 돌아갑니다.Clicking a column without Shift returns to single column sorting.

열 제목을 클릭한 순서에 따라 정렬 수행 순서가 결정됩니다.The sequence in which you click the column headings determines the order in which the sorting is performed. 예를 들어 Shift 키를 누른 채 cyl 열을 클릭하고 Shift 키를 누른 채 mpg 열을 두 번 클릭하면 목록에서 실린더가 오름차순으로, 연료 소비량이 내림차순으로 정렬됩니다.For example, Shift-clicking the cyl column, then Shift-clicking the mpg column twice, sorts the list for ascending cylinders and descending miles-per-gallon:

두 개의 열 기준으로 정렬하는 데이터의 테이블 뷰.

변수 탐색기 및 테이블 뷰는 개별 Visual Studio 창에 있으므로 정렬할 수 있지만 사용자는 단계별 작업을 좋아합니다.Because Variable Explorer and the table views are in separate Visual Studio windows, you can arrange them however you like for side-by-side work. 일반적인 지침은 Visual Studio에서 창 레이아웃 사용자 지정을 참조하세요.See Customize window layouts in Visual Studio for general instructions.

Excel(또는 기타 CSV 지원 응용 프로그램)에서 열기Open in Excel (or other CSV-capable application)

추가 조작 및 분석을 위해 일반적으로 세션 변수를 CSV로 내보내는 것이 좋습니다.For further manipulation and analysis, it's often useful to export session variables to CSV. 변수 탐색기에서 각 노드 옆에 있는 작은 Excel 아이콘(Excel 내보내기 아이콘)을 사용하거나 항목을 마우스 오른쪽 단추로 클릭하고 CSV 앱에서 열기를 선택하여 내보내기를 수행합니다.Exporting is done with the small Excel icon (Excel export icon) next to each node in the Variable Explorer, or by right-clicking an item and selecting Open in CSV App. 아이콘을 선택하면 데이터가 %userprofile%\Documents\RTVS_CSV_Exports 폴더의 새 CSV 파일에 기록되고 해당 파일이 시작됩니다. 파일은 .csv 확장과 연결된 응용 프로그램에서 열립니다.Selecting the icon writes the data to a new CSV file in the %userprofile%\Documents\RTVS_CSV_Exports folder and then launches that file, which opens it in whatever application is associated with the .csv extension.

범위Scopes

기본적으로 변수 탐색기는 전역 범위에 대해 열립니다.By default the Variable Explorer opens to the global scope. 패키지 범위로 전환하려면 창 맨 위의 드롭다운에서 패키지를 선택합니다.You can switch to a package scope by selecting a package from the drop-down at the top of the window.

패키지 범위가 표시된 변수 탐색기

디버거의 중단점에서 멈춘 경우 함수 범위로 전환할 수도 있습니다. 변수 탐색기가 디버그되는 코드의 함수 범위로 자동으로 전환되지는 않습니다.You can also switch to a function scope when stopped at a breakpoint in the debugger (note that Variable Explorer does not automatically switch to the function scope of the code being debugged):

디버그 중인 데이터 프레임이 표시된 변수 탐색기

변수 탐색기에서는 디버거에서 함수의 로컬 변수 표시와 같이 코드를 단계별로 진행함에 따라 자동으로 함수 범위를 변경합니다.Variable Explorer automatically changes function scope as you step through code in the debugger, such as showing local variables in a function.

변수 탐색기로 데이터 가져오기Importing data into Variable Explorer

변수 탐색기 도구 모음의 다음 두 가지 명령(R 도구 > 데이터 메뉴를 통해 사용할 수도 있음)은 외부 CSV 데이터 집합을 R 세션으로 가져옵니다. 웹 URL에서 R 세션으로 데이터 집합 가져오기텍스트 파일에서 R 세션으로 데이터 집합 가져오기.Two commands on the Variable Explorer toolbar, which are also available through the R Tools > Data menu, import external CSV datasets into your R session: Import Dataset into R Session from Web URL and Import Dataset into R Session from Text File.

가져올 CSV 파일을 확정하고 나면 Visual Studio에서 데이터 집합 가져오기 대화 상자를 표시합니다. 여기에는 해당 데이터 파일을 구문 분석하는 방법(필드 구분 기호 및 따옴표 처리 방법 선택)을 제어하는 옵션이 있습니다.Once you've identified the CSV file to import, Visual Studio displays an Import Dataset dialog in which you have options to control how that data file is parsed (that is, what the field separator is and how to handle quotes). 가져온 데이터 프레임 및 원본 데이터 파일의 미리 보기를 확인할 수도 있습니다.You can also see a preview of the imported data frame and the original data file:

데이터 집합 가져오기 대화 상자