R을 사용하여 시각적 데이터 플롯 만들기Creating visual data plots with R

그리기는 데이터 과학자 워크플로의 주요 부분입니다.Plotting is a key part of a data scientist's workflow. RTVS(Visual Studio용 R 도구)에서 모든 그리기 작업은 이 주요 작업을 통해 생산성을 향상하도록 디자인된 하나 이상의 플롯 창을 중심으로 수행됩니다.In R Tools for Visual Studio (RTVS), all plotting activity centers around one or more plot windows, which are designed to improve your productivity with this key activity.

영웅 이미지 그리기

항목 내용:In this topic:

다음 비디오(2분 02초)에서는 RTVS에서 수행되는 그리기를 간단히 둘러봅니다.The following video (2m 02s) provides a brief tour of plotting in RTVS:

플롯 창The plot window

플롯 창에는 일련의 플롯이 포함됩니다. 여기서 각 플롯은 plot 명령으로 생성됩니다.A plot window holds a series of plots, where each plot is generated by a plot command. 예를 들어 plot(1:100)를 사용하면 새 플롯 창이 만들어집니다(없는 경우).For example, using plot(1:100) creates a new plot window if one isn't already available:

1:100 선형 플롯

기술적으로 말하면 R plot 명령은 R 그래픽 장치에 대한 출력을 렌더링하고, 플롯 창에서는 R 그래픽 장치의 콘텐츠를 렌더링합니다. 이런 이유로 각 플롯 창에는 장치 번호가 지정됩니다.Technically speaking, R plot commands render their output to an R graphics device; a plot window renders the contents of an R graphics device, which is why each plot window is given a device number.

플롯 창은 Visual Studio 프로젝트에 독립적이고 프로젝트를 열고 닫을 때 열려 있습니다.Plot windows are independent of Visual Studio projects, and remain open as you load and close projects.

플롯 생성 시 모든 이전 플롯을 플롯 기록에 저장하는 “활성” 플롯 창이 사용됩니다(플롯 기록 참조).Generating a plot uses the "active" plot window, saving any previous plot it the plot history (see Plot history). 예를 들어 plot(100:1)을 입력하면 첫 번째 플롯이 아래쪽 방향 선으로 바뀝니다.For example, enter plot(100:1) and the first plot is replaced with a downward line.

모든 기타 Visual Studio 창처럼Like all other Visual Studio windows. 플롯 창에서는 사용자 지정 레이아웃을 지원합니다(Visual Studio에서 창 레이아웃 사용자 지정 참조).the plot window supports customized layouts (see Customize window layouts in Visual Studio. 플롯 창은 Visual Studio 프레임 내의 여러 위치에 고정되거나, 해당 프레임 내에서 크기가 조정되거나, 독립적인 크기 조정을 위해 프레임에서 완전히 분리됩니다.Plot windows can be docked at different locations within the Visual Studio frame, resized within that frame, or pulled out of the frame entirely for independent resizing.

플롯 창의 크기를 조정하면 항상 플롯이 다시 렌더링되어 최고 품질의 이미지를 제공합니다.Resizing a plot window always re-renders the plot to provide the best quality image. 일반적으로 다음 섹션에 설명된 명령을 사용하여 플롯을 파일 또는 클립보드로 내보내기 전에 플롯 크기를 조정하는 것이 좋습니다.You typically want to resize a plot before exporting the plot to a file or to the clipboard using the commands described in the next section.

플롯 창 명령Plot window commands

플롯 창의 도구 모음에는 적용 가능한 명령이 포함되고 이러한 명령은 대부분 R 도구 > 플롯 메뉴를 통해서도 사용할 수 있습니다.The plot window's toolbar holds applicable commands, most of which are also available through the R Tools > Plots menu.

단추Button 명령Command 설명Description
새 플롯 창 단추 새 플롯 창New plot window 자체 기록이 포함된 별도의 플롯 창을 만듭니다.Creates a separate plot window with its own history. 여러 플롯 창을 참조하세요.See Multiple plot windows.
플롯 창 활성화 단추 플롯 창 활성화Activate plot window 현재 플롯 창을 활성 창으로 설정하므로 후속 plot 명령은 해당 창으로 렌더링됩니다.Sets the current plot window as the active window, so that subsequent plot commands are rendered to that window. 여러 플롯 창을 참조하세요.See Multiple plot windows. 여러 플롯 창을 참조하세요.See Multiple plot windows.
플롯 기록 창 단추 플롯 기록 창Plot history window 기록의 모든 플롯이 미리 보기로 표시되는 창을 엽니다.Opens a window with all the plots in the history shown as thumbnails. 플롯 기록을 참조하세요.See Plot history.
플롯 기록 단추 이전/다음 플롯Previous/Next Plot 기록에서 이전 또는 다음 플롯으로 이동합니다.Navigates to the previous or next plot in the history. Ctrl+Alt+F11(이전) 및 Ctrl+Alt+F12(다음)를 사용하여 기록을 탐색할 수도 있습니다.You can also navigate the history with Ctrl+Alt+F11 (Previous) and Ctrl+Alt+F12 (Next). 플롯 기록을 참조하세요.See Plot history.
이미지로 저장 단추 이미지로 저장Save As Image 파일 이름을 입력하라는 메시지를 표시하고 현재 플롯(창 콘텐츠, 창 크기)을 이미지 파일에 저장합니다.Prompts for a filename and saves the current plot (the window contents, at the window size) to an image file. 사용 가능한 형식은 .png, .jpg, .bmp.tif입니다.Available formats are .png, .jpg, .bmp, and .tif.
PDF로 저장 단추 PDF로 저장Save As PDF 현재 창 크기를 사용하여 현재 플롯을 PDF 파일로 저장합니다.Saves the current plot to a PDF file, using the current window size. PDF 크기를 조정하면 플롯이 다시 렌더링됩니다.The plot will re-render if the PDF is scaled.
비트맵으로 복사 단추 비트맵으로 복사Copy As Bitmap 현재 창 크기를 사용하여 플롯을 클립보드에 래스터 비트맵으로 복사합니다.Copies the plot to the clipboard as a raster bitmap, using the current window size.
메타파일로 복사 단추 메타파일로 복사Copy As Metafile 플롯을 클립보드에 Windows 메타파일(Wikipedia)로 복사합니다.Copies the plot to the clipboard as a Windows metafile (Wikipedia).
플롯 제거 단추 플롯 제거Remove Plot 기록에서 현재 플롯을 제거합니다.Removes the current plot from the history.
모든 플롯 지우기 단추 모든 플롯 지우기Clear All Plots 기록에서 모든 플롯을 제거합니다(확인 메시지 표시).Removes all plots from the history (prompts for confirmation).

여러 플롯 창Multiple plot windows

데이터 과학자는 보통 다양한 데이터 집합의 많은 플롯을 사용하므로 RTVS를 통해 해당 개수만큼 독립적인 플롯 창을 만들 수 있습니다.Because data scientists often work with many plots from many different datasets, RTVS lets you create as many independent plot windows. 그런 다음 Visual Studio 프레임 내부 또는 해당 프레임 외부에서 이러한 창을 원하는 대로 정렬할 수 있습니다.You can then arrange those windows however you like within the Visual Studio frame or outside that frame altogether. 창 고정 및 크기 조정에 대한 일반적인 내용은 Visual Studio에서 창 레이아웃 사용자 지정을 참조하세요.(See Customize window layouts in Visual Studio for general information on docking and resizing windows.)

도구 모음 단추 또는 R 도구 > 플롯 > 새 플롯 창을 사용하여 새 플롯 창을 만듭니다.You create a new plot window using the toolbar button or R Tools > Plots > New Plot Window. 새 플롯 창은 새 플롯활성 창이 되며, 여기서 새 플롯이 렌더링됩니다.The new plot window becomes the active window, which is where new plots are rendered. 활성 창을 변경하려면 해당 창으로 전환하고 [플롯 창 활성화] 도구 모음 단추 또는 R 도구 > 플롯 > 플롯 창 활성화를 선택합니다.To change the active window, switch to it and select the Activate Plot Window toolbar button or R Tools > Plots > Activate Plot Window.

플롯도 독립적인 개체입니다. 따라서 마우스로 끌어서 놓기를 사용하거나 마우스 오른쪽 클릭 상황에 맞는 메뉴 및 편집 메뉴의 복사, 잘라내기, 붙여넣기 명령을 사용하여 플롯을 복사하거나 이동할 수 있습니다.Plots, too, are independent objects, which means you can copy or move them between plot windows using either drag-and-drop with the mouse, or by using the Copy, Cut, and Paste commands on the right-click context and Edit menus.

끌어서 놓기의 기본 동작은 복사입니다. 이동하려면 Shift 키를 누른 채 끌어서 놓습니다.The default behavior for drag-and-drop is copy; to move, drag-and-drop while holding down the Shift key.

플롯 기록Plot history

플롯 명령은 각 창에 대한 플롯 기록 내에 유지되므로 세션 내의 모든 그리기가 보존됩니다.Plot commands are maintained in a plot history for each window, ensuring that all your plotting within a session is preserved. 기록을 탐색하려면 플롯 창 도구 모음의 화살표 단추를 사용하거나 Ctrl+Alt+F11 및 Ctrl+Alt+F12를 사용합니다.To navigate the history, use the arrow buttons on the plot window toolbar, or Ctrl+Alt+F11 and Ctrl+Alt+F12. 다시 도구 모음 단추 또는 R 도구 > 플롯 메뉴 명령을 사용하여 창에서 단일 플롯을 제거하거나 모든 플롯을 지울 수도 있습니다.You can also remove single plots or clear all plots from the window again using toolbar buttons or the R Tools > Plots menu commands.

전체 플롯 컬렉션을 확인하려면 도구 모음 단추 또는 R 도구 > 플롯 > 플롯 기록 창을 사용하여 플롯 기록 창을 엽니다.To see the entire collection of plots, open the plot history window using the toolbar button or R Tools > Plots > Plot History Window. 기록은 해당 창에 표시된 플롯의 미리 보기 목록을 플롯 창(또는 장치)별로 그룹화하여 제공합니다.The history gives you a list of thumbnails for the plots that have been displayed in that window, grouped by the different plot windows (or devices). 도구 모음에서 확대/축소 단추를 사용하여 미리 보기 크기를 변경할 수 있습니다.Using the zoom buttons on the toolbar changes the size of the thumbnails.

플롯 기록 창

플롯을 연결된 창에서 열려면 해당 플롯을 두 번 클릭하여 선택하고 플롯 표시 도구 모음 단추를 선택하거나, 마우스 오른쪽 단추를 클릭하고 플롯 표시를 선택합니다.To open a plot in its associated window, double-click that plot, select it, and then select the Show Plot toolbar button or right-click and select Show Plot. 개별 플롯을 선택하고 마우스 오른쪽 단추 클릭 상황에 맞는 메뉴 또는 편집 메뉴에서 복사, 잘라내기 또는 삭제할 수도 있습니다.You can also select an individual plot and copy, cut, or delete from the right-click context or Edit menus.

모든 창에 대한 플롯 기록의 수명은 대화형 R 세션의 수명으로 제한됩니다.The lifetime of your plot history across all windows is bound to the lifetime of your interactive R session. R 세션을 다시 설정하거나 Visual Studio를 종료하고 다시 시작하면 플롯 기록이 다시 설정됩니다.If you reset your R session, or exit and restart Visual Studio, your plot history is reset.

프로그래밍 방식으로 플롯 창 조작Programmatically manipulating plot windows

장치 번호를 통해 특정 플롯 창을 식별하여 R 코드에서 플롯 창을 프로그래밍 방식으로 조작할 수 있습니다.You can programmatically manipulate plot windows from R code, using device numbers to identify specific plot windows.

  • dev.list(): 현재 R 세션 내의 그래픽 장치를 모두 나열합니다.dev.list(): List all of the graphics devices within the current R session.
  • dev.new(): 새 그래픽 장치를 만듭니다(새 플롯 장치).dev.new(): Create a new graphics device (a new plot window).
  • dev.set(<device number>): 활성 그래픽 장치를 설정합니다.dev.set(<device number>): Set the active graphics device.
  • dev.off(): 활성 장치를 삭제합니다.dev.off(): Delete the active device.