단위 테스트 프로젝트 만들기Create a unit test project

단위 테스트는 종종 테스트 중인 코드의 구조를 반영합니다.Unit tests often mirror the structure of the code under test. 예를 들어 프로젝트의 각 코드 프로젝트에 대해 단위 테스트 프로젝트를 만들 수 있습니다.For example, a unit test project would be created for each code project in the product. 테스트 프로젝트는 프로덕션 코드와 동일한 솔루션에 있거나 개별 솔루션에 있을 수 있습니다.The test project can be in the same solution as the production code, or it can be in a separate solution. 한 솔루션에 여러 개의 테스트 프로젝트를 포함할 수 있습니다.You can have multiple unit test projects in a solution.

참고

네이티브 코드의 유닛 테스트 위치와 테스트 프로젝트 구조는 이 항목에서 설명하는 구조와 다를 수 있습니다.The location of unit tests for native code and the test project structure can be different than the structure that is described in this topic. 자세한 내용은 C/C++에 대한 단위 테스트 작성을 참조하세요.For more information, see Writing Unit Tests for C/C++.

단위 테스트 프로젝트를 만들려면:To create a unit test project:

  1. 파일 메뉴에서 새로 만들기 를 선택한 후 프로젝트 를 선택합니다(키보드 Ctrl+Shift+N).On the File menu, choose New and then choose Project (Keyboard Ctrl + Shift + N).

  2. 새 프로젝트 대화 상자에서 설치됨 노드를 확장하고 테스트 프로젝트에 사용하려는 언어를 선택한 후 테스트를 선택합니다.In the New Project dialog box, expand the Installed node, choose the language that you want to use for your test project, and then choose Test.

  3. Microsoft 단위 테스트 프레임워크 중 하나를 사용하려면 프로젝트 템플릿 목록에서 단위 테스트 프로젝트 를 선택합니다.To use one of the Microsoft unit test frameworks, choose Unit Test Project from the list of project templates. 그렇지 않으면 사용하려는 단위 테스트 프레임워크의 프로젝트 템플릿을 선택합니다.Otherwise, choose the project template of the unit test framework that you want to use. 이 예제의 Accounts 프로젝트를 테스트하기 위해 프로젝트 이름을 AccountsTests로 지정합니다.To test the Accounts project of our example, you would name the project AccountsTests.

  4. 단위 테스트 프로젝트에서 테스트 중인 코드에 대한 참조를 추가합니다.In your unit test project, add a reference to the code under test. 동일한 솔루션에서 코드 프로젝트에 대한 참조를 만드는 방법은 다음과 같습니다.Here's how to create the reference to a code project in the same solution:

    1. 솔루션 탐색기에서 프로젝트를 선택합니다.Select the project in Solution Explorer.

    2. 프로젝트 메뉴에서 참조 추가를 선택합니다.On the Project menu, choose Add Reference....

    3. 참조 관리자 대화 상자에서 솔루션 노드를 열고 프로젝트를 선택합니다.In the Reference Manager dialog box, open the Solution node and choose Projects. 코드 프로젝트 이름을 선택하고 대화 상자를 닫습니다.Check the code project name and close the dialog box.

  5. 테스트하려는 코드가 다른 위치에 있는 경우 참조 추가에 대한 자세한 내용은 프로젝트의 참조 관리를 참조하세요.If the code that you want to test is in another location, see Managing references in a project for information about adding references.

다음 단계Next steps

단위 테스트 작성Writing unit tests

다음 섹션 중 하나를 참조하십시오.See one of the following sections: