버그 검사 0x7A: KERNEL_DATA_INPAGE_ERROR

KERNEL_DATA_INPAGE_ERROR 버그 검사 값은 0x0000007A. 이 버그 검사 페이징 파일의 커널 데이터의 요청된 페이지를 메모리로 읽을 수 없음을 나타냅니다.

중요

이 문서는 프로그래머용입니다. 컴퓨터를 사용하는 동안 파란색 화면 오류 코드를 받은 고객인 경우 블루 스크린 오류 문제 해결을 참조하세요.

매개 변수

메시지에 나열된 4개의 매개 변수는 세 가지 가능한 의미를 가질 수 있습니다.

첫 번째 매개 변수가 1, 2 또는 3이고 세 번째 매개 변수가 0이면 매개 변수에 다음 정의가 있습니다.

매개 변수 Description
1 보관된 잠금 유형(1, 2 또는 3)
2 오류 상태(일반적으로 I/O 상태 코드)
3 잠금 유형이 1인 경우: 현재 프로세스

잠금 유형이 2 또는 3인 경우: 0
4 메모리로 페이징할 수 없는 가상 주소

첫 번째 매개 변수가 3 또는 4이고 세 번째 매개 변수가 0이 아닌 경우 매개 변수에는 다음 정의가 있습니다.

매개 변수 Description
1 보관된 잠금 유형(3 또는 4)
2 오류 상태(일반적으로 I/O 상태 코드)
3 InPageSupport 구조체의 주소
4 오류 주소

그렇지 않으면 매개 변수에 다음 정의가 있습니다.

매개 변수 Description
1 페이지 테이블 항목의 주소(PTE)
2 오류 상태(일반적으로 I/O 상태 코드)
3 PTE 콘텐츠
4 오류 주소

원인

오류 상태(매개 변수 2)에서 KERNEL_DATA_INPAGE_ERROR 버그 검사 원인을 확인할 수 있는 경우가 많습니다. NTSTATUS 값입니다.

몇 가지 일반적인 상태 코드는 다음과 같습니다.

  • 0xC000009A 또는 STATUS_INSUFFICIENT_RESOURCES 페이징이 아닌 풀 리소스가 없음을 나타냅니다.

  • 0xC000009C 또는 STATUS_DEVICE_DATA_ERROR 일반적으로 하드 디스크의 잘못된 블록(섹터)을 나타냅니다.

  • 0xC000009D 또는 STATUS_DEVICE_NOT_CONNECTED 결함이 있거나 느슨한 케이블 연결, 종료 또는 컨트롤러에 하드 디스크가 표시되지 않음을 나타냅니다.

  • 0xC000016A 또는 STATUS_DISK_OPERATION_FAILED 하드 디스크의 잘못된 블록(섹터)을 나타냅니다.

  • 0xC0000185 또는 STATUS_IO_DEVICE_ERROR SCSI 디바이스에서 부적절한 종료 또는 결함이 있는 케이블을 나타내거나 두 디바이스가 동일한 IRQ를 사용하려고 했음을 나타냅니다.

  • 0xC000000E 또는 STATUS_NO_SUCH_DEVICE 하드웨어 오류 또는 잘못된 드라이브 구성을 나타냅니다. 케이블을 확인하고 드라이브 제조업체에서 사용할 수 있는 진단 유틸리티를 사용하여 드라이브를 검사. 이전 PATA(IDE) 드라이브를 사용하는 경우 이 상태 코드는 잘못된 master/하위 드라이브 구성을 나타낼 수 있습니다.

이러한 상태 코드는 특정 원인이 있는 가장 일반적인 코드입니다. 특정 버전의 Windows에 대해 반환할 수 있는 다른 가능한 상태 코드에 대한 자세한 내용은 Microsoft WDK(Windows 드라이버 키트)의 파일을 참조 Ntstatus.h 하세요. 타사 OSR은 NTSTATUS를 Win32 오류 코드 NTSTATUS와 Win32 오류 코드 매핑에 매핑하는 PDF 문서를 제공합니다.

이 오류 메시지의 또 다른 일반적인 원인은 결함이 있는 스토리지 하드웨어 또는 RAM 메모리 실패입니다.

바이러스 감염은 또한 이 버그 검사 일으키는 원인이 될 수 있습니다.

해결 방법

잘못된 블록 문제 해결: 0xC000009C 또는 0xC000016A I/O 상태 코드는 일반적으로 잘못된 블록(섹터)으로 인해 디스크에서 데이터를 읽을 수 없음을 나타냅니다. 오류 후 컴퓨터를 다시 시작할 수 있는 경우 Autochk가 자동으로 실행되고 잘못된 섹터를 매핑하여 더 이상 사용되지 않도록 합니다.

Autochk가 하드 디스크에서 오류를 검사하지 않는 경우 디스크 스캐너를 수동으로 시작할 수 있습니다. 시스템 파티션에서 를 실행 Chkdsk /f /r 합니다. 디스크 검사가 시작되기 전에 컴퓨터를 다시 시작해야 합니다. 오류로 인해 컴퓨터를 시작할 수 없는 경우 복구 콘솔을 사용하고 를 실행 Chkdsk /r합니다.

실패한 RAM 문제 해결: 시스템 제조업체에서 제공하는 하드웨어 진단, 특히 메모리 스캐너를 실행합니다. 이러한 절차에 대한 자세한 내용은 컴퓨터에 대한 소유자 설명서를 참조하세요.

결함이 있는 하드웨어 문제 해결: I/O 상태 C0000185 페이징 파일이 이전 SCSI 디스크에 있는 경우 문제에 대해 디스크 케이블 연결 및 SCSI 종료를 검사.

바이러스 감염 해결: 하드 디스크의 마스터 부팅 레코드를 검사하는 최신 상업용 바이러스 검사 소프트웨어를 사용하여 컴퓨터에 바이러스가 있는지 확인합니다. Windows 파일 시스템은 바이러스에 감염될 수 있습니다.

시스템 이벤트 뷰어 오류를 일으키는 디바이스를 식별하는 데 도움이 될 수 있는 오류 메시지를 확인합니다. 특히 버그 검사 바로 전에 발생하는 오류를 검사해야 합니다.

최신 Windows 업데이트가 설치되어 있는지 확인합니다.

PC에 사용 가능한 진단 테스트 소프트웨어를 찾아 실행합니다. 마더보드의 균열, 긁힌 추적 또는 결함이 있는 구성 요소로 인해 이 버그가 검사 수 있습니다.

PC의 경우 카드 슬롯이 있는 경우 컴퓨터의 모든 어댑터 카드가 제대로 앉을 수 검사. 전자 제품 공급 매장에서 사용할 수 있는 잉크 지우개 또는 전기 접촉 처리를 사용하여 어댑터 카드 접점이 클린 수 있도록 합니다.

추가 정보

버그 검사 0x77: KERNEL_STACK_INPAGE_ERROR