2. 홀로그램 원격 PC 애플리케이션 만들기2. Creating a Holographic Remoting PC application

이 자습서에서는 혼합 현실에서 3D 콘텐츠를 시각화하는 방법을 제공하여 언제든지 홀로그램 원격을 위한 PC 앱을 만들고 HoloLens 2에 연결하는 방법을 알아봅니다.In this tutorial, you will learn how to create a PC app for Holographic Remoting and connect to HoloLens 2 at any point, providing a way to visualize 3D content in mixed reality.

목표Objectives

  • 홀로그램 원격에 대한 Unity 구성Configure Unity for Holographic Remoting
  • Visual Studio를 사용하여 애플리케이션을 빌드하고 배포하는 방법 알아보기Learn how to build and deploy the application with Visual Studio
  • 홀로그램 원격 애플리케이션 개발 및 HoloLens에 연결Developing Holographic Remoting application and connecting to HoloLens

홀로그램 원격에 대한 장면 구성Configuring your scene for Holographic Remoting

이 섹션에서는 Wi-Fi 연결을 통해 실시간으로 PC에서 HoloLens 2 디바이스로 혼합 현실 환경을 스트리밍하는 프로젝트를 구성합니다.In this section, you will configure your project to stream your Mixed Reality experience to your HoloLens 2 device from your PC in real-time over a Wi-Fi connection.

Project 창에서 Assets > MRTK.Tutorials.PCHolograhicRemoting > Prefabs 폴더로 이동하고,HolographicRemoting 프리팹을 클릭하여 장면으로 끕니다.In the Project window, navigate to the Assets > MRTK.Tutorials.PCHolograhicRemoting > Prefabs folder, and click and drag HolographicRemoting prefab into your scene.

새로 추가한 HolographicRemoting 프리팹이 여전히 선택된 Unity

PC로 애플리케이션 빌드Build your application to PC

이제 홀로그램 원격 앱을 PC에서 빌드할 준비가 되었습니다.Your Holographic Remoting app is now ready to build on your PC. 아래 단계를 수행하고 이 애플리케이션을 PC에 빌드하려면 이러한 변경을 수행합니다.Follow the below steps and make these changes to build this application on to your PC.

1. 플레이어 설정 지정1. Set the player settings

Unity 메뉴에서 편집 >프로젝트 설정을 차례로 선택하여 플레이어 설정 창을 엽니다.In the Unity menu, select Edit > Project Settings to open the Player Settings window.

프로젝트 설정 창에서 게시 설정 을 확장하고 기능 섹션으로 스크롤하여 기존 기능 외에 아래 표시 기능 확인란을 선택합니다.In the Project Settings window, expand the Publishing Settings, scroll down to the Capabilities section and select the below-shown capability checkbox in addition to the existing capabilities.

  • 인터넷 클라이언트 서버Internet Clint server
  • 개인 네트워크 클라이언트 서버Private Network Client Server

XR 설정 섹션에서 WSA 홀로그램 원격 지원 확인란을 선택하고 홀로그램 원격을 사용하도록 설정합니다.In the XR Settings section, select the WSA Holographic Remoting Supported checkbox and enable the Holographic Remoting.

WSA 홀로그램 원격 지원이 사용되도록 설정된 Unity XR 설정 창

2. Unity 프로젝트 빌드2. Build the Unity Project

Unity 메뉴에서 파일 > 빌드 설정을 차례로 선택하여 빌드 설정 창을 엽니다.In the Unity menu, select File > Build Settings to open the Build Settings window.

Build Settings(빌드 설정) 창에서 *Add Open Scenes _ 단추를 클릭하여 현재 장면을 Scenes(장면)에 추가합니다.In the Build Settings window, click the *Add Open Scenes _ button to add your current scene to the Scenes. Build(빌드) 목록에서 Build 단추 를 클릭하여 Build Universal Windows Platform(유니버설 Windows 플랫폼 빌드) 창을 엽니다.In the Build list, then click the Build button to open the Build Universal Windows Platform window:

장면이 추가된 Unity Build Settings 창

빌드 유니버설 Windows 플랫폼 창에서 빌드를 저장할 적합한 위치(예: Documents\MixedRealityLearning)를 선택합니다.In the Build Universal Windows Platform window, choose a suitable location to store your build, for example, Documents\MixedRealityLearning. 새 폴더를 만들고 적절한 이름(예: PCHolographicRemoting)을 지정합니다.Create a new folder and give it a suitable name, for example, PCHolographicRemoting. 그런 다음, Select Folder(폴더 선택) 단추를 클릭하여 빌드 프로세스를 시작합니다.Then click the Select Folder button to start the build process:

Select Folder 프롬프트 창이 있는 Unity Build Settings 창

Unity에서 빌드 프로세스가 완료될 때까지 기다립니다.Wait for Unity to finish the build process.

진행 중인 Unity 빌드 프로세스

3. 애플리케이션 빌드 및 배포3. Build and deploy the application

빌드 프로세스가 완료되면 Unity에서 빌드를 저장한 위치를 열라는 메시지를 Windows 파일 탐색기에 표시합니다.When the build process is completed, Unity will prompt Windows File Explorer to open the location you stored the build. 폴더 내부를 탐색하고 .sln 파일을 두 번 클릭하여 Visual Studio에서 엽니다.Navigate inside the folder, and double-click the .sln file to open it in Visual Studio:

새로 만든 Visual Studio 솔루션이 선택된 Windows 탐색기

참고

Visual Studio에서 새 구성 요소를 설치하라는 메시지가 표시되면 도구 설치 설명서에서 지정한 대로 모든 필수 구성 요소가 설치되어 있는지 확인합니다.If Visual Studio asks you to install new components, take a moment to ensure that all prerequisite components are installed as specified in the Install the Tools documentation.

릴리스 구성, x64 아키텍처 및 로컬 머신을 대상으로 선택하여 PC에 대해 Visual Studio를 구성합니다.Configure Visual Studio for PC by selecting the Release configuration, the x64 architecture, and Local Machine as target:

로컬 컴퓨터에 대해 구성된 Visual Studio

*로컬 컴퓨터* 라고 표시된 단추를 클릭합니다.Click the button that says Local Machine. 애플리케이션을 빌드하고 PC에 배포하기 시작합니다.It starts to build and deploy the application on to your PC. 애플리케이션은 기본적으로 PC에 설치됩니다.The application will be installed in your PC by default.

홀로그램 원격 원격 애플리케이션 테스트Testing Holographic Remoting remote application

PC 애플리케이션을 HoloLens 2에 연결하려면 아래 프로세스를 수행합니다.To connect your PC application to your HoloLens 2, follow the below process:

1. HoloLens 2 디바이스에 원격 플레이어 애플리케이션 설치1. Install the Remoting Player application on HoloLens 2 device

HoloLens 2에서 스토어 앱을 방문하여 "원격 플레이어"를 검색합니다._ On your HoloLens 2, visit the Store app and search for "Remoting Player."

  • 원격 플레이어 앱을 선택합니다.Select the Remoting Player app.
  • 설치 를 탭하여 앱을 다운로드하고 설치합니다.Tap Install to download and install the app.

2. 원격 플레이어에 홀로그램 원격 PC 앱 연결2. Connect the Holographic remoting PC app to the Remoting Player

  • HoloLens에서 원격 플레이어 를 시작합니다.Start the Remoting Player on your HoloLens.
  • HoloLens IP 주소 를 기록해 둡니다.Take note of the HoloLens IP address. 시작되는 즉시 원격 플레이어 에서 홀로그램으로 표시됩니다.It will be displayed as a hologram by the Remoting Player as soon as it launches.
  • 홀로그램 원격 PC 애플리케이션을 PC에서 엽니다.Open the Holographic Remoting PC application on your PC.
  • 애플리케이션이 시작되면 IP 주소 를 입력하고 연결 단추를 클릭하여 연결합니다.Once the application is launched, enter the IP address and click on the Connect button to connect.

축하합니다.Congratulations

이 자습서에서는 혼합 현실에서 3D 콘텐츠를 시각화하는 방법을 제공하여 언제든지 홀로그램 원격 원격 앱을 만들고 HoloLens 2에 연결하는 방법을 알아보았습니다.In this tutorial, you learned how to create a Holographic Remoting remote app and connect to HoloLens 2 at any point, providing a way to visualize 3D content in mixed reality. HoloLens가 홀로그램 원격 PC 애플리케이션에 연결되면 HoloLens 2 디바이스로 스트리밍되는 혼합 현실 환경이 표시됩니다.Once the HoloLens connected to the Holographic Remoting PC application, you should see the mixed reality experience streaming into your HoloLens 2 device.