2. Photon Unity 네트워킹 설정

이 자습서에서는 PUN(Photon Unity Networking)을 사용하여 공유 환경을 만들기 위해 준비합니다. PUN 앱을 만들고 PUN 자산을 Unity 프로젝트로 가져오고 Unity 프로젝트를 PUN 앱에 연결하는 방법을 알아봅니다.

목표

  • PUN 앱을 만드는 방법 알아보기
  • PUN 자산을 찾아서 가져오는 방법 알아보기
  • Unity 프로젝트를 PUN 앱에 연결하는 방법 알아보기

Unity 프로젝트 만들기 및 준비

이 섹션에서는 새 Unity 프로젝트를 만들고 MRTK 개발을 준비합니다.

먼저 프로젝트 초기화 및 첫 번째 애플리케이션 배포를 수행합니다. 단, 개체에 손 상호 작용 추가디바이스에 애플리케이션 빌드 지침은 제외합니다. 단계는 다음과 같습니다.

  1. Unity 프로젝트 만들기 및 적절한 이름(예: MRTK Tutorials) 지정
  2. 빌드 플랫폼 전환
  3. TextMeshPro 필수 리소스 가져오기
  4. Mixed Reality Toolkit 가져오기 및 Unity 프로젝트 구성
  5. 장면 만들기 및 MRTK 구성 및 장면에 적절한 이름(예: MultiUserCapabilities) 지정

그런 다음, 공간 인식 표시 옵션 변경 지침에 따라 다음을 수행합니다.

  1. MRTK 구성 프로필DefaultHoloLens2ConfigurationProfile로 변경
  2. 공간 인식 메시 표시 옵션폐색으로 변경

추가 기능 사용

Unity 메뉴에서 편집>프로젝트 설정... 을 차례로 선택하여 [플레이어 설정] 창을 연 다음, 플레이어>게시 설정 섹션을 차례로 찾습니다.

Unity Player settings

게시 설정에서 기능 섹션까지 아래로 스크롤하여 위의 Unity 프로젝트 구성 단계 중에 사용하도록 설정한 InternetClient, Microphone, SpatialPerceptionGazeInput 기능이 사용하도록 설정되어 있는지 다시 확인합니다.

그런 다음, 다음과 같은 추가 기능을 사용하도록 설정합니다.

  • InternetClientServer 기능
  • PrivateNetworkClientServer 기능

Unity Capabilities settings

자습서 자산 가져오기

다음 Unity 사용자 지정 패키지를 나열된 순서대로 다운로드하여 가져옵니다.

 Unity 사용자 지정 패키지를 가져오는 방법을 미리 알아보려면 자습서 자산 가져오기 지침을 참조할 수 있습니다.

참고

MultiUserCapabilities 자습서 자산 패키지를 가져오면 유형 또는 네임스페이스가 누락되었음을 나타내는 CS0246 오류가 Console 창에 보입니다. 이것은 예상한 오류이며, 다음 섹션에서 PUN 자산을 가져오면 해결됩니다.

PUN 자산 가져오기

Unity 메뉴에서 Window>Asset Store를 선택하여 Asset Store 창을 열고 Exit Games에서 PUN 2 - FREE를 검색하여 선택하고, Download 단추를 클릭하여 자산 패키지를 Unity 계정에 다운로드합니다.

다운로드가 완료되면 Import 단추를 클릭하여 Import Unity Package 창을 엽니다.

Unity Asset Store with PUN 2 - Free

Import Unity Package(Unity 패키지 가져오기) 창에서 All(모두) 단추를 클릭하여 모든 자산이 선택되었는지 확인한 다음, Import(가져오기) 단추를 클릭하여 자산을 가져옵니다.

Unity with PUN 2 import window

Unity에서 Import(가져오기) 프로세스가 완료되면 Pun Wizard 창이 PUN Setup 메뉴가 로드된 상태로 나타납니다. 지금은 이 창을 무시하거나 닫으면 됩니다.

Unity with PUN Setup window

PUN 애플리케이션 만들기

이 섹션에서는 Photon 계정이 없으면 만들고 새 PUN 앱을 만듭니다.

Photon 대시보드로 이동하여 로그인하고(사용할 계정이 있는 경우) 그렇지 않으면 Create One 링크를 클릭하여 지침에 따라 새 계정을 등록합니다.

Photon login page

로그인되면 Create a New App 단추를 클릭합니다.

Photon dashboard welcome page

Create a New Application(새 애플리케이션 만들기) 페이지에서 다음 값을 입력합니다.

  • Photon 유형의 경우 PUN을 선택합니다.
  • 이름에는 적절한 이름(예: MRTK Tutorials)을 입력합니다.
  • 설명에는 적절한 설명(선택 사항)을 입력합니다.
  • URL 필드는 비워둡니다.

그런 다음, 만들기 단추를 클릭하여 새 앱을 만듭니다.

Photon create application page

Photon에서 만들기 프로세스가 완료되면 새 PUN 앱이 대시보드에 나타납니다.

Photon application page

Unity 프로젝트를 PUN 애플리케이션에 연결

이 섹션에서는 Unity 프로젝트를 이전 섹션에서 만든 PUN 앱에 연결합니다.

Photon 대시보드에서 App ID 필드를 클릭하고 앱 ID 필드를 표시하여 클립보드에 복사합니다.

Photon application page with App Id selected

Unity 메뉴에서 Window>Photon Unity Networking>PUN Wizard를 선택하여 Pun Wizard 창을 열고 Setup Project 창을 클릭하여 PUN Setup 메뉴를 열어서 다음과 같이 구성합니다.

  • AppId or Email 필드에 이전 단계에서 복사한 PUN App ID를 붙여넣습니다.

그런 다음, Setup Project 단추를 클릭하여 App ID를 적용합니다.

Unity PUN Setup window with AppId filled in

Unity가 PUN 설치 프로세스를 완료하면 PUN 설치 메뉴에 완료! 메시지가 표시되고 Project 창에서 PhotonServerSettings 자산이 자동으로 선택되므로 해당 속성이 검사기 창에 표시됩니다.

Unity PUN Setup window with Setup Project applied

축하합니다.

PUN 앱을 만들어서 Unity 프로젝트에 연결하는 데 성공했습니다. 다음 단계에서는 여러 사용자가 서로 볼 수 있도록 다른 사용자와 연결을 허용할 수 있습니다.