버전 정보 및 로그는 어디에서 확인할 수 있나요?Where can I find my version information and logs?

윤곽선Outline

버전 정보Version information

일반적으로 가장 효율적인 전송 다시 정보에 대 한 모든 합니다 복사 정보 단추.It's usually best to send back all of the information from the Copy Information buttons. 그렇지 않은 경우 추가 정보를 요청 해야 경우가 많습니다.Otherwise we will often need to request additional information. 예를 들어 Android API 수준을 설치 하는 운영 체제 버전, Xcode 버전 및.NET 버전 모두 때 중요할 수 있습니다 문제를 해결 하는 데 합니다.For example, operating system versions, Xcode version, installed Android API levels, and .NET version can all be important when helping to troubleshoot a problem.

Windows 버전 정보Windows version information

Xamarin StudioXamarin Studio

도움말 > 정보 > 자세한 정보 표시 > 복사본 정보 [단추]Help > About > Show Details > Copy Information [button]

Visual StudioVisual Studio

도움말 > Microsoft Visual Studio 정보 > [단추] 정보 복사Help > About Microsoft Visual Studio > Copy Info [button]

Mac 버전 정보Mac version information

Visual Studio for MacVisual Studio for Mac

Visual Studio > Visual Studio 정보 > 자세한 정보 표시 > 복사본 정보 [단추]Visual Studio > About Visual Studio > Show Details > Copy Information [button]

Android SDK Tools, 플랫폼 도구 빌드-도구Android SDK Tools, Platform-tools, Build-tools

Android SDK Manager를 열고 위쪽의 스크린샷의 찍을 도구 섹션입니다.Open the Android SDK Manager, and take a screenshot of the top Tools section.

Visual Studio for MacVisual Studio for Mac

도구 > Android SDK Manager 열기Tools > Open Android SDK Manager

Visual StudioVisual Studio

도구 > Android > Android SDK Manager를 열고...Tools > Android > Open Android SDK Manager...

IDE 및 설치 관리자 로그IDE and installer logs

각 로그 위치에 대해 해야 압축 하 고 전체 로그 폴더를 연결 합니다.For each log location, be sure to zip up and attach the entire log folder.

Windows 로그Windows logs

Visual Studio Tools for Xamarin Visual Studio Tools for Xamarin

%LOCALAPPDATA%\Xamarin\Logs

Visual Studio 2017 Visual Studio 2017

Visual Studio 설치 로그를 가져오는 방법How to get the Visual Studio installation logs

Visual Studio 2015 Visual Studio 2015

Xamarin "범용" 설치 관리자 Xamarin "Universal" installer

%LOCALAPPDATA%\Xamarin\Universal

이러한 로그는에서 로그를 XamarinInstaller.exe 설치 관리자입니다.These are the logs from the XamarinInstaller.exe installer.

개별 .msi 설치 관리자, 자세한 정보 표시 로그Individual .msi installers, verbose logs

msiexec /i Xamarin.msi /l*vx "%USERPROFILE%\Desktop\Xamarin.log"

참조: 명령줄 옵션Reference: Command-Line Options

Visual Studio 시작, 자세한 정보 표시 로그Visual Studio startup, verbose logs

devenv.exe /log "%USERPROFILE%\Desktop\VisualStudio.log"

참조: /Log (devenv.exe)Reference: /Log (devenv.exe)

Mac 로그Mac logs

선택할 수 있습니다 합니다 이동 > 폴더로 이동 메뉴 항목 Finder에서 복사 하 고 대화 상자에 이러한 경로 붙여 넣습니다.You can select the Go > Go to Folder menu item in Finder, and then copy and paste any of these paths into the dialog.

Mac용 Visual StudioVisual Studio for Mac

~/Library/Logs/VisualStudio/7.0 (이 숫자는 사용 중인 버전에 따라 변경 될 수 있습니다.)~/Library/Logs/VisualStudio/7.0 (this number may change depending on the version you are using)

이 폴더를 열 수도 있습니다를 통해 "로그 디렉터리 열기-> Help"입니다.This folder can also be opened via "Help -> Open Log Directory".

Xamarin StudioXamarin Studio

~/Library/Logs/XamarinStudio-6.0 (이 숫자는 사용 중인 버전에 따라 변경 될 수 있습니다.)~/Library/Logs/XamarinStudio-6.0 (this number may change depending on the version you are using)

이 폴더를 열 수도 있습니다를 통해 "로그 디렉터리 열기-> Help"입니다.This folder can also be opened via "Help -> Open Log Directory".

Xamarin "범용" 설치 관리자Xamarin "Universal" installer

~/Library/Logs/XamarinInstaller/Universal

이러한 로그는에서 로그를 XamarinInstaller.dmg 설치 관리자입니다.These are the logs from the XamarinInstaller.dmg installer.

Xamarin 빌드 호스트Xamarin Build Host

~/Library/Logs/Xamarin-[MAJOR.MINOR]

자세한 빌드 출력Verbose build output

  1. 사용 하도록 설정 진단 MSBuild 출력합니다.Enable diagnostic MSBuild output.

  2. IOS 앱을 사용 하도록 설정할 수도 verbose mtouch 출력 더하여 -v -v -v -v 아래 프로젝트 속성 > iOS 빌드 > 일반 (탭) > 추가 옵션 > 추가 mtouch 인수합니다.For iOS apps, also enable verbose mtouch output by adding -v -v -v -v under Project Properties > iOS Build > General (tab) > Additional Options > Additional mtouch arguments.

  3. 정리 하 고 프로젝트를 다시 빌드하십시오.Clean and rebuild the project.

  4. 복사 하 여 텍스트 파일에 IDE에서 빌드 출력을 붙여넣습니다.Copy and paste the build output from the IDE into a text file.

    • Visual Studio (Windows): 보기 > 출력 >에서 출력 보기: 빌드Visual Studio (Windows): View > Output > Show output from: Build
    • Visual Studio for Mac: 보기 > 패드 > 오류 > 빌드 출력 (탭)Visual Studio for Mac: View > Pads > Errors > Build Output (tab)

Xamarin.iOS 및 Xamarin.Android 앱에 대 한 로그 디버그Debug logs for Xamarin.Android and Xamarin.iOS apps

Visual Studio for MacVisual Studio for Mac

보기 > 패드 > 응용 프로그램 출력View > Pads > Application Output

(Note: 앱 실행 된 후이 메뉴 항목만 표시 됩니다.)(Note that this menu item will only appear after the app has been launched.)

Visual StudioVisual Studio

보기 > 출력 >에서 출력 보기: 디버그View > Output > Show output from: Debug

Android adb logcat 로그Android adb logcat logs

실행 한 후 합니다 adb 명령에 다시 연결 합니다 android_logcat.txt 바탕 화면에서 파일입니다.After running the adb command, attach back the android_logcat.txt file from your Desktop. 이러한 지침 연결 된 장치가 하나만 있다고 가정 합니다.These instructions assume you have only one device attached.

참고 항목의 Android 디버그 로그 페이지입니다.See also the Android Debug Log page.

Visual StudioVisual Studio

  1. 도구 > Android > Android Adb 명령 프롬프트를 시작 합니다.Tools > Android > Start Android Adb Command Prompt
  2. 로그를 정리 합니다. adb logcat -cClean the log: adb logcat -c
  3. 문제를 재현 합니다.Reproduce the issue.
  4. 로그를 출력 합니다. adb logcat -vtime -d > "%USERPROFILE%\Desktop\android_logcat.txt"Output the log: adb logcat -vtime -d > "%USERPROFILE%\Desktop\android_logcat.txt"

Visual Studio for MacVisual Studio for Mac

  1. 도구 > Android SDK 명령 프롬프트 열기Tools > Open Android SDK Command Prompt
  2. 로그를 정리 합니다. adb logcat -cClean the log: adb logcat -c
  3. 문제를 재현 합니다.Reproduce the issue.
  4. 로그를 출력 합니다. adb logcat -vtime -d > ~/Desktop/android_logcat.txtOutput the log: adb logcat -vtime -d > ~/Desktop/android_logcat.txt

iOS 시뮬레이터 로그온 (Mac)iOS simulator logs (on Mac)

  • 시스템 로그에 액세스 하려면 디버그 > 시스템 로그 열기... iOS 시뮬레이터 앱에서.To access the system log, select Debug > Open System Log... in the iOS Simulator app.

  • 시뮬레이터에서 크래시 보고서를 보려면 Console.app 열고 이동할 ~/Library/Logs > DiagnosticReports합니다.To view crash reports from the simulator, open Console.app and navigate to ~/Library/Logs > DiagnosticReports.

iOS 장치 로그온 (Mac)iOS device logs (on Mac)

Visual Studio for MacVisual Studio for Mac

보기 > 패드 > iOS 장치 로그View > Pads > iOS Device Log

XcodeXcode

창 > 장치 > ${DeviceName}Window > Devices > ${DeviceName}

충돌 보고서에서 사용할 수는 장치 로그 보기 단추입니다.Crash reports are available under the View Device Logs button. 장치에 대 한 시스템 로그의 공개 화살표 창의 맨 아래에 나타납니다.The system log for the device appears at the bottom of the window under the disclosure arrow.

Xcode 5Xcode 5

창 > 도우미 > 장치 (탭) > ${DeviceName}Window > Organizer > Devices (tab) > ${DeviceName}