통합 문서 설치 및 요구 사항Workbooks Installation and Requirements

다운로드 및 설치Download and Install

  1. 아래 요구 사항을 확인 하세요.Check the requirements below.
  2. Windows 용 Xamarin Workbooks를 다운로드 하 고 설치 합니다.Download and install Xamarin Workbooks for Windows.
  3. 통합 문서를 재생 하기 시작 합니다.Start playing around with workbooks.

요구 사항Requirements

Supported Operating SystemsSupported Operating Systems

  • Mac -OS X 10.11 이상Mac - OS X 10.11 or greater
  • Windows -windows 7 이상 (Internet Explorer 11 이상 및 .net 4.6.1 이상)Windows - Windows 7 or greater (with Internet Explorer 11 or greater and .NET 4.6.1 or greater)

지원 되는 앱 플랫폼Supported App Platforms

앱 플랫폼App Platform OS 지원OS Support 노트Notes
MacMac Mac 에서만 지원 됨Only supported on Mac
iOSiOS Mac 및 Windows에서 지원 됨Supported on Mac and Windows Xamarin.ios 11.0 및 Xcode 9.0 이상이 Mac에 설치 되어 있어야 합니다.Xamarin.iOS 11.0 and Xcode 9.0 or greater must be installed on Mac. Windows에서 iOS 통합 문서를 실행 하려면 위의 모든를 실행 하는 Mac 빌드 호스트와 Windows에 원격 Ios 시뮬레이터 가 설치 되어 있어야 합니다.Running iOS workbooks on Windows requires a Mac build host running all of the above, and the Remoted iOS Simulator installed on Windows.
AndroidAndroid Mac 및 Windows에서 지원 됨Supported on Mac and Windows 가상 장치 > = 5.0를 사용 하 여 Google, Visual Studio 또는 Xamarin Android emulator를 사용 해야 합니다.Must use Google, Visual Studio or Xamarin Android emulator, with a virtual device >= 5.0
WPFWPF Windows 에서만 지원 됨Only supported on Windows
콘솔 (.NET Framework)Console (.NET Framework) Mac 및 Windows에서 지원 됨Supported on Mac and Windows
콘솔 (.NET Core)Console (.NET Core) Mac 및 Windows에서 지원 됨Supported on Mac and Windows

버그 보고Reporting Bugs

GitHub에서 문제를 보고하 고 다음 정보를 모두 포함 하세요.Please report issues on GitHub, and include all of the following information:

로그 파일Log Files

항상 통합 문서 클라이언트 로그 파일 첨부:Always attach Workbooks client log files:

  • Mac: ~/Library/Logs/Xamarin/Workbooks/Xamarin Workbooks {date}.logMac: ~/Library/Logs/Xamarin/Workbooks/Xamarin Workbooks {date}.log
  • Windows: %LOCALAPPDATA%\Xamarin\Workbooks\logs\Xamarin Workbooks {date}.logWindows: %LOCALAPPDATA%\Xamarin\Workbooks\logs\Xamarin Workbooks {date}.log

1.4. x에는 주 메뉴에서 직접 Finder (macOS) 또는 탐색기 (Windows)의 로그 파일을 선택 하는 기능도 있습니다.1.4.x also features the ability to select the log file in Finder (macOS) or Explorer (Windows) directly from the main menu:

  • 로그 파일을 표시 > 도움말Help > Reveal Log File

통합 문서 1.3 및 이전 버전에 대 한 로그 경로:Log paths for Workbooks 1.3 and earlier:

  • Mac: ~/Library/Logs/Xamarin/Inspector/Xamarin Inspector {date}.logMac: ~/Library/Logs/Xamarin/Inspector/Xamarin Inspector {date}.log
  • Windows: %LOCALAPPDATA%\Xamarin\Inspector\logs\Xamarin Inspector {date}.logWindows: %LOCALAPPDATA%\Xamarin\Inspector\logs\Xamarin Inspector {date}.log

플랫폼 버전 정보Platform Version Information

운영 체제 및 설치 된 Xamarin 제품에 대 한 세부 정보를 파악 하는 것이 매우 유용 합니다.It is very helpful to know details about your Operating System and installed Xamarin products.

통합 문서의 주 메뉴에서 다음을 수행 합니다.From the main menu in Workbooks:

  • 버전 정보를 복사 > 도움말Help > Copy Version Information

통합 문서 1.3 및 이전 버전에 대 한 지침:Instructions for Workbooks 1.3 and earlier:

Mac 용 Visual StudioVisual Studio For Mac

  • Visual studio > > 정보를 > 복사 정보를 표시 합니다.Visual Studio > About Visual Studio > Show Details > Copy Information
  • 버그 보고서에 붙여넣기Paste into bug report

Visual StudioVisual Studio

  • Visual Studio > 정보 복사에 대 한 도움말 >Help > About Visual Studio > Copy Info
  • 운영 체제 버전 및 32 비트 또는 64 비트 Windows를 실행 하 고 있는지 여부를 알려주세요.Let us know your Operating System version and whether you are running 32-bit or 64-bit Windows.

샘플Samples

문제가 있는 통합 문서 파일에 연결 하거나 연결할 수 있는 경우 버그를 보다 신속 하 게 해결 하는 데 도움이 될 수 있습니다.If you can attach or link to the .workbooks file you are having trouble with, that might help solve your bug more quickly.

장치Devices

IOS 또는 Android 통합 문서를 연결 하는 데 문제가 있고 문제 해결 페이지를 이미 확인 한 경우 다음 사항을 알고 있어야 합니다.If you are having trouble connecting your iOS or Android workbook, and have already checked our troubleshooting page, we'll need to know:

  • 연결 하려는 장치의 이름Name of device you are trying to connect to
  • 장치의 OS 버전OS version of your device
  • Android: x86 에뮬레이터를 사용 하 고 있는지 확인Android: Verify that you are using an x86 emulator
  • Android: 어떤 에뮬레이터 플랫폼을 사용 하 고 있나요?Android: What emulator platform are you using? Google Emulator?Google Emulator? Visual Studio Android Emulator?Visual Studio Android Emulator? Xamarin Android Player?Xamarin Android Player?
  • Windows의 iOS: 설치 된 Xamarin 원격 iOS 시뮬레이터의 버전 ( 제어판프로그램 추가/제거 확인)iOS on Windows: What version of the Xamarin Remote iOS Simulator do you have installed (check Add/Remove Programs in Control Panel)?
  • Windows의 iOS: Mac 빌드 호스트에 대 한 플랫폼 버전 정보를 제공 하세요.iOS on Windows: Please also provide Platform Version Information for your Mac build host
  • 장치가 네트워크에 연결 되어 있나요 (웹 브라우저를 통해 확인)?Does the device have network connectivity (check via web browser)?

제거Uninstall

Windows

통합 문서를 구입한 방법에 따라 두 가지 제거 절차를 수행 해야 할 수 있습니다.Depending on how you acquired Workbooks, you may have to perform two uninstallation procedures. 소프트웨어를 완전히 제거 하려면이 두 가지를 모두 확인 하세요.Please check both of these to completely uninstall the software.

Visual Studio 설치 관리자Visual Studio Installer

Visual Studio 2017가 있는 경우 Visual Studio 설치 관리자를 열고 Xamarin Workbooks개별 구성 요소 를 확인 합니다.If you have Visual Studio 2017, open Visual Studio Installer, and look in Individual Components for Xamarin Workbooks. 확인란이 선택 되어 있으면 선택을 취소 한 다음 수정 을 클릭 하 여 제거 합니다.If it is checked, uncheck it and then click Modify to uninstall.

시스템 제거System Uninstall

다운로드 한 설치 관리자를 사용 하 여 통합 문서를 설치한 경우 Windows 10의 앱 & 기능 시스템 설정 페이지 또는 이전 버전의 Windows에서 제어판의 프로그램 추가/제거 를 통해 제거 해야 합니다.If you installed Workbooks yourself with a downloaded installer, it will need to be uninstalled via the Apps & features system settings page on Windows 10 or via Add/Remove Programs in the Control Panel on older versions of Windows.

시스템 > 앱 & 기능 > > 설정 시작Start > Settings > System > Apps & features

Visual Studio 설치 관리자에 대 한 절차를 계속 수행 하 여 사용자 모르게 통합 문서를 다시 설치 하지 않도록 해야 합니다.You should still follow the procedure for the Visual Studio Installer to make sure Workbooks does not get reinstalled without your knowledge.

macOSmacOS

1.2.2부터를 실행 하 여 터미널에서 Xamarin Workbooks 제거할 수 있습니다.Starting with 1.2.2, Xamarin Workbooks can be uninstalled from a terminal by running:

sudo /Library/Frameworks/Xamarin.Interactive.framework/Versions/Current/uninstall

제거 하는 파일 및 디렉터리에 대 한 세부 정보를 표시 하 고 계속 하기 전에 확인 합니다.The uninstaller will detail the files and directories it will remove and ask for confirmation before proceeding.

더 많은 고급 시나리오를 위해 -help 인수를 uninstall 스크립트에 전달 합니다.Pass the -help argument to the uninstall script for more advanced scenarios.

이전 버전의 경우 다음 항목을 수동으로 제거해야 합니다.For older versions, you will need to manually remove the following:

  1. "/Applications/Xamarin Workbooks.app"에서 Workbooks 앱 삭제Delete the Workbooks app at "/Applications/Xamarin Workbooks.app"
  2. "Applications/Xamarin Inspector.app"에서 Inspector 앱 삭제Delete the Inspector app at "Applications/Xamarin Inspector.app"
  3. "~/Library/Application Support/XamarinStudio-6.0/LocalInstall/Addins/Xamarin.Interactive""~/Library/Application Support/XamarinStudio-6.0/LocalInstall/Addins/Xamarin.Inspector" 추가 기능 삭제Delete the add-ins: "~/Library/Application Support/XamarinStudio-6.0/LocalInstall/Addins/Xamarin.Interactive" and "~/Library/Application Support/XamarinStudio-6.0/LocalInstall/Addins/Xamarin.Inspector"
  4. /Library/Frameworks/Xamarin.Interactive.framework/Library/Frameworks/Xamarin.Inspector.framework에서 Inspector 및 지원 파일 삭제Delete Inspector and supporting files here: /Library/Frameworks/Xamarin.Interactive.framework and /Library/Frameworks/Xamarin.Inspector.framework

다운Downgrading

/Applications/Xamarin 통합 문서 에 대 한 번들 식별자는 com.xamarin.Inspector에서 1.4 릴리스의 com.xamarin.Workbooks로 변경 되었습니다. 이제 통합 문서와 검사기는 완전히 분할 됩니다.The bundle identifier for /Applications/Xamarin Workbooks.app changed from com.xamarin.Inspector to com.xamarin.Workbooks in the 1.4 release, as Workbooks and Inspector are now fully split.

이전 설치 관리자의 버그로 인해 1.3.2 또는 이전 설치 관리자를 사용 하 여 1.4 이상의 릴리스를 다운 그레이드할 수 없습니다.Because of a bug in older installers, it is not possible to downgrade 1.4 or newer releases using the 1.3.2 or older installers.

1.4 이상에서 1.3.2 또는 이전 버전으로 다운 그레이드 하려면:To downgrade from 1.4 or newer to 1.3.2 or older:

  1. 통합 문서 & 검사기를 수동으로 제거Uninstall Workbooks & Inspector manually
  2. 1.3.2 또는 이전 .pkg 설치 관리자를 실행 합니다.Run the 1.3.2 or older .pkg installer