Microsoft Store app does not open from Internet Explorer print menu on Windows 8.1

Important

The Internet Explorer 11 desktop application will be retired and go out of support on June 15, 2022 (for a list of what's in scope, see the FAQ). The same IE11 apps and sites you use today can open in Microsoft Edge with Internet Explorer mode. Learn more here.

This article helps you work around the problem where the Microsoft Store device app does not open.

Applies to:   Windows 8.1, Windows 8.1 Enterprise, Windows 8.1 Pro
Original KB number:   3079382

Symptoms

Consider the following scenario:

  • You have a Windows 8.1-based system that has a third-party Microsoft Store device app installed.
  • The system has a custom paper form.
  • You open Internet Explorer and try to print a webpage through the Charms menu (Devices > Print).
  • You select the printer for which the custom paper form is set.
  • When the Internet Explorer print menu appears, you select More Settings to start the Microsoft Store device app.

In this scenario, the Microsoft Store device app does not open. Instead, the Internet Explorer print menu reappears.

Cause

The Microsoft Store device app does not open because of an incorrect size calculation in Internet Explorer.

Workaround

This is a known issue with Windows 8.1 and Internet Explorer.

To work around this issue, reduce the margins of the custom paper form to increase the printable area.