Optimize performance with auto cleanup tasks
Important
The functionality noted in this article is currently available for customers on the stand-alone Dynamics 365 Human Resources. Some or all of the functionality will be available as part of a future release on the Finance infrastructure after Finance release 10.0.25.
Applies to these Dynamics 365 apps:
Human Resources
Issue
Microsoft Dynamics 365 Human Resources can experience performance issues if the batch job history grows too large.
Cause
Batch jobs that run frequently can lead to unsustainable growth of the batch job history. This can cause performance issues.
Resolution
Schedule an automatic task to clean up your batch job history. We recommend setting up the task to run weekly, but you might need to run the cleanup more or less frequently, depending on your environment. The following procedure contains our recommended settings, but you can change these according to your needs.
In Human Resources, select System administration.
In the Search bar, enter Batch job history clean-up.

In History limit (days), enter 30.

Select Run in the background and then select Recurrence.

Under Define recurrence, set the Start date and Start time to occur during off-hours or the weekend, and then select NO END DATE.

Under RECURRENCE PATTERN, select Days and set REPEAT AFTER SPECIFIED INTERVAL to 7.

Select OK.
Change any other parameters under Run in the background as necessary, and then select OK.
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