ArchiveStatus er satt til Ingen for en aktiv arkivpostboks i Microsoft 365

Opprinnelig KB-nummer: 4486848

Symptomer

Microsoft 365 Online-arkiver tillater ytterligere lagring av brukernes e-postmeldinger. I noen scenarioer kan imidlertid ArchiveStatus-egenskapen settes til «Ingen», selv om du har aktivert et aktivt arkiv for en brukers postboks i Microsoft 365.

Når du for eksempel kjører følgende cmdlet i Exchange Online PowerShell for å kontrollere arkivstatusen, vises statusen som «Ingen» i stedet for «Aktiv»:

Get-mailbox id|fl ArchiveStatus

Utdataene til cmdleten ligner på følgende:

ArchiveStatus: None

Obs!

Selv om ArchiveStatus viser «Ingen», kan brukeren få tilgang til nettarkivet, og gyldige ArchiveGuid- og ArchiveDatabase-egenskaper angis.

Årsak

Ett av følgende scenarioer kan føre til at ArchiveStatus vises som Ingen.

  • En bruker lisensieres på nytt for en arkivpostboks.
  • Flytte en primærpostboks og arkivere postboks fra lokal til Microsoft 365.

Løsning

Du bør ikke bruke egenskapsverdien ArchiveStatus til å kontrollere statusen for arkivet, med mindre dette er et lokalt scenario der den primære postboksen er lokal og arkivpostboksen finnes i Microsoft 365 (det vil si det lokale arkivet). I alle andre scenarioer bør du bruke begge disse egenskapene til å bekrefte statusen for arkivet:

  • ArchiveDatabase
  • ArchiveGuid

Kjør for eksempel følgende cmdlet:

Get-mailboxUserName|fl archivedatabase,archiveguid

Utdataene ligner på følgende:

ArchiveDatabase :DatabaseIdParameterArchiveGuid :GUID