Finner ikke feilen Digital ID når du dekrypterer en melding ved hjelp av et 3DES-sertifikat

Opprinnelig KB-nummer:   4459215

Symptomer

Når du åpner en kryptert e-postmelding i Microsoft Outlook ved hjelp av et sertifikat som bare har 3DES-krypteringsfunksjoner, får du følgende feilmelding:

Det underliggende sikkerhetssystemet finner ikke navnet på den digitale ID-en

Årsak

Fra og med Outlook bygg 16.0.8518.1000 oppgraderte Microsoft standard tilbakefallsalgoritme fra 3DES til AES256. I problemet som er nevnt i Symptom-delen, sendes den krypterte e-postmeldingen av en bruker som bruker dette Outlook-bygget eller et nyere bygg.

Løsning

Viktig!

Følg fremgangsmåten i dette avsnittet nøye. Det kan oppstå alvorlige problemer hvis du endrer registret på feil måte. Du bør sikkerhetskopiere registeret slik at det kan gjenopprettes før du endrer det, i tilfelle det skulle oppstå problemer.

Hvis du vil løse dette problemet, anbefaler vi at du krypterer meldinger ved hjelp av et sertifikat som har AES256-krypteringsfunksjoner eller større.

Hvis du må bruke 3DES-krypteringsalgoritmen, kan du legge til følgende registerverdier på avsenderens datamaskin:

HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Security

DWORD = UseAlternateDefaultEncryptionAlg
Verdi = 1

Streng = DefaultEncryptionAlgOID
Verdi = 1,2,840,113549.3.7

Obs!

Den angitte strengverdien viser OID for 3DES-krypteringsalgoritmen.

Mer informasjon

Sertifikatet som avsenderen brukte til å kryptere e-postmeldingen, inneholder ikke SMIMECapabilities attributtet. Dette betyr at Outlook ikke kunne bestemme funksjonene til mottakeren på forhånd. Derfor valgte den en ofte godtatt sikker algoritme.

Hvis du vil ha mer informasjon, kan du se delen 2.5.2 SMIME Capabilities Attribute i Internet Engineering Task Force (IETF) RFC 5751: