Problemen oplossen met een gedeeltelijk uitgebrachte batch in Accounts Payable in Microsoft Dynamics SL

Dit artikel biedt oplossingen voor fouten die optreden wanneer u een batch probeert vrij te geven in Accounts Payable in Microsoft Dynamics SL.

Van toepassing op: Microsoft Dynamics SL 2011
Origineel KB-nummer: 871362

Symptomen

Wanneer u probeert een batch vrij te geven in Accounts Payable in Microsoft Dynamics SL, wordt de batch niet vrijgegeven. Wanneer u dit onderzoekt, ziet u dat de batch in het dialoogvenster RELEASE AP Batches (03.400.00) de status Gedeeltelijk vrijgegeven heeft. Mogelijk ziet u een van de volgende foutberichten in een gebeurtenislogboek:

Systeembericht 8888 - Er is een onverwachte fout opgetreden tijdens het vrijgeven van batch %s. Neem contact op met Solomon voor hulp bij deze batch.

Systeembericht 6019 - Batch is uit balans en niet vrijgegeven.

Systeembericht 6909 - Een ander proces heeft het item %s al toegevoegd. Het programma moet worden beƫindigd.

Oorzaak

Er zijn verschillende mogelijke oorzaken voor de foutberichten.

Opmerking

Als geen van de volgende oorzaken van toepassing is, voert u een foutopsporingsscript uit. Zie oplossing 2 voor meer informatie over het uitvoeren van een foutopsporingsscript.

  • Tijdens het releaseproces is de verbinding tussen Microsoft Dynamics SL en het exemplaar van SQL Server verbroken. Zie resolutie 1.
  • Tijdens het releaseproces hebt u Annuleren geselecteerd in het dialoogvenster Release AP Batches (03.400.00). Zie resolutie 1.
  • Het foutbericht Systeembericht 6909 kan optreden wanneer u de batches controleafstemming probeert vrij te geven vanuit het dialoogvenster Controleafstemming (03.060.00) nadat u de periode hebt gewijzigd in Posten.
  • In Microsoft Business Solutions - Solomon 6.0 kan fout 7318 ertoe leiden dat het foutbericht Systeembericht 6909 wordt weergegeven.

Oplossing

Opmerking

Als u momenteel Microsoft Dynamics SL 2011 of latere versies gebruikt, kunt u de batch verwijderen uit het scherm voor gegevensinvoer en deze opnieuw invoeren.

Oplossing 1

Probeer de batch opnieuw vrij te geven. Volg deze stappen om dit te doen:

  1. Open het dialoogvenster AP Batches (03.400.00) vrijgeven.
  2. Schakel het selectievakje Geselecteerd in naast het batchnummer waarnaar wordt verwezen in het gebeurtenislogboek.
  3. Selecteer Verwerking starten.

Oplossing 2

Als u Microsoft SQL Server 2000 uitvoert, voert u het AP_6019_DEBUG-script uit in SQL Query Analyzer en verzendt u vervolgens de scriptresultaten en het gebeurtenislogboek naar Microsoft Customer Support Services. Voer hiervoor de volgende stappen uit. Er is ook een video beschikbaar die het proces van het uitvoeren van het AP-foutopsporingsscript doorloopt:

  1. Download het bestand AP_6019_DEBUG.sql .

    Microsoft heeft dit bestand gescand op virussen. Microsoft heeft de meest recente virusdetectiesoftware gebruikt die beschikbaar was op de datum waarop het bestand werd gepost. Het bestand wordt opgeslagen op beveiligde servers die onbevoegde wijzigingen in het bestand helpen voorkomen.

  2. Selecteer Start, wijs Alle programma's aan, wijs Microsoft SQL Server aan en selecteer vervolgens Query analyzer.

  3. Typ in het dialoogvenster Verbinding maken met SQL Server de naam van het exemplaar van SQL Server naam in het vak SQL Server en selecteer vervolgens SQL Server Verificatie.

  4. Typ sa in het vak Aanmeldingsnaam , typ het wachtwoord in het vak Wachtwoord en selecteer vervolgens OK.

  5. Selecteer op de werkbalk Query Analyzer de toepassingsdatabase.

  6. Selecteer in het menu Extrade optie Opties en selecteer vervolgens het tabblad Resultaten .

  7. Selecteer in het vak Standaardresultatendoelde optie Resultaten naar tekst.

  8. Selecteer in het vak Uitvoerindeling van resultatende optie Tab gescheiden en selecteer vervolgens OK.

  9. Vervang XXXXXX door uw zescijferige batchnummer.

  10. Druk op F5 om het script uit te voeren.

  11. Nadat het script is uitgevoerd, klikt u op het onderste venster.

  12. Selecteer in het menu BestandOpslaan als.

  13. Typ IncidentAP in het vak Bestandsnaam. Vervang Incident door uw werkelijke incidentnummer.

  14. Selecteer in het vak Opslaan als de optie Rapportbestanden (*.rpt) en selecteer vervolgens Opslaan.

  15. Zip dit bestand samen met het gebeurtenislogboek en verzend de bestanden vervolgens naar Microsoft Customer Support Services.

Als u Microsoft SQL Server 2005 of Microsoft SQL Server 2008 uitvoert, voert u het AP_6019_DEBUG-script uit in SQL Server Management Studio en verzendt u de scriptresultaten en het gebeurtenislogboek naar Microsoft Customer Support Services. Volg deze stappen om dit te doen:

  1. Download het AP_6019_DEBUG.sql-foutopsporingsbestand.

    Het volgende bestand kan worden gedownload via de Microsoft Dynamics File-Exchange Server: AP_6019_DEBUG.sql.

    Microsoft heeft dit bestand gescand op virussen. Microsoft heeft de meest recente virusdetectiesoftware gebruikt die beschikbaar was op de datum waarop het bestand werd gepost. Het bestand wordt opgeslagen op beveiligde servers die onbevoegde wijzigingen in het bestand helpen voorkomen.

  2. Start SQL Server Management Studio, meld u aan bij de server en wijzig vervolgens de uitvoeropmaak. Volg deze stappen om dit te doen:

    1. Selecteer in het menu ExtraOpties.
    2. Selecteer Queryresultaten.
    3. Selecteer in het vak Standaardbestemming voor resultatende optie Resultaten naar tekst.
    4. Vouw Queryresultaten uit en vouw vervolgens het exemplaar van SQL Server uit.
    5. Selecteer Resultaten naar tekst.
    6. Selecteer in het vak Uitvoerindelingde optie Tab gescheiden.
    7. Schakel het selectievakje Kolomkoppen opnemen in de resultatenset in.
    8. Selecteer OK om het dialoogvenster Opties te sluiten.
  3. Selecteer in het menu Bestandde optie Openen, zoek het AP_6019_DEBUG.sql bestand en dubbelklik op het AP_6019_DEBUG.sql-bestand .

  4. Vervang de tijdelijke aanduiding XXXXXX door het zescijferige batchnummer van de opgeschorte batch.

  5. Druk op F5.

  6. Nadat het script is voltooid, klikt u met de linkermuisknop op het onderste deelvenster van het venster.

  7. Selecteer in het menu BestandOpslaan als.

  8. Typ IncidentAP in het vak Bestandsnaam.

    Opmerking

    Vervang de tijdelijke aanduiding Incident door het batchnummer van de opgeschorte batch.

  9. Selecteer in het vak Opslaan als de optie Rapportbestanden (*.rpt).

  10. Kies Opslaan.

  11. Comprimeer het bestand.

  12. Verzend het gecomprimeerde bestand samen met het gebeurtenislogboek naar De klantenservice van Microsoft.

Klanten

Klanten van Microsoft Business Solutions die het Enhancement-plan hebben of die een serviceplan hebben, kunnen naar CustomerSource gaan om een nieuwe ondersteuningsaanvraag in te dienen. Ga hiervoor naar CustomerSource.

Typ uw beveiligingssleutel om toegang te krijgen tot de site. Selecteer de koppeling Ondersteuning om naar de pagina Ondersteuning te gaan. Selecteer onder Ondersteuning de optie Nieuwe ondersteuningsaanvragen.

Business Solutions Partners

Gecertificeerde Microsoft Business Solutions-partners kunnen PartnerSource bezoeken om een nieuwe ondersteuningsaanvraag in te dienen.

Typ uw beveiligingssleutel om toegang te krijgen tot de site. Selecteer op de startpagina van PartnerSource de koppeling Ondersteuning onder Resources en selecteer vervolgens Nieuwe ondersteuningsaanvraag.

Algemene informatie

Klanten van Microsoft Business Solutions die geen abonnement hebben en andere Microsoft-partners kunnen ondersteuningsaanvragen indienen en hun ondersteuningsopties bekijken op de website Microsoft Ondersteuning. Ga hiervoor naar Microsoft Ondersteuning.