Data Lake-Hulpprogram Ma's voor Visual Studio gebruiken om verbinding te maken met Azure HDInsight en Apache Hive query's uit te voerenUse Data Lake Tools for Visual Studio to connect to Azure HDInsight and run Apache Hive queries

Meer informatie over het gebruik van Microsoft Azure Data Lake en Stream Analytics Hulpprogram Ma's voor Visual Studio (ook wel Data Lake-Hulpprogram Ma's genoemd) om verbinding te maken met Apache Hadoop clusters in azure HDInsight en Hive-query's te verzenden.Learn how to use Microsoft Azure Data Lake and Stream Analytics Tools for Visual Studio (also called Data Lake Tools) to connect to Apache Hadoop clusters in Azure HDInsight and submit Hive queries.

Zie aan de slag met hdinsightvoor meer informatie over het gebruik van hdinsight.For more information about using HDInsight, see Get started with HDInsight.

Zie voor meer informatie over het maken van verbinding met een Apache Storm-cluster topologieën ontwikkelen C# voor Apache Storm met behulp van de data Lake-Hulpprogram Ma's voor Visual Studio.For more information about connecting to an Apache Storm cluster, see Develop C# topologies for Apache Storm by using the Data Lake tools for Visual Studio.

U kunt Data Lake Tools voor Visual Studio gebruiken voor toegang tot Azure Data Lake Analytics en HDInsight.You can use Data Lake Tools for Visual Studio to access Azure Data Lake Analytics and HDInsight. Zie voor informatie over Data Lake Tools Zelfstudie: U-SQL-scripts ontwikkelen met Data Lake Tools voor Visual Studio.For information about Data Lake Tools, see Develop U-SQL scripts by using Data Lake Tools for Visual Studio.

VereistenPrerequisites

Als u dit artikel wilt volt ooien en Data Lake-Hulpprogram Ma's voor Visual Studio wilt gebruiken, hebt u de volgende items nodig:To complete this article and use Data Lake Tools for Visual Studio, you need the following items:

Data Lake Tools voor Visual Studio installerenInstall Data Lake Tools for Visual Studio

Volg de onderstaande instructies om Data Lake-Hulpprogram Ma's te installeren voor uw versie van Visual Studio:Follow the appropriate instructions to install Data Lake Tools for your version of Visual Studio:

  • Voor Visual Studio 2017 of Visual Studio 2019:For Visual Studio 2017 or Visual Studio 2019:

    Zorg er tijdens de installatie van Visual Studio voor dat u de werk belasting voor Azure Development of de werk belasting voor gegevens opslag en-verwerking opneemt.During Visual Studio installation, make sure you include the Azure development workload or the Data storage and processing workload.

    Voor bestaande Visual Studio-installaties gaat u naar de IDE-menu balk en selecteert u Hulpprogram ma's > Hulpprogram Ma's en functies ophalen om Visual Studio Installer te openen.For existing Visual Studio installations, go to the IDE menu bar, and select Tools > Get Tools and Features to open Visual Studio Installer. Op het tabblad workloads selecteert u ten minste de werk belasting van Azure Development (onder Web & Cloud) of de werk belasting voor gegevens opslag en-verwerking (onder andere sluit).In the Workloads tab, select at least the Azure development workload (under Web & Cloud) or the Data storage and processing workload (under Other Toolsets).

    Werkbelasting selectie, Visual Studio Installer

  • Voor Visual Studio 2015:For Visual Studio 2015:

    Down load data Lake-Hulpprogram ma's.Download Data Lake Tools. Kies de versie van Data Lake Tools die overeenkomt met uw versie van Visual Studio.Choose the version of Data Lake Tools that matches your version of Visual Studio.

Data Lake-Hulpprogram Ma's voor Visual Studio bijwerkenUpdate Data Lake Tools for Visual Studio

Zorg er vervolgens voor dat u Data Lake-Hulpprogram Ma's bijwerkt naar de meest recente versie.Next, make sure you update Data Lake Tools to the most recent version.

  1. Open Visual Studio.Open Visual Studio.

  2. Selecteer door gaan zonder codein het Start venster.In the Start window, select Continue without code.

  3. Kies in de menu balk van Visual Studio IDE de optie extensies > extensies beheren.In the Visual Studio IDE menu bar, choose Extensions > Manage Extensions.

  4. Vouw in het dialoog venster extensies beheren het knoop punt updates uit.In the Manage Extensions dialog box, expand the Updates node.

  5. Als de lijst met beschik bare updates Azure data Lake en stream analytic-Hulpprogram ma'sbevat, selecteert u deze.If the list of available updates includes Azure Data Lake and Stream Analytic Tools, select it. Selecteer vervolgens de knop bijwerken .Then select its Update button. Nadat het dialoog venster downloaden en installeren wordt weer gegeven en verdwijnt, voegt Visual Studio de extensie Azure data Lake en stream analytic-hulpprogram ma's toe aan de update planning.After the Download and Install dialog box appears and disappears, Visual Studio adds the Azure Data Lake and Stream Analytic Tools extension to the update schedule.

  6. Sluit alle Visual Studio-Vensters.Close all Visual Studio windows. Het dialoog venster VSIX installatie programma wordt weer gegeven.The VSIX Installer dialog box appears.

  7. Selecteer de licentie om de licentie voorwaarden te lezen en selecteer vervolgens sluiten om terug te keren naar het dialoog venster VSIX Installer .Select License to read the license terms, then select Close to return to the VSIX Installer dialog box.

  8. Selecteer wijzigen.Select Modify. De installatie van de extensie-update wordt gestart.Installation of the extension update begins. Na enige tijd wordt het dialoog venster weer gegeven om aan te geven dat de wijzigingen zijn aangebracht.After a while, the dialog box changes to show that it's done making modifications. Selecteer sluitenen Start Visual Studio opnieuw om de installatie te volt ooien.Select Close, and then restart Visual Studio to complete the installation.

Notitie

U kunt alleen Data Lake Tools versie 2.3.0.0 of hoger gebruiken om verbinding te maken met Interactive Query-clusters en interactieve Hive-query's uit te voeren.You can use only Data Lake Tools version 2.3.0.0 or later to connect to Interactive Query clusters and run interactive Hive queries.

Verbinding maken met Azure-abonnementenConnect to Azure subscriptions

U kunt Data Lake-Hulpprogram Ma's voor Visual Studio gebruiken om verbinding te maken met uw HDInsight-clusters, enkele eenvoudige beheer bewerkingen uitvoeren en Hive-query's uit te voeren.You can use Data Lake Tools for Visual Studio to connect to your HDInsight clusters, do some basic management operations, and run Hive queries.

Notitie

Zie Hive-query's schrijven en verzenden met Visual Studiovoor meer informatie over het maken van verbinding met een algemeen Hadoop-cluster.For information about connecting to a generic Hadoop cluster, see How to write and submit Hive queries using Visual Studio.

Verbinding maken met een Azure-abonnementConnect to an Azure subscription

Verbinding maken met uw Azure-abonnement:To connect to your Azure subscription:

  1. Open Visual Studio.Open Visual Studio.

  2. Selecteer door gaan zonder codein het Start venster.In the Start window, select Continue without code.

  3. Kies in de IDE-menu balk de optie > Server Explorer weer geven .In the IDE menu bar, choose View > Server Explorer.

  4. In Server Explorerklikt u met de rechter muisknop op Azure, selecteert u verbinding maken met Microsoft Azure abonnementen voltooit u het verificatie proces.In Server Explorer, right-click Azure, select Connect to Microsoft Azure Subscription, and complete the authentication process. Vouw in Server Explorer Azure > hdinsight uit om een lijst met bestaande HDInsight-clusters weer te geven.From Server Explorer, expand Azure > HDInsight to view a list of existing HDInsight clusters.

  5. Als u geen clusters hebt, kunt u er een maken met behulp van de Azure Portal, Azure PowerShell of de HDInsight SDK.If you don't have any clusters, create one by using the Azure portal, Azure PowerShell, or the HDInsight SDK. Zie clusters instellen in HDInsightvoor meer informatie.For more information, see Set up clusters in HDInsight.

    HDInsight-cluster lijst, Server Explorer, Visual Studio

  6. Een HDInsight-cluster uitbreiden.Expand an HDInsight cluster. Het cluster bevat knoop punten voor Hive-data bases, een standaard opslag account, eventuele extra gekoppelde opslag accounts en Hadoop-service logboek.The cluster contains nodes for Hive Databases, a default storage account, any additional linked storage accounts, and Hadoop Service Log. U kunt de entiteiten verder uitbreiden.You can further expand the entities.

Nadat u verbinding hebt gemaakt met het Azure-abonnement, kunt u de volgende taken uitvoeren.After you've connected to your Azure subscription, you can do the following tasks.

Verbinding maken met Azure vanuit Visual StudioConnect to Azure from Visual Studio

Verbinding maken met Azure Portal vanuit Visual Studio:To connect to the Azure portal from Visual Studio:

  1. Vouw in Server Explorer Azure > HDInsight uit en selecteer uw cluster.In Server Explorer, expand Azure > HDInsight and select your cluster.

  2. Klik met de rechter muisknop op een HDInsight-cluster en selecteer cluster beheren in azure Portal.Right-click an HDInsight cluster, and select Manage Cluster in Azure portal.

Vragen en feedback van Visual Studio biedenOffer questions and feedback from Visual Studio

Vragen stellen en/of feedback geven vanuit Visual Studio:To ask questions and/or provide feedback from Visual Studio:

  1. Kies in Server Explorer Azure > HDInsight.From Server Explorer, choose Azure > HDInsight.

  2. Klik met de rechter muisknop op HDInsight en selecteer MSDN-forum om vragen te stellen of Geef feedback om feedback te geven.Right-click HDInsight and select either MSDN Forum to ask questions, or Give Feedback to give feedback.

Notitie

Momenteel is het enige type HDInsight-cluster waarmee u kunt koppelen, is een Hive-type.Currently the only type of HDInsight cluster you can link to is a Hive type.

Een HDInsight-cluster koppelen:To link an HDInsight cluster:

  1. Klik met de rechter muisknop op HDInsighten selecteer vervolgens koppelen van een hdinsight-cluster om het dialoog venster een hdinsight-cluster te koppelen weer te geven.Right-click HDInsight, and then select Link a HDInsight Cluster to display the Link a HDInsight Cluster dialog box.

  2. Geef een verbindings-URL op in het formulier https://<cluster name >. azurehdinsight. net.Enter a Connection Url in the form https://<cluster name>.azurehdinsight.net. De cluster naam wordt automatisch ingevuld met het cluster naam gedeelte van uw URL wanneer u naar een ander veld gaat.The Cluster Name automatically fills in with the cluster name portion of your URL when you go to another field. Voer vervolgens een gebruikers naam en wacht woordin en selecteer volgende.Then enter a Username and Password, and select Next.

    Een cluster koppelen, HDInsight, Visual Studio

  3. Selecteer Finish.Select Finish. Als de cluster koppeling is geslaagd, wordt het cluster weer gegeven onder het HDInsight -knoop punt.If the cluster linking is successful, the cluster is then listed under the HDInsight node.

Als u een gekoppeld cluster wilt bijwerken, klikt u met de rechter muisknop op het cluster en selecteert u bewerken.To update a linked cluster, right-click the cluster and select Edit. U kunt vervolgens de cluster gegevens bijwerken.You can then update the cluster information.

Een gekoppeld cluster, HDInsight, Visual Studio bewerken

Gekoppelde resources verkennenExplore linked resources

In Server Explorer worden het standaardaccount voor opslag en alle gekoppelde opslagaccounts weergegeven.From Server Explorer, you can see the default storage account and any linked storage accounts. Als u het standaardopslagaccount uitvouwt, kunt u de containers op het opslagaccount zien.If you expand the default storage account, you can see the containers on the storage account. Het standaardopslagaccount en de standaardcontainer worden gemarkeerd.The default storage account and the default container are marked.

Data Lake-Hulpprogram Ma's voor Visual Studio gekoppelde resources in Server Explorer

Klik met de rechter muisknop op een container en selecteer container weer geven om de inhoud van de container weer te geven.Right-click a container and select View Container to view the container's contents. Nadat u een container hebt geopend, kunt u de knoppen op de werk balk gebruiken om de inhouds lijst te vernieuwen , BLOB te uploaden, geselecteerde blobs te verwijderen, blob te openenen te downloaden (Opslaan als) geselecteerde blobs.After opening a container, you can use the toolbar buttons to Refresh the content list, Upload Blob, Delete selected blobs, Open Blob, and download (Save As) selected blobs.

Container lijst en BLOB-bewerkingen, HDInsight-cluster, Visual Studio

Interactieve Apache Hive query's uitvoerenRun interactive Apache Hive queries

Apache Hive is een datawarehouse-infrastructuur die is gebouwd op Hadoop.Apache Hive is a data warehouse infrastructure that's built on Hadoop. Hive wordt gebruikt voor gegevenssamenvatting, query's en analyse.Hive is used for data summarization, queries, and analysis. U kunt Data Lake Tools voor Visual Studio gebruiken om Hive-query's uit te voeren vanuit Visual Studio.You can use Data Lake Tools for Visual Studio to run Hive queries from Visual Studio. Zie Wat is Apache Hive en HiveQL in azure HDInsight?voor meer informatie over Hive.For more information about Hive, see What is Apache Hive and HiveQL on Azure HDInsight?.

Interactieve query's in azure HDInsight gebruiken Hive op LLAP in Apache hive 2,1.Interactive Query in Azure HDInsight uses Hive on LLAP in Apache Hive 2.1. Interactieve query brengt interactiviteit op complexe, Data Warehouse-stijl query's op grote opgeslagen gegevens sets.Interactive Query brings interactivity to complex, data warehouse-style queries on large, stored datasets. Het uitvoeren van Hive-query's op interactieve Query's is veel sneller dan de traditionele Hive-batch taken.Running Hive queries on Interactive Query is much faster than traditional Hive batch jobs.

Notitie

U kunt alleen interactieve Hive-query's uitvoeren wanneer u verbinding maakt met een HDInsight Interactive Query-cluster.You can run interactive Hive queries only when you connect to an HDInsight Interactive Query cluster.

U kunt Data Lake Tools voor Visual Studio ook gebruiken om te zien wat er in een Hive-taak zit.You can also use Data Lake Tools for Visual Studio to see what’s inside a Hive job. Data Lake Tools voor Visual Studio verzamelt de Yarn-logboeken van bepaalde Hive-taken en maakt ze zichtbaar.Data Lake Tools for Visual Studio collects and surfaces the Yarn logs of certain Hive jobs.

Kies in Server Explorer Azure > HDInsight en selecteer uw cluster.From Server Explorer, choose Azure > HDInsight and select your cluster. Dit knoop punt is het begin punt in Server Explorer voor de volgende secties.This node is the starting point in Server Explorer for the sections to follow.

Hivesampletable weer gevenView hivesampletable

Alle HDInsight-clusters hebben een standaard voor beeld-Hive-tabel met de naam hivesampletable.All HDInsight clusters have a default sample Hive table called hivesampletable.

Kies in uw cluster Hive-data bases > standaard > hivesampletable.From your cluster, choose Hive Databases > default > hivesampletable.

  • Het hivesampletable schema weer geven:To view the hivesampletable schema:

    Vouw hivesampletableuit.Expand hivesampletable. De namen en gegevens typen van de hivesampletable kolommen worden weer gegeven.The names and data types of the hivesampletable columns are shown.

  • De hivesampletable gegevens weer geven:To view the hivesampletable data:

    Klik met de rechter muisknop op hivesampletableen selecteer Top 100-rijen weer geven.Right-click hivesampletable, and select View Top 100 Rows. De lijst met 100 resultaten wordt weer gegeven in de Hive-tabel: hivesampletable -venster.The list of 100 results appears in the Hive Table: hivesampletable window. Deze actie is gelijk aan het uitvoeren van de volgende Hive-query met behulp van het Hive ODBC-stuur programma:This action is equivalent to running the following Hive query by using the Hive ODBC driver:

    SELECT * FROM hivesampletable LIMIT 100

    U kunt het aantal rijen aanpassen door het wijzigen van de waarde vaneen rij. u kunt kiezen uit de vervolg keuzelijst 50, 100, 200 of 1000 rijen.You can customize the row count by changing Number of rows; you can choose 50, 100, 200, or 1000 rows from the drop-down list.

Hive-tabellen makenCreate Hive tables

U een Hive-tabel maken door de GUI te gebruiken of door Hive-query's te gebruiken.To create a Hive table, you can use the GUI or you can use Hive queries. Zie Hive-Query's maken en uitvoerenvoor meer informatie over het gebruik van Hive-query's.For information about using Hive queries, see Create and run Hive queries.

  1. Kies in uw cluster Hive-data bases > standaard.From your cluster, choose Hive Databases > default.

  2. Klik met de rechter muisknop op standaarden selecteer tabel maken.Right-click default, and select Create Table.

  3. Configureer de tabel.Configure the table.

  4. Selecteer de knop tabel maken om de taak te verzenden, waarmee de nieuwe Hive-tabel wordt gemaakt.Select the Create Table button to submit the job, which creates the new Hive table.

    Tabel venster maken, Hive, HDInsight-cluster, Visual Studio

Hive-query's maken en uitvoerenCreate and run Hive queries

U hebt twee opties voor het maken en uitvoeren van Hive-query's:You have two options for creating and running Hive queries:

  • Ad-hocquery's makenCreate ad-hoc queries
  • Een Hive-toepassing makenCreate a Hive application

Een ad-hoc-query makenCreate an ad-hoc query

Een ad-hoc query maken en uitvoeren:To create and run an ad-hoc query:

  1. Klik met de rechter muisknop op het cluster waar u de query wilt uitvoeren en selecteer een Hive-query schrijven.Right-click the cluster where you want to run the query, and select Write a Hive Query.

  2. Voer een Hive-query in.Enter a Hive query.

    De Hive-editor ondersteunt IntelliSense.The Hive editor supports IntelliSense. Data Lake Tools voor Visual Studio biedt ondersteuning voor het laden van externe metagegevens wanneer u het Hive-script bewerkt.Data Lake Tools for Visual Studio supports loading remote metadata when you edit your Hive script. Als u bijvoorbeeld SELECT * FROMtypt, geeft IntelliSense alle voorgestelde tabel namen weer.For example, if you type SELECT * FROM, IntelliSense lists all the suggested table names. Wanneer een tabelnaam wordt opgegeven, geeft IntelliSense de kolomnamen weer.When a table name is specified, IntelliSense lists the column names. De hulpprogramma's ondersteunen de meeste DML-instructies, subquery's en ingebouwde UDF's van Hive.The tools support most Hive DML statements, subqueries, and built-in UDFs.

    IntelliSense-voor beeld 1, Hive ad-hoc query, HDInsight-cluster, Visual Studio

    IntelliSense-voor beeld 2, Hive ad-hoc query, HDInsight-cluster, Visual Studio

    Notitie

    IntelliSense suggereert alleen de metagegevens van het cluster dat in de HDInsight-werkbalk is geselecteerd.IntelliSense suggests only the metadata of the cluster that is selected in the HDInsight toolbar.

    Hier volgt een voor beeld van een query die u kunt gebruiken:Here is a sample query that you can use:

    SELECT devicemodel, COUNT(devicemodel) AS deviceCount
    FROM hivesampletable
    GROUP BY devicemodel
    ORDER BY devicemodel
    
  3. De uitvoerings modus kiezen:Choose the execution mode:

    • InteractiefInteractive

      Kies in de eerste vervolg keuzelijst de optie interactiefen selecteer vervolgens uitvoeren.In the first drop-down list, choose Interactive, and then select Execute.

      Interactieve modus, Hive ad-hoc query, HDInsight-cluster, Visual Studio

    • BatchBatch

      Kies in de eerste vervolg keuzelijst batch, en selecteer vervolgens verzenden (of selecteer het pictogram vervolg keuzelijst naast verzenden en kies Geavanceerd).In the first drop-down list, choose Batch, and then select Submit (or select the drop-down icon next to Submit and choose Advanced).

      Batch-modus, Hive ad-hoc query, HDInsight-cluster, Visual Studio

      Als u de optie Geavanceerde verzen ding selecteert, wordt het dialoog venster script indienen weer gegeven.If you select the advanced submit option, the Submit Script dialog box appears. Configureer de taak naam, argumenten, aanvullende configuratiesen de status Directory voor het script.Configure the Job Name, Arguments, Additional Configurations, and Status Directory for the script.

      Het dialoog venster script indienen, Hive ad-hoc query, HDInsight-cluster, Visual Studio

      Notitie

      U kunt geen batches naar interactieve query clusters verzenden.You can't submit batches to Interactive Query clusters. U moet de interactieve modus gebruiken.You must use interactive mode.

Een Hive-toepassing makenCreate a Hive application

Een Hive-oplossing maken en uitvoeren:To create and run a Hive solution:

  1. Kies in de menu balk bestand > Nieuw > project.From the menu bar, choose File > New > Project.

  2. Selecteer in het venster een nieuw project maken het onderdeelzoeken en type.In the Create a new project window, select the search box and type Hive. Kies vervolgens Hive-toepassing en selecteer volgende.Then choose Hive Application and select Next.

  3. Voer in het venster uw nieuwe project configureren een project naamin, selecteer of maak de project locatieen selecteer vervolgens maken.In the Configure your new project window, enter a Project name, select or create the project Location, and then select Create.

    Nieuwe Hive-toepassing, het nieuwe project venster configureren, HDInsight Visual Studio

  4. Dubbelklik in Solution Explorer op Script.hql om het script te openen.In Solution Explorer, double-click Script.hql to open the script.

Taak samenvatting en-uitvoer weer gevenView job summary and output

De samen vatting van de taak varieert enigszins tussen batch en interactieve modus.The job summary varies slightly between Batch and Interactive mode.

Overzicht van Hive-taken Windows, batch en interactieve modus, Visual Studio

Gebruik het vernieuwings pictogram om de status bij te werken totdat de taak status is gewijzigd in voltooid.Use the Refresh icon to update the status until the job status changes to Finished.

  • Voor de taak Details van de batch modus selecteert u de koppelingen onderaan om de taak query, taak uitvoerof taak logboekte bekijken of om de garens te bekijken.For the job details from Batch mode, select the links at the bottom to see the Job Query, Job Output, or Job Log, or to View Yarn Logs.

  • Zie de uitvoer-en HiveServer2 uitvoer deel Vensters voor de taak Details van de interactieve modus.For the job details from Interactive mode, see the Output and HiveServer2 Output panes.

    Onderdeel interactieve taak uitvoer, HDInsight-cluster, Visual Studio

Taak grafiek weer gevenView job graph

Taak grafieken worden momenteel alleen weer gegeven voor Hive-taken die gebruikmaken van TEZ als uitvoerings engine.Currently, job graphs are only shown for Hive jobs that use Tez as the execution engine. Zie Wat is Apache Hive en HiveQL in azure HDInsight?voor meer informatie over het inschakelen van TEZ.For information about enabling Tez, see What is Apache Hive and HiveQL on Azure HDInsight?. Zie ook Apache TEZ gebruiken in plaats van toewijzings reductie.See also, Use Apache Tez instead of Map Reduce.

Dubbel klik op de hoek punten van de taak grafiek om alle Opera tors in het hoek punt weer te geven.To view all the operators inside the vertex, double-click the vertices of the job graph. U kunt ook een bepaalde operator aanwijzen voor meer informatie over de operator.You can also point to a specific operator to see more details about the operator.

Zelfs als TEZ is opgegeven als de uitvoerings engine, wordt de taak grafiek mogelijk niet weer gegeven als er geen TEZ-toepassing wordt gestart.Even if Tez is specified as the execution engine, the job graph may not appear if no Tez application is launched. Deze situatie kan zich voordoen omdat de taak geen DML-instructies bevat of omdat de DML-instructies kunnen retour neren zonder een TEZ-toepassing te starten.This situation might occur because the job doesn't contain DML statements, or because the DML statements can return without launching a Tez application. SELECT * FROM table1 de toepassing TEZ bijvoorbeeld niet starten.For example, SELECT * FROM table1 won't launch the Tez application.

Apache Hive-taak grafiek, Visual Studio

Details van taak uitvoering weer gevenView task execution detail

Vanuit de taak grafiek kunt u details van taak uitvoering selecteren om gestructureerde en gevisualiseerde informatie voor Hive-taken op te halen.From the job graph, you can select Task Execution Detail to get structured and visualized information for Hive jobs. U kunt ook meer taak Details ophalen.You may also get more job details. Als er prestatieproblemen optreden, kunt u de weergave gebruiken om meer informatie over het probleem op te vragen.If performance issues occur, you can use the view to get more details about the issue. U kunt bijvoorbeeld gegevens ophalen over de werking van elke taak en gedetailleerde informatie over elke taak (gegevens lezen/schrijven, planning/begin-en eind tijd en meer).For example, you may retrieve information about how each task operates and detailed information about each task (data read/write, schedule/start/end time, and more). Gebruik de informatie om taakconfiguraties of systeemarchitectuur bij te stellen op basis van de gevisualiseerde informatie.Use the information to tune job configurations or system architecture based on the visualized information.

Venster taak uitvoering weer geven, Data Lake Visual Studio Tools

Hive-taken weergevenView Hive jobs

U kunt taakquery's, taakuitvoer, logboeken van taken en Yarn-logboeken voor Hive-taken weergeven.You can view job queries, job output, job logs, and Yarn logs for Hive jobs.

In de meest recente versie van de hulpprogramma's kunt u in uw Hive-taken kijken door Yarn-logboeken te verzamelen en zichtbaar te maken.In the most recent release of the tools, you can see what’s inside your Hive jobs by collecting and surfacing Yarn logs. Een Yarn-logboek kan u helpen bij het onderzoeken van prestatieproblemen.A Yarn log can help you investigating performance issues. Zie Access Apache HADOOP garens van toepassings logboekenvoor meer informatie over hoe HDInsight garens verzamelt.For more information about how HDInsight collects Yarn logs, see Access Apache Hadoop YARN application logs.

Hive-taken weergeven:To view Hive jobs:

  1. Klik met de rechter muisknop op een HDInsight-cluster en selecteer taken weer geven.Right-click an HDInsight cluster, and select View Jobs.

    Taken weer geven, Apache Hive, HDInsight-cluster, Visual Studio

    Er wordt een lijst weergegeven met de Hive-taken die op het cluster zijn uitgevoerd.A list of the Hive jobs that ran on the cluster appears.

  2. Selecteer een taak.Select a job. Selecteer in het venster samen vatting van Hive-taak een van de volgende koppelingen:In the Hive Job Summary window, select one of the following links:

    • TaakqueryJob Query
    • TaakuitvoerJob Output
    • TakenlogboekJob Log
    • Logboek voor garenYarn Log

Apache Pig-scripts uitvoerenRun Apache Pig scripts

  1. Kies in de menu balk bestand > Nieuw > project.From the menu bar, choose File > New > Project.

  2. Schakel in het Start venster het zoekvak in en voer Pigin.In the Start window, select the search box and enter Pig. Selecteer vervolgens varkens toepassing en selecteer volgende.Then select Pig Application and select Next.

  3. Voer in het venster uw nieuwe project configureren een project naamin en selecteer of maak een locatie voor het project.In the Configure your new project window, enter a Project name, and select or create a Location for the project. Selecteer vervolgens Maken.Then select Create.

  4. Dubbel klik in het deel venster IDE- Solution Explorer op script. Pig om het script te openen.In the IDE Solution Explorer pane, double-click Script.pig to open the script.

Feedback en bekende problemenFeedback and known issues

  • Een probleem waardoor resultaten beginnend met null-waarden niet worden weergegeven, is opgelost.An issue in which results that are started with null values aren't shown has been fixed. Neem contact op met het ondersteuningsteam als u vastloopt op dit probleem.If you're blocked on this issue, contact the support team.

  • Het HQL-script dat door Visual Studio wordt gemaakt, word gecodeerd op basis van de lokale regio-instellingen van de gebruiker.The HQL script that Visual Studio creates is encoded, depending on the user’s local region setting. Het script wordt niet correct uitgevoerd als u het script als binair bestand naar een cluster uploadt.The script doesn't execute correctly if you upload the script to a cluster as a binary file.

Volgende stappenNext steps

In dit artikel hebt u hoe geleerd u het Data Lake Tools-pakket voor Visual Studio kunt gebruiken om verbinding te maken met HDInsight-clusters vanuit Visual Studio.In this article, you learned how to use the Data Lake Tools for Visual Studio package to connect to HDInsight clusters from Visual Studio. U hebt ook geleerd hoe u een Hive-query uitvoert.You also learned how to run a Hive query. Raadpleeg voor meer informatie de volgende artikelen:For more information, see these articles: