Implementatieproblemen oplossen met het opnieuw opstarten of wijzigen van het formaat van een bestaande Windows-VM in Azure

Wanneer u probeert een gestopte Virtuele Azure-machine (VM) te starten of het formaat van een bestaande Azure-VM te wijzigen, is de veelvoorkomende fout een toewijzingsfout. Deze fout treedt op wanneer het cluster of de regio geen resources beschikbaar heeft of de aangevraagde VM-grootte niet kan ondersteunen.

Als uw Azure-probleem niet wordt opgelost in dit artikel, gaat u naar de Azure-forums op MSDN en Stack Overflow. U kunt uw probleem posten in deze forums of posten op @AzureSupport op Twitter. U kunt ook een ondersteuning voor Azure-aanvraag indienen. Als u een ondersteuningsaanvraag wilt indienen, selecteert u ondersteuning krijgen op de pagina ondersteuning voor Azure.

Activiteitenlogboeken verzamelen

Als u problemen wilt oplossen, verzamelt u de activiteitenlogboeken om de fout te identificeren die aan het probleem is gekoppeld. De volgende koppelingen bevatten gedetailleerde informatie over het proces:

Implementatiebewerkingen weergeven

Activiteitenlogboeken weergeven voor het beheren van Azure-resources

Probleem: Fout bij het starten van een gestopte VM

U probeert een gestopte VM te starten, maar krijgt een toewijzingsfout.

Oorzaak

De aanvraag om de gestopte VM te starten, moet worden uitgevoerd in het oorspronkelijke cluster dat als host fungeert voor de cloudservice. Het cluster heeft echter geen vrije ruimte om aan de aanvraag te voldoen.

Oplossing

  • Stop alle VM's in de beschikbaarheidsset en start elke VM opnieuw op.

    1. Klik op Resourcegroepen>uw resourcegroep>Resources>uw beschikbaarheidsset>Virtual Machines>uw virtuele machine>stoppen.
    2. Nadat alle VM's zijn gestopt, selecteert u elk van de gestopte VM's en klikt u op Starten.
  • Voer de aanvraag voor opnieuw opstarten op een later tijdstip opnieuw uit.

Probleem: Fout bij het wijzigen van het formaat van een bestaande VM

U probeert het formaat van een bestaande VM te wijzigen, maar krijgt een toewijzingsfout.

Oorzaak

De aanvraag om het formaat van de VM te wijzigen, moet worden uitgevoerd op het oorspronkelijke cluster dat als host fungeert voor de cloudservice. Het cluster biedt echter geen ondersteuning voor de aangevraagde VM-grootte.

Oplossing

  • Probeer de aanvraag opnieuw uit te voeren met een kleinere VM-grootte.

  • Als de grootte van de aangevraagde VM niet kan worden gewijzigd:

    1. Stop alle VM's in de beschikbaarheidsset.

      • Klik op Resourcegroepen>uw resourcegroep>Resources>uw beschikbaarheidsset>Virtual Machines>uw virtuele machine>stoppen.
    2. Nadat alle VM's zijn gestopt, wijzigt u het formaat van de gewenste VM naar een groter formaat.

    3. Selecteer de vm waarvan het formaat is gewijzigd, klik op Start en start vervolgens elk van de gestopte VM's.

Fout wanneer u een bestaande VM stopt, start, opnieuw start of opnieuw implementeert

Wanneer u probeert een bestaande VM te stoppen, te starten, opnieuw te starten of opnieuw te implementeren, mislukt het proces en ontvangt u de melding 'Er is een onverwachte fout opgetreden tijdens het verwerken van het netwerkprofiel van de VM. Probeer het later opnieuw' foutbericht. Wanneer deze fout optreedt, wordt de VM in een mislukte status geplaatst.

Oorzaak

Dit probleem treedt op als er een probleem is met het toewijzen of bijwerken van netwerkresources.

Oplossing

Probeer de status van de virtuele machine opnieuw toe te past. Met deze bewerking wordt de VM-inrichting opnieuw uitgevoerd en wordt de fout met de VM-status opgelost die optreedt als vm-inrichting is mislukt toen u een eerdere VM-actie uitvoerde.

  1. Navigeer naar de VM die is vastgelopen in de status Mislukt.
  2. Selecteer onder Helpde optie Opnieuw implementeren + opnieuw toepassen.
  3. Selecteer de optie Opnieuw toepassen .

Volgende stappen

Als u problemen ondervindt bij het maken van een nieuwe Virtuele Windows-machine in Azure, raadpleegt u Implementatieproblemen oplossen met het maken van een nieuwe Virtuele Windows-machine in Azure.

Contacteer ons voor hulp

Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Feedback-community van Azure.