Windows geeft een fout met een blauw scherm weer bij het opstarten van een Azure-VM
In dit artikel worden fouten met een blauw scherm beschreven die kunnen optreden wanneer u een virtuele Windows-machine (VM) opstart in Microsoft Azure. Het bevat stappen voor het verzamelen van gegevens voor een ondersteuningsticket.
Symptomen
Een Windows-VM wordt niet gestart. Wanneer u de opstartschermafbeeldingen in Diagnostische gegevens over opstarten controleert, ziet u een van de volgende foutberichten in een blauw scherm:
Er is een probleem opgetreden op uw pc en moet opnieuw worden opgestart. We verzamelen alleen wat foutgegevens en vervolgens kunt u opnieuw opstarten.
Er is een probleem opgetreden op uw pc en moet opnieuw worden opgestart.
Oorzaak
Er kunnen veel redenen zijn waarom u een stopfout ondervindt. De meest voorkomende oorzaken zijn de volgende problemen:
- Probleem binnen een stuurprogramma
- Beschadigd systeembestand of geheugen
- Een toepassing die toegang heeft tot een verboden sector van het geheugen
Oplossing
Tip
Als u een recente back-up van de VM hebt, kunt u proberen de VM te herstellen vanuit de back-up om het opstartprobleem op te lossen.
Om dit probleem op te lossen, moet u eerst een dumpbestand voor de crash verzamelen voordat u contact opneemt met ondersteuning. Voer de volgende stappen uit om het dumpbestand te verzamelen:
Stap 1: Zoek het dumpbestand en dien een ondersteuningsticket in
Deel 1: De besturingssysteemschijf koppelen aan een herstel-VM
Maak een momentopname van de besturingssysteemschijf van de betreffende VM om een back-up te maken. Zie Een momentopname van een virtuele harde schijf maken voor meer informatie.
Gebruik Remote Desktop Protocol (RDP) om extern verbinding te maken met de herstel-VM.
Als de besturingssysteemschijf van de betreffende VM is versleuteld, schakelt u versleuteling uit voordat u naar de volgende stap gaat. Zie De versleutelde besturingssysteemschijf ontsleutelen voor meer informatie.
Deel 2: Zoek het dumpbestand en dien een ondersteuningsticket in
Ga op de herstel-VM naar de map Windows op de gekoppelde besturingssysteemschijf. Als de stationsletter die is toegewezen aan de gekoppelde besturingssysteemschijf bijvoorbeeld F is, gaat u naar F:\Windows.
Zoek het Memory.dmp-bestand , dien vervolgens een ondersteuningsticket in en voeg het dumpbestand toe.
Als u het dumpbestand niet kunt vinden, gaat u naar de volgende stappen om het dumplogboek en de seriële console in te schakelen en reproduceert u het probleem.
Stap 2: het dumplogboek en de seriële console inschakelen
Belangrijk
Deze sectie, methode of taak bevat stappen voor het bewerken van het register. Als u het register op onjuiste wijze wijzigt, kunnen er echter grote problemen optreden. Het is dan ook belangrijk dat u deze stappen zorgvuldig uitvoert. Maak ter beveiliging een back-up van het register voordat u het wijzigt, zodat u het kunt herstellen als er zich een probleem voordoet. Raadpleeg Een back-up maken van en het herstellen van het register in Windows voor meer informatie over het maken van een back-up en het herstellen van het register.
Voer de volgende stappen uit om het dumplogboek en de seriële console in te schakelen:
Open een opdrachtpromptsessie met verhoogde bevoegdheid als beheerder.
Voer de volgende BCDEdit-opdrachten uit met de opties /ems en /emssettings :
Schakel de seriële console in:
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Controleer of de vrije ruimte op de besturingssysteemschijf groter is dan de geheugengrootte (RAM) op de VM.
Als er onvoldoende ruimte is op de besturingssysteemschijf, wijzigt u de locatie waar het geheugendumpbestand wordt gemaakt en verwijst u die locatie naar een gegevensschijf die is gekoppeld aan de VM die voldoende vrije ruimte heeft. Als u de locatie wilt wijzigen, vervangt u door
%SystemRoot%
de stationsletter van de gegevensschijf, zoalsF:
, in de volgende opdrachten.Als u het dumpbestand van het besturingssysteem wilt inschakelen, voert u de volgende opdrachten uit om de voorgestelde configuratie te implementeren met behulp van het hulpprogramma reg:
Laad de registercomponent van de defecte besturingssysteemschijf:
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
Inschakelen op ControlSet001:
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Inschakelen op ControlSet002:
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Verwijder de defecte besturingssysteemschijf:
reg unload HKLM\<broken-system>
Stap 3: het probleem reproduceren
Start de VM om het probleem te reproduceren, zodat er een dumpbestand wordt gegenereerd.
Herhaal de instructies in de sectie Stap 1: Zoek het dumpbestand en dien een ondersteuningsticket in .
Contacteer ons voor hulp
Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Feedback-community van Azure.
Feedback
https://aka.ms/ContentUserFeedback.
Binnenkort beschikbaar: In de loop van 2024 zullen we GitHub-problemen geleidelijk uitfaseren als het feedbackmechanisme voor inhoud en deze vervangen door een nieuw feedbacksysteem. Zie voor meer informatie:Feedback verzenden en weergeven voor