Onverwacht gedrag bij Automatisch opsporen wanneer u registerinstellingen hebt onder de \Autodiscover-sleutel

Symptomen

Wanneer Microsoft Outlook probeert informatie over Automatisch opsporen op te halen van een server met Microsoft Exchange Server, kunt u onverwachte resultaten krijgen als u een of meer van de beschikbare registerwaarden gebruikt die kunnen worden gebruikt om Automatisch te beheren.

Oorzaak

Wanneer Outlook probeert contact te maken met de service voor Automatisch opsporen op de Exchange Server met de serverfunctie voor clienttoegang, kunnen er verschillende methoden worden gebruikt om de service te bereiken, afhankelijk van de client/server-topologie. De huidige geïmplementeerde methoden die door Outlook worden gebruikt, zijn:

  • SCP zoeken
  • HTTPS-hoofddomein opvragen
  • HTTPS-domein voor Automatisch opsporen opvragen
  • Lokaal XML-bestand
  • Methode voor HTTP-omleiding
  • SRV-record opvragen
  • In de cache opgeslagen URL in het Outlook-profiel (nieuw voor Outlook 2010 versie 14.0.7140.5001 en latere versies)
  • Directe verbinding naar Microsoft 365 (nieuw voor Outlook 2016 versie 16.0.6741.2017 en latere versies)

Standaard probeert Outlook een of meerdere van deze methode uit te voeren als Automatisch opsporen niet kan worden bereikt. In een scenario met een computer die geen lid is van een domein, probeert Outlook bijvoorbeeld verbinding te maken met de vooraf gedefinieerde URL's (zoals https://autodiscover.contoso.com/autodiscover/autodiscover.xml) met behulp van DNS. Als dit mislukt, probeert Outlook de HTTP-omleidingsmethode. Als dat ook mislukt, zal Outlook proberen de SRV-recordopzoekmethode te gebruiken. Als alle opzoekmethoden mislukken, kan Outlook de Outlook Anywhere-configuratie en URL-instellingen niet verkrijgen.

Raadpleeg de volgende Exchange Autodiscover Service-documenten voor meer informatie over de verschillende Autodiscover-verbindingsmethoden die door Outlook worden gebruikt:

In sommige scenario's echter kunt u register-/beleidswaarden met betrekking tot Automatisch opsporen gebruiken om controle te krijgen over de methode(n) die wordt/worden gebruikt door Outlook om Automatisch opsporen te bereiken. Als u echter de register-/beleidswaarden voor Automatisch opsporen onjuist configureert, verhindert u mogelijk dat Outlook informatie over Automatisch opsporen verkrijgt.

Oplossing

Om dit probleem op te lossen, raadpleegt u de registergegevens met betrekking tot Automatisch opsporen die mogelijk op uw Outlook-client aanwezig zijn om ervoor te zorgen dat de gegevens correct zijn geconfigureerd. Als u niet zeker weet of de registergegevens nodig zijn, kunt u overwegen om de gegevens voor een van deze registerwaarden te wijzigen naar nul (0) en kunt u vervolgens Outlook testen om te kijken of er een verschil is in Automatisch opsporen.

Belangrijk

Deze sectie, methode of taak bevat stappen voor het bewerken van het register. Als u het register op onjuiste wijze wijzigt, kunnen er echter grote problemen optreden. Het is dan ook belangrijk dat u deze stappen zorgvuldig uitvoert. Maak een back-up van het register voordat u wijzigingen aanbrengt. Als er een probleem optreedt, kunt u het register altijd nog herstellen. Als u meer informatie wilt over het maken van een back-up van het register en het herstellen van het register, gaat u naar het volgende artikel in de Microsoft Knowledge Base: 322756 Een reservekopie van het register maken en het register herstellen in Windows

  1. De Register-editor starten.

  2. Selecteer de volgende registersubsleutel:

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoDiscover

    Opmerking

    x.0 in dit registerpad komt overeen met de Outlook-versie (16.0 = Outlook 2016, 15.0 = Outlook 2013, 14.0 = Outlook 2010, 12.0 = Outlook 2007).

  3. Controleer de volgende mogelijke DWORD-waarden die zich mogelijk onder de \Autodiscover-subsleutel bevinden.

    • PreferLocalXML

    • PreferProvidedEmailInAutoDiscoverAuthPrompts

      Met deze waarde kunnen Exchange-beheerders opgeven of gebruikers tijdens scenario's van Automatisch opsporen worden geverifieerd aan de hand van het geconfigureerde e-mailadres van het account of de gebruikersnaam (UPN). Raadpleeg 5 november 2019, update voor Outlook 2016 (KB4484139) voor meer informatie.

    • ExcludeHttpRedirect

    • ExcludeHttpsAutoDiscoverDomain

    • ExcludeHttpsRootDomain

    • ExcludeScpLookup

    • ExcludeSrvRecord

    • ExcludeLastKnownGoodURL (alleen van toepassing op Outlook 2010 versie 14.0.7140.5001 en latere versies)

    • ExcludeExplicitO365Endpoint (alleen van toepassing op Outlook 2016 versie 16.0.6741.2017 en latere versies)

    Opmerking

    In sommige documentatie staat dat de ExcludeSrvLookup-waarde door Outlook wordt gebruikt in dit scenario. Helaas is deze documentatie onjuist omdat de ExcludeSrvLookup-waarde niet bestaat in Outlook-code. Alleen de ExcludeSrvRecord-registerwaarde wordt door Outlook gebruikt om het opzoeken van SRV-records voor Automatisch opsporen te controleren. Daarom kunt u de ExcludeSrvLookup-waarde onder de \Autodiscover-subsleutel probleemloos wijzigen naar 0 als u een waarde met deze naam vindt.

  4. Herhaal stap 3 door de volgende registersleutel te gebruiken:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\AutoDiscover

    Opmerking

    x.0 in dit registerpad komt overeen met de Outlook-versie (16.0 = Outlook 2016, 15.0 = Outlook 2013, 14.0 = Outlook 2010, 12.0 = Outlook 2007).

Meer informatie

U kunt de volgende stappen in Outlook gebruiken om de methode te bepalen waarmee Outlook probeert informatie over Automatisch opsporen op te halen van Exchange:

  1. Start Outlook.
  2. Druk op de CTRL-toets, klik met de rechtermuisknop op het Outlook-pictogram in het meldingsvak en klik vervolgens op Automatische e-mailconfiguratie testen.
  3. Controleer of het e-mailadres correct is ingevoerd in het vak E-mailadres.
  4. Voer uw wachtwoord in als u niet bent aangemeld bij een domein of als u een andere postbus opent dan de uwe.
  5. Klik om de selectievakjes voor Guessmart gebruiken en Veilige Guessmart-verificatie uit te schakelen.
  6. Klik op Testen.
  7. Bekijk de details op het tabblad Logboek.

De volgende afbeelding toont het tabblad Logboek wanneer de waarden ExcludeScpLookup en ExcludeHttpsAutoDiscoverDomain zijn ingesteld op 1.

De schermafbeelding toont informatie op het tabblad Logboek wanneer de waarden ExcludeScpLookup en ExcludeHttpsAutoDiscoverDomain zijn ingesteld op 1.

Vergelijk deze informatie wanneer alleen de ExcludeScpLookup-waarde is ingesteld op 1.

De schermafbeelding toont informatie op het tabblad Logboek wanneer de waarde ExcludeScpLookup is ingesteld op 1.

Opmerking

Negeer de fouten in deze afbeeldingen. Deze informatie is alleen bedoeld om u de verschillende opzoekpogingen van Outlook te tonen.

Als u inloggen in Outlook (2007 of 2010) inschakelt, kunnen de verschillende Automatisch opsporen-opzoekpogingen worden gevonden in het bestand %temp%\Olkdisc.log. Dit logboekbestand bevat ook eventuele registerinstellingen die u mogelijk hebt geconfigureerd om een van de methoden voor Automatisch opzoeken uit te sluiten. In de volgende afbeelding ziet u dat de waarden ExcludeScpLookup en ExcludeHttpsAutoDiscoverDomain allebei zijn ingesteld op 1.

De schermafbeelding toont het logboekbestand waarin ExcludeScpLookup en ExcludeHttpsAutoDiscoverDomain beide zijn ingeschakeld.

Voor meer informatie over het beheer van Automatisch opzoeken aan de clientzijde gaat u naar het volgende Knowledge Base-artikel:

2612922 Outlook AutoDiscover beheren met behulp van Groepsbeleid