Onverwachte Autodiscover-gedrag wanneer u registerinstellingen onder de sleutel \Autodiscovery

Symptomen

Wanneer Microsoft Outlook probeert op te halen van Autodiscover-informatie van een server waarop Microsoft Exchange Server wordt uitgevoerd, kunnen onverwachte resultaten optreden als u een of meer van de beschikbare registerwaarden die kunnen worden gebruikt voor het beheren van Autodiscover.

Oorzaak

Wanneer Outlook probeert contact op te nemen met de Autodiscover-service op de Exchange-server met de rol van Client Access server (CAS), kan deze verschillende methoden gebruiken om de service te bereiken, afhankelijk van de client/server-topologie. De momenteel geïmplementeerde methoden die worden gebruikt door Outlook zijn als volgt:

  • SCP opzoeken
  • HTTPS-hoofddomein query
  • HTTPS Autodiscover-domein query
  • Lokaal XML-bestand
  • HTTP-omleidingsmethode
  • SRV-recordquery
  • URL in cache in het Outlook-profiel (nieuw voor Outlook 2010 versie 14.0.7140.5001 en latere versies)
  • Directe verbinding met Office 365 (nieuw voor Outlook 2016 versie 16.0.6741.2017 en latere versies)

Outlook probeert standaard een of meer van deze methoden als deze kan niet worden bereikt Autodiscover. In een scenario met een machine die niet is gekoppeld aan een domein, probeert Outlook bijvoorbeeld verbinding te maken met de vooraf gedefinieerde Url's (bijvoorbeeld https://autodiscover.contoso.com/autodiscover/autodiscover.xml) door DNS te gebruiken. Als dat mislukt, probeert Outlook de HTTP-omleidingsmethode en, als dat niet het is, probeert Outlook de opzoek methode SRV-record te gebruiken. Als alle opzoek methoden mislukken, is Outlook niet in staat Outlook Anywhere-configuratie en URL-instellingen te verkrijgen.

Raadpleeg de Exchange Autodiscover-service White Paper die geschikt is voor uw versie van Exchange voor meer informatie over alle van de verschillende Autodiscover-verbindingsmethoden die worden gebruikt door Outlook.

In sommige scenario's u echter Autodiscover-gerelateerde register/beleid waarden gebruiken voor het beheren van de methode (s) die worden gebruikt door Outlook voor het bereiken van Autodiscover. Echter, als u de Autodiscover-register/beleid waarden onjuist configureert, u voorkomen dat Outlook Autodiscover-informatie verkrijgen.

Oplossing

U lost dit probleem, raadpleegt u de Autodiscover-gerelateerde registergegevens die u op uw Outlook-client hebt om ervoor te zorgen dat de gegevens correct is geconfigureerd. Als u niet zeker weet of de registergegevens nodig zijn, u overwegen de gegevens voor een van deze registerwaarden te wijzigen in nul (0) en vervolgens Outlook testen om te zien of er een verschil in Autodiscover optreden.

Belangrijk deze sectie, methode of taak bevat stappen die u vertellen hoe u het register moet wijzigen. Er kunnen echter ernstige problemen optreden als u het register onjuist wijzigt. Zorg er daarom voor dat u deze stappen zorgvuldig volgt. Voor extra beveiliging maakt u een back-up van het register voordat u deze wijzigt. Vervolgens u het register herstellen als er een probleem optreedt. Ga naar het volgende artikel in de Microsoft Knowledge Base voor meer informatie over het maken en terugzetten van een back-up van het register: 322756 back-up en herstel van het register in Windows

  1. Start de Register-editor.

    Druk in Windows 10 en Windows 8 op de Windows-toets + R om een dialoogvenster uitvoeren te openen. Typ regedit. exe en druk op OK.

    In Windows 7, klikt u op Start, typ regeditin het vak Zoeken in Programma's en bestanden en druk op ENTER.

  2. Zoek en selecteer de volgende registersubsleutel:

    HKEY_CURRENT_USER \Software\Microsoft\Office\x.0\Outlook\AutoDiscover

    Notitie

    x. 0 in dit registerpad komt overeen met de Outlook-versie (16,0 = Outlook 2016, 15,0 = Outlook 2013, 14,0 = Outlook 2010, 12,0 = Outlook 2007).

  3. Controleer de volgende mogelijke DWORD-waarden die zich kunnen bevinden onder de subsleutel \Autodis cover.

    • PreferLocalXML
    • ExcludeHttpRedirect
    • ExcludeHttpsAutoDiscoverDomain
    • ExcludeHttpsRootDomain
    • ExcludeScpLookup
    • Niet-uitsluitings
    • ExcludeLastKnownGoodURL (alleen van toepassing op Outlook 2010 versie 14.0.7140.5001 en latere versies)
    • ExcludeExplicitO365Endpoint (alleen van toepassing op Outlook 2016 versie 16.0.6741.2017 en latere versies)

    Notitie

    In sommige documentatie wordt bepaald dat de ExcludeSrvLookupvalue wordt gebruikt door Outlook in dit scenario. Helaas is deze documentatie onjuist omdat de ExcludeSrvLookup-waarde niet bestaat in de Outlook-code. Alleen de ExcludeSrvRecordregistry waarde wordt gebruikt door Outlook voor het beheren van de SRV-recordlookup voor Autodiscover. Als u een waarde met de naam ExcludeSrvLookup onder de subsleutel \Autodiscover vindt, u de waarde ervan dus veilig wijzigen in 0.

  4. Herhaal stap 3 met de volgende registersubsleutel:

    HKEY_CURRENT_USER \Software\Policies\Microsoft\Office\x.0\Outlook\AutoDiscover

    Notitie

    x. 0 in dit registerpad komt overeen met de Outlook-versie (16,0 = Outlook 2016, 15,0 = Outlook 2013, 14,0 = Outlook 2010, 12,0 = Outlook 2007).

Meer informatie

U de volgende stappen in Outlook gebruiken om de methode te bepalen waarmee Outlook Autodiscover-informatie probeert op te halen uit Exchange:

  1. Start Outlook.
  2. Druk op de CTRL-toets, klik met de rechtermuisknop op het Outlook-pictogram in het systeemvak en klik vervolgens op test E-mail automatische configuratie.
  3. Controleer of het e-mailadres correct is ingevoerd in het vak e-mailadres.
  4. Voer uw wachtwoord in als u niet bent ingelogd bij een domein of als u een postbus wilt openen die verschilt van uw mailbox.
  5. Schakel het selectievakje Gismart en Secure Gismart Authentication gebruiken uit.
  6. Klik op testen.
  7. Bekijk de details op het tabblad logboek.

De volgende afbeelding ziet u het tabblad logboek wanneer de waarden ExcludeScpLookup en ExcludeHttpsAutoDiscoverDomain zijn ingesteld op 1.

Tabblad logboek

Vergelijk deze informatie wanneer alleen de ExcludeScpLookup-waarde is ingesteld op 1.

tabblad Logboek 2

Opmerking Negeer de fouten in deze cijfers omdat deze informatie alleen bedoeld is om u de verschillende opzoek pogingen te laten zien die door Outlook zijn gemaakt.

Als u logboekregistratie inschakelt in Outlook (2007 of 2010), u ook de verschillende opzoek pogingen van Autodiscover vinden in het bestand%Temp%\olkdisc.log. Dit logboekbestand bevat ook alle registerinstellingen die u hebt geconfigureerd voor het uitsluiten van een van de methoden voor automatisch opsporen opzoeken. In de volgende afbeelding u duidelijk zien dat de waarden ExcludeScpLookup en ExcludeHttpsAutoDiscoverDomain beide zijn ingesteld op 1.

Logboekbestand

Ga naar het volgende Knowledge Base-artikel voor meer informatie over de client-side management en het beheer van Autodiscover:

2612922 het automatisch opsporen van Outlook beheren met behulp van Groepsbeleid