MAPI-oplossingen werken niet omdat Outlook.exe niet correct is geregistreerd onder de sleutel \App Paths in het register

Origineel KB-nummer: 2698523

Symptomen

Als u een aangepaste MAPI-oplossing gebruikt (bijvoorbeeld een Outlook-invoegtoepassing), werkt de oplossing mogelijk niet omdat Outlook.exe niet correct is geregistreerd in het Windows-register.

Opmerking

Het werkelijke probleem dat u ondervindt met de aangepaste oplossing, is afhankelijk van hoe de Outlook.exe registratiegegevens worden gebruikt.

Oorzaak

Dit probleem kan optreden als Outlook.exe niet correct is geregistreerd onder de volgende sleutels in het Windows-register:

  • 32-bits versies van Windows

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths

  • 64-bits versies van Windows

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths

Als Outlook.exe correct is geregistreerd, vindt u een \Outlook.exe subsleutel onder de bovenstaande sleutel en onder de \Outlook.exe subsleutel vindt u een tekenreekswaarde met de naam Pad waarvan de gegevens verwijzen naar het juiste pad naar Outlook.exe op uw computer. In de volgende afbeelding ziet u de juiste Outlook.exe registratie op een 32-bits versie van Windows.

Schermopname van de Outlook.exe registratie.

Opmerking

Het pad naar Outlook.exe op uw computer kan afwijken van de bovenstaande afbeelding als u Office op een niet-standaardlocatie hebt geïnstalleerd.

Oplossing

U kunt dit probleem oplossen door de installatie van Office te herstellen.