Een scherm toevoegen en tussen schermen navigerenAdd a screen and navigate between screens

Maak een app met meerdere schermen en voeg manieren toe waarop gebruikers ertussen kunnen navigeren.Create an app with multiple screens, and add ways for users to navigate between them.

VereistenPrerequisites

Een scherm toevoegen en de naam wijzigenAdd and rename a screen

  1. Op het tabblad Startpagina klikt of tikt u op Nieuw scherm.On the Home tab, click or tap New screen.

    De optie Scherm toevoegen op het tabblad Startpagina

  2. Klik of tik in het rechterdeelvenster op de naam van het scherm (boven het tabblad Eigenschappen) en typ vervolgens de nieuwe naam Bron.In the right-hand pane, click or tap the name of the screen (just above the Properties tab), and then type the new name Source.

    De naam van het standaardscherm wijzigen

  3. Voeg nog een scherm toe en noem het Target.Add another screen, and name it Target.

    Twee schermen in de navigatiebalk links

Navigatie toevoegenAdd navigation

  1. Wanneer het scherm Source is geopend, opent u het tabblad Invoegen en klikt of tikt u op Pictogrammen. Klik of tik vervolgens op de pijl Volgende.With the Source screen selected, open the Insert tab, click or tap Icons, and then click or tap Next arrow.

    De optie Vormen op het tabblad Invoegen

  2. (optioneel) Verplaats de pijl zodat deze in de rechterbenedenhoek van het scherm wordt weergegeven.(optional) Move the arrow so that it appears in the lower-right corner of the screen.

  3. Nu de pijl nog is geselecteerd, klikt of tikt u op het tabblad Actie en klikt of tikt u op Navigate.With the arrow still selected, click or tap the Action tab, and then click or tap Navigate.

    De eigenschap OnSelect van de pijl wordt automatisch ingesteld op de functie Navigate.The OnSelect property for the arrow is automatically set to a Navigate function.

    De eigenschap OnSelect ingesteld op de functie Navigate

    Wanneer een gebruiker op de pijl klikt of tikt, wordt het scherm Target geopend.When a user clicks or taps the arrow, the Target screen fades in.

  4. Op het scherm Target voegt u de pijl Vorige toe en stelt u de eigenschap OnSelect in op deze formule:On the Target screen, add a Back arrow, and set its OnSelect property to this formula:
    Navigate(Bron, Schermovergang.Fade)Navigate(Source, ScreenTransition.Fade)

  5. Open de preview-modus ( of druk op F5) en schakel tussen de schermen door op de toegevoegde pijlen te klikken of tikken.Open Preview mode ( or press F5), and then switch between the screens by clicking or tapping the arrows that you added.

  6. Druk op ESC om terug te gaan naar de standaardwerkruimte.Press Esc to return to the default workspace.