Fout AADSTS50011 met SAML-verificatie: de antwoord-URL die in de aanvraag is opgegeven, komt niet overeen

Dit artikel biedt een oplossing voor de AADSTS50011 fout die optreedt tijdens federatieve verificatie met Microsoft Entra ID.

Symptomen

U krijgt een foutbericht AADSTS50011 wanneer u zich probeert aan te melden bij een toepassing die is ingesteld voor het gebruik van Microsoft Entra ID voor identiteitsbeheer met behulp van eenmalige aanmelding op basis van SAML.

Fout AADSTS50011: de antwoord-URL komt niet overeen met de antwoord-URL's die zijn geconfigureerd voor de toepassings-GUID<>. Zorg ervoor dat de antwoord-URL die is verzonden in de aanvraag overeenkomt met de url die in de Azure Portal aan uw toepassing is toegevoegd. Ga naar https://aka.ms/urlMismatchError voor meer informatie over het oplossen van dit probleem.' wanneer u zich probeert aan te melden bij een op SAML gebaseerde app met één Sign-On (SSO) die is geïntegreerd met Microsoft Entra ID.

Oorzaak

De AssertionConsumerServiceURL waarde in de SAML-aanvraag komt niet overeen met de waarde of het patroon van de antwoord-URL dat is geconfigureerd in Microsoft Entra ID. De AssertionConsumerServiceURL waarde in de SAML-aanvraag is de URL die u in de fout ziet.

Oplossing

Volg deze stappen om het probleem op te lossen:

  1. Zorg ervoor dat de AssertionConsumerServiceURL waarde in de SAML-aanvraag overeenkomt met de waarde van de antwoord-URL die is geconfigureerd in Microsoft Entra ID.
  2. Controleer of werk de waarde in het tekstvak Antwoord-URL bij zodat deze overeenkomt met de AssertionConsumerServiceURL waarde in de SAML-aanvraag.

Raadpleeg als voorbeeld het volgende artikel voor gedetailleerde stappen over het configureren van de waarden in Microsoft Entra ID:

Opmerking

De antwoord-URL wordt ook wel omleidings-URI genoemd. Deze waarden zijn afhankelijk van de toepassing die wordt gebruikt. U moet de waarden ophalen van de leverancier van de toepassing.

Nadat u de waarde voor antwoord-URL in Microsoft Entra ID hebt bijgewerkt en deze overeenkomt met de waarde die door de toepassing in de SAML-aanvraag is verzonden, kunt u zich aanmelden bij de toepassing.

Meer informatie

Zie Microsoft Entra verificatie- en autorisatiefoutcodes voor een volledige lijst met active directory-verificatie- en autorisatiefoutcodes.

Contacteer ons voor hulp

Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Feedback-community van Azure.