Problemen met de foutcode SubscriptionRequestsThrottled oplossen (429)
In dit artikel wordt beschreven hoe u de SubscriptionRequestsThrottled
fout (status 429) kunt identificeren en oplossen die optreedt wanneer u een AKS-cluster (Microsoft Azure Kubernetes Service) probeert te maken en implementeren.
Symptomen
Wanneer u een AKS-cluster probeert te maken, ontvangt u het volgende foutbericht 'Standaard load balancer is mislukt' met de waarde 'SubCode' van SubscriptionRequestsThrottled en de waarde 'Status' van 429:
Standaard load balancer afstemmen is mislukt.
Details: opnieuw proberen van outboundReconciler is mislukt:
Categorie: ClientError;
SubCode: SubscriptionRequestsThrottled;
Afhankelijkheid: Microsoft.Network/PublicIPAddresses;
OrginalError: autorest/azure: Service heeft een fout geretourneerd. Status=429
Code="SubscriptionRequestsThrottled"
Message="Aantal aanvragen voor abonnement '<subscription-id-guid>' en bewerking 'GET/SUBSCRIPTIONS/RESOURCEGROUPS/PROVIDERS/MICROSOFT. NETWORK/PUBLICIPADDRESSES' heeft de limiet voor back-endopslag overschreden. Probeer het opnieuw na '6' seconden.";
AKSTeam: Netwerken, Ophalen: onwaar.
Aanvraagbeperking kan optreden op verschillende Azure-onderdelen, dus het foutbericht kan verschillen op basis van het type resource waarop dit probleem zich voordoet.
Oorzaak
Azure Resource Manager-aanvragen worden beperkt. Zie Beperking van Resource Manager-aanvragen voor meer informatie over de werking van Azure Resource Manager limieten en de specifieke limieten per uur.
Oplossing 1: Een ander abonnement gebruiken
Als u toegang hebt tot een ander abonnement, kunt u het cluster eenvoudig implementeren in dat abonnement.
Oplossing 2: Uw toegangspatronen wijzigen
U kunt dit probleem oplossen door uw toegangspatronen voor het vertraagde abonnement te bekijken. De volgende tabel bevat de mogelijke toegangspatronen en bijbehorende oplossingen.
Toegangspatroon | Oplossing |
---|---|
Geautomatiseerde scripts scannen het abonnement voortdurend | Voer de scripts minder vaak uit |
Veel gebruikers hebben toegang tot het abonnement | Laat elke gebruiker een eigen abonnement gebruiken |
Scripts scannen elk opslagaccount in het abonnement | Bereik van het script om alleen de resources op te vragen die het moet hebben |
Meer informatie
Contacteer ons voor hulp
Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Feedback-community van Azure.
Feedback
https://aka.ms/ContentUserFeedback.
Binnenkort beschikbaar: In de loop van 2024 zullen we GitHub-problemen geleidelijk uitfaseren als het feedbackmechanisme voor inhoud en deze vervangen door een nieuw feedbacksysteem. Zie voor meer informatie:Feedback verzenden en weergeven voor