De DPM-beveiligingsagentservice kan niet worden gestart

Dit artikel helpt u bij het oplossen van een probleem waarbij u de DPMRA-service beëindigd met servicespecifieke fout 10048 (0x2740) ontvangt wanneer u de DPM-beveiligingsagentservice (Data Protection Manager) start.

Oorspronkelijke productversie: System Center Data Protection Manager
Origineel KB-nummer: 947682

Symptomen

Nadat u de DPM-beveiligingsagent in Microsoft System Center Data Protection Manager hebt geïmplementeerd, kan de DPM-beveiligingsagentservice niet worden gestart op de beveiligde servers. (Een beveiligde server is een server die gegevensbronnen bevat die lid zijn van een beveiligingsgroep.)

Oorzaak

Dit probleem kan een van de volgende oorzaken hebben:

  • Een ander proces is het gebruik van TCP-poort 5718 en TCP-poort 5719. Deze twee poorten zijn vereist voor de DPM-beveiligingsagentservice.
  • TCP-poort 5718 en TCP-poort 5719 zijn niet geopend voor firewalltoepassingen of voor firewallapparaten op de computer.

Oplossing 1

U kunt dit probleem oplossen door het proces te zoeken dat gebruikmaakt van de vereiste TCP-poorten. Ga hiervoor als volgt te werk:

  1. Open een opdrachtpromptvenster. Voer de volgende opdrachten uit bij de opdrachtprompt:

    netstat -ano > netstat.txt
    tasklist > tasklist.txt
    tasklist /svc >svclist.txt
    

    Opmerking

    In deze stap worden de uitvoer van de netstat opdracht en de tasklist opdracht naar tekstbestanden geschreven, zodat u de uitvoer gemakkelijker kunt controleren. Voer de tasklist opdracht samen met de /svc switch uit omdat het proces dat gebruikmaakt van de vereiste poorten mogelijk als een service wordt uitgevoerd.

  2. Open de tekstbestanden die zijn gegenereerd in stap 1. Voer hiervoor de volgende opdrachten uit bij de opdrachtprompt:

    notepad netstat.txt
    notepad tasklist.txt
    notepad svclist.txt
    
  3. Zoek in het bestand Netstat.txt alle vermeldingen die overeenkomen met TCP-poort 5718 en TCP-poort 5719. Noteer de proces-id (PID) voor elke vermelding.

  4. Zoek in het bestand Tasklist.txt de PID's die u in stap 3 hebt gevonden om te bepalen welke processen gebruikmaken van de vereiste poorten. Als u de pincodes niet in het Tasklist.txt-bestand vindt, probeert u de pincodes in het Svclist.txt-bestand te vinden.

  5. Nadat u hebt ontdekt welk proces gebruikmaakt van de vereiste poorten, configureert u het bijbehorende programma om andere beschikbare poorten te gebruiken. Als u de poorten van het programma niet kunt wijzigen of als het programma dynamisch poorten gebruikt, moet u het programma stoppen.

Opmerking

Als een andere toepassing gebruikmaakt van de poort of poorten (5718 en 5719), kunnen de poorten niet worden gewijzigd. In dit geval kunt u in plaats daarvan het hulpprogramma SetAgentcfg.exe gebruiken. Dit hulpprogramma biedt de mogelijkheid om de standaardpoorten te wijzigen die door de DPM-agent worden gebruikt.

Als u de poorten wilt wijzigen die worden gebruikt door de DPM-agent, volgt u deze stappen op de beveiligde computer waarop het probleem zich voordoet. Zorg ervoor dat de poorten die u opnieuw toedeelt, niet worden gebruikt door andere toepassingen.

Opmerking

Voer de volgende opdracht uit om het DPM-installatiepad weer te geven:

Reg query "HKLM\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Setup" /v installpath

  1. Zoek het SetAgentcfg.exe-bestand vanaf de DPM-server. Het bestand bevindt zich standaard op %PROGRAMFILES%\Microsoft DPM\DPM\Setup\SetAgentCfg.exe.

  2. Kopieer het bestand naar de beveiligde computer waarop het probleem zich voordoet. Kopieer het bestand naar de map DPM\Bin van de agent. Het bestand bevindt zich standaard op %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin.

  3. Open op de beveiligde computer waarop het probleem zich voordoet een opdrachtpromptvenster met beheerdersrechten.

  4. Ga in het opdrachtpromptvenster naar de map waarnaar het SetAgentCfg.exe-bestand is gekopieerd. Ga bijvoorbeeld naar de map %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin.

  5. Voer de volgende opdracht uit om de poorten te wijzigen die worden gebruikt door de DPM-agent:

    SetAgentCfg e dpmra <port number> <alternate port number>
    
  6. Start de DPMRA-service opnieuw.

Als deze stappen dit probleem niet oplossen, bepaalt u of de firewalltoepassingen vereisen dat u deze poorten verifieert. Open vervolgens handmatig de poorten.

Oplossing 2

Als u TCP-poorten 5718 en 5719 wilt reserveren, volgt u de stappen die worden beschreven in Een reeks tijdelijke poorten reserveren op een computer waarop Windows Server 2003 of Windows 2000 Server wordt uitgevoerd.

Meer informatie

Data Protection Manager en beveiligde servers openen verbindingen via TCP-poort 5718 en via TCP-poort 5719 om Data Protection Manager-bewerkingen in te schakelen, zoals synchronisatie en herstel. Het huidige probleem kan optreden op beveiligde servers waarop de Microsoft Exchange System Attendant-service wordt uitgevoerd. Deze service maakt dynamisch gebruik van TCP-poorten. Deze service kan een of beide van de vereiste poorten gebruiken.

Data Protection Manager gebruikt ook de volgende poorten:

  • TCP 135 dynamisch
  • User Datagram Protocol (UDP) 53
  • UDP 88
  • TCP 88
  • UDP 137
  • UDP 138
  • TCP 139
  • TCP 389
  • UDP 389