Zarządzanie Azure Machine Learning zasobami za pomocą rozszerzenia VS Code (wersja zapoznawcza)Manage Azure Machine Learning resources with the VS Code Extension (preview)

Dowiedz się, jak zarządzać zasobami Azure Machine Learning za pomocą VS Code rozszerzenia.Learn how to manage Azure Machine Learning resources with the VS Code extension.

Azure Machine Learning VS Code rozszerzenia

Wymagania wstępnePrerequisites

We wszystkich poniższych procesach założono, że jesteś w widoku Azure Machine Learning w Visual Studio Code.All of the processes below assume that you are in the Azure Machine Learning view in Visual Studio Code. Aby uruchomić rozszerzenie, wybierz ikonę platformy Azure na pasku VS Code aktywności.To launch the extension, select the Azure icon in the VS Code activity bar.

Obszary roboczeWorkspaces

Aby uzyskać więcej informacji, zobacz obszary robocze.For more information, see workspaces.

Tworzenie obszaru roboczegoCreate a workspace

  1. W widoku Azure Machine Learning kliknij prawym przyciskiem myszy węzeł subskrypcji i wybierz pozycję Utwórz obszar roboczy.In the Azure Machine Learning view, right-click your subscription node and select Create workspace.
  2. W wierszu polecenia:In the prompt:
    1. Podaj nazwę obszaru roboczegoProvide a name for your workspace
    2. Wybieranie subskrypcji platformy AzureChoose your Azure subscription
    3. Wybierz lub utwórz nową grupę zasobów, aby aprowizować obszar roboczy w programieChoose or create a new resource group to provision the workspace in
    4. Wybierz lokalizację, w której chcesz aprowizować obszar roboczy.Select the location where to provision the workspace.

Alternatywne metody tworzenia obszaru roboczego obejmują:Alternative methods to create a workspace include:

  • Otwórz paletę poleceń View (Widok) > Command Palette (Paleta poleceń) i wprowadź tekst w wierszu polecenia Azure ML: Create Workspace (Azure ML: Tworzenie obszaru roboczego).Open the command palette View > Command Palette and enter into the text prompt Azure ML: Create Workspace.
  • Kliknij + ikonę w górnej części Azure Machine Learning widoku.Click the + icon at the top of the Azure Machine Learning view.
  • Utwórz nowy obszar roboczy po wyświetleniu monitu o wybranie obszaru roboczego podczas aprowizowania innych zasobów.Create a new workspace when prompted to select a workspace during the provisioning of other resources.

Usuwanie obszaru roboczegoRemove a workspace

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Kliknij prawym przyciskiem myszy obszar roboczy, który chcesz usunąć.Right-click the workspace you want to remove.
  3. Wybierz, czy chcesz usunąć:Select whether you want to remove:
    • Tylko obszar roboczy: ta opcja usuwa tylko zasób platformy Azure obszaru roboczego.Only the workspace: This option deletes only the workspace Azure resource. Grupa zasobów, konta magazynu i inne zasoby, do których dołączono obszar roboczy, nadal znajdują się na platformie Azure.The resource group, storage accounts, and any other resources the workspace was attached to are still in Azure.
    • Ze skojarzonymi zasobami: ta opcja usuwa obszar roboczy i wszystkie skojarzone z nim zasoby.With associated resources: This option deletes the workspace and all resources associated with it.

Magazyny danychDatastores

Rozszerzenie VS Code obecnie obsługuje magazyny danych następujących typów:The VS Code extension currently supports datastores of the following types:

  • Udział plików platformy AzureAzure File Share
  • Azure Blob StorageAzure Blob Storage

Podczas tworzenia obszaru roboczego dla każdego z tych typów jest tworzony magazyn danych.When you create a workspace, a datastore is created for each of these types.

Aby uzyskać więcej informacji, zobacz magazyny danych.For more information, see datastores.

Tworzenie magazynu danychCreate a datastore

  1. Rozwiń węzeł subskrypcji, który zawiera obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego, w którym chcesz utworzyć magazyn danych.Expand the workspace node you want to create the datastore under.
  3. Kliknij prawym przyciskiem myszy węzeł Magazyny danych i wybierz polecenie Zarejestruj magazyn danych.Right-click the Datastores node and select Register datastore.
  4. W wierszu polecenia:In the prompt:
    1. Podaj nazwę magazynu danych.Provide a name for your datastore.
    2. Wybierz typ magazynu danych.Choose the datastore type.
    3. Wybierz zasób magazynu.Select your storage resource. Możesz wybrać zasób magazynu skojarzony z obszarem roboczym lub wybrać dowolny prawidłowy zasób magazynu w subskrypcjach platformy Azure.You can either choose a storage resource that's associated with your workspace or select from any valid storage resource in your Azure subscriptions.
    4. Wybierz kontener, w którym dane są w wcześniej wybranym zasobie magazynu.Choose the container where your data is inside the previously selected storage resource.
  5. Plik konfiguracji zostanie wyświetlony w VS Code.A configuration file appears in VS Code. Jeśli plik konfiguracji jest zadowalany, wybierz pozycję Zapisz i kontynuuj lub otwórz paletę poleceń programu VS Code (View > Command Palette) i wpisz Ciąg Azure ML: Zapisz i kontynuuj. If you're satisfied with your configuration file, select Save and continue or open the VS Code command palette (View > Command Palette) and type Azure ML: Save and Continue.

Zarządzanie magazynem danychManage a datastore

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego.Expand your workspace node.
  3. Rozwiń węzeł Magazyny danych w obszarze roboczym.Expand the Datastores node inside your workspace.
  4. Wybierz magazyn danych, który chcesz:Select the datastore you want to:
    • Ustaw jako domyślny.Set as default. Za każdym razem, gdy uruchamiasz eksperymenty, jest to magazyn danych, który będzie używany.Whenever you run experiments, this is the datastore that will be used.
    • Sprawdź ustawienia tylko do odczytu.Inspect read-only settings.
    • Modify.Modify. Zmień typ uwierzytelniania i poświadczenia.Change the authentication type and credentials. Obsługiwane typy uwierzytelniania obejmują klucz konta i token SAS.Supported authentication types include account key and SAS token.

Zestawy danychDatasets

Rozszerzenie obsługuje obecnie następujące typy zestawów danych:The extension currently supports the following dataset types:

  • Tabelaryka: umożliwia zmaterializować dane w ramce danych (Pandas lub PySpark).Tabular: Allows you to materialize data into a DataFrame (Pandas or PySpark).
  • Plik: plik lub kolekcja plików.File: A file or collection of files. Umożliwia pobieranie i montowania plików w obliczeniach.Allows you to download or mount files to your compute.

Aby uzyskać więcej informacji, zobacz zestawy danychFor more information, see datasets

Utworzenie zestawu danychCreate dataset

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego, w którym chcesz utworzyć magazyn danych.Expand the workspace node you want to create the datastore under.
  3. Kliknij prawym przyciskiem myszy węzeł Zestawy danych i wybierz polecenie Utwórz zestaw danych.Right-click the Datasets node and select Create dataset.
  4. W wierszu polecenia:In the prompt:
    1. Wybieranie typu zestawu danychChoose the dataset type
    2. Określanie, czy dane znajdują się na komputerze, czy w InternecieDefine whether the data is located on your PC or on the web
    3. Podaj lokalizację danych.Provide the location of your data. Może to być pojedynczy plik lub katalog zawierający pliki danych.This can either be a single file or a directory containing your data files.
    4. Wybierz magazyn danych, do którego chcesz przekazać dane.Choose the datastore you want to upload your data to.
    5. Podaj prefiks, który ułatwia identyfikację zestawu danych w sklepie danych.Provide a prefix that helps identify your dataset in the datastore.

Zestawy danych wersjiVersion datasets

Podczas tworzenia modeli uczenia maszynowego w przypadku zmiany danych możesz chcieć wersji zestawu danych.When building machine learning models, as data changes, you may want to version your dataset. Aby to zrobić w rozszerzeniu VS Code:To do so in the VS Code extension:

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego.Expand your workspace node.
  3. Rozwiń węzeł Zestawy danych.Expand the Datasets node.
  4. Kliknij prawym przyciskiem myszy zestaw danych, którego wersję chcesz zmienić, a następnie wybierz pozycję Utwórz nową wersję.Right-click the dataset you want to version and select Create New Version.
  5. W wierszu polecenia:In the prompt:
    1. Wybierz typ zestawu danychSelect the dataset type
    2. Określ, czy dane znajdują się na komputerze, czy w Internecie.Define whether the data is located on your PC or on the web.
    3. Podaj lokalizację danych.Provide the location of your data. Może to być pojedynczy plik lub katalog zawierający pliki danych.This can either be a single file or a directory containing your data files.
    4. Wybierz magazyn danych, do którego chcesz przekazać dane.Choose the datastore you want to upload your data to.
    5. Podaj prefiks, który ułatwia identyfikację zestawu danych w sklepie danych.Provide a prefix that helps identify your dataset in the datastore.

Wyświetlanie właściwości zestawu danychView dataset properties

Ta opcja umożliwia wyświetlanie metadanych skojarzonych z określonym zestawem danych.This option allows you to see metadata associated with a specific dataset. Aby to zrobić w VS Code rozszerzenia:To do so in the VS Code extension:

  1. Rozwiń węzeł obszaru roboczego.Expand your workspace node.
  2. Rozwiń węzeł Zestawy danych.Expand the Datasets node.
  3. Kliknij prawym przyciskiem myszy zestaw danych, który chcesz sprawdzić, a następnie wybierz polecenie Wyświetl właściwości zestawu danych.Right-click the dataset you want to inspect and select View Dataset Properties. Spowoduje to wyświetlenie pliku konfiguracji z właściwościami najnowszej wersji zestawu danych.This will display a configuration file with the properties of the latest dataset version.

Uwaga

Jeśli masz wiele wersji zestawu danych, możesz wyświetlić tylko właściwości zestawu danych określonej wersji, rozwijając węzeł zestawu danych i wykonując te same kroki opisane w tej sekcji dotyczące wersji, która Cię interesuje.If you have multiple version of your dataset, you can choose to only view the dataset properties of a specific version by expanding the dataset node and performing the same steps described in this section on the version of interest.

Wyrejestrowywuj zestawy danychUnregister datasets

Aby usunąć zestaw danych i całą jego wersję, wyrejestruj go.To remove a dataset and all version of it, unregister it. Aby to zrobić w VS Code rozszerzenia:To do so in the VS Code extension:

  1. Rozwiń węzeł obszaru roboczego.Expand your workspace node.
  2. Rozwiń węzeł Zestawy danych.Expand the Datasets node.
  3. Kliknij prawym przyciskiem myszy zestaw danych, który chcesz wyrejestrować, a następnie wybierz polecenie Wyrejestruj zestaw danych.Right-click the dataset you want to unregister and select Unregister dataset.

ŚrodowiskaEnvironments

Aby uzyskać więcej informacji, zobacz środowiska.For more information, see environments.

Tworzenie środowiskaCreate environment

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego, w którym chcesz utworzyć magazyn danych.Expand the workspace node you want to create the datastore under.
  3. Kliknij prawym przyciskiem myszy węzeł Środowiska i wybierz polecenie Utwórz środowisko.Right-click the Environments node and select Create Environment.
  4. W wierszu polecenia:In the prompt:
    1. Podaj nazwę środowiskaProvide a name for your environment
    2. Zdefiniuj konfigurację środowiska:Define your environment configuration:
      • Środowiska z curated: wstępnie skonfigurowane środowiska w Azure Machine Learning.Curated environments: Preconfigured environments in Azure Machine Learning. Środowisko można dodatkowo dostosować, modyfikując dependencies właściwość w pliku JSON.You can further customize the environment by modifying the dependencies property in the JSON file. Dowiedz się więcej o środowiskach wyedytowanych.Learn more about curated environments.
      • Plik zależności Conda: w środowiskach Anaconda można określić plik zawierający definicję środowiska.Conda dependencies file: For Anaconda environments, the file containing your environment definition can be provided.
      • Plik wymagań pip: w przypadku środowisk pip można określić plik zawierający definicję środowiska.Pip requirements file: For pip environments, the file containing your environment definition can be provided.
      • Istniejące środowisko Conda: ta opcja wyszukuje środowiska conda na komputerze lokalnym i próbuje utworzyć środowisko z wybranego środowiska.Existing Conda environment: This option looks for the conda environments in your local PC and tries to build an environment from the selected environment.
      • Niestandardowy: zdefiniuj własne kanały i zależnościCustom: Define your own channels and dependencies
    3. Plik konfiguracji zostanie otwarty w edytorze.A configuration file opens in the editor. Jeśli konfiguracja jest zadowalała, wybierz pozycję Zapisz i kontynuuj lub otwórz paletę poleceń usługi VS Code (View > Command Palette) i wpisz Ciąg Azure ML: Zapisz i kontynuuj. If you're satisfied with your configuration, select Save and continue or open the VS Code command palette (View > Command Palette) and type Azure ML: Save and Continue.

Wyświetlanie konfiguracji środowiskaView environment configurations

Aby wyświetlić zależności i konfiguracje dla określonego środowiska w rozszerzeniu:To view the dependencies and configurations for a specific environment in the extension:

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego.Expand your workspace node.
  3. Rozwiń węzeł Środowiska.Expand the Environments node.
  4. Kliknij prawym przyciskiem myszy środowisko, które chcesz wyświetlić, a następnie wybierz pozycję Wyświetl środowisko.Right-click the environment you want to view and select View Environment.

Edytowanie konfiguracji środowiskaEdit environment configurations

Aby edytować zależności i konfiguracje dla określonego środowiska w rozszerzeniu:To edit the dependencies and configurations for a specific environment in the extension:

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Środowiska w obszarze roboczym.Expand the Environments node inside your workspace.
  3. Kliknij prawym przyciskiem myszy środowisko, które chcesz wyświetlić, a następnie wybierz polecenie Edytuj środowisko.Right-click the environment you want to view and select Edit Environment.
  4. Po wpisania modyfikacji, jeśli konfiguracja jest zadowalała, wybierz pozycję Zapisz i kontynuuj lub otwórz paletę poleceń programu VS Code (View > Command Palette) (Wyświetl paletę poleceń usługi >) i wpisz Ciąg Azure ML: Save and Continue(Zapisz i kontynuuj). After making the modifications, if you're satisfied with your configuration, select Save and continue or open the VS Code command palette (View > Command Palette) and type Azure ML: Save and Continue.

EksperymentyExperiments

Aby uzyskać więcej informacji, zobacz experiments (Eksperymenty).For more information, see experiments.

Tworzenie eksperymentuCreate experiment

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego.Expand your workspace node.
  3. Kliknij prawym przyciskiem myszy węzeł Experiments (Eksperymenty) w obszarze roboczym i wybierz pozycję Create experiment (Utwórz eksperyment). Right-click the Experiments node in your workspace and select Create experiment.
  4. W wierszu polecenia podaj nazwę eksperymentu.In the prompt, provide a name for your experiment.

Uruchamianie eksperymentuRun experiment

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Experiments (Eksperymenty) w obszarze roboczym.Expand the Experiments node inside your workspace.
  3. Kliknij prawym przyciskiem myszy eksperyment, który chcesz uruchomić.Right-click the experiment you want to run.
  4. Wybierz ikonę Uruchom eksperyment na pasku działań.Select the Run Experiment icon in the activity bar.
  5. Wybierz, czy chcesz uruchomić eksperyment lokalnie, czy zdalnie.Select whether you want to run your experiment locally or remotely. Zobacz przewodnik debugowania, aby uzyskać więcej informacji na temat lokalnego uruchamiania i debugowania eksperymentów.See the debugging guide for more information on running and debugging experiments locally.
  6. Wybierz subskrypcję.Choose your subscription.
  7. Wybierz usługę Azure Obszar roboczy usługi ML, w ramach których ma być uruchamiany eksperyment.Choose the Azure ML Workspace to run the experiment under.
  8. Wybierz eksperyment.Choose your experiment.
  9. Wybierz lub utwórz obliczenia, na których ma być uruchamiany eksperyment.Choose or create a compute to run the experiment on.
  10. Wybierz lub utwórz konfigurację uruchamiania dla eksperymentu.Choose or create a run configuration for your experiment.

Alternatywnie możesz wybrać przycisk Uruchom eksperyment w górnej części rozszerzenia i skonfigurować przebieg eksperymentu w wierszu polecenia.Alternatively, you can select the Run Experiment button at the top of the extension and configure your experiment run in the prompt.

Wyświetlanie eksperymentuView experiment

Aby wyświetlić eksperyment w programie Azure Machine Learning Studio:To view your experiment in Azure Machine Learning Studio:

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Experiments (Eksperymenty) w obszarze roboczym.Expand the Experiments node inside your workspace.
  3. Kliknij prawym przyciskiem myszy eksperyment, który chcesz wyświetlić, a następnie wybierz pozycję Wyświetl eksperyment.Right-click the experiment you want to view and select View Experiment.
  4. Zostanie wyświetlony monit z prośbą o otwarcie adresu URL eksperymentu w Azure Machine Learning studio.A prompt appears asking you to open the experiment URL in Azure Machine Learning studio. Wybierz pozycję Otwórz.Select Open.

Śledzenie postępu uruchamianiaTrack run progress

Podczas uruchamiania eksperymentu możesz zobaczyć jego postęp.As you're running your experiment, you may want to see its progress. Aby śledzić postęp uruchomienia w Azure Machine Learning studio z rozszerzenia:To track the progress of a run in Azure Machine Learning studio from the extension:

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Experiments (Eksperymenty) w obszarze roboczym.Expand the Experiments node inside your workspace.
  3. Rozwiń węzeł eksperymentu, dla którego chcesz śledzić postęp.Expand the experiment node you want to track progress for.
  4. Kliknij prawym przyciskiem myszy przebieg i wybierz polecenie Wyświetl przebieg w Azure Portal.Right-click the run and select View Run in Azure portal.
  5. Zostanie wyświetlony monit z prośbą o otwarcie adresu URL uruchomienia w Azure Machine Learning studio.A prompt appears asking you to open the run URL in Azure Machine Learning studio. Wybierz pozycję Otwórz.Select Open.

Pobieranie dzienników uruchamiania & danych wyjściowychDownload run logs & outputs

Po zakończeniu uruchomienia możesz pobrać dzienniki i zasoby, takie jak model wygenerowany w ramach uruchomienia eksperymentu.Once a run is complete, you may want to download the logs and assets such as the model generated as part of an experiment run.

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Experiments (Eksperymenty) w obszarze roboczym.Expand the Experiments node inside your workspace.
  3. Rozwiń węzeł eksperymentu, dla którego chcesz śledzić postęp.Expand the experiment node you want to track progress for.
  4. Kliknij prawym przyciskiem myszy przebieg:Right-click the run:
    • Aby pobrać dane wyjściowe, wybierz pozycję Pobierz dane wyjściowe.To download the outputs, select Download outputs.
    • Aby pobrać dzienniki, wybierz pozycję Pobierz dzienniki.To download the logs, select Download logs.

Wyświetlanie metadanych uruchamianiaView run metadata

W rozszerzeniu można sprawdzić metadane, takie jak konfiguracja uruchamiania używana do uruchomienia, a także szczegóły uruchomienia.In the extension, you can inspect metadata such as the run configuration used for the run as well as run details.

Wystąpienia obliczenioweCompute instances

Aby uzyskać więcej informacji, zobacz Compute instances (Wystąpienia obliczeniowe).For more information, see compute instances.

Tworzenie wystąpienia obliczeniowegoCreate compute instance

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego, w którym chcesz utworzyć wystąpienie obliczeniowe.Expand the workspace node you want to create the compute instance under.
  3. Kliknij prawym przyciskiem myszy węzeł Wystąpienia obliczeniowe i wybierz polecenie Utwórz wystąpienie obliczeniowe.Right-click the Compute instances node and select Create compute instance.
  4. W wierszu polecenia:In the prompt:
    1. Podaj nazwę wystąpienia obliczeniowego.Provide a name for your compute instance.
    2. Wybierz rozmiar maszyny wirtualnej z listy.Select a VM size from the list.
    3. Wybierz, czy chcesz włączyć dostęp SSH.Choose whether you want to enable SSH access.
      1. Jeśli włączysz dostęp SSH, musisz również podać publiczny klucz SSH lub plik zawierający klucz.If you enable SSH access, you'll have to also provide the public SSH key or the file containing the key. Aby uzyskać więcej informacji, zobacz przewodnik dotyczący tworzenia i używania kluczy SSH na platformie Azure.For more information, see the guide on creating and using SSH keys on Azure.

Zatrzymywanie lub ponowne uruchamianie wystąpienia obliczeniowegoStop or restart compute instance

  1. Rozwiń węzeł subskrypcji, który zawiera obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Wystąpienie obliczeniowe w obszarze roboczym.Expand the Compute instance node inside your workspace.
  3. Kliknij prawym przyciskiem myszy wystąpienie obliczeniowe, które chcesz zatrzymać lub ponownie uruchomić, a następnie wybierz odpowiednio pozycję Zatrzymaj wystąpienie obliczeniowe lub Uruchom ponownie wystąpienie obliczeniowe.Right-click the compute instance you want to stop or restart and select Stop Compute instance or Restart compute instance respectively.

Wyświetlanie konfiguracji wystąpienia obliczeniowegoView compute instance configuration

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Wystąpienie obliczeniowe w obszarze roboczym.Expand the Compute instance node inside your workspace.
  3. Kliknij prawym przyciskiem myszy wystąpienie obliczeniowe, które chcesz sprawdzić, a następnie wybierz pozycję Wyświetl właściwości wystąpienia obliczeniowego.Right-click the compute instance you want to inspect and select View Compute instance Properties.

Usuwanie wystąpienia obliczeniowegoDelete compute instance

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Wystąpienie obliczeniowe w obszarze roboczym.Expand the Compute instance node inside your workspace.
  3. Kliknij prawym przyciskiem myszy wystąpienie obliczeniowe, które chcesz usunąć, a następnie wybierz polecenie Usuń wystąpienie obliczeniowe.Right-click the compute instance you want to delete and select Delete compute instance.

Klastry obliczenioweCompute clusters

Rozszerzenie obsługuje następujące typy obliczeniowe:The extension supports the following compute types:

  • Azure Machine Learning obliczeniowyAzure Machine Learning compute cluster
  • Azure Kubernetes ServiceAzure Kubernetes Service

Aby uzyskać więcej informacji, zobacz docelowe obiekty obliczeniowe.For more information, see compute targets.

Tworzenie zasobów obliczeniowychCreate compute

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego, w którym chcesz utworzyć klaster obliczeniowy.Expand the workspace node you want to create the compute cluster under.
  3. Kliknij prawym przyciskiem myszy węzeł Klastry obliczeniowe i wybierz polecenie Utwórz klaster obliczeniowy.Right-click the Compute clusters node and select Create Compute.
  4. W wierszu polecenia:In the prompt:
    1. Wybieranie typu obliczeniowegoChoose a compute type
    2. Wybierz rozmiar maszyny wirtualnej.Choose a VM size. Dowiedz się więcej o rozmiarach maszyn wirtualnych.Learn more about VM sizes.
    3. Podaj nazwę dla obliczeń.Provide a name for your compute.

Wyświetlanie konfiguracji obliczeńView compute configuration

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Klastry obliczeniowe w obszarze roboczym.Expand the Compute clusters node inside your workspace.
  3. Kliknij prawym przyciskiem myszy obliczenia, które chcesz wyświetlić, a następnie wybierz pozycję Wyświetl właściwości obliczeniowe.Right-click the compute you want to view and select View Compute Properties.

Edytowanie ustawień skalowania obliczeńEdit compute scale settings

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Klastry obliczeniowe w obszarze roboczym.Expand the Compute clusters node inside your workspace.
  3. Kliknij prawym przyciskiem myszy obliczenia, które chcesz edytować, a następnie wybierz polecenie Edytuj obliczenia.Right-click the compute you want to edit and select Edit Compute.
  4. W edytorze zostanie otwarty plik konfiguracji dla zasobów obliczeniowych.A configuration file for your compute opens in the editor. Jeśli konfiguracja jest zadowalała, wybierz pozycję Zapisz i kontynuuj lub otwórz paletę poleceń usługi VS Code (View > Command Palette) i wpisz Ciąg Azure ML: Zapisz i kontynuuj. If you're satisfied with your configuration, select Save and continue or open the VS Code command palette (View > Command Palette) and type Azure ML: Save and Continue.

Usuwanie zasobów obliczeniowychDelete compute

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Klastry obliczeniowe w obszarze roboczym.Expand the Compute clusters node inside your workspace.
  3. Kliknij prawym przyciskiem myszy zasoby obliczeniowe, które chcesz usunąć, a następnie wybierz polecenie Usuń obliczenia.Right-click the compute you want to delete and select Delete Compute.

Tworzenie konfiguracji uruchamianiaCreate run configuration

Aby utworzyć konfigurację uruchamiania w rozszerzeniu:To create a run configuration in the extension:

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Klastry obliczeniowe w obszarze roboczym.Expand the Compute clusters node inside your workspace.
  3. Kliknij prawym przyciskiem myszy docelowy obiekt obliczeniowy, w ramach którego chcesz utworzyć konfigurację uruchamiania, a następnie wybierz pozycję Utwórz konfigurację uruchamiania.Right-click the compute target you want to create the run configuration under and select Create Run Configuration.
  4. W wierszu polecenia:In the prompt:
    1. Podaj nazwę docelowego obiektu obliczeniowegoProvide a name for your compute target
    2. Wybierz lub utwórz nowe środowisko.Choose or create a new environment.
    3. Wpisz nazwę skryptu, który chcesz uruchomić, lub naciśnij klawisz Enter w przeglądarce, aby uzyskać skrypt na komputerze lokalnym.Type the name of the script you want to run or press Enter to browser for the script on your local computer.
    4. (Opcjonalnie) Wybierz, czy chcesz utworzyć odwołanie do danych dla swojego uruchomienia trenowania.(Optional) Chose whether you want to create a data reference for your training run. Spowoduje to monit o zdefiniowanie zestawu danych w konfiguracji uruchamiania.Doing so will prompt you to define a dataset in your run configuration.
      1. Wybierz jeden z zarejestrowanych zestawów danych, aby połączyć go z konfiguracją uruchamiania Plik konfiguracji zestawu danych zostanie otwarty w edytorze.Select from one of your registered datasets to link to the run configuration A configuration file for your dataset opens in the editor. Jeśli konfiguracja jest zadowalała, wybierz pozycję Zapisz i kontynuuj lub otwórz paletę poleceń usługi VS Code (View > Command Palette) i wpisz Ciąg Azure ML: Zapisz i kontynuuj. If you're satisfied with your configuration, select Save and continue or open the VS Code command palette (View > Command Palette) and type Azure ML: Save and Continue.
    5. Jeśli konfiguracja jest zadowalała, wybierz pozycję Zapisz i kontynuuj lub otwórz paletę poleceń usługi VS Code (View > Command Palette) i wpisz Ciąg Azure ML: Zapisz i kontynuuj. If you're satisfied with your configuration, select Save and continue or open the VS Code command palette (View > Command Palette) and type Azure ML: Save and Continue.

Edytowanie konfiguracji uruchamianiaEdit run configuration

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł klastra obliczeniowego w węźle Klastry obliczeniowe w obszarze roboczym.Expand your compute cluster node in the Compute clusters node of your workspace.
  3. Kliknij prawym przyciskiem myszy konfigurację uruchamiania, którą chcesz edytować, a następnie wybierz polecenie Edytuj konfigurację uruchamiania.Right-click the run configuration you want to edit and select Edit Run Configuration.
  4. Plik konfiguracji konfiguracji uruchamiania zostanie otwarty w edytorze.A configuration file for your run configuration opens in the editor. Jeśli konfiguracja jest zadowalała, wybierz pozycję Zapisz i kontynuuj lub otwórz paletę poleceń usługi VS Code (View > Command Palette) i wpisz Ciąg Azure ML: Zapisz i kontynuuj. If you're satisfied with your configuration, select Save and continue or open the VS Code command palette (View > Command Palette) and type Azure ML: Save and Continue.

Usuwanie konfiguracji uruchamianiaDelete run configuration

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego.Expand your workspace node.
  3. Rozwiń węzeł klastra obliczeniowego, który cię interesuje, w węźle Klastry obliczeniowe.Expand the compute cluster node of interest inside the Compute clusters node.
  4. Kliknij prawym przyciskiem myszy konfigurację uruchamiania, którą chcesz edytować, a następnie wybierz polecenie Usuń konfigurację uruchamiania.Right-click the run configuration you want to edit and select Delete Run Configuration.

ModeleModels

Aby uzyskać więcej informacji, zobacz modeleFor more information, see models

Rejestrowanie modeluRegister model

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego.Expand your workspace node.
  3. Kliknij prawym przyciskiem myszy węzeł Modele i wybierz polecenie Zarejestruj model.Right-click the Models node and select Register Model.
  4. W wierszu polecenia:In the prompt:
    1. Podaj nazwę modeluProvide a name for your model
    2. Wybierz, czy model jest plikiem, czy folderem.Choose whether your model is a file or folder.
    3. Znajdź model na komputerze lokalnym.Find the model in your local PC.
    4. Plik konfiguracji modelu w edytorze.A configuration file for your model in the editor. Jeśli konfiguracja jest zadowalała, wybierz pozycję Zapisz i kontynuuj lub otwórz paletę poleceń usługi VS Code (View > Command Palette) i wpisz Ciąg Azure ML: Zapisz i kontynuuj. If you're satisfied with your configuration, select Save and continue or open the VS Code command palette (View > Command Palette) and type Azure ML: Save and Continue.

Wyświetlanie właściwości modeluView model properties

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Modele w obszarze roboczym.Expand the Models node inside your workspace.
  3. Kliknij prawym przyciskiem myszy model, którego właściwości chcesz wyświetlić, a następnie wybierz pozycję Wyświetl właściwości modelu.Right-click the model whose properties you want to see and select View Model Properties. W edytorze zostanie otwarty plik zawierający właściwości modelu.A file opens in the editor containing your model properties.

Pobieranie modeluDownload model

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Modele w obszarze roboczym.Expand the Models node inside your workspace.
  3. Kliknij prawym przyciskiem myszy model, który chcesz pobrać, a następnie wybierz polecenie Pobierz plik modelu.Right-click the model you want to download and select Download Model File.

Usuwanie modeluDelete a model

  1. Rozwiń węzeł subskrypcji, który zawiera obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Modele w obszarze roboczym.Expand the Models node inside your workspace.
  3. Kliknij prawym przyciskiem myszy model, który chcesz usunąć, a następnie wybierz polecenie Usuń model.Right-click the model you want to delete and select Remove Model.

Punkty końcoweEndpoints

Rozszerzenie VS Code obsługuje następujące cele wdrożenia:The VS Code extension supports the following deployment targets:

  • Azure Container InstancesAzure Container Instances
  • Azure Kubernetes ServiceAzure Kubernetes Service

Aby uzyskać więcej informacji, zobacz Punkty końcowe usługi internetowej.For more information, see web service endpoints.

Tworzenie wdrożeńCreate deployments

Uwaga

Tworzenie wdrożenia obecnie działa tylko ze środowiskami Conda.Deployment creation currently only works with Conda environments.

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł obszaru roboczego.Expand your workspace node.
  3. Kliknij prawym przyciskiem myszy węzeł Punkty końcowe, a następnie wybierz polecenie Wd wdrażaj usługę.Right-click the Endpoints node and select Deploy Service.
  4. W wierszu polecenia:In the prompt:
    1. Wybierz, czy chcesz użyć już zarejestrowanego modelu, czy lokalnego pliku modelu.Choose whether you want to use an already registered model or a local model file.
    2. Wybierz modelSelect your model
    3. Wybierz cel wdrożenia, w którym chcesz wdrożyć model.Choose the deployment target you want to deploy your model to.
    4. Podaj nazwę modelu.Provide a name for your model.
    5. Podaj skrypt do uruchomienia podczas oceniania modelu.Provide the script to run when scoring the model.
    6. Podaj plik zależności Conda.Provide a Conda dependencies file.
    7. W edytorze zostanie wyświetlony plik konfiguracji wdrożenia.A configuration file for your deployment appears in the editor. Jeśli konfiguracja jest zadowalała, wybierz pozycję Zapisz i kontynuuj lub otwórz paletę poleceń usługi VS Code (View > Command Palette) i wpisz Ciąg Azure ML: Zapisz i kontynuuj. If you're satisfied with your configuration, select Save and continue or open the VS Code command palette (View > Command Palette) and type Azure ML: Save and Continue.

Uwaga

Alternatywnie możesz kliknąć prawym przyciskiem myszy zarejestrowany model w węźle Modele i wybrać polecenie Deploy Service From Registered Model (Wd wdrażaj usługę z zarejestrowanego modelu).Alternatively, you can right-click a registered model in the Models node and select Deploy Service From Registered Model.

Usuwanie wdrożeńDelete deployments

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Punkty końcowe w obszarze roboczym.Expand the Endpoints node inside your workspace.
  3. Kliknij prawym przyciskiem myszy wdrożenie, które chcesz usunąć, a następnie wybierz polecenie Usuń usługę.Right-click the deployment you want to remove and select Remove service.
  4. Zostanie wyświetlony monit z potwierdzeniem, że chcesz usunąć usługę.A prompt appears confirming you want to remove the service. Wybierz przycisk OK.Select Ok.

Zarządzanie wdrożeniamiManage deployments

Oprócz tworzenia i usuwania wdrożeń można wyświetlać i edytować ustawienia skojarzone z wdrożeniem.In addition to creating and deleting deployments, you can view and edit settings associated with the deployment.

  1. Rozwiń węzeł subskrypcji zawierający obszar roboczy.Expand the subscription node that contains your workspace.
  2. Rozwiń węzeł Punkty końcowe w obszarze roboczym.Expand the Endpoints node inside your workspace.
  3. Kliknij prawym przyciskiem myszy wdrożenie, którym chcesz zarządzać:Right-click the deployment you want to manage:
    • Aby edytować ustawienia, wybierz pozycję Edytuj usługę.To edit settings, select Edit service.
      • W edytorze zostanie wyświetlony plik konfiguracji wdrożenia.A configuration file for your deployment appears in the editor. Jeśli konfiguracja jest zadowalała, wybierz pozycję Zapisz i kontynuuj lub otwórz paletę poleceń usługi VS Code (View > Command Palette) i wpisz Ciąg Azure ML: Zapisz i kontynuuj. If you're satisfied with your configuration, select Save and continue or open the VS Code command palette (View > Command Palette) and type Azure ML: Save and Continue.
    • Aby wyświetlić ustawienia konfiguracji wdrożenia, wybierz pozycję Wyświetl właściwości usługi.To view deployment configuration settings, select View service properties.

Następne krokiNext steps

Trenowanie modelu klasyfikacji obrazów przy użyciu VS Code danych.Train an image classification model with the VS Code extension.