Odczytywanie i poznawanie kodu C++ w programie Visual StudioRead and understand C++ code in Visual Studio

Edytor kodu C++ i środowisko IDE programu Visual Studio zapewniają wiele narzędzi do kodowania.The C++ code editor and Visual Studio IDE provide many coding aids. Niektóre z nich są unikatowe dla języka C++, a niektóre są zasadniczo takie same dla wszystkich języków programu Visual Studio.Some are unique to C++, and some are essentially the same for all Visual Studio languages. Aby uzyskać więcej informacji o funkcjach udostępnionych, zobacz pisanie kodu w edytorze kodu i tekstu.For more information about the shared features, see Writing Code in the Code and Text Editor.

KolorowanieColorization

Program Visual Studio koloruje elementy składni w celu rozróżnienia typów symboli, takich jak słowa kluczowe języka, nazwy typów, nazwy zmiennych, parametry funkcji, literały ciągów i tak dalej.Visual Studio colorizes syntax elements to differentiate between types of symbols such as language keywords, type names, variable names, function parameters, string literals, and so on.

Kolorowanie koduCode colorization

Nieużywany kod (taki jak kod w #if 0) jest bardziej wyblakły kolorem.Unused code (such as code under an #if 0) is more faded in color.

Nieaktywny kodInactive code

Kolory można dostosować, wpisując "Fonts" ( Szybkie uruchamianie), a następnie wybierając czcionkę i kolory.You can customize the colors by typing "Fonts" in Quick Launch, and then choosing Fonts and Colors. W oknie dialogowym czcionki i kolory przewiń w dół do opcji C/C++, a następnie wybierz niestandardową czcionkę i/lub kolor.In the Fonts and Colors dialog scroll down to the C/C++ options and then choose a custom font and/or color.

Tworzenie konspektuOutlining

Kliknij prawym przyciskiem myszy w dowolnym miejscu w pliku kodu źródłowego i wybierz opcję Konspekt , aby zwinąć lub rozwinąć bloki kodu i/lub regiony niestandardowe, aby ułatwić przeglądanie tylko kodu, który Cię interesuje.Right-click anywhere in a source code file and choose Outlining to collapse or expand code blocks and/or custom regions to make it easier to browse only the code you are interested in. Aby uzyskać więcej informacji, zobacz Tworzenie konspektu.For more information, see Outlining.

Konspekt języka C++ C++ Outlining

Gdy umieścisz kursor przed nawiasem klamrowym, "{" lub "}", Edytor wyróżnia swój pasujący odpowiednik.When you place your cursor in front of a curly brace, '{' or '}', the editor highlights its matching counterpart.

Inne opcje tworzenia konspektu znajdują się w obszarze Edytuj > Konspekt w menu głównym.Other outlining options are located under Edit > Outlining in the main menu.

Numery wierszyLine numbers

Możesz dodać numery wierszy do projektu, przechodząc do opcji Narzędzia > Options > Edytor tekstu > wszystkie języki > Ogólne lub wyszukując "wiersz num" przy użyciu szybkiego uruchamiania (Ctrl + Q).You can add line numbers to your project by going to Tools > Options > Text Editor > All Languages > General or by searching for "line num" with Quick Launch (Ctrl + Q). Numery wierszy można ustawić dla wszystkich języków lub tylko dla określonych języków, w tym C++.Line numbers can be set for all languages or for specific languages only, including C++.

Przewiń i PowiększScroll and zoom

Możesz powiększyć lub pomniejszyć w edytorze, naciskając klawisz Ctrl i przewijając kółkiem myszy.You can zoom in or out in the editor by pressing the Ctrl key and scrolling with your mouse wheel. Możesz również powiększać, używając ustawienia powiększenia w lewym dolnym rogu.You can also zoom by using the zoom setting in the bottom left corner.

Kontrolka powiększenia języka C++ C++ Zoom Control

Tryb mapy ScrollBar umożliwia szybkie przewijanie i przeglądanie pliku kodu bez opuszczania bieżącej lokalizacji.Scrollbar Map Mode enables you to quickly scroll and browse through a code file without leaving your current location. Możesz kliknąć w dowolnym miejscu mapy kodu, aby przejść bezpośrednio do tej lokalizacji.You can click anywhere on the code map to go directly to that location.

Mapa kodu w języku C++Code Map in C++

Aby włączyć tryb mapowania, wpisz "map" w polu wyszukiwania szybkiego uruchamiania na głównym pasku narzędzi i wybierz opcję Użyj trybu Scroll map.To turn on Map Mode, type "map" in the Quick Launch search box in the main toolbar and choose Use scroll map mode. Aby uzyskać więcej informacji, zobacz jak: śledzić kod przez dostosowanie paska przewijania.For more information, see How to: Track your code by customizing the scrollbar.

Gdy tryb mapy jest wyłączony, pasek przewijania nadal wyróżnia zmiany wprowadzone w pliku.When Map Mode is off, the scroll bar still highlights the changes you have made in the file. Zielony oznacza zapisane zmiany i żółty wskazuje niezapisane zmiany.Green indicates saved changes and yellow indicates unsaved changes.

Szybkie informacje i informacje o parametrachQuick Info and Parameter Info

Umieść kursor nad dowolną zmienną, funkcją lub innym symbolem, aby uzyskać informacje na jego temat, w tym deklarację i wszelkie komentarze, które znajdują się przed nim.Hover over any variable, function, or other symbol to get information about it, including the declaration, and any comments that are located just preceding it.

Zrzut ekranu przedstawiający etykietka Szybka podpowiedź w programie Visual Studio 2019.Screenshot showing the Quick Info tooltip in Visual Studio 2019.

Etykietka narzędzia szybkie informacje zawiera link wyszukiwania online .The Quick Info tooltip has a Search Online link. Przejdź do pozycji Narzędzia > Opcje > Edytor tekstu > C++ > Widok , aby określić dostawcę wyszukiwania.Go to Tools > Options > Text Editor > C++ > View to specify the search provider.

Jeśli wystąpi błąd w kodzie, możesz umieścić wskaźnik myszy nad nim, a w oknie szybkie informacje zostanie wyświetlony komunikat o błędzie.If there is an error in your code, you can hover over it and Quick Info will display the error message. Komunikat o błędzie można również znaleźć w oknie Lista błędów.You can also find the error message in the Error List window.

Szybkie informacje o błędzieQuick Info on error

Zrzut ekranu przedstawiający etykietka Szybka podpowiedź w programie Visual Studio 2017.Screenshot showing the Quick Info tooltip in Visual Studio 2017.

Jeśli wystąpi błąd w kodzie, możesz umieścić wskaźnik myszy nad nim, a w oknie szybkie informacje zostanie wyświetlony komunikat o błędzie.If there is an error in your code, you can hover over it and Quick Info will display the error message. Komunikat o błędzie można również znaleźć w oknie Lista błędów .You can also find the error message in the Error List window.

Szybkie informacje o błędzieQuick Info on error

Gdy wywołujesz funkcję, Informacje o parametrach przedstawiają typy parametrów i kolejność, w jakiej są oczekiwane.When you call a function, Parameter Info shows the types of parameters and the order in which they are expected.

Informacje o parametrach w języku C++Parameter Info in C++

Podejrzyj definicjęPeek Definition

Umieść kursor nad deklaracją zmiennej lub funkcji, kliknij prawym przyciskiem myszy, a następnie wybierz polecenie wgląd do definicji , aby wyświetlić wbudowany widok jego definicji bez nawigowania w bieżącej lokalizacji.Hover over a variable or function declaration, right-click, then choose Peek Definition to see an inline view of its definition without navigating away from your current location. Aby uzyskać więcej informacji, zobacz wgląd do definicji (Alt + F12).For more information, see Peek Definition (Alt+F12).

Definicja wglądu w++ języka CC++ Peek Definition

Pomoc F1F1 Help

Umieść kursor na lub zaraz po dowolnym typie, słowie kluczowym lub funkcji, a następnie naciśnij klawisz F1 , aby przejść bezpośrednio do odpowiedniego tematu referencyjnego w witrynie docs.Microsoft.com.Place the cursor on or just after any type, keyword or function and press F1 to go directly to the relevant reference topic on docs.microsoft.com. F1 działa również w przypadku elementów na liście błędów i w wielu oknach dialogowych.F1 also works on items in the error list, and in many dialog boxes.

Widok klasClass View

Widok klasy Wyświetla zestaw drzew z możliwością wyszukiwania dla wszystkich symboli kodu oraz ich zakres i hierarchie nadrzędny/podrzędny, zorganizowane na podstawie projektu.Class View displays a searchable set of trees of all code symbols and their scope and parent/child hierarchies, organized on a per-project basis. Można skonfigurować, jakie Widok klasy są wyświetlane z poziomu Widok klasy ustawień (kliknij ikonę koła zębatego w górnej części okna).You can configure what Class View displays from Class View Settings (click the gear box icon at the top of the window).

Widok klasy w języku C++Class View in C++

Generowanie grafu plików dołączanychGenerate graph of include files

Kliknij prawym przyciskiem myszy plik kodu w projekcie i wybierz polecenie Generuj Graf plików dołączanych , aby zobaczyć Graf, które pliki są dołączone przez inne pliki.Right click on a code file in your project and choose Generate graph of include files to see a graph of which files are included by other files.

++ grafu plików dołączanychC++ graph of include files

Wyświetl hierarchię wywołańView Call Hierarchy

Kliknij prawym przyciskiem myszy każde wywołanie funkcji i Wyświetl listę cykliczną wszystkich funkcji, które wywołuje, oraz wszystkie funkcje, które je wywołują.Right click on any function call and view a recursive list of all the functions that it calls, and all the functions that call it. Każda funkcja na liście może być rozwinięta w ten sam sposób.Each function in the list can be expanded in the same way. Aby uzyskać więcej informacji, zobacz temat Hierarchia wywołań.For more information, see Call Hierarchy.

Hierarchia wywołań języka C++ C++ Call Hierarchy

Zobacz teżSee Also

Edytuj i Refaktoryzacja kodu (C++)Edit and refactor code (C++)
Nawigowanie po bazie kodu C++ w programie Visual StudioNavigate your C++ code base in Visual Studio
Współpraca z Live Shareami dla języka C++Collaborate with Live Share for C++