Edytory zasobów (C++)Resource Editors (C++)

Edytor zasobów to wyspecjalizowane środowisko do tworzenia lub modyfikowania zasobów uwzględnionych w projekcie programu Visual Studio.A resource editor is a specialized environment for creating or modifying resources that are included in a Visual Studio project. Edytory zasobów programu Visual Studio udostępniają techniki i interfejsy ułatwiające szybkie i łatwe tworzenie i modyfikowanie zasobów aplikacji.The Visual Studio resource editors share techniques and interfaces to help you create and modify application resources quickly and easily. Edytory zasobów umożliwiają wyświetlanie i edytowanie zasobów w odpowiednim edytorze i Podgląd zasobów.Resource editors enable you to view and edit resources in the appropriate editor and preview resources.

Odpowiedni edytor zostanie otwarty automatycznie podczas tworzenia lub otwierania zasobu.The appropriate editor opens automatically when you create or open a resource.

Uwaga

Ponieważ projekty zarządzane nie używają plików skryptów zasobów, należy otworzyć zasoby z Eksplorator rozwiązań.Because managed projects do not use resource script files, you must open your resources from Solution Explorer. Możesz użyć edytora obrazów i edytora binarnego do pracy z plikami zasobów w projektach zarządzanych.You can use the Image Editor and the Binary Editor to work with resource files in managed projects. Wszelkie zarządzane zasoby, które chcesz edytować, muszą być powiązanymi zasobami.Any managed resources you want to edit must be linked resources. Edytory zasobów programu Visual Studio nie obsługują edycji zasobów osadzonych.The Visual Studio resource editors do not support editing embedded resources.

Korzystanie z...Use the... Aby edytować...To edit...
Edytor akceleratorówAccelerator Editor Tabele akceleratora w projektach programu Visual Studio C++.Accelerator tables in Visual Studio C++ projects.
Edytor binarnyBinary Editor Informacje o danych binarnych i zasoby niestandardowe w projektach Visual C++, Visual Basic lub Visual C#.Binary data information and custom resources in Visual C++, Visual Basic, or Visual C# projects.
Edytor okien dialogowychDialog Editor Okna dialogowe w projektach programu Visual Studio C++.Dialog boxes in Visual Studio C++ projects.
Edytor obrazówImage Editor Mapy bitowe, ikony, kursory i inne pliki obrazów w projektach Visual C++, Visual Basic lub Visual C#.Bitmaps, icons, cursors, and other image files in Visual C++, Visual Basic, or Visual C# projects.
Edytor menuMenu Editor Zasoby menu w projektach programu Visual Studio C++.Menu resources in Visual Studio C++ projects.
Edytor wstążkiRibbon Editor Zasoby wstążki w projektach MFC.Ribbon resources in MFC projects.
Edytor ciągówString Editor Tabele ciągów w projektach programu Visual Studio C++.String tables in Visual Studio C++ projects.
Edytor paska narzędziToolbar Editor Zasoby paska narzędzi w projektach programu Visual Studio C++.Toolbar resources in Visual Studio C++ projects. Edytor paska narzędzi jest częścią edytora obrazu.The Toolbar Editor is part of the Image Editor.
Edytor informacji o wersjiVersion Information Editor Informacje o wersji w projektach programu Visual Studio C++.Version information in Visual Studio C++ projects.

Uwaga

Jeśli projekt nie zawiera jeszcze pliku. RC, zobacz How to: Create Resources.If your project doesn't already contain an .rc file, see How to: Create Resources.

Wyświetlanie i edytowanie zasobówView and Edit Resources

Każdy typ zasobu ma Edytor zasobów specyficzny dla tego typu zasobu.Each resource type has a resource editor specific to that resource type. Można zmieniać rozmieszczenie, zmieniać rozmiar, dodawać kontrolki i funkcje albo modyfikować aspekty zasobu przy użyciu skojarzonego z nim edytora.You can rearrange, resize, add controls and features, or otherwise modify aspects of a resource using the associated editor. Możesz również edytować zasób w formacie tekstowym i formacie binarnym.You can also edit a resource in text format and binary format. Aby uzyskać więcej informacji, zobacz How to: Create Resources.For more information, see How to: Create Resources.

Niektóre typy zasobów są pojedynczymi plikami, które mogą być importowane i używane na różne sposoby. obejmują one mapy bitowe, ikony, kursory, paski narzędzi i pliki HTML.Some resource types are individual files that can be imported and used in various ways; these include bitmaps, icons, cursors, toolbars, and html files. Takie zasoby mają nazwy plików i identyfikatory zasobów.Such resources have file names and resource identifiers. Inne, takie jak okna dialogowe, menu i tabele ciągów w projektach Win32, istnieją tylko jako część pliku skryptu zasobu (. RC) lub plik szablonu zasobów (. rct).Others, such as dialogs, menus, and string tables in Win32 projects, exist only as part of a resource script (.rc) file or resource template (.rct) file.

Zasoby mogą być również edytowane poza projektem bez otwierania projektu.Resources can also be edited outside of the project without having the project open. Aby uzyskać więcej informacji, zobacz How to: Create Resources.For more information, see How to: Create Resources.

Uwaga

Właściwości zasobu można zmodyfikować przy użyciu okna Właściwości .Properties of a resource can be modified using the Properties window.

  • Aby edytować właściwości zasobu, w Widok zasobówkliknij prawym przyciskiem myszy zasób, który chcesz edytować, a następnie wybierz polecenie Właściwości.To edit the properties of a resource, in Resource View, right-click the resource you want to edit and choose Properties. Następnie w okno właściwościzmienić właściwości zasobu.Then, in the Properties window, change the properties of your resource.

  • Aby cofnąć zmiany wprowadzone we właściwościach zasobu, upewnij się, że zasób ma fokus w Widok zasobów i wybierz polecenie Cofnij z menu Edycja .To undo a change made to the properties of a resource, make sure your resource has focus in Resource View and choose Undo from the Edit menu.

Zasoby Win32Win32 Resources

Dostęp do zasobów Win32 można uzyskać w okienku Widok zasobów .You can access Win32 resources in the Resource View pane.

Aby wyświetlić zasób Win32 w edytorze zasobówTo view a Win32 resource in a resource editor

  1. Przejdź do menu Wyświetl > inne widok zasobów systemu Windows > .Go to menu View > Other Windows > Resource View.

  2. Jeśli okno Widok zasobów nie jest oknem najwyższego poziomu, wybierz kartę Widok zasobów , aby ją wyświetlić.If the Resource View window isn't the top-most window, select the Resource View tab to bring it to the top.

  3. W Widok zasobów rozwiń folder dla projektu zawierającego zasoby, które chcesz wyświetlić.From Resource View, expand the folder for the project that contains resources you want to view. Jeśli na przykład chcesz wyświetlić zasób okna dialogowego, rozwiń folder okna dialogowego .For example, if you want to view a dialog resource, expand the Dialog folder.

  4. Kliknij dwukrotnie zasób, na przykład IDD_ABOUTBOX.Double-click the resource, for example, IDD_ABOUTBOX.

    Zasób zostanie otwarty w odpowiednim edytorze.The resource opens in the appropriate editor. Na przykład dla zasobów okna dialogowego zasób zostanie otwarty w edytorze okien dialogowych.For example, for dialog resources, the resource opens inside the Dialog Editor.

Aby usunąć istniejący zasób Win32To delete an existing Win32 resource

  1. W Widok zasobów rozwiń węzeł dla typu zasobu.In Resource View, expand the node for a resource type.

  2. Kliknij prawym przyciskiem myszy zasób, który chcesz usunąć, a następnie wybierz polecenie Usuń.Right-click on the resource you want to delete and choose Delete.

Porada

Tej metody można również użyć, gdy plik. RC jest otwarty w oknie dokumentu poza projektem.You can also use this method when you have the .rc file open in a document window outside a project.

Zarządzane zasoby projektuManaged Project Resources

Ponieważ projekty zarządzane nie używają plików skryptów zasobów, należy otworzyć zasoby z Eksplorator rozwiązań.Because managed projects don't use resource script files, you must open your resources from Solution Explorer. Użyj edytora obrazów i edytora binarnego do pracy z plikami zasobów w projektach zarządzanych.Use the Image Editor and the Binary Editor to work with resource files in managed projects. Wszystkie zarządzane zasoby, które chcesz edytować, muszą być zasobami połączonymi i edytorami zasobów programu Visual Studio nie obsługują edycji zasobów osadzonych.Any managed resources you want to edit must be linked resources and Visual Studio resource editors don't support editing embedded resources.

  • Aby wyświetlić zasób zarządzany w edytorze zasobów, w Eksplorator rozwiązań kliknij dwukrotnie zasób, na przykład Bitmap1.bmp, a zasób zostanie otwarty w odpowiednim edytorze.To view a managed resource in a resource editor, in Solution Explorer, double-click the resource, for example, Bitmap1.bmp, and the resource opens in the appropriate editor.

  • Aby usunąć istniejący zasób zarządzany, w Eksplorator rozwiązań kliknij prawym przyciskiem myszy zasób, który chcesz usunąć, a następnie wybierz polecenie Usuń.To delete an existing managed resource, in Solution Explorer, right-click the resource you want to delete and choose Delete.

Podgląd zasobówPreview Resources

Wyświetl podgląd zasobów, aby umożliwić wyświetlanie zasobów graficznych bez ich otwierania.Preview your resources to allow you to view graphical resource without opening them. Podgląd jest również przydatny dla plików wykonywalnych po ich skompilowaniu, ponieważ identyfikatory zasobów zmieniają się na liczby.Previewing is also useful for executables after you've compiled them, because the resource identifiers change to numbers. Ponieważ te identyfikatory liczbowe często nie zapewniają wystarczającej ilości informacji, Podgląd zasobów ułatwia ich szybkie identyfikowanie.Since these numeric identifiers often don't provide enough information, previewing the resources helps you quickly identify them.

Następujące typy zasobów udostępniają podgląd układu wizualizacji: Mapa bitowa, okno dialogowe, ikona, menu, kursor, pasek narzędziThe following resource types provide a visual layout preview: Bitmap, Dialog, Icon, Menu, Cursor, Toolbar

Następujące zasoby nie udostępniają wizualizacji Visual Preview: akcelerator, manifest, tabela ciągów, informacje o wersjiThe following resources don't provide a visual preview: Accelerator, Manifest, String Table, Version Information

Uwaga

Aby uzyskać podgląd zasobów, wymagany jest system Win32.To preview resources requires Win32.

Aby wyświetlić podgląd zasobówTo preview resources

  1. W Widok zasobów lub oknie dokumentu wybierz zasób, na przykład IDD_ABOUTBOX.In Resource View or a document window, select your resource, for example, IDD_ABOUTBOX.

  2. W okno właściwościwybierz przycisk strony właściwości .In the Properties window, select the Property Pages button.

    Porada

    Użyj skrótu, przejdź do widoku menu > strony właściwości.Use a shortcut, go to menu View > Property Pages.

    Zostanie otwarta strona Właściwości zasobu wyświetlająca podgląd tego zasobu.The Property page for the resource opens displaying a preview of that resource. Możesz użyć klawiszy strzałek w górę i w dół , aby nawigować po formancie drzewa w Widok zasobów lub oknie dokumentu.You can use the Up and Down arrow keys to navigate the tree control in Resource View or the document window. Na stronie Właściwości pozostanie otwarta i zostanie wyświetlony dowolny zasób, który ma fokus i będzie można go wyświetlić.The Property page will stay open and show any resource that has focus and can be previewed.

WymaganiaRequirements

BrakNone

Zobacz teżSee also

Praca z plikami zasobówWorking with Resource Files
Pliki zasobówResource Files
Identyfikatory zasobów (symbole)Resource Identifiers (Symbols)