(Podczas przenoszenia skrzynek pocztowych do lub z pakietu Office 365 w ramach wdrożenia hybrydowego Wystąpił błąd wyjątek zwrócony przez docelowy)

Uwaga

Nazwa usługi Office 365 ProPlus została zmieniona na Aplikacje usługi Microsoft 365 dla przedsiębiorstw. Aby uzyskać więcej informacji na temat tej zmiany, przeczytaj ten wpis w blogu.

Uwaga

Kreator konfiguracji hybrydowej dostępny w konsoli zarządzania programu Exchange w programie Microsoft Exchange Server 2010 nie jest już obsługiwany. Dlatego nie należy już używać starego Kreatora konfiguracji hybrydowej. Zamiast tego użyj Kreatora konfiguracji hybrydowej pakietu Office 365, który jest dostępny w witrynie https://aka.ms/HybridWizard . Aby uzyskać więcej informacji, zobacz Kreator konfiguracji hybrydowej pakietu Office 365 dla programu Exchange 2010.

Problem

Masz wdrożenie hybrydowe programu Microsoft Exchange Online w pakiecie Microsoft Office 365 i w lokalnym środowisku programu Microsoft Exchange Server. Podczas próby przeniesienia skrzynek pocztowych do lub z usługi Office 365 jest wyświetlany następujący komunikat o błędzie:

Element docelowy wywołania zwrócił wyjątek.

Poprzednio można było pomyślnie przenieść skrzynki pocztowe do lub z pakietu Office 365 i lokalnego środowiska programu Exchange Server. Ten symptom występuje dopiero po uaktualnieniu środowiska lokalnego z programu Exchange Server 2010 z dodatkiem Service Pack 1 (SP1) do programu Exchange Server 2010 z dodatkiem Service Pack 2 (SP2) lub nowszego.

Przyczyna

Ten problem występuje, jeśli plik Web.config został zastąpiony podczas uaktualnienia z dodatku Service Pack 1 do programu Exchange Server 2010 do programu Exchange Server 2010 z dodatkiem SP2 lub nowszego. Funkcja przenoszenia zdalnej skrzynki pocztowej wymaga włączenia punktu końcowego usługi proxy replikacji skrzynki pocztowej (MRSProxy) na serwerze dostępu klienta. W programie Exchange Server 2010 z dodatkiem SP1 i Exchange Server 2010 ustawienie MRSProxy jest skonfigurowane w pliku Web.config.

W programie Exchange Server 2010 z dodatkiem SP2 lub nowszym ustawienia MRSProxy są przechowywane w usłudze Active Directory i konfigurowane za pomocą Set-WebServicesVirtualDirectoryWindows polecenia cmdlet programu PowerShell.

Uwaga

Istnieje kilka możliwych powodów tego komunikatu o błędzie. Ten artykuł zawiera omówienie jednego scenariusza, który może powodować wyświetlenie tego komunikatu o błędzie.

Rozwiązanie

Użyj Set-WebServicesVirtualDirectory polecenia cmdlet, aby ponownie włączyć MRSProxy na każdym serwerze dostępu klienta w środowisku lokalnym, za pośrednictwem którego chcesz zezwolić na zdalne przekazywanie żądań przeniesienia. Aby to zrobić, wykonaj następujące kroki.

  1. Otwórz powłokę zarządzania programu Exchange.

  2. Upewnij się, że MRSProxyEnabled parametr na serwerze jest ustawiony na wartość FAŁSZ.

    Aby to zrobić, uruchom następujące polecenie cmdlet:

    Get-WebServicesVirtualDirectory-Identity "Server\EWS(default Web site)"
    
  3. Włącz usługę MRSProxy. Aby to zrobić, uruchom następujące polecenie cmdlet:

    Set-WebServicesVirtualDirectory-Identity "Server\EWS(default Web site)" –MRSProxyEnabled $true
    

Więcej informacji

Po włączeniu MRSProxy na serwerach może być konieczne poprawne opublikowanie punktu końcowego za pośrednictwem zapory. Aby uzyskać więcej informacji o tym, jak to zrobić, zobacz Konfigurowanie programu FOREFRONT TMG dla środowiska hybrydowego.

Aby uzyskać więcej informacji na temat rozwiązywania problemów z komunikatem o błędzie wspomnianym w sekcji Symptomy, zobacz wyjątek został zgłoszony przez błąd docelowy we wdrożeniu hybrydowym.

Jeśli podczas przenoszenia skrzynek pocztowych do usługi Exchange Online w pakiecie Office 365 występują problemy, możesz uruchomić narzędzie do migracji skrzynki pocztowej pakietu Office 365. Ta Diagnostyka to narzędzie do automatycznego rozwiązywania problemów. Jeśli występuje znany problem, zostanie wyświetlony komunikat informujący o błędach. Wiadomość zawiera łącze do artykułu zawierającego rozwiązanie. Obecnie narzędzie jest obsługiwane tylko w programie Internet Explorer.

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community lub Exchange TechNet forum.