Błąd w aplikacji Outlook Web App po uaktualnieniu do programu Exchange Server 2013 w wersji 11 lub nowszej: nie można teraz ukończyć żądania

Oryginalny numer artykułu KB:   3191636

Symptomy

W środowisku programu Microsoft Exchange Server 2013, które zostało uaktualnione do aktualizacji zbiorczej (CU) 11 lub nowszej wersji, występują co najmniej jeden z następujących symptomów w aplikacji Outlook Web App (OWA):

  • Użytkownik otrzyma żądanie nie może być teraz zrealizowane. Komunikat o błędzie spróbuj ponownie później , gdy próbujesz otworzyć, odpowiedzieć lub przesłać dalej elementy w aplikacji Outlook Web App.
  • Podczas próby zalogowania się do aplikacji Outlook Web App lub wybrania innych folderów jest również wyświetlany ten błąd.

Ponadto następujące zdarzenie jest rejestrowane wielokrotnie w dzienniku aplikacji systemu Windows:

Time:     7/5/2016 2:20:24 PM
ID:       4999
Level:    Error
Source: MSExchange Common
Machine:  MBX1.contoso.com
Message:  Watson report about to be sent for process id: 10472, with parameters: E12IIS, c-RTL-AMD64, 15.00.1178.004, w3wp#MSExchangeOWAAppPool, m.exchange.services, M.E.S.C.T.IdConverter.ConvertId, System.MissingMethodException, a16f, 15.00.1104.003.
ErrorReportingEnabled: False

Przyczyna

Gdy zostanie zastosowana Zbiorcza aktualizacja, w podkatalogu bin katalogu instalacyjnego programu Exchange jest wykorzystana konfiguracja bitów poprzedniej aktualizacji zbiorczej. Na przykład: w folderze C:\Program Files\Microsoft\Exchange Server\V15\Bin\Setup.

Po uruchomieniu procesu konfiguracji w tym scenariuszu plik SharedWebConfig.config znajdujący się w katalogu C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess (rola skrzynki pocztowej) lub C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy (rola dostępu klienta) wskazuje c:\Program Files\Microsoft\Exchange Server\V15\Bin\Setup. Te pliki nie są aktualizowane przez proces konfiguracji.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj poniższe czynności w celu usunięcia plików z katalogu C:\Program Files\Microsoft\Exchange Server\V15\Bin\Setup i zaktualizowanie plików SharedWebConfig.config, aby wskazywały właściwe lokalizacje:

  1. W wierszu polecenia z podwyższonym poziomem uprawnień uruchom następujące polecenie w celu zatrzymywania usług IIS w celu umożliwienia dostępu do plików:

    iisreset /stop
    
  2. Przenieś folder C:\Program Files\Microsoft\Exchange Server\V15\Bin\Setup do innej lokalizacji katalogu poza ścieżką instalacji programu Exchange. Na przykład przenieś ją na C:\TEMP\Setup.

  3. Utwórz kopię zapasową pliku SharedWebConfig.config w folderze C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess i C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy w alternatywnym miejscu.

  4. W wierszu polecenia z podwyższonym poziomem uprawnień uruchom polecenie, cd %ExchangeInstallPath%\bin Aby zmienić katalog na prawidłowy. Następnie uruchom następujące polecenie, aby ponownie utworzyć plik SharedWebConfig.config w katalogu C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess:

    DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\ClientAccess" -configFile "%ExchangeInstallPath%\ClientAccess\SharedWebConfig.config"
    
  5. W wierszu polecenia z podwyższonym poziomem uprawnień uruchom następujące polecenie w celu odbudowania pliku SharedWebConfig.config w katalogu C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy:

    DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\FrontEnd\HttpProxy" -configFile "%ExchangeInstallPath%\FrontEnd\HttpProxy\SharedWebConfig.config"
    
  6. W wierszu polecenia z podwyższonym poziomem uprawnień uruchom następujące polecenie, aby ponownie uruchomić usługi IIS:

    iisreset /start