Użytkownicy we wdrożeniu hybrydowym nie mogą uzyskać dostępu do udostępnionej skrzynki pocztowej utworzonej w usłudze Exchange Online

Uwaga

Kreator konfiguracji hybrydowej dostępny w konsoli zarządzania programu Exchange w programie Microsoft Exchange Server 2010 nie jest już obsługiwany. Dlatego nie należy już używać starego Kreatora konfiguracji hybrydowej. Zamiast tego użyj Kreatora konfiguracji hybrydowej pakietu Office 365. Aby uzyskać więcej informacji, zobacz Kreator konfiguracji hybrydowej pakietu Office 365 dla programu Exchange 2010.

Problem

Rozpatrzmy następujący scenariusz:

  • Masz wdrożenie hybrydowe lokalnego programu Microsoft Exchange Server i usługi Microsoft Exchange Online w pakiecie Office 365.
  • Możesz utworzyć udostępnioną skrzynkę pocztową bezpośrednio w usłudze Exchange Online.
  • Użytkownik przypisuje uprawnienia pełnego dostępu jednemu lub więcej użytkownikom.

W tym scenariuszu występują co najmniej jeden z następujących problemów:

  • Użytkownicy nie mogą otworzyć udostępnionej skrzynki pocztowej w programie Outlook.
  • Użytkownicy nie mogą wyświetlać informacji o wolnych/zajętych dla udostępnionej skrzynki pocztowej.
  • Użytkownicy nie mogą wysyłać poczty do udostępnionej skrzynki pocztowej.

Przyczyna

Te problemy mogą występować, jeśli udostępniona Skrzynka pocztowa została utworzona za pomocą narzędzi do zarządzania usługi Exchange Online. W tej sytuacji lokalne środowisko programu Exchange nie ma obiektu do odwołania się do udostępnionej skrzynki pocztowej. Dlatego wszystkie zapytania dotyczące tego adresu SMTP kończą się niepowodzeniem.

Rozwiązanie

Utwórz zdalną skrzynkę pocztową w środowisku lokalnym, a następnie przenieś skrzynkę pocztową do usługi Exchange Online. W tym celu wykonaj następujące czynności.

Uwaga

W przypadku środowisk lokalnych korzystających z programu Exchange Server 2013 (aktualizacja zbiorcza 21 lub nowsze wersje) lub programu Exchange Server 2016 (aktualizacja zbiorcza 10 lub nowsza wersja) możesz pominąć poniższe czynności i wykonać czynności opisane w sekcji Metoda alternatywna .

  1. Przekonwertuj udostępnioną skrzynkę pocztową na zwykłą skrzynkę pocztową, korzystając z centrum administracyjnego programu Exchange w usłudze Exchange Online. Aby to zrobić, wykonaj następujące kroki.

    1. Otwórz Centrum administracyjne programu Exchange w usłudze Exchange Online.
    2. Kliknij pozycję Adresaci, a następnie kliknij pozycję udostępnione.
    3. Zaznacz udostępnioną skrzynkę pocztową, a następnie kliknij pozycję Konwertuj.
    4. Na stronie ostrzeżenie wybierz pozycję tak , aby przekonwertować udostępnioną skrzynkę pocztową.
  2. Utwórz obiekt lokalny dla skrzynki pocztowej w chmurze za pomocą New-RemoteMailbox polecenia cmdlet w powłoce zarządzania programem Exchange.

    Uwaga

    Ten obiekt musi mieć taką samą nazwę, alias i główną nazwę użytkownika (główną) jako skrzynkę pocztową w chmurze.

    Aby uzyskać więcej informacji, zobacz Nowość-RemoteMailbox.

  3. Ustaw właściwość ExchangeGuid w nowym obiekcie lokalnym utworzonym w kroku 2, aby dopasować ją do skrzynki pocztowej chmury. Aby to zrobić, wykonaj następujące kroki.

    1. Nawiązywanie połączenia z usługą Exchange Online przy użyciu sesji zdalnej programu Windows PowerShell.

      Aby uzyskać więcej informacji o tym, jak to zrobić, zobacz nawiązywanie połączenia z programem Exchange Online PowerShell.

    2. Użyj Get-Mailbox polecenia cmdlet, aby pobrać wartość ExchangeGuid właściwości skrzynki pocztowej w chmurze. Na przykład uruchom następujące polecenie:

      Get-Mailbox <MailboxName> | FL ExchangeGuid  
      

      Aby uzyskać więcej informacji, zobacz Get-Skrzynka pocztowa.

    3. Otwórz powłokę zarządzania programu Exchange na lokalnym serwerze programu Exchange.

    4. Użyj Set-RemoteMailbox polecenia cmdlet, aby ustawić wartość ExchangeGuid właściwości obiektu lokalnego na wartość pobraną w kroku 3B. Na przykład uruchom następujące polecenie:

      Set-RemoteMailbox <MailboxName> -ExchangeGuid <GUID>
      

      Aby uzyskać więcej informacji, zobacz Set-RemoteMailbox.

  4. Poczekaj na wykonanie synchronizacji katalogów. Lub Wymuś synchronizację katalogów.

    Aby uzyskać więcej informacji, zobacz synchronizowanie katalogów.

  5. Upewnij się, że obiekt użytkownika pakietu Office 365 jest wyświetlany jako zsynchronizowany z usługą Active Directory.

  6. Przenieś skrzynkę pocztową z usługi Exchange Online do środowiska lokalnego.

    Aby uzyskać więcej informacji, zobacz Przenoszenie skrzynek pocztowych w organizacjach lokalnych i Exchange Online w wdrożeniach hybrydowych.

  7. Przekonwertuj skrzynkę pocztową do udostępnionej skrzynki pocztowej przy użyciu Set-Mailbox polecenia cmdlet w powłoce zarządzania programem Exchange. Na przykład uruchom następujące polecenie:

    Set-Mailbox <MailboxName> -Type Shared
    

    Aby uzyskać więcej informacji, zobacz Ustawianie-Skrzynka pocztowa.

  8. Przenieś skrzynkę pocztową z środowiska lokalnego do usługi Exchange Online.

    Aby uzyskać więcej informacji, zobacz Przenoszenie skrzynek pocztowych w organizacjach lokalnych i Exchange Online w wdrożeniach hybrydowych.

Metoda alternatywna

W przypadku środowisk lokalnych korzystających z programu Exchange Server 2013 (zbiorcza aktualizacja 21 lub nowsze wersje) lub Exchange Server 2016 (zbiorcza aktualizacja 10 lub nowsza wersja):

Utwórz obiekt lokalny dla skrzynki pocztowej w chmurze za pomocą New-RemoteMailbox polecenia cmdlet w powłoce zarządzania programem Exchange.

Uwaga

Ten obiekt musi mieć taką samą nazwę, alias i główną nazwę użytkownika (główną) jako skrzynkę pocztową w chmurze. Aby uzyskać więcej informacji, zobacz Nowość-RemoteMailbox.

Na przykład uruchom następujące polecenie:

New-Remotemailbox sharedmailbox@contoso.com -Remoteroutingaddress sharedmailbox@contoso.mail.onmicrosoft.com -Shared

Więcej informacji

Aby uzyskać więcej informacji na temat zdalnych udostępnionych skrzynek pocztowych, zobacz polecenia cmdlet do tworzenia lub modyfikowania zdalnej udostępnionej skrzynki pocztowej w lokalnym środowisku programu Exchange.

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community lub Exchange TechNet forum.